Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

stefanRTR's Win Integrator


  • This topic is locked This topic is locked
228 replies to this topic

#201
Dakota42784

Dakota42784
  • Member
  • 9 posts
  • OS:Windows 7 x86
  • Country: Country Flag

Hi,
i'am working on something.
Old Topic by Intelmaster

Features:
• Bootable Iso Image Creation
• Image Rebuilding

with a Windows 7 or Windows Server 2008 R2 Image
• Driver Integration including Bootcritical-Option if you need a Driver to Install Windows
• Package Integration (Updates, LocalPacks and LanguagePacks)
• Package Removing
• Preset Creation
• Windows Feature Enabling and Disabling

with a Windows Vista SP1 or Windows Server 2008 Image
• Package Integration (Updates and LanguagePacks)
• ServicePack 2 Integration into a original MS DVD or Image with SP1


Supported Operating Systems:
• Windows Vista SP1
• Windows Server 2008 family
• Windows 7 family
• Windows Server 2008 R2 family


Software Requirements:
Microsoft .NET Framework 4 Client Profile Beta 2 Important! You must reboot you Computer after installing the Framework or the Win Integrator Setup will fail.
and for Vista and Server 2008
Windows® Automated Installation Kit (AIK) for Windows® 7 or Windows® OEM Preinstallation Kit (OPK) for Windows® 7


Version History:
Version 1.0.2.7 Beta:
• Added: New Tool "Cleanup Image Mounts". If you get an Cannot Mount Image Error try this.
• Small Fixes
Version 1.0.2.6 Beta:
• Fixed: Some Packages have been listed twice in presets and have been removed twice from the Image.
• Fixed: If a Packages has children only the parent has to be removed the children will be removed automatically.
Version 1.0.2.5 Beta:
• Fixed: Some Updates have been listed twice in the RemovePackages TreeView
• Fixed: Error 50 then Enabling IIS FtpServer
Version 1.0.2.4 Beta:
• Changed: The Packages to Remove are now showed in a TreeView and i started to sort them into Categories(Drivers, Multimedia...)
• Fixed: Error 50 then Enabling some Features.
• Fixed: Error 50 then Integrating some Updates into Vista.
• Small Fixes and Changes.
Version 1.0.2.1 Beta:
• Small Fixes.
Version 1.0.2.0 Beta:
• New Feature: Enable and Disable Windows-Features

Download



Any Progress on including a feature to add Applications??

How about an unattended feature?? :unsure:


How to remove advertisement from MSFN

#202
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Any Progress on including a feature to add Applications??

How about an unattended feature??


How about reading? Its been dead for awhile

#203
Ganbayar

Ganbayar
  • Member
  • 7 posts
i don't understand one thing.
re-build image?
yes
no

what does it mean?

if want just all my drivers integrated version, which i choose?

sorry my bad english.

#204
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag
You choose yes ofcourse. You have to rebuild the image.

#205
Ganbayar

Ganbayar
  • Member
  • 7 posts

While integrate ATI Catalyst Driver, package from ATI site.

The original graphics drivers like ATI's Catalyst or NVIDIA's GeForce cannot be integrated, because they do not contain all the files, which are listed within the INF files (either compressed or even hidden within EXE or CAB files).
>Here< you will find an already prepared version of ATI's actual Catalyst drivers 9-11. Just download, unzip and integrate it.


i this error too.
i follow your suggestion, but nothing changed.

#206
Cosmin3

Cosmin3

    Member

  • Member
  • PipPip
  • 145 posts
  • OS:XP Pro x86
  • Country: Country Flag
Hi.
Thank you for the program.

I tried to integrate Windows 7 x86 updates (downloaded by wsusoffline) into Windows 7 x86 Ultimate (just to test how it works).
I get this error:

Posted Image

I have the latest DotNet and the latest Waik.
OS is Windows 7 x64 latest updates included freshly installed.
The partition with temp folder has 200 GB free space.

I have attached the log.

What can I do...?

Attached Files


Edited by Cosmin3, 07 January 2011 - 05:28 AM.


#207
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,985 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

this is because of your strange folder name: -= Downloads =-

Use a simple path like C:\Updates
Posted Image

#208
Cosmin3

Cosmin3

    Member

  • Member
  • PipPip
  • 145 posts
  • OS:XP Pro x86
  • Country: Country Flag
Ok, this helped, thank you. It should of worked even with that name but it's not so important.
Anyway it processes a few updates until it shows another error:

Posted Image

Attached Files


Edited by Cosmin3, 07 January 2011 - 03:51 PM.


#209
yucelakpinar

yucelakpinar
  • Member
  • 3 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Hi, I used this tool to create an updated windows 7 install dvd. It did it without an error. But there is a problem which i dont know why.
My source install dvd which is original windows 7 ultimate x64 en contains ei.cfg in sources folder. This is Ok.
Output .iso from Win Integrator doesn't have this file in sources folder. Tool is deleting this file I think. (Also If tool didn't delete i will delete it)
After all when i am testing the new install dvd on virtual machine, installation doesn't ask me to install which version to install. :blink:
Why it doesn't show me the version list in installition.
I only updated the HomePremium image in dvd.
After installition complete i see that windows home premium installed to my virtual machine.

Is there any change to modify(I want to slipstream all windows updates to all version) all versions in dvd. Because Tool can only select one version to modify.


Also I use this tool in Windows7x64 without installing AIK and OPK. Why you wrote AIK or OPK is required.(is OPK come with windows 7 default)

Edited by yucelakpinar, 30 January 2011 - 09:49 AM.


#210
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Maybe its deleting all the other versions.. After, when you are done, restart the tool and see..

#211
tulnio

tulnio
  • Member
  • 7 posts
  • OS:Windows 7 x86
  • Country: Country Flag
Hi all, I'm trying to use Win Integrator on a Windows Seven 32bit SP1 italian msdn iso, but when I try to apply the changes and rebuild Win7 ultimate image, I get an error message.

--- EXCEPTION #1/2 [Win32Exception]
Message = “Failed to load registry key! Error = -2145452027”
ExceptionPath = Root.InnerException
NativeErrorCode = -2145452027
ClassName = System.ComponentModel.Win32Exception
HResult = -2147467259
Source = stefanRTR.Base
StackTraceString = “
  at 1gMKm3XvBXqPvEdS4h.6yV8ZtOfAX4jYNwAEh.BvGI4A84b(RegistryHive , String , String )
     at 1gMKm3XvBXqPvEdS4h.6yV8ZtOfAX4jYNwAEh.xlcB0Yiou(String )
     at stefanRTR.WimImage.SevenImage.lK3SsWkIDRnkUUArrG.RdpFNZihGHJvUUMNVfH(Object , Object )
     at stefanRTR.WimImage.SevenImage.lK3SsWkIDRnkUUArrG.1LJBjxNei()
     at stefanRTR.ErrorHandling.Catch(String comment, Action action)
”

--- Outer ---

--- EXCEPTION #2/2 [ArgumentException]
Message = “PreparePackagesRemove Failed to load registry key! Error = -2145452027”
ExceptionPath = Root
ClassName = System.ArgumentException
InnerException = “Exception #1 at Root.InnerException”
HResult = -2147024809

Here is the .log file too.
The image folder path is D:\ISO. The temp folder is D:\TEMPUSER (environmental variable changed in advanced options)

Hope the problem is solvable :)

Attached Files



#212
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Hi all, I'm trying to use Win Integrator on a Windows Seven 32bit SP1 italian msdn iso, but when I try to apply the changes and rebuild Win7 ultimate image, I get an error message.

--- EXCEPTION #1/2 [Win32Exception]
Message = "Failed to load registry key! Error = -2145452027"
ExceptionPath = Root.InnerException
NativeErrorCode = -2145452027
ClassName = System.ComponentModel.Win32Exception
HResult = -2147467259
Source = stefanRTR.Base
StackTraceString = "
  at 1gMKm3XvBXqPvEdS4h.6yV8ZtOfAX4jYNwAEh.BvGI4A84b(RegistryHive , String , String )
 	at 1gMKm3XvBXqPvEdS4h.6yV8ZtOfAX4jYNwAEh.xlcB0Yiou(String )
 	at stefanRTR.WimImage.SevenImage.lK3SsWkIDRnkUUArrG.RdpFNZihGHJvUUMNVfH(Object , Object )
 	at stefanRTR.WimImage.SevenImage.lK3SsWkIDRnkUUArrG.1LJBjxNei()
 	at stefanRTR.ErrorHandling.Catch(String comment, Action action)
"

--- Outer ---

--- EXCEPTION #2/2 [ArgumentException]
Message = "PreparePackagesRemove Failed to load registry key! Error = -2145452027"
ExceptionPath = Root
ClassName = System.ArgumentException
InnerException = "Exception #1 at Root.InnerException"
HResult = -2147024809

Here is the .log file too.
The image folder path is D:\ISO. The temp folder is D:\TEMPUSER (environmental variable changed in advanced options)

Hope the problem is solvable :)


Dont use this tool as it is unsupported and havent been updated for a very long time.

#213
tulnio

tulnio
  • Member
  • 7 posts
  • OS:Windows 7 x86
  • Country: Country Flag

Dont use this tool as it is unsupported and havent been updated for a very long time.


Which one should I use then? Thanks in advance :)

#214
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag
7Lite or 7Customizer here on msfn, know there's another tool on wincert forums i think.

#215
tulnio

tulnio
  • Member
  • 7 posts
  • OS:Windows 7 x86
  • Country: Country Flag

7Lite or 7Customizer here on msfn, know there's another tool on wincert forums i think.


Thank you very much, I try them now

#216
Doktor-X

Doktor-X
  • Member
  • 4 posts

Dont use this tool as it is unsupported and havent been updated for a very long time.

this is bad because when i integrate language this is only tool which have translated installation and not only gui after installation

#217
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag


Dont use this tool as it is unsupported and havent been updated for a very long time.

this is bad because when i integrate language this is only tool which have translated installation and not only gui after installation



Yea its bad beacuse StefanRTR hasnt worked with this tool for a very long time and it is definitly unsupported. It barely worked with SP0 and now SP1 is released.

Its easy to localize the setup and you have to install WAIK anyway so ou might as well want to learn something about this process: by doing it yourself the manual way:)

#218
Doktor-X

Doktor-X
  • Member
  • 4 posts

Its easy to localize the setup and you have to install WAIK anyway so ou might as well want to learn something about this process: by doing it yourself the manual way:)

and how to do this

#219
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag


Its easy to localize the setup and you have to install WAIK anyway so ou might as well want to learn something about this process: by doing it yourself the manual way:)

and how to do this


Using dism mount-wim, dism add-package and dism unmount-wim.

#220
Doktor-X

Doktor-X
  • Member
  • 4 posts

Using dism mount-wim, dism add-package and dism unmount-wim.


C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /Mount-Wim /WimFile:D:\7\Sources\install.wim /index:1 /MountDir:D:\mount
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Add-Package /PackagePath:D:\lp.cab
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Gen-LangIni /Distribution:D:\7
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Set-AllIntl:hr-hr
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Set-TimeZone:"Central Europe Standard Time"
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Set-SetupUILang:hr-hr /Distribution:D:\7
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Gen-LangIni /Distribution:D:\7
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Get-Packages /Format:Table
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Get-Intl
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /Unmount-Wim /MountDir:D:\mount /commit

mkdir D:\temp
expand D:\lp.cab -f:* D:\temp
xcopy D:\temp\setup\sources\hr-hr\* D:\7\sources\hr-hr /cherkyi
xcopy D:\temp\sources\license\hr-hr\* D:\7\sources\license\hr-hr /cherkyi
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /Mount-Wim /WimFile:D:\7\Sources\boot.wim /index:2 /MountDir:D:\mount
xcopy D:\temp\setup\sources\hr-hr\* D:\mount\sources\hr-hr /cherkyi
xcopy D:\temp\sources\license\hr-hr\* D:\7\mount\license\hr-hr /cherkyi
copy D:\7\sources\Lang.ini D:\mount\sources\Lang.ini
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /Unmount-Wim /MountDir:D:\mount /commit
rd /S /Q D:\temp


#221
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag


Using dism mount-wim, dism add-package and dism unmount-wim.


C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /Mount-Wim /WimFile:D:\7\Sources\install.wim /index:1 /MountDir:D:\mount
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Add-Package /PackagePath:D:\lp.cab
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Gen-LangIni /Distribution:D:\7
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Set-AllIntl:hr-hr
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Set-TimeZone:"Central Europe Standard Time"
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Set-SetupUILang:hr-hr /Distribution:D:\7
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Gen-LangIni /Distribution:D:\7
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Get-Packages /Format:Table
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /image:D:\mount /Get-Intl
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /Unmount-Wim /MountDir:D:\mount /commit

mkdir D:\temp
expand D:\lp.cab -f:* D:\temp
xcopy D:\temp\setup\sources\hr-hr\* D:\7\sources\hr-hr /cherkyi
xcopy D:\temp\sources\license\hr-hr\* D:\7\sources\license\hr-hr /cherkyi
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /Mount-Wim /WimFile:D:\7\Sources\boot.wim /index:2 /MountDir:D:\mount
xcopy D:\temp\setup\sources\hr-hr\* D:\mount\sources\hr-hr /cherkyi
xcopy D:\temp\sources\license\hr-hr\* D:\7\mount\license\hr-hr /cherkyi
copy D:\7\sources\Lang.ini D:\mount\sources\Lang.ini
C:\Program Files\Windows AIK\Tools\amd64\Servicing\dism.exe /Unmount-Wim /MountDir:D:\mount /commit
rd /S /Q D:\temp



I already knew that..



#222
vigoprince

vigoprince
  • Member
  • 1 posts
  • OS:Windows 7 x64
  • Country: Country Flag

7Lite or 7Customizer here on msfn, know there's another tool on wincert forums i think.



Thanks a lot, now I know the right direction.

#223
ruchirrathore

ruchirrathore
  • Member
  • 1 posts
  • OS:Windows 7 x64
  • Country: Country Flag
@stefanRTR:
This is the first time I am writing on any forum, mainly because I am quite hopeful about Win Integrator. :rolleyes: :thumbup
I am using Win Integrator 1.2.0.7 and trying to modify a Win8 DP image. The image is clean, not modified before. I have WAIK for Win7 installed. OS on which I have installed Win Integrator is Windows 8.
It's able to identify contents of DVD and correctly shows as Windows Developer Preview x64. But at the end of copying contents from source DVD to folder in hard drive, it crashes and generate an error log. I tried various settings, and uninstalled / installed it in compatibility mode, even installed it on Windows 7 x64 too. But no difference. It still crashes....
This is as far as it could go till now.
Here is the error log attached with this post.
----------------------------------------------------------------
7:26:36 PM.432: Thread:1: Starting WinIntegrator, Version=1.0.9196.371, Culture=neutral, PublicKeyToken=861173525dbe9e68
7:26:36 PM.512: Thread:1: Running on Microsoft Windows NT 6.2.8102.0
7:26:36 PM.622: Thread:1: Privileges:
IncreaseQuota => Disabled
Security => Enabled
TakeOwnership => Enabled
LoadDriver => Disabled
SystemProfile => Disabled
SystemTime => Disabled
ProfileSingleProcess => Disabled
IncreaseBasePriority => Disabled
CreatePageFile => Disabled
Backup => Enabled
Restore => Enabled
Shutdown => Disabled
Debug => Enabled
SystemEnvironment => Disabled
ChangeNotify => EnabledByDefault, Enabled
RemoteShutdown => Disabled
Undock => Disabled
ManageVolume => Disabled
Impersonate => EnabledByDefault, Enabled
CreateGlobal => EnabledByDefault, Enabled
IncreaseWorkingSet => Disabled
TimeZone => Disabled
CreateSymbolicLink => Disabled

7:26:36 PM.622: Thread:1: ServicingPath = C:\Program Files\Windows AIK\Tools\Servicing\
7:26:36 PM.622: Thread:1: Using WIMGAPI from C:\Program Files (x86)\stefanRTR\Win Integrator\wimgapi.dll
7:27:02 PM.054: Thread:1: Wim selected:I:\sources\install.wim
7:27:05 PM.696: Thread:1: WimImageInfo Loaded:Windows Developer Preview_6.2.8102.0_x64_en-US
7:27:05 PM.696: Thread:1: WimImage selected:Windows Developer Preview_6.2.8102.0_x64
7:28:13 PM.263: Thread:1: Wim selected:I:\sources\install.wim
7:28:16 PM.665: Thread:1: WimImageInfo Loaded:Windows Developer Preview_6.2.8102.0_x64_en-US
7:28:16 PM.665: Thread:1: WimImage selected:Windows Developer Preview_6.2.8102.0_x64
7:28:28 PM.081: Thread:4: Copying from I:\ to G:\WinTemp
7:42:04 PM.000: Thread:4: WimImageInfo Loaded:Windows Developer Preview_6.2.8102.0_x64_en-US
7:42:04 PM.079: Thread:4: WimImageInfo Loaded:Microsoft Windows PE (x64)_6.2.8102.0_x64_en-US
7:42:04 PM.079: Thread:4: WimImageInfo Loaded:Microsoft Windows Setup (x64)_6.2.8102.0_x64_en-US
7:42:08 PM.164: Thread:4: EXCEPTION: LoadPackages2 Could not load type 'System.Threading.Parallel' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.
LoadPackages2 Could not load type 'System.Threading.Parallel' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

--- EXCEPTION #1/2 [TypeLoadException]
Message = “Could not load type 'System.Threading.Parallel' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.”
ExceptionPath = Root.InnerException
ClassName = System.TypeLoadException
HResult = -2146233054
Source = stefanRTR.Base
TypeLoadClassName = System.Threading.Parallel
TypeLoadAssemblyName = “mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089”
TypeLoadResourceID = -2146233054
StackTraceString = “
at stefanRTR.WimImage.SevenImage.c6pQaUKVNBcrOgwiJk.ucjJJg0OM()
at stefanRTR.ErrorHandling.r2VTgO9hpCVCSR1a8v(Object )
at stefanRTR.ErrorHandling.Catch(String comment, Action action)


--- Outer ---

--- EXCEPTION #2/2 [ArgumentException]
Message = “LoadPackages2 Could not load type 'System.Threading.Parallel' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.”
ExceptionPath = Root
ClassName = System.ArgumentException
InnerException = “Exception #1 at Root.InnerException”
HResult = -2147024809


7:43:09 PM.767: Thread:1: Closing
-----------------------------------------------------------------------------------------------
I am not a developer, or has much of a software background. So, my knowledge about internal coding and that geek stuff is pretty much limited. However, I am quite curious about Windows and keep on tinkering my C drive.. :P

My first choice was rt7lite, but that doesn't even identify Windows 8 iso image. And feature for feature, Win Integrator comes closest to that.
I have also tried Windows 7 Toolkit, and I was able to reduce iso size from original 3.63 GB to 3.49GB. But W7T doesn't give much flexibility and choices in removing components. Not at least as much as RT7Lite. I am looking for something better.

So, stefanRTR, can you please help me with this? Is WI compatible with Windows 8 DP and can it be used to reduce size of Windows 8 DP? :angel :huh:
Keep up the good work dear... :thumbup

#224
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,985 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

the tool is dead. Don't use the tool any longer
Posted Image

#225
czyt

czyt
  • Member
  • 4 posts
  • OS:Windows 7 x86
  • Country: Country Flag
a nice tool,thx!




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users



How to remove advertisement from MSFN