MagicAndre1981

Trace Windows 7 boot/shutdown/hibernate/standby/resume issues

1,275 posts in this topic

The resume of the nVIDIA driver takes 3 seconds which is a bit long. Try the 285.27 instead of the 280.26.

It seams you use the Hybrid Sleep which write the data also in the hiberfile.sys. And reading the data takes 7.4s to read the data.

0

Share this post


Link to post
Share on other sites

Hey.

I'm completely new to this forum, but my first impression is that you people are doing great work. I can hardly say thanks enough for the time and effort the contributors seem to put into helping others out.

In any case, here's my problem: I'm using Windows 7 Professional, 64 Bit, SP1, on a Thinkpad SL510. Not the fastest machine, but good enough. Until a few days ago, my startup time was around 1 minute, perhaps a bit above. Then suddenly, it increased to close to 3 minutes, and I can't tell why. I tried to un-install some programs that I thought caused trouble, updated my graphics driver, and finally ran Performance Analyzer, but I still can't tell what causes the delay.

Is there any chance someone could take a look at my files? If so, what should I upload? the .xml, the .etl (~400MB), or both?

Thanks a lot!

EDIT: I'm using the /German/ version of the OS, so some of the names in the log might not be immediately understandable to non-German users.

Edited by primvirlaux
0

Share this post


Link to post
Share on other sites

compress the etl file with 7Zip to a 7z archive and upload the 7z file. I'm German so I can read it ;)

0

Share this post


Link to post
Share on other sites

MagicAndre,

Thanks for looking at my trace. I didn't realize 285.27 was out. I updated it and turned off hybrid sleep. The only difference was when the computer hung on resume, resetting caused a hard reboot rather than a Windows resume. I was unable to get a good trace with this configuration so I turned hybrid sleep back on and got a new trace. It also hangs and I have to reset to get a Windows resume. Before sending you my first trace it looked like avg was causing a long delay so I removed it. I should have suspected the video driver since the monitor does not wake-up. I have since googled similar problems and it seems Nvidia has a history of problems with sleep and their drivers. I am running a 9800Gt card. I took a new trace with the new driver installed. When I tried to convert it to an .xml file, I got an error message which read "xperf: error: /tti: does not expect 1 argument(s)." so I am sending you a link to the compressed .etl file. Thanks for your help.

https://skydrive.live.com/?cid=0d8f89132a995684#!/?cid=0d8f89132a995684&sc=documents&uc=1&id=D8F89132A995684%21325

Greg

0

Share this post


Link to post
Share on other sites

Your boot prefetcher (ReadyBoot) is completely broken and doesn't work the way the prefetcher should. This casues the HDD to be busy all the time:

post-70718-0-17445800-1316957347_thumb.p

Install the hotfixes from here:

http://www.msfn.org/board/index.php?showtopic=152622

and optimize the Prefetcher:

http://www.msfn.org/board/index.php?showtopic=140262

The only difference was when the computer hung on resume, resetting caused a hard reboot rather than a Windows resume. I was unable to get a good trace with this configuration so I turned hybrid sleep back on and got a new trace. It also hangs and I have to reset to get a Windows resume.

That's how Hybrid sleep works. If something happens during standby Windows doesn't loose data it resumes from the hibernation file.

When I tried to convert it to an .xml file, I got an error message which read "xperf: error: /tti: does not expect 1 argument(s)."

https://skydrive.live.com/?cid=0d8f89132a995684#!/?cid=0d8f89132a995684&sc=documents&uc=1&id=D8F89132A995684%21325

Greg

this is the complete command: to get the overview XML:

xperf -i standby_BASE+CSWITCH+DRIVERS+POWER_1.etl -o summary_standby.xml -a suspend

This time the following USb device takes 5s to wake up and resume:

- <resumedevices start="163018123" duration="5922378">
- <device start="163582798" duration="4157050" name="USB\VID_04A9&PID_107F\101HJL">

From what I see this is USB Printing Support. So try to disconnect your Canon Inkjet i860 before resuming Windows and it takes 11s to read the hibernation file:

hiberread="11470000" 

But I can't see why it takes so long before you forced the reboot.

Here you must run Process Monitor, start the logging and next run the xbootmgr command to start tracing and this don't reboot. Wait several minutes. I had an issue with my PC where hibernation takes 10minutes to resume. Which the ProcMon log I was able to solve it.

0

Share this post


Link to post
Share on other sites

I tried suspending with the i860 unplugged. It still hung. I tried the command line for making an .xml file and got the following:

xperf: warning: applying restrictions of access for trace processing

xperf: error: summary_standby.xml: failed to open output file [0x80070005]

My command prompt starts with C:\Windows\system32>

I'm sorry. the process monitor sounds familiar but I don't remember how to run it. Can you enlighten me.

Again, thanks for all your help.

0

Share this post


Link to post
Share on other sites

Run the xboot comand in C:\Temp where you stored the data.

ProcMon is easy. Configure it to log the data into a file (not the pagefile), start the logging, next run the xbootmgr command. After you resumed, run ProcMon again and stop the logging. Now look at the duration column what takes so long. For me it was reading the MFT and hibernationfile, so I defragged the $MFT and the hibernation file and the issue was gone. I only saw this with ProcMon. the XML told be a driver was slow to resume, but it was the HDD.

0

Share this post


Link to post
Share on other sites

Your boot prefetcher (ReadyBoot) is completely broken and doesn't work the way the prefetcher should. This casues the HDD to be busy all the time:

post-70718-0-17445800-1316957347_thumb.p

Install the hotfixes from here:

http://www.msfn.org/board/index.php?showtopic=152622

and optimize the Prefetcher:

http://www.msfn.org/board/index.php?showtopic=140262

Thanks, going through the steps. Will report back if (and how much) it improves. One follow-up question though: should Superfetch be set to automatic start or automatic (delayed)?

0

Share this post


Link to post
Share on other sites

automatic. This is already done on your system.

Edited by MagicAndre1981
0

Share this post


Link to post
Share on other sites

automatic. This is already down on your system.

It was set to 'delayed' on my system (perhaps installation of SP1 changed the original value?), but in any case, I re-booted a few times with alternating values (automatic vs. automatic delayed) and it appears as if there's no noticeable difference in overall startup time, so in the end I set it, as you suggested, to (non-delayed) auto.

I also finished the other steps (installing the 3 hotfixes, then running the 6-times reboot/defrag optimization cycle) and my startup significantly decreased, although it's hard to say what exactly caused the improvement. Even before installing any of the hotfixes, just after a booting a few times, the startup time went down a lot, to 1 min. When I then installed the hotfixes it actually increased it again, and then, after the optimization/defragmentation, I'm down to about 1 minute, which is what I wanted. Thanks!

Here's the weird thing though: it fluctuates, quite a bit actually. Without installing any new programs or changing any settings, I just rebooted a few times, and at one time, I get a startup time (until start of explorer) of 50 secs, then, for no apparent reason, it takes 1:20. That's still kind of fast enough for me, but now I wonder what could be the reason for that.

0

Share this post


Link to post
Share on other sites

ok, I only see that the service was running so I thought it was set to automatic.

I highlighted Avast in the first trace. Look how long Avast takes this time to start.

0

Share this post


Link to post
Share on other sites

ok, I only see that the service was running so I thought it was set to automatic.

I highlighted Avast in the first trace. Look how long Avast takes this time to start.

Yeah, I was afraifd you would say that :P I kind of like Avast, so I guess I have to live with that delay. And a startup of 1 minute is quite good, I guess. Thanks again for helping me out here!

0

Share this post


Link to post
Share on other sites

Here are the trace and procedure monitor log. I tried reading the procmon log. There seem to be a lot of registry entries with problems. I don't know if that is normal. I know a lot of registry cleaners erase entries with zero values and then they show up again on the next reboot.

https://skydrive.live.com/?sc=documents&cid=0d8f89132a995684#!/?cid=0d8f89132a995684&sc=documents&nl=1&uc=2&id=D8F89132A995684%21327!cid=0D8F89132A995684&id=D8F89132A995684%21327

0

Share this post


Link to post
Share on other sites
Here are the trace and procedure monitor log.

Eye can't see? :(

skydrive.jpg

:)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.