MagicAndre1981

Trace Windows 7 boot/shutdown/hibernate/standby/resume issues

1,275 posts in this topic

The SSD is a OCZSSD2-1VTXLE100G. It sure seems compatible with the motherboard since absolutely all disk-related aspects of the system are operating perfectly. It is running in IDE mode so that I can still boot to and use the XP SATA HDD while I get the Win7 bugs ironed out.

I had a second identical SSD installed in another computer here. In this other computer (with an ABIT motherboard) this second SSD did not exhibit this problem. I tried moving the second SSD to the problem system and it behaved just like the first SSD; it too would hang when the system restarted from standby. That would seem to say that the problem is probably not a defective SSD.

The Gigabyte motherboard in the problem system, in addition to the six SATA ports hanging off the Intel ICH10R south bridge, also has two SATA ports hanging off a “Gigabyte SATA 2 chip” and I finally got around to trying the SSD off one of those two ports and I’m happy to report that it does not experience this problem when run in this manner. I have a solution that I can live with.

0

Share this post


Link to post
Share on other sites

The files are not complete. Those 2 etl files will normally be merged to a shutdown_BASE+CSWITCH+DRIVERS+POWER_1.etl. Which hardware/software do you use?

0

Share this post


Link to post
Share on other sites

The files are not complete. Those 2 etl files will normally be merged to a shutdown_BASE+CSWITCH+DRIVERS+POWER_1.etl. Which hardware/software do you use?

i am trying to solve reboot-shutdown issues in winpe3 environment. start menu butons doesn't work. After i read your topic i thought maybe it can be usefull to solve shutdown issues in winpe with explorer enabled shell too. :blushing: it is not a real system. because of it is live environment there is not a possibility to take the data after reboot. i could only take theese. can it be possible to find missing files only with that data? i have related topic in winpe section.

0

Share this post


Link to post
Share on other sites

This only works afaik on regular Windows versions, not PE.

0

Share this post


Link to post
Share on other sites

Tracing requires a system with full ETL support, and you will not have full ETL support in WinPE as it's just meant for preinstallation of Windows and a recovery environment. There is some (mostly for disk and network tracing), but nothing equaling what is required to do a boot or shutdown (or even perf) tracing.

0

Share this post


Link to post
Share on other sites

Just want to say thanks for the post. My windows 7 on ACER took 5 mins to go from ACER's screen to begin the boot process. The culprit turns out to be USBstor.sys (I think). I disable the USB and reinstall the driver, the problem went away.

0

Share this post


Link to post
Share on other sites

ok, great that you were able to find the cause :)

0

Share this post


Link to post
Share on other sites

Hello

I have a fresh install of Window 7 x64 thats a guest on a vmware ESX 4 host. Windows 7 has been patched and has QB 2010 installed. A couple of other smaller supporting apps have also been installed but basically the PC is just to be used for QB. Shut down is problematic and takes for ever. I did some searching via Google and came across this thread.

I've followed the the information for installing the MS tool to create a trace of whats going on in the system and I opened the files to see if I could find the issue without posting linking the file here.

However after looking at the program I realize I'm not savvy enough to look through the displayed information and determine what is the root cause of my issue.

Now my issue is getting the files out there on the internet so someone here can look at it and then assist hopefully me. The problem is that I'm not 100% sure I want this information out in the public as I'm unsure what can be gleamed from what I put out there to put the PC or the network its on in jeopardy. Can someone post up some more details about the contents of files and on making them public?

Also, do not have LiveID or a Rapidshare account. I can open an account on Rapid share but I did not want to do unless I was more comfortable with the this.

0

Share this post


Link to post
Share on other sites

zip the etl and use a password. Now upload it and send me the link per Personal Message.

0

Share this post


Link to post
Share on other sites

zip the etl and use a password. Now upload it and send me the link per Personal Message.

Your PM won't accept msgs?

What risk is there if you do not password protect it?

0

Share this post


Link to post
Share on other sites

zip the etl and use a password. Now upload it and send me the link per Personal Message.

Your PM won't accept msgs?

What risk is there if you do not password protect it?

Went ahead and passworded it, but how to I tell you the password?

Thanks!!!!

http://cid-5f415a3ae2fd7692.skydrive.live.com/redir.aspx?resid=5F415A3AE2FD7692!257&Bpub=SDX.Docs&Bsrc=GetSharingLink

Windows 7 Pro 64bit

It takes about 30 minutes to boot up after the windows 7 startupscreen comes and goes to black screen for 30 mins or so

ASUS P5N32-E SLI nvidia 680i chipset using onboard NIC and included sound card

Intel E6750

Corsair 2x1GB XMS2 TWIN2X2048-6400C5

SAPPHIRE 100186L Radeon X1950XT 256MB 256-bit GDDR3 PCI Express x16 HDCP Ready CrossFireX Support Video Card

It seems I started having trouble after trying to update ATI drivers and using ATI traytool and/or rays traytool to try to speed up fan on vid card. I attempted to remove but it doesn't seem to remove nicely perhaps.

Your help greatly appreciated!

0

Share this post


Link to post
Share on other sites

the log is not complete, from what I see (without extracting it). What is shown in the log?

0

Share this post


Link to post
Share on other sites

@supjack

I got your Trace and the shutdown hangs because of Clearing the Hibernation file (ZeroHiberFile). This takes 430 seconds.


<interval name="WaitForWinstationShutdown" startTime="5855" endTime="6200" duration="345" />
<interval name="PreShutdownNotification" startTime="6733" endTime="9562" duration="2829" />
<interval name="NtShutdownSystem" startTime="14569" endTime="450322" duration="435752" />
<interval name="ZeroHiberFile" startTime="14595" endTime="444415" duration="429820" /> <---------

But I only know the registry entry ClearPageFileAtShutdown to clear the pagefile, but not the hibernation file. Have you used any kind of "Tweaking" tools?

Edited by MagicAndre1981
0

Share this post


Link to post
Share on other sites

the log is not complete, from what I see (without extracting it). What is shown in the log?

how did you get into the file without the password?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.