MagicAndre1981

Trace Windows 7 boot/shutdown/hibernate/standby/resume issues

1,275 posts in this topic

I made another trace and process daemonu.exe from nvidia update seems to last till the end of shut down process. I disabled it, but still the same. If nothing can be done, I am going to install another OS (xp, or linux), to make sure problem is not windows 7 related.

send me the latest trace file, please.

Reinstalled system, step by step, one update, then restart, another update, restart, driver by driver, app by app, restart after every installation.

Everything good now, shutting down in less then 20 seconds.

It seems that I had multiple wireless adapter drivers, so they caused conflict, but not really sure what was the problem.

Thanks...

0

Share this post


Link to post
Share on other sites

It seems that I had multiple wireless adapter drivers, so they caused conflict, but not really sure what was the problem.

nice to hear that you fixed it :):thumbup

0

Share this post


Link to post
Share on other sites

set the startyp to manual/on demand and not disabled.

Can you provide instructions or a link to an example? I'm having difficultly understanding your suggestion.

0

Share this post


Link to post
Share on other sites

I believe that he is asking you to set the Superfetch Service Startup type to "Manual" instead of "Disabled". You can do this manually by going to Computer Management -> Services and Applications -> Services -> Superfetch. In the Pulldown box for Startup type select Manual then click Apply and OK. Then reboot the system, maybe a couple of times, then redo your tests and see if that makes any difference. You can then go back into Services and see if indeed the Superfetch service was started, or if just allowing for the possibility that it could be started allows the system to perform correctly. I understand your concern about having the service running effecting the life of the SSD, but doing this test just to see if indeed it is the problem will not effect it's life enough to notice. You can always disable the service again after completing the test. Once we can find what is causing your problem, then we can try and figure out how to prevent it.

Cheers and Regards

0

Share this post


Link to post
Share on other sites

I believe that he is asking you to set the Superfetch Service Startup type to "Manual" instead of "Disabled". You can do this manually by going to Computer Management -> Services and Applications -> Services -> Superfetch. In the Pulldown box for Startup type select Manual then click Apply and OK.

yes, this is what I want you to do.

0

Share this post


Link to post
Share on other sites

So, I'm currently booting into Windows 7 Pro 64-bit w/ a P9x79 Deluxe mobo, an Intel i7 3930K CPU, 4x4GB DDR3-1600, and an OCZ Vertex 3 240GB SSD...but it generally stays on the Windows loading screen for 15-20 seconds or more, when many others are telling me that their UEFI computers boot up in <8 seconds and that the Windows loading screen barely has time to flash, and I can't for the life of me figure out what could be causing the delay. I created a thread over in the Tom's Hardware forums and when I wasn't having much luck, one of the other members referred me to your thread, so I was hoping maybe you might spot something I've missed. I've attached the xml file from the trace boot, please let me know if there's anything else that might help figure out what I'm doing wrong.

0

Share this post


Link to post
Share on other sites

I can't see an attached file :unsure:

0

Share this post


Link to post
Share on other sites

Gah! What the hell? I swear I double checked that before I posted... Okay, I'm attaching it again, and if for some reason there's no file, than it's also on pastebin here: http://pastebin.com/EPZcvRgF

EDIT: ah...you have to click that button after selecting it...skipped that step before...

summary_boot.xml

0

Share this post


Link to post
Share on other sites

ok, your Windows takes 23s to boot to the desktop and 25s to boot completely:


<timing bootDoneViaExplorer="23344" bootDoneViaPostBoot="35044"

The PreSMSS phase takes too long (10s):

<interval name="PreSMSS" startTime="0" endTime="10429" duration="10429">

I can see that the driver for the Intel SATA controller takes too long to load (4s) and scaning for the attached devices also takes too log

<pnpObject name="PCI\VEN_8086+DEV_1D02+SUBSYS_84EF1043+REV_05\3+11583659+0+FA" type="Device" activity="Enum" startTime="4602" endTime="8683" duration="4080" prePendTime="4080" description="Intel® C600 Series Chipset SATA AHCI Controller" friendlyName="" />

<pnpObject name="PCIIDE\IDEChannel\5+3a447424+0+0" type="Device" activity="Enum" startTime="1032" endTime="4541" duration="3509" prePendTime="0" description="IDE Channel" friendlyName="ATA Channel 0" />

<pnpObject name="PCIIDE\IDEChannel\5+3a447424+0+1" type="Device" activity="Enum" startTime="1033" endTime="4541" duration="3508" prePendTime="0" description="IDE Channel" friendlyName="ATA Channel 1" />

Which IDE devices do you still use?

0

Share this post


Link to post
Share on other sites

I'm unfamiliar with PreSMSS or how to speed it up. As for devices, I have 1 SSD, 3 HDD's, and a BluRay writer connected to the Intel SATA connectors (I don't use the Marvell connectors). Then I've got 2 USB 3.0 external HDD's (one is a dual enclosure), and a USB 2.0 external HDD (Seagate FreeAgent, which also seems to be slowing down the boot, if I'm reading the results correctly...)

0

Share this post


Link to post
Share on other sites

PreSMSS is explained in the first post. here all drivers are loaded and the devices are started. Try to use the Marvell chip, too. Play a bit with combinations of connecting devices to Intel and Marvell. Does this make a difference?

Yes, your USB drive also slows down boot. So try to connect it to a different uSB port or attach it after boot.

0

Share this post


Link to post
Share on other sites

normal HDD likes your WD are not slow-downed by SATA2. No normal HDD is so fast. Only SSDs reach the limits.

You can try to update the BIOS and load the default setting and try to install never AHCI drivers. If nothing helps, try a PCIe card which provides additional SATA ports.

I deleted the active partition of WD 3 TB drive and created two partitions of 2 and 1 TB. The system now boots in less than 23 s. I guessing this has something to do with how Win 7 64 bit handles drives greater than the 2 TB limit for non 64 bit OS. Not real happy with this solution but I haven't found another one yet.

0

Share this post


Link to post
Share on other sites

ok, thanks for the feedback. I don't have a 3TB HDD so I can't really test this.

0

Share this post


Link to post
Share on other sites

Hi all,

Currently, I found my WIN7 has a issue that "UMBus Enumerator" appears in Device Manager slowly sometimes.

Please kindly refer to my attach files. umbus1.png is shown the beginning of bootup and wait 2~3 minutes the "UMBus Enumerator" will show up as shown in umbus2.png.

I tried to use below command to trace what is going on here, but the recording time is too short for this case.

xbootmgr -trace boot -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP

Does any way to increase the recording time? Or any one met this issue before?

Thanks.

post-359558-0-67852400-1344493969_thumb.

post-359558-0-99619600-1344493979_thumb.

0

Share this post


Link to post
Share on other sites

You can add the -postBootDelay XYZ Parameter to the command. This sets the post-boot delay (in seconds) before stopping the trace. So add 180-240s to capture 3-4 minutes after Windows booted completely.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.