Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Trace Windows 7 boot/shutdown/hibernate/standby/resume issues

Recommended Posts

Farcough    0

Hello, my PC is taking up to 4-5 mins to be fully ready after a boot. I have had a look through it and there seems to be a lot of stuff loading at the start, I have tried removing some of them but when I tried to run another trace I got the error message "Could not register for callback at the next boot", even after reinstalling the tool. Do you have any idea why it cant register now?

Thanks in advance for any insight.

Dropbox trace file

have pm'd password

Edit: The error message in the log is:

[2012/10/30-10:53:11.547] Performance Analyzer Power Transition Performance Testing Utility (Microsoft® Windows® Performance Analyzer) Version 6.2.9200 - © 2012 Microsoft Corporation. All rights reserved.

[2012/10/30-10:53:11.549] Detected Win7RTM physical (ReadyBoot) prefetcher; the SysMain service is auto-started.

[2012/10/30-10:53:11.549] Registering for auto-run with a 120000 msec delay...

[2012/10/30-10:53:11.549] Failed to open auto-run reg key with 0x00000002.

[2012/10/30-10:53:11.549] Could not register for callback at next boot.

Edited by Farcough

Share this post

Link to post
Share on other sites

our disk is busy during boot. I can see that Avast causes it. So remove it and try other tools. My favorite is NOD32.

Also cleanup your tools that launch at start (All the ASUS tools, Pando Networks Media Booster and others).

Next install the hotfixes from here:


and run the optimization from here:


Share this post

Link to post
Share on other sites
luca72c    0

Hello, i find this topic really VERY interesting and i hope someone among you good guys can help me with a very annoying issue i am experiencing in my system, that is driving me mad and that i could not solve in a month of tries. I own an HTPC based on the following configuration:

AMD Phgenom II X4 945 CPU


8Gb Corsair XMS3 DDR (2x4Gb)

Corsair AX-650 PSU

Samsung 256Gb 830 SATA SSD (2 partitions, system + data), AHCI SATA mode

Seagate 3Tb Barracuda SATA HDD with GPT table

ATI HD 5750 video card (2 displays attached)

Terratec Cinergy DVB-S2 card

Hauppauge HVR-2200 DVB-T card

Silverstone LC-16m case with Imon VFD + Imon Pad remote and USB card reader

Internal serial port, 1394 and eSATA ports enabled

Logitech USB Webcam, USB speakers and USB G110 illuminated keyboard

Toshiba laser mouse

Windows 7 x64 sp1, windows Media Center + DVBLink TV source, MST and various other programs.

Hibernation disabled

No overclok

I used this HTPC with much satisfaction from nearly 1 year, never experiencing an issue: i used to keep it in S3 mode 24/7 and it always got out from S3 state to record TV programs without any problem.

I installed the second drive, the 3Tb Seagate Barracuda, the first week of september. Then a day between the firsts of october i installed Mediaportal to give it a try; fearing system modifications by that software, i saved a backup image in my second drive. After a pair of days (or maybe at that time i noticed it for the first time), the issue has started.

The issue consists in a strange system freeze when the HTPC tries to wake up from S3: when the HTPC tries to exit S3 state the case led gets on, the HDD led blinks once or twice and then fans start running loudly and the HTPC freezes BEFORE the display can show any image (it remains black and goes to power saving mode) - power led on and HDD led off. No blue screen (the display is off). No memory dump. Keyboard's leds off. No manual crash dump possible. All i can do is keep power switch pressed until system complete shutdown.

But the really strange thing is that it happens ONLY once or twice a day, in the rest of the times the HTPC gets to wake up from S3 normally without any issue: it usually wakes up from S3 a number of times per day (7/8 minimum), but only 1/2 times the freeze issue happens (more often early in the morning or around twilight, seldom in other time slots)... Also, when on, the HTPC runs flawlessly as ever.

Thinking MP was guilty in some way, i restored the backup image but unfortunately the issue didn't disappear! So MP was no to blame... something different had happened to my PC...

I think you can understand that such an issue is really serious for an HTPC, because it makes it really untrustable for scheduled recording work: often recordings fail because of the HTPC freezing when it tries to resume... my wife is really sad about it...

Trying to solve the issue, i made the following:

running memtest and video card memory test - no error found

change nearly every MST options - no effect

reading carefully W7's event viewer logs after and between freezes - nothing found that could clarify the issue

changing all ACPI and power related BIOS options (C3 support, EUR 2013, CPU phases, DDR phases, shadowing, etc...) - no effect

updating BIOS and all drivers - no effect

disabling cool'n'quiet - no effect

unplugging Segate 3Tb HDD - no effect

unplugging all external and internal USB devices (except mouse) - no effect

uninstalling ATI video card and running with legacy drivers - no effect

disabling embedded Ethernet adapter - no effect

unplugging the second display (an HDTV) - no effect

tried to get a manual crash dump - not possible as when the issue happens the HTPC is freezed

Those tries took very long to be made, because every time i have to wait all day long for the issue to happen: it NEVER takes place if i wake up the HTPC after a few seconds sleep, seems like it needs at least a few hours of S3 state to take place. Unfortunatly this makes tracing the issue really difficult.

I got several tracings using the method described in this thread, the HTPC wakes up normally in that case but i can find nothing that can be blamed for the issue... maybe i don't know well what to look for... what i noticed is that if i try to trace using the DRIVERS flag, a blue screen appears at wake up (that blames hidusb.sys) if i keep my USB keyboard (an illuminated device) or USB speakers (that have media controls) plugged; if i unplug all USB devices the system exits S3 without blue screens and the tracing is succesful. BUT even this way after a day of sleep the issue takes place as well. No blue screen anyway if i avoid using the DRIVERS flag, even with all USB devices plugged. This is my last trace file, taken with USB devices unplugged and DRIVERS flag, so that you can have a look if you like to help me: https://rapidshare.com/files/1898367886/standby_BASE%2BCSWITCH%2BDRIVERS%2BPOWER_1.etl.

At this time i really don't know what i could do more: i reached my PC skills limit... a software related or W7 issue? An hardware compatibility problem? A power related misfunction? A background Windows update changed system behaviour? Maybe solar magnetic field increasing? I don't know if there is a more efficent way to debug the S3 resume and find out what really my HTPC is doing in the exact time it freezes, if you can suggest me anything it would be REALLY very appreciated! Please help me to find out what the hell happened in that SAD october days!!!

Thanks in advance and forgive my long post: i wanted to describe well my problem to help you analyze the issue...

Edited by luca72c

Share this post

Link to post
Share on other sites
luca72c    0

xbootmgr is only useful for detecting perf issues and not freezes.

try a different PSU and look for a BIOS update

I updated my BIOS 2 times last month and now i have the latest version, but no update was useful. My PSU is one of the best you can find on the market, i bought it to avoid this kind of issues... what else could i buy? Seasonic? But my PSU actually IS Seasonic-manufactured!

I understand what you say about xbootmgr, but as long as you know is there some other tool that can debug this kind of issues?

Thank you anyway!

Share this post

Link to post
Share on other sites
luca72c    0

to detect freezes you must create a dump of the complete system and analyze it with the Debugger, but this is very hard.

Could you help me in doing this? I don't know how to do it... how could i create a dump of the system while resuming from S3 if the PC freezes?

Share this post

Link to post
Share on other sites
dmntd    0

Hello MagicAndre1981, I can see you are into figuring out issues with boot and shutdown. Well, I have a frustrating situation with my shutdown, It is something that I installed but I don't change my installs very often so it confuses me on WHAT could be the issue.

I ran the tests you suggested and what I came back with was something I can't read into very well. Can you take a look? I think it has something to do with either Utorrent or maybe even STEAM..I can't figure it out. report Pm'd the pass.

Edited by dmntd

Share this post

Link to post
Share on other sites

<timing shutdownTime="17918" servicesShutdownDuration="5069">

Windows takes 18s to shutdown. Stopping the services takes 5s:

Here I can only see that the services.exe takes over 4s to close. And I think it is the Skype service:


Also Superfetch takes some time to stop.

Closing all running programs in your user session takes over 9s:

<sessionShutdown sessionID="1" startTime="322" endTime="9775" duration="9453">

Here is steam the cause:

<shutdownProcess name="Steam.exe" shutdownStartTime="4108" shutdownEndTime="8317" processEndTime="8310" shutdownDuration="4209"

steam takes over 4s to close.

Share this post

Link to post
Share on other sites
adnedarn    0

Hello! Thanks so much for your great help to everyone! Please allow me to join in the fun. =)

I have installed the hotfixes you have listed, installed WPT, and attempted to run the verbosereadyboot thing that reboots 7 times... Although, that fails after rebooting the 2nd or 3rd time and says it can't wait for...prefetcher? anymore and gives up. I've tried it twice. So, no I am here to see if you could provide me with some personalized help to speed my bootup time! I have uploaded my trace file and PMd you the link and hopefully haven't missed out any details that I'm supposed to give you.

Thanks so much!


Edited by adnedarn

Share this post

Link to post
Share on other sites

about he error check this:


Your boot is slow because the disk is busy all the time. 1st, check if your WDC WD3200JS runs in AHCI mode and next, try to uninstall ZoneAlarm. Also don't install the AMD CCC, it is a .net application and is slow to start. I can also see that the QBCFMonitorService and Windows Image Acquisition services (stisvc) start very slowly.

This maybe also related to the high activity.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.