MagicAndre1981

Trace Windows 7 boot/shutdown/hibernate/standby/resume issues

1,275 posts in this topic

Thanks! I'll look into the errors thing and see about re-running it. You are correct- my HDD stays active for a long time when I boot up.... I've moved my HDD to AHCI in BIOS, uninstalled ZoneAlarm, uninstalled AMD CCC, and disabled QBFMonitorService. I left Windows IMage Acquisition service since I do use my scanner/webcam/cameras often. (If I understand that service correctly I need those). Startup still seems super slow I've sent a new trace.

THANK YOU!

Andrew

Edited by adnedarn
0

Share this post


Link to post
Share on other sites

yes, boot is still slow. What I can see is that the enumeration of the IDE drives takes over 10s:

pnpObject name="PCIIDE\IDEChannel\4+3803e7e3+0+1" type="Device" activity="Enum" startTime="362" endTime="11862" duration="11501" prePendTime="0" description="IDE Channel" friendlyName="ATA Channel 1" />

Which IDE devices do you have connected?

The disk is still the issue. It is busy during boot nearly all the time. Remove as much as tools as you can.

A possible solution would be using a SSD as systemdrive and use the HDD only to store data on it.

0

Share this post


Link to post
Share on other sites

I see, Maybe I changed the sata settings for the wrong controller, I will double check (there are two on this motherboard). By tools do you mean spyware/antivirus/optimization stuff? I don't think there are anymore on here. I only had zonealarm and malwarebytes- malwarebytes I had removed a few days ago. For hardware I have a 1 dvd drive, 1 dvd rw, 1 floppy drive, 1 sata HDD, video card, audio card.

Thanks,

Andrew

Yep, I activated it on the wrong sata plugs.... So I did the other and got BSOD. Maybe I'll try plugging the drive into the other sata plug and see what that does.

Edited by adnedarn
0

Share this post


Link to post
Share on other sites

I mean remove all programs that you don't really need. If you need the all, buy a SSD. Your HDD is too slow to handle them all.

0

Share this post


Link to post
Share on other sites

Hi Magic and many thanks for helping us improving our computers!

I found you when searching for ways to reduce the boot time and I did it! from about 120 secs to about 30 secs... (I load avast after all services and I made also a few similar tweaks for Teamviewer etc.).

I still have two issues though:

1. I can't reduce the time needed for resuming from hibernation.... It's resuming in about 70 secs now...

First of all I had about 180 secs, then I stopped the superfetch service and got 70 secs... I made a few tweaks thanks to you and I re-enabled superfetch and managed to keep the 70 secs time.

My hibernation file is half of RAM (4/2=2 GB). and RAM in use is 1.5 GB when I put it to hibernate. I tried also the 100% and 75% size and the difference in resuming speed is pretty low if among them.

I still think it's too much time though only to resume from hibernation and first of all I would like to know only if it's possible to reduce it.

2. I don't have any event in the event viewer - windows - diagnostics performance - operational...They stopped logging one year ago, I cleared them, did all sort of things I found out on the internet but without success...

Also when opening the event file from Windows Prefetch/Ready boot folder it says I have some events lost and I should run some help query in the commander prompt (pretty useless), then the program is having a problem and it closes.

I had some time ago several partitions of my drive formatted by Mac Os and and LinuxOpenSuse, maybe they interfered with the MBR and that's why the problems? The respective time I was using a GRUB 2 bootloader.

In order to hibernate again I gave up both of them and everything is formatted in NTFS now.

My computer is a MSI G41M4-F MB with Intel G41 chipset, E5700 DualCore processor, 4 GB of RAM, 1 TB Sata II, Realtek Network/Sound, GeForce GT 7300.

Thank you in advance!

0

Share this post


Link to post
Share on other sites

Generate the hibernation XML and look at the suspend, resume and hibernation file read/write times. What is slow?

0

Share this post


Link to post
Share on other sites

thanks, i've generated it.

where should I look at?

0

Share this post


Link to post
Share on other sites

attach the XML here, please.

0

Share this post


Link to post
Share on other sites

reading the hibernation file is slow:


hiberread="90076000"

Is your HDD running in AHCI mode?

0

Share this post


Link to post
Share on other sites

I believe not as I don't find any option in Bios and I already updated it several days ago. :(

also the MSI doesn't tell anything as far as my level of understading... I still have SATA II but I don't know whether also AHCI.

can you please check: MSI G41M4-F is the Mobo.

should I reinstall the OS and choose AHCI when installing? (if it's possible, otherwise I leave it this way).

Thanks for advice.

0

Share this post


Link to post
Share on other sites

ok, your board has the ICH7, which doesn't support AHCI :(

Try to update the BIOS, maybe this helps.

0

Share this post


Link to post
Share on other sites

:(

still happy with the boot time. :) so no more hiberfil. :)

thank you very much!

0

Share this post


Link to post
Share on other sites

<timing pnpSystemStartDuration="578" pnpSystemStartEndTime="6076" pnpSystemStartStartTime="5498" pnpBootStartDuration="3621" pnpBootStartEndTime="3657" pnpBootStartStartTime="36" postBootDisturbance="9223372001875" postBootRequiredIdleTime="10000" osLoaderDuration="7514" bootDoneViaPostBoot="-1" bootDoneViaExplorer="24979">

I think it's OK. ;) Cheers!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.