MagicAndre1981

How to speed up boot process under Windows Vista or Windows 7

673 posts in this topic

This, along with setting the amount of cores used at boot in msconfig->boot->advanced options from the default 1 to 8 on my hp envy 14 has halved my boot up time to just under a minute :)

only xbootmgr did it, Windows ALWAYS uses all cores.

http://www.withinwindows.com/2008/08/09/tweaking-myth-increase-boot-performance-for-multi-core-users-with-msconfig/

@Marian

run sfc /Scannow to detect and fix missing Windows files.

0

Share this post


Link to post
Share on other sites

@MagicAndre1981: did that and it didn't help. But I did find a problem: the ImagePath of SysMain was incorrect, so I fixed that and I am not getting the "Error 2" error, but I am getting another error:

post-325794-0-44685700-1309785214_thumb.

Any thoughts on this?

0

Share this post


Link to post
Share on other sites

Oh, btw... I can't see to open Local Group Policy Object Editor either... :huh:

0

Share this post


Link to post
Share on other sites

it looks like you damaged the security configuration of your account. Create a new admin account and try it there again.

0

Share this post


Link to post
Share on other sites

I have installed all the updated for Windows 7 SP1 and Superfetch started to work again.

Then I tried to speed up the boot process, but an error occurred at the last step (I think), then I followed the steps presented here: http://social.msdn.microsoft.com/Forums/en/wptk_v4/thread/447f8512-9a33-43bd-a1cf-f0ca25b4b33a and the process worked fine! :) But bootDoneViaPostBoot shows -1 on both xml files.

0

Share this post


Link to post
Share on other sites

-1 measn the data are not in the file. By default xperf traces 120 seconds after the desktop was loaded. Add

-postBootDelay 240

to the command line

0

Share this post


Link to post
Share on other sites

@Marian

I feel your system files may be corrupt.

So, try this:

SFC.EXE /SCANNOW

Again in an elevated command prompt

0

Share this post


Link to post
Share on other sites

he already fixed the issue. Please read before posting

0

Share this post


Link to post
Share on other sites

@MagicAndre1981

I did not figure it out that the problem had been resolved.

I was just trying to help.

0

Share this post


Link to post
Share on other sites

[OT]you don't help if you post things twice if they are already fixed. So please read the older posts, too. I'm getting email notfications for all replies. So if you post over and over agaon things which are already solved I get a lot of useless notifications[/OT]

0

Share this post


Link to post
Share on other sites

Hi Andre,

I have eliminated as much as I could from startup, first using autoruns.

Then I ran the comand as suggested in your first post which appeared to run fine, and reduced my boot time from 3.5 minutes to 2 ( according to soluto)

But when I run the command to generate the second xml file I get following warning, and the xml file is empty

xperf: warning: applying restriction of access for trace processing 7931 Events were lost in this trace. Data may be unreliable.....

Some potential issues,

1] The readyboost services doesnt appear in services list (services.exe)

although it does appear in the registry and its start command is set to 0

2] OS shows as win7RTM in the xbootmgr.log although it is actually win7 with sp1 (home premium x64, acer oem)

3] This is the only other susipcious line in the log (I think)

Failed to save prefetcher data (C:\Windows\prefetch\layout.ini) in cab archive (stage 1, error 0)

I carried the whole procedure 3 times and the result is the same everytime, any ideas to what the problem maybe?

Regards,

V

Edit:

The warning suggests increasing the MinBuffers, MaxBuffers and BufferSize for xperf, I tried this but I still get the warning

Edited by volting
0

Share this post


Link to post
Share on other sites

I had the first hotfix installed already, installed the second.. and I ran the sfc / scannow which didnt find any problems

I ran the trace for two reboots and checked the first etl file, which gave the same error as before (when trying to generate the second xml file ) upon opening.

Edited by volting
0

Share this post


Link to post
Share on other sites

in this case the HDD is the bottleneck and very busy. Open the etl with a doubleclick and look under the DISK IO graph which programs assess the HDD

0

Share this post


Link to post
Share on other sites

I check all the graphs but I dont see any mention of what applications are accessing the hdd.

etldiskio.png

edit: Nevermind I see that you can right click the graph for more info, Ill check now...

Edited by volting
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.