MagicAndre1981

How to get the cause of high CPU usage by DPC / Interrupt

1,451 posts in this topic

Thank you. I have produced two tables (DPC CPU Usage Summary Table and Interrupt CPU Usage Summary Tables), saved as Excel CSV files. But then I read that you mentioned: "now wait a time while the high DPC and Interreupt usage occurs." Do you mean I should wait until the next time my CPU starts working furiously, causing delays, to run the second command to produce the summary tables? I have already run the first one: xperf -on latency and hopefully this is running now! (Pardon me - as mentioned before, I have no knowledge on these kind of issues...).

0

Share this post


Link to post
Share on other sites

open a command prompt all the time. And when you get the issue run the commands immediately, wait 1 minute to capture some data, next save them into the etl file.

0

Share this post


Link to post
Share on other sites

Hello!

MagicAndre1981, it's really cool that you are helping people here :-)

I've started getting problems with high DPC Latencies lately - when I listen to music my sound gets interrupted about every 30 seconds and that sucks really hard. I've followed all the instructions here and I've also googled a bit and tried some other things. So here are my findings:

I've got Alcohol 120 % installed and when the sptd.sys driver (which is installed with Alcohol 120 % and also with Daemon Tools) is loaded, the Windows Performance Tools kit shows an "Unknown" module which makes lots of DPCs. But when I disable the sptd.sys driver via these instructions I get other results - and it seems that the issue is related to my network adapters. If you look at the screenshots, you'll see that tcpip.sys makes a peak DPC of 90ms.

I've got LAN, WLAN, two virtual adapters installed by OpenVPN and one virtual adapter installed by VirtualBox. I've updated both the WLAN and the LAN drivers to the latest version. When I disable sptd and all of the network adapters, the problem is solved. Even with sptd enabled and all of the network adapters disabled there seem to be no problems.

However, I'd like to be able to surf the net and listen to music simultaneously...

It would be great if you could look into this. I'll only attach the screenshots at first but I can also upload the .etl files if you need them.

Here is the version with sptd disabled and all network adapters enabled:

post-300260-128104878224_thumb.png

And here is the version with sptd disabled and all network adapters disabled:

post-300260-128104892422_thumb.png

PS. I've also made logs with sptd enabled but these seem to be more helpful.

Edited by Mornel
0

Share this post


Link to post
Share on other sites

could please upload the trace file and send me the link?

0

Share this post


Link to post
Share on other sites

Hello André,

I've uploaded all the trace files, both with sptd enabled and disabled and with network enabled and disabled (4 files altogether).

Here is the link:

[edit: link removed]

Thanks a lot for your time!

Edited by Mornel
0

Share this post


Link to post
Share on other sites

The issue is the IppTimeout function from the TCPIP.sys. This causes in both cases some spikes. But without the network/sptd driver the CPU usage is ok. So you should update Alcohol and the VPN software. Also Winamp causes a high regular CPU usage.

0

Share this post


Link to post
Share on other sites

The issue is the IppTimeout function from the TCPIP.sys. This causes in both cases some spikes. But without the network/sptd driver the CPU usage is ok. So you should update Alcohol and the VPN software. Also Winamp causes a high regular CPU usage.

Thanks for your advice! I've tried upgrading Alcohol but it did not really help... so now I've uninstalled it and the sptd driver completely. Didn't use it that often anyway. OpenVPN and VirtualBox already are the newest versions. I've also upgraded the nvidia driver just to be sure. However, my problem is still not solved. Looking at DPC Latency Checker I still get spikes up to 19ms and an overall bad performance in the area of 2ms (it was mostly below 0.4ms last time with sptd and all network adapters disabled). And now the trace seems to show that usbport.sys is the new villain and enabling/disabling the network adapters does not seem to make any difference anymore... well, I've uploaded the new trace here: [edit: link removed]

Edited by Mornel
0

Share this post


Link to post
Share on other sites

does it also happen without the USB web cam? Have you installed the latest Intel mainboard drivers?

0

Share this post


Link to post
Share on other sites

Yeah, it also happens without the USB web cam (it's integrated in the notebook but I tried disabling it in the device manager). The Intel Chipset drivers are up-to-date (but they don't seem to include USB drivers anyway). Maybe I should try disabling all the USB Host Controllers in the Device Manager and see if that helps?

Also, what's more important when looking at the DPC CPU Usage Summary Table? The "Max Actual Duration" or the the "Actual Duration"?

Without the 90ms dpc calls I don't seem to get noticeable sound interruptions anymore but I'd still like to fix this problem completely...

0

Share this post


Link to post
Share on other sites

Hi,

I have a Gateway SX2800-07 desktop with Windows 7 64bit operating system. I have had the similar issue of occasional high system interrupts that slow my system down. I have updated all the drivers that I can find and still haven't solved the problem.

You can view my traces at www.willowproperties.net/1temp.pdf and I have attached that file here as well.

Any advice would be appreciated.

1temp.pdf

0

Share this post


Link to post
Share on other sites

I need the etl file. The usbport.sys is the cause. So update the mainboard drivers and all drivers for your USB devices.

0

Share this post


Link to post
Share on other sites

Thank you very much for this tutorial Andre :hello:

I have a HP Pavilion a1267c MS-7184 Mainboard with now unsupported ATISB400 chipset, no BIOS update past 3.47. The USBPORT.SYS was maxing one of my AthlonX2 4800+ cores after installing Windows 7 Pro. It didn't slow things down much but the CPU fan was at mid rpm all the time. I had to disable the USB's before things went bask to normal.

I am triple booting XP, Vista and 7 with no issues with the other OS's and thinking I will use a add in USB card and continue to test 7.

Posting this....I just realized that I will not be using any of the MOBO onboard devices now. My HD GPU, HD Audio, GB Net and now USB are all add in cards.

Again Thanks :D

0

Share this post


Link to post
Share on other sites

and using the other USB card solves it?

0

Share this post


Link to post
Share on other sites

Booting Win7 the USB disabled in device manager CPU 0&1 0-3% at idle. USB enabled CPU 0 is 15ish % and 1 is always 100% at idle.

To test this theory, I will try a Win7 supported chipset PCI 4 ? port USB adapter with 4 ? pin headers, to replace the MOBO's.

If this is a solution it would help others too.

I will post back the results.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.