MagicAndre1981

How to get the cause of high CPU usage by DPC / Interrupt

1,451 posts in this topic

I have discovered that my issue is with usbport.sys.

Hi,

with chipset drivers I mean the Southbridge/USB drivers from your mainboard. Which Mainboard do you have? Go to the homepage and look look for the latest drivers and install them.

You can also try to install the Update KB976972, which updates the microsoft USB drivers.

0

Share this post


Link to post
Share on other sites

I followed you're instruction on how to find the cause of high cpu usage. i completed it but I would like to also know where does the DPC_Interrupt.etl get saved I found mine in '' C:\ '' and it was named Kernel not DPC_Interrupt.etl. Is there a way to name it something else? or put it on the desktop initially during it's creation?

@sounds,

you did not run

xperf -d

to merge the trace to a new etl.

The Wdf01000.sys is a kernel driver framework provided by MS to simplify the coding of kernel drivers.

Are you running the latest drivers for your Pro Sonus device?

Download the latest drivers and install them:

http://www.presonus.com/technical-support/downloads/drivers-software/

André

0

Share this post


Link to post
Share on other sites

Hi,

with chipset drivers I mean the Southbridge/USB drivers from your mainboard. Which Mainboard do you have? Go to the homepage and look look for the latest drivers and install them.

You can also try to install the Update KB976972, which updates the microsoft USB drivers.

Andre,

Thank you for the timely response. How do I determine which Mainboard I have?

CanPCUser

0

Share this post


Link to post
Share on other sites

Download Diagnostic Tools like Everest Ultimate or SIW to see which mainboard do you have. Everest also provides links to the driver page.

0

Share this post


Link to post
Share on other sites

I followed you're instruction on how to find the cause of high cpu usage. i completed it but I would like to also know where does the DPC_Interrupt.etl get saved I found mine in '' C:\ '' and it was named Kernel not DPC_Interrupt.etl. Is there a way to name it something else? or put it on the desktop initially during it's creation?

@sounds,

you did not run

xperf -d

to merge the trace to a new etl.

The Wdf01000.sys is a kernel driver framework provided by MS to simplify the coding of kernel drivers.

Are you running the latest drivers for your Pro Sonus device?

Download the latest drivers and install them:

http://www.presonus.com/technical-support/downloads/drivers-software/

André

Thanks for taking the time to look into this, I ran xperf -d DPC_Interrupt.etl in a elevated CMD. I just edited my message I realize how to store the test else were on my drive.

Does it make sense that Wdf01000.sys is causing a function 0xfffff88000eb07f0 and the actual duration is 795.243263. I think this could be causing my dropout, but i don't understand this stuff to well.

As for the Presonus Firestudio drivers they are up to date for W7.

Any suggestion?

Edited by sounds
0

Share this post


Link to post
Share on other sites

Which device to you have exactly? The Firestudio only has beta drivers for Windows 7.

0

Share this post


Link to post
Share on other sites

Which device to you have exactly? The Firestudio only has beta drivers for Windows 7.

That's right they are beta. but it doesn't explain what windows 7 is saying in the health report. I have a high interrupt rate. it does it even if my firestudio is not plugged in.

0

Share this post


Link to post
Share on other sites

Hey MagicAndre,

I followed your very instructive method and got to the bottom of it (BTW, might be interesting to point out that one needs to de-select all in a custom install of the SDK, and then only select Development Tools - including the .NET part. Then it's only a 400Mb download).

My problem now lies in the fix. I am running W7 64-bit on a 27" iMac (late 2009 model) on a Core i7 (quad) using Bootcamp 3.0 with OSX SL 10.6..

I'm currently downloading the 3.1 update of Bootcamp, but am not hopeful that it will solve my problem.

The process you described yielded the very clear finding that ACPI.sys is causing the pb:

post-282536-126804943439_thumb.png

This is using up a full processor out of my 4 processors 100% of the time... My iMac is red-hot.

Now I have cruised the forums all over the place, but nobody has identified this particular problem with Boocamp on this iMac, although similar problems point to the fact that one should disable ACPI compatibility stuff. My problem?

My Windows 7 won't let me do that. I just don't get the Remove or Disable buttons when I go to these devices. I can't go in BIOS either as there is no BIOS, it's Bootcamp.

I'm at a loss here.

Just to be quite complete: I'm running Windows with Bootcamp, but also have VMware installed on the machine, using the Bootcamp intall when in OSX. I've tried disabling the VMWare stuff while in native W7 mode, but it doesn't change anything.

Any pointers?

(It's extremely rare that I post a question, usually the answer is already somewhere. In this case, it isn't, or I'm really not looking right.)

post-282536-126804943439_thumb.png

0

Share this post


Link to post
Share on other sites

I have a high interrupt rate. it does it even if my firestudio is not plugged in.

but the drivers are installed! What happens if you remove the drivers? If the issue gone?

My problem now lies in the fix. I am running W7 64-bit on a 27" iMac (late 2009 model) on a Core i7 (quad) using Bootcamp 3.0 with OSX SL 10.6..

I'm currently downloading the 3.1 update of Bootcamp, but am not hopeful that it will solve my problem.

The process you described yielded the very clear finding that ACPI.sys is causing the pb:

post-282536-126804943439_thumb.png

This is using up a full processor out of my 4 processors 100% of the time... My iMac is red-hot.

Now I have cruised the forums all over the place, but nobody has identified this particular problem with Boocamp on this iMac, although similar problems point to the fact that one should disable ACPI compatibility stuff. My problem?

My Windows 7 won't let me do that. I just don't get the Remove or Disable buttons when I go to these devices. I can't go in BIOS either as there is no BIOS, it's Bootcamp.

I'm at a loss here.

Just to be quite complete: I'm running Windows with Bootcamp, but also have VMware installed on the machine, using the Bootcamp intall when in OSX. I've tried disabling the VMWare stuff while in native W7 mode, but it doesn't change anything.

Any pointers?

You can't disable ACPI, this is required for using Windows >= Vista. Have you tried the latest Bootcamp?

0

Share this post


Link to post
Share on other sites

Hello MagicAndre1981,

This is my summary table, as you can see it's not good!

I'm using Windows 7 x64 - please help...

post-282630-126808682896_thumb.png

post-282630-126808682896_thumb.png

0

Share this post


Link to post
Share on other sites

Hi,

I've used a disassembler to look what the function does and from what I see, it belongs to the PowerManagment which control the new CoreParking ( http://thelazyadmin.com/blogs/thelazyadmin/archive/2009/02/05/what-s-new-in-2008-r2-core-parking.aspx, http://blogs.technet.com/mattmcspirit/archive/2009/05/07/seeing-core-parking-in-action.aspx, http://www.windowsitpro.com/article/john-savills-windows-faqs/q-how-can-i-enable-core-parking-in-my-system-without-changing-my-power-scheme-.aspx ) feature.

Can you disable it and check if the CPU usage is reduced?

André

0

Share this post


Link to post
Share on other sites

Hello André, Thanks for your quick reply :)

It was a bug in bios, I had a beta bios installed for sometime and forgot about it, I just reverted to latest stable bios and the problem is now gone.

0

Share this post


Link to post
Share on other sites

Hi,

great to hear, that it is fixed. So the BIOS had some trouble with the CoreParking feature.

Have fun with your Windows now :)

0

Share this post


Link to post
Share on other sites

My problem now lies in the fix. I am running W7 64-bit on a 27" iMac (late 2009 model) on a Core i7 (quad) using Bootcamp 3.0 with OSX SL 10.6..

I'm currently downloading the 3.1 update of Bootcamp, but am not hopeful that it will solve my problem.

The process you described yielded the very clear finding that ACPI.sys is causing the pb:

post-282536-126804943439_thumb.png

This is using up a full processor out of my 4 processors 100% of the time... My iMac is red-hot.

Now I have cruised the forums all over the place, but nobody has identified this particular problem with Boocamp on this iMac, although similar problems point to the fact that one should disable ACPI compatibility stuff. My problem?

My Windows 7 won't let me do that. I just don't get the Remove or Disable buttons when I go to these devices. I can't go in BIOS either as there is no BIOS, it's Bootcamp.

I'm at a loss here.

Just to be quite complete: I'm running Windows with Bootcamp, but also have VMware installed on the machine, using the Bootcamp intall when in OSX. I've tried disabling the VMWare stuff while in native W7 mode, but it doesn't change anything.

Any pointers?

You can't disable ACPI, this is required for using Windows >= Vista. Have you tried the latest Bootcamp?

So, problem identified and circumvented for now, not solved. It turns out that this crazy processor hogging happens when I connect a headset to the headset jack. Plug it in, boom, CPU at 100%. Unbelievable.

As it happens, I also had a huge network latency problem (my 10Mbps connexion wouldn't go past 300Kbps - i.e. instead of 2-3Megabytes per second I'd get 10Kbytes per second download). I thought it was related. In fact it wasn't.

So I have also, eventually, connected an external WiFi device (Belkin F5D8053) and it works. I think it's very clear now that the Atheros WiFi installed on the 27" Core i7 basically doesn't work with W7 Bootcamp. I have reinstalled drivers and so on (BTW, finding Atheros drivers on the net is close to impossible). Will have to wait until they release new drivers before I enable it again. It works like a breeze on Snow Leopard, though.

I'll investigate the headset freaky issue. Will resintall or change drivers and see what happens. Will keep you posted.

Thanks for posting.

0

Share this post


Link to post
Share on other sites

this is a really strange issue with your headset. Ok, post us what you found out later :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.