MagicAndre1981

How to get the cause of high CPU usage by DPC / Interrupt

1,451 posts in this topic

Hi Andre: Your tuotrial is truly magical. It worked like a charm using both xperf and Latency Monitor. After running both test, it seems like the culprit is ATAPORT.sys. I have searched this thread for all instances of ATAPORT.sys to see if someone posted a solution. Unfortunately it seems like there was no real solution... unless i just didnt understand what people did to fix theirs.

My version of the drivers is "ataport.SYS", "6.1.7600.16385 (win7_rtm.090713-1255)"

I am using a Hitachi Deskstar™ 5K3000 for my internal HD and a Western Digital WD My Book 1110 USB External Drive.

I have had this set up now for months with no problems until recently my music was popping and hissing and then I noticed one core at full blast which eventually led me to this thread. Are there any other possibilities other than what I have read so far to alleviate this problem? I realy and truly scoured the net for a solution and tried using this thread to do it myself but i am lost at the moment.

post-335125-0-76729300-1319019599_thumb.

post-335125-0-40704200-1319019607_thumb.

0

Share this post


Link to post
Share on other sites

ataport is the IDE driver. Do you run your IDE DVD drives or HDDs in PIO mode for example?

0

Share this post


Link to post
Share on other sites

Hi Andre,

Great tutorial you made there!

I have some serious audio dropouts, and distortions, which is pretty bad since I making music is my hobby.

When I run latencymon, I have multiple drivers and processes, which looks like they cause dpc spikes.

I have tried to disable the ethernet card, but that does not help. I don't really know where to go from here.

Do you think there´s hope for me, or am I totally screwed on this?

post-335159-0-01308700-1319033638_thumb.

0

Share this post


Link to post
Share on other sites

please run the xperf trace for 60s and upload the compressed DPC_Interrupt.etl

0

Share this post


Link to post
Share on other sites

Yes. In Device Manager I have two ATA Channel 0.

The 1st one says ATA Disk in PIO Mode 4 (I beleive that is the Hitachi)

The 2nd one says 'Target Id 0, ATAPI Cdrom in Multi-Word DMA Mode 2' & 'Target 1, ATAPI Cdrom PIO Mode 4'

I did notice that my device manager does not have a SATA controller listed under the IDE ATA/ATAPI Controller group. Could this be the reason. All of my internal drivers are SATA and the Hitachi is a SATA2

Edited by BaSubScribe
0

Share this post


Link to post
Share on other sites

delete both drives in device manager and reboot. Windows installs the drivers again. Windows switches to PIO mode if there are error when using DMA.

0

Share this post


Link to post
Share on other sites

Already solved it!!!!!! For now at least :>) I didnt need to delete the drives. Just use the check box in device manager. After ur suggestion i did a search on PIO mode and found an article explaining why in particular with the sleep state which i use ALL the time. So i made the corrections in registry and have not had a problem thus far. Will reboot and place in sleep mode to see if it comes back but the registry fix should prevent it from happening again.

Gotta say it officailly.... You are DA BOMB techie!!!!! Truly living up to your name as Magic Andre !!!!!!!!!!!!!!!!

One last thing befoe i go. any reason why my device manager does not have a SATA controller listed under the IDE ATA/ATAPI Controller group. All of my internal drivers are SATA and the Hitachi is a SATA3 (6Gb/s) It says UltraDMA 6 an i feel like im not getting anywhere near the performance of my board and disk drive.

If by chance I have to delete them. Will i loose the drive letter or have trouble booting if i delete all my internal drives?

Here is the link to the registry fix

http://support.microsoft.com/kb/817472

Let me fix it myself

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in Windows

Follow these steps, and then quit Registry Editor: 1.Click Start, click Run, type regedit, and then click OK.

2.Locate and then click the following key in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001

3.On the Edit menu, point to New, and then click DWORD Value.

4.Type ResetErrorCountersOnSuccess, and then press ENTER.

5.On the Edit menu, click Modify.

6.Type 1, and then click OK.

Follow these steps, and then quit Registry Editor: 1.Click Start, click Run, type regedit, and then click OK.

2.Locate and then click the following key in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002

3.On the Edit menu, point to New, and then click DWORD Value.

4.Type ResetErrorCountersOnSuccess, and then press ENTER.

5.On the Edit menu, click Modify.

6.Type 1, and then click OK.

Note The numbered subkeys that are listed earlier correspond to the primary and secondary IDE channels on a computer that contains a single IDE controller. If your computer contains two IDE controllers, the numbered subkeys for the primary and secondary IDE channels for each of the two controllers may be:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0003

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0004

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0005

To verify that you have located the correct subkey, verify that the

DriverDesc

value for the subkey contains the string value "Primary IDE Channel" or the string value "Secondary IDE Channel."

Back to the top

Edited by BaSubScribe
0

Share this post


Link to post
Share on other sites

If it works now don't do anything. leave it and be happy.

0

Share this post


Link to post
Share on other sites

G'day guys, i know this isn't a hot topic or anything but...

I've gotten to the stage where it shows me the DPC CPU usage Summary table, my problem is i have no idea on what "ntoskrnl.exe" is.. If i google it it comes up with "FIX BSOD"..

Infact there's lots of stuff in there.

What should i do about this? Would a reformat be easier? I don't really want to, but this sound problems getting to me..

Is anyone able to help me with my problem? :/

post-338009-0-28758100-1321619789_thumb.

Edited by MattMatt
0

Share this post


Link to post
Share on other sites

load the symbols and expand the ntoskrnl.exe node until you see a name in the column "function".

0

Share this post


Link to post
Share on other sites

load the symbols and expand the ntoskrnl.exe node until you see a name in the column "function".

Gah! So many things causing DPC/Interrupt.. They're mostly windows services too.. Going to reformat on Monday it's easier and should fix it..

Thanks for the support anyways!

0

Share this post


Link to post
Share on other sites

can you please zip the ETL and upload it (mediafore.com, Rapidshare.com)?

0

Share this post


Link to post
Share on other sites

can you please zip the ETL and upload it (mediafore.com, Rapidshare.com)?

Okay sure!

Here

The password is MagicAndre1981.

Thanks for your help! :)

0

Share this post


Link to post
Share on other sites

what are your power plan settings? It looks you have an issue with the power saving features of your Intel Core 2 Quad. The intelppm.sys and the PpmPerfApplyProcessorState function from the kernel cause the DPC usage.

0

Share this post


Link to post
Share on other sites

what are your power plan settings? It looks you have an issue with the power saving features of your Intel Core 2 Quad. The intelppm.sys and the PpmPerfApplyProcessorState function from the kernel cause the DPC usage.

It was just on "High Performance"

Could this be related to that i upgraded the processor from a Core 2 Duo to a Core 2 Quad?

What should i be changing?

Wow changing it to "Balanced" fixed it, there's still a few spikes but videos are watchable now!

You're a genius! (;

EDIT: Nope, it's ALOT better. But not quite there..

Edited by MattMatt
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.