MagicAndre1981

How to get the cause of high CPU usage by DPC / Interrupt

1,451 posts in this topic

the nvlddmkm.sys causes the high CPU usage. it is version 8.17.12.9551 which should be the latest beta driver version. So go back to the latest WHQL driver 285.58 and look if this fixes it. I can also see that it shares the IRQ with the USB controller. So try to put your NVIDIA GeForce GTX 460 into a different PCI-E slot which doesn't share IRQ with other devices.

0

Share this post


Link to post
Share on other sites

the nvlddmkm.sys causes the high CPU usage. it is version 8.17.12.9551 which should be the latest beta driver version. So go back to the latest WHQL driver 285.58 and look if this fixes it. I can also see that it shares the IRQ with the USB controller. So try to put your NVIDIA GeForce GTX 460 into a different PCI-E slot which doesn't share IRQ with other devices.

thank you for the reply.

I have a SLI system with two gtx460 on it.

today I removed one and put it into slot 1 and this afternoon I swapped the slot with both cards (one card in slot2) didnt change anything.

after systemrollback I went back to 285.62 which is the latest whql driver but I'll check this out again. one moment.

Edited by littlegoliath
0

Share this post


Link to post
Share on other sites

ok, test it and tell me please if the driver rollback fixed it or not.

0

Share this post


Link to post
Share on other sites

still the nvidia driver. Does it also happen if you remove 1 of the 2 cards?

@doveman

I see you also read the topic. Is your issue fixed with disabling the effects?

0

Share this post


Link to post
Share on other sites

still the nvidia driver. Does it also happen if you remove 1 of the 2 cards?

still occuring, 1 gtx460 in pci-e slot 2:

http://www.mediafire.com/?9ifs917zk339bp6

still occuring when I put the other card into slot 2. did a further rollback on 275.33 with both cards, no success. the error dissappear when I deactivate the driver in the device manager.

Edited by littlegoliath
0

Share this post


Link to post
Share on other sites

which motherboard do you use? I can't see this from the trace. Also which USB devices do you use? Try to plug them into a different port (not the one which shares the IRQ).

0

Share this post


Link to post
Share on other sites
@doveman

I see you also read the topic. Is your issue fixed with disabling the effects?

Hey,

Unfortunately there's no EAX settings to change in Deus Ex. I haven't had time yet, but I plan to make a trace with a game that does have a setting to disable EAX for you to look at to see if it shows the same problem.

0

Share this post


Link to post
Share on other sites

which motherboard do you use? I can't see this from the trace. Also which USB devices do you use? Try to plug

them into a different port (not the one which shares the IRQ).

Good morning!

its an ASROCK P55 DELUXE3

http://www.asrock.com/mb/overview.de.asp?Model=P55%20Deluxe3

USB devices plugged in:

Logitech Illuminated Keyboard with SetPoint Software Vers. 6.32.7, Driver 5.33.14

http://www.logitech.com/de-ch/434/4740?section=downloads&bit=&osid=14

Kinzu Steelseries Optical Gaming Mouse with Software Vers. 1.0.10, Firmware 2.9.20

http://steelseries.com/support/downloads

on USB23.

Plugged the devices into front USB, then NEC USB 3.0 Controller:

No changes.

http://www.mediafire.com/?0y8hp3ca1wmmqxn

0

Share this post


Link to post
Share on other sites

still the same. IRQ is still shared with your GPUs and Intel USB controller. Disable the Intel USB controller in the device manager if you use the USB3.0 ones. Does this make a difference?

0

Share this post


Link to post
Share on other sites

still the same. IRQ is still shared with your GPUs and Intel USB controller. Disable the Intel USB controller in the device manager if you use the USB3.0 ones. Does this make a difference?

weird. when I deactivate the the 3B3C Controller which shares IRQ with the graphic card, it disables the usb 3.0 ports, but usb 2.0 still working, so I plugged the keyboard and mice back on a usb 2.0 port.

But no effects:

http://www.mediafire.com/?l1b727a6yyqj56b

0

Share this post


Link to post
Share on other sites

try to stop tools like Rainmeter and RocketDock.exe. Does this make a difference? Do you also have the issue if you remove 1 460GTX and only use 1 card (no SLI)?

0

Share this post


Link to post
Share on other sites

try to stop tools like Rainmeter and RocketDock.exe. Does this make a difference? Do you also have the issue if you remove 1 460GTX and only use 1 card (no SLI)?

I already had only 1 460GTX without SLI running in the last few tests.

Disabled most of the tools, no effect. removed the 460gtx from slot 2, put the 2nd 460gtx back into slot 1, run the system without tools, no effects.

http://www.mediafire.com/?usrzs2867obm6fe

0

Share this post


Link to post
Share on other sites

please uninstall all nVIDIA drivers and rollback to the original inbox drivers of Windows 7. MS provides debug symbols for those driver version and maybe I can see more.

0

Share this post


Link to post
Share on other sites

please uninstall all nVIDIA drivers and rollback to the original inbox drivers of Windows 7. MS provides debug symbols for those driver version and maybe I can see more.

here you are, removing all nvidia drivers and prevent Win7 to download and install any nvidia drivers removes the error, its like disabling the graphic card.

http://www.mediafire.com/?ernlmigjmjm3f84

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.