MagicAndre1981

How to get the cause of high CPU usage by DPC / Interrupt

1,451 posts in this topic

Hi andre, i registered to this board just cause i figured you have just the tools i need.

To start things of, lately i've been having wierd spikes in game with around 0.2s freeze every now and then (much like microstuttering, but not quite), so i checked my resource monitor and i noticed something i've never seen before; System interrupts process. Now i understand this is bad, and i believe you have the solution for me!

I tried both LatencyMon and xperf but since i didnt quite catch what to look for it didnt do much good for me, so here i'll upload the .etl file for you to look at!

DPC_interrupt.zip

My specs:

i5 2500k

GeForce GTX 670

8GB Corsair 1600MHz ram

Fractal Design Integra 650W

MSI P67A-C45

Usb devices:

SteelSeries Xai (Mouse)

PS/2 Devices:

Qpad MK-50 (Keyboard)

Thanks in advance! :) <3

0

Share this post


Link to post
Share on other sites

I have problems with my battery but it didn't make my computer laggy before. It even shows a warning when I boot the PC but I don't have money to buy another one and also I can't see the connection; if I remove it it will solve the high cpu usage?

yes, disable the battery or remove it and only use AC power.

I tried both LatencyMon and xperf but since i didnt quite catch what to look for it didnt do much good for me, so here i'll upload the .etl file for you to look at!

DPC_interrupt.zip

you have ISR (interrupt) spieks of the ataport.SYS driver. Do you run all your drives in AHCI mode or do you use the IDE mode?

0

Share this post


Link to post
Share on other sites

I have problems with my battery but it didn't make my computer laggy before. It even shows a warning when I boot the PC but I don't have money to buy another one and also I can't see the connection; if I remove it it will solve the high cpu usage?

yes, disable the battery or remove it and only use AC power.

I tried both LatencyMon and xperf but since i didnt quite catch what to look for it didnt do much good for me, so here i'll upload the .etl file for you to look at!

DPC_interrupt.zip

you have ISR (interrupt) spieks of the ataport.SYS driver. Do you run all your drives in AHCI mode or do you use the IDE mode?

Now that you mentioned it, i did have a overclock malfunction not to long ago and had to reset cmos, and it seems it reverted the drives back to IDE mode, i swapped back to AHCI again but the process is still there :( However im playing BF3 right now and it dont seem like i have the stutter anymore, will edit if i notice it again.

edit: nope, it's not gone. What i've done up til now was changing back to ACHI mode, swapped the drives SATA ports a couple of times. I also tried resetting CMOS and immediatly put the AHCI mode on, no progress either... MEHHHHHH

What can i possibly try now ? I'm considering doing a fresh install, but i'm pretty scared it wont make a difference. What would you do in this situation? :P

note: In idle, the System Interrupts is no more than 0.5-1% usage on average, but when i play games that 1% bumps up to 3% and its all on Core0 which makes the game stutter from time to time... Pls halp!

Edited by enzity
0

Share this post


Link to post
Share on other sites

Hey Andre!

I'm running into some issues with my system and I am starting to get desperate. I've been trying to fix this issue for the past 4 hours without any luck.

I've managed to locate that my ACPI.sys file is getting DPC errors a lot.

So far, I've tried: Updating everything Windows wanted to update.

Tried (Unsucessfully) to update BIOS. For some reason it just won't flash.

I've tried all 3 power modes that come with my system. All 3 power modes that come with Windows.

Have tried updating all drivers I could find, but they all come back up to date.

Here's my Xperf file, hope you can make some use of it, as I just can't. http://www39.zippyshare.com/v/28911232/file.html

Win7 64Bit.

i5 3770k

16Gb Ram

Gtx 670

(Note: I will be at work until 2PM GMT, so no rush in responding until then.

0

Share this post


Link to post
Share on other sites

edit: nope, it's not gone. What i've done up til now was changing back to ACHI mode, swapped the drives SATA ports a couple of times. I also tried resetting CMOS and immediatly put the AHCI mode on, no progress either... MEHHHHHH

What can i possibly try now ? I'm considering doing a fresh install, but i'm pretty scared it wont make a difference. What would you do in this situation? :P

note: In idle, the System Interrupts is no more than 0.5-1% usage on average, but when i play games that 1% bumps up to 3% and its all on Core0 which makes the game stutter from time to time... Pls halp!

make a new tarce, this timw when using AHCI.

I've managed to locate that my ACPI.sys file is getting DPC errors a lot.

So far, I've tried: Updating everything Windows wanted to update.

Tried (Unsucessfully) to update BIOS. For some reason it just won't flash.

I've tried all 3 power modes that come with my system. All 3 power modes that come with Windows.

Have tried updating all drivers I could find, but they all come back up to date.

I can't really use the trace because it misses several events Increasing the buffer can help. Please run this:


xperf -on latency -stackwalk profile -buffersize 2048 -MaxFile 256 -FileMode Circular && timeout -1 && xperf -d DPC_Interrupt.etl

0

Share this post


Link to post
Share on other sites

Comes up with an error: "xperf: error: -on: does not expect 4 argument(s)."

What am I doing wrong? XD

0

Share this post


Link to post
Share on other sites

it works fine for me. copy and paste the complete command into the command prompt

0

Share this post


Link to post
Share on other sites

@Furyclaw

we posted the same time.

The new tarce shows you have high CPU usgae caused by he ACPI driver. ACPI.sys!OSNotifyDeviceWake looks like Windows has issues to enable devices after they were send to sleep. so disable the powersaving options in device manager for all devices.

0

Share this post


Link to post
Share on other sites

@Andre

I will definately try that out when I get home. Power management is getting to be an annoying thing in this new rig.

Will get back to you with the results. Thank you for your patience and expertise.

0

Share this post


Link to post
Share on other sites

Not many good news :(

I came home and tried to disable power saving on all my units that had the option in Device Management. This didn't have any difference. I also managed to get my bios updated to the newest version available on the website, but this also have not proved useful.

Still sitting at 33-36% CPU usage when just having a webpage up. are there any more steps we can do to resolve this?

0

Share this post


Link to post
Share on other sites

yes, disable the battery or remove it and only use AC power.

I removed it and the CPU still remains at a minimum of around 60%

0

Share this post


Link to post
Share on other sites

@both

make new traces and upload them.

0

Share this post


Link to post
Share on other sites

I've just installed a brand new copy of Win7, in a desperate attempt to make this s*** work. Can barely play BF3 with this rig at 1368, Low Gfx.

Same problems are occuring, but might have moved location. Hopefully you can help. Working on installing new drivers as we speak.

http://www40.zippyshare.com/v/87667420/file.html

0

Share this post


Link to post
Share on other sites

it is the same APCI issue again. ry to switch to the powerplan "High Perfomance". this disables the power saving options. Does this fix the issue?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.