Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

How to get the cause of high CPU usage by DPC / Interrupt

- - - - -

  • Please log in to reply
1419 replies to this topic

#1176
jords16

jords16
  • Member
  • 9 posts
  • Joined 10-April 13
  • OS:Windows 7 x64
  • Country: Country Flag



The BIOS update doesn't seem to have fixed anything.


yeah, you have again spikes:

Total = 7117 for module tcpip.sys
Elapsed Time, >     4096 usecs AND <=     8192 usecs,      0, or   0.00%
Elapsed Time, >     8192 usecs AND <=    16384 usecs,      8, or   0.11%
Total,                                                  7117

Have you tried it without the discrete GPU?

Do you mean moving the card around? I need the GeForce for the games I play. The onboard video is of no use for games.


yeah!! i tried it w/ nvidia graphics card installed...


How to remove advertisement from MSFN

#1177
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,128 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

Do you mean moving the card around? I need the GeForce for the games I play. The onboard video is of no use for games.


only tst it without the discrete GPU. Do you still have issues or not?

yeah!! i tried it w/ nvidia graphics card installed...


this reply was not for you. Does updating the nvidia network driver fixes it or not?
Posted Image

#1178
jords16

jords16
  • Member
  • 9 posts
  • Joined 10-April 13
  • OS:Windows 7 x64
  • Country: Country Flag


Do you mean moving the card around? I need the GeForce for the games I play. The onboard video is of no use for games.


only tst it without the discrete GPU. Do you still have issues or not?

yeah!! i tried it w/ nvidia graphics card installed...


this reply was not for you. Does updating the nvidia network driver fixes it or not?

sorry!!! i did not try it yet!!! if i will downgrade my OS to windows xp... can this be fixed??

#1179
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,128 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

why do you want to go back to XP? XP is dead. Do you still have issues after updating the nvidia driver or not?
Posted Image

#1180
Bluebomber4evr

Bluebomber4evr

    Newbie

  • Member
  • 10 posts
  • Joined 24-March 13
  • OS:Windows 7 x64
  • Country: Country Flag


Do you mean moving the card around? I need the GeForce for the games I play. The onboard video is of no use for games.


only tst it without the discrete GPU. Do you still have issues or not?

Sorry, I'm not sure what you mean by "discrete GPU." Is this referring to the GeForce card?

#1181
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,128 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

yes, I refer to the Geforce. Remove the card and only use the internal GPU. Are the issues gone?
Posted Image

#1182
haterz111

haterz111
  • Member
  • 6 posts
  • Joined 16-April 13
  • OS:Windows 7 x64
  • Country: Country Flag
i have high dpc on a fresh install it gets to the point i cannot move my mouse or scroll a webpage

Highest ISR routine execution time (µs): 115.437578
Driver with highest ISR routine execution time: dxgkrnl.sys - DirectX Graphics Kernel, Microsoft Corporation

Highest reported total ISR routine time (%): 0.038439

Highest DPC routine execution time (µs): 6753.189634
Driver with highest DPC routine execution time: storport.sys - Microsoft Storage Port Driver, Microsoft Corporation

Highest reported total DPC routine time (%): 0.072144
Driver with highest DPC total execution time: rspLLL64.sys - Resplendence Latency Monitoring and Auxiliary Kernel Library, Resplendence Software Projects Sp.river with highest ISR total time: storport.sys - Microsoft Storage Port Driver, Microsoft Corporation

ive tried changing my hd drivers/ disconnecting all drives and using a known good drive
please help



sabertooth 990fx
amd 8350
nvidia 660ti
4x4 corsair 1333mhz
corsair tx750 v2
crucial m4 128 gig ssd

Edited by haterz111, 16 April 2013 - 02:46 AM.


#1183
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,128 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

Highest DPC routine execution time (µs): 6753.189634
Driver with highest DPC routine execution time: storport.sys - Microsoft Storage Port Driver, Microsoft Corporation


this looks like HDD/SD issues. Which AHCI driver do you use?
Posted Image

#1184
haterz111

haterz111
  • Member
  • 6 posts
  • Joined 16-April 13
  • OS:Windows 7 x64
  • Country: Country Flag
amd catalyst sata drivers 0.331 and the one before that both give same issue ii keep getting big spikes when anything accesses my drives like win updates
this is my latest 51 minutes

this is idle with sleep function enabled and monitor turning off
but my pc just kept waking up as soon as it fell asleep


Highest ISR routine execution time (µs): 2332.491154
Driver with highest ISR routine execution time: hal.dll - Hardware Abstraction Layer DLL, Microsoft Corporation

Highest reported total ISR routine time (%): 0.011788
Driver with highest ISR total time: storport.sys - Microsoft Storage Port Driver, Microsoft Corporation

Total time spent in ISRs (%) 0.02860

Highest DPC routine execution time (µs): 320202.434089
Driver with highest DPC routine execution time: ntoskrnl.exe - NT Kernel & System, Microsoft Corporation

Highest reported total DPC routine time (%): 0.062856
Driver with highest DPC total execution time: rspLLL64.sys - Resplendence Latency Monitoring and Auxiliary Kernel Library, Resplendence Software Projects Sp.


this is a brand new retail copy of windows 7 x64 with sp1
ive been struggling with this for months
ive even just changed every single part with known good ones
even the motherboard

it must be software related

i remember i used to use scsiport.sys for my ssd
but now i see its storport

cant i change it back somehow

i suspect a conflict

find attached a copy of my system info

Attached File  mypc.rar   37.13KB   2 downloads

edit : and ive already tested all my drives no issues found with chkdisk or hitachi diagnostics seatools and also most of the time was running with just 1 drive
i notice that 24mbs is constant with latencymon on my disk and when i access my disk from another tool or software
i get a spike
but my mouse stops working randomly
and my graphics stutter

ive also tested my memory with both memtest x86+ and windows diagnostic tool for 10 hours each no errors

i feel like pulling my hair out

Edited by haterz111, 16 April 2013 - 02:25 PM.


#1185
haterz111

haterz111
  • Member
  • 6 posts
  • Joined 16-April 13
  • OS:Windows 7 x64
  • Country: Country Flag
i just added jmicron driver and a newer catalyst driver for my sata ports version 1.2.1.337


just got 2 beeps while trying to connect remotely to my pc and my mouse stopped responding

Edited by haterz111, 16 April 2013 - 03:34 PM.


#1186
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,128 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

connect it back to the old controller and run the xperf commands and give me the ETL file.
Posted Image

#1187
haterz111

haterz111
  • Member
  • 6 posts
  • Joined 16-April 13
  • OS:Windows 7 x64
  • Country: Country Flag
i added the driver i was using previously
i tried to do the performance trace but when i went to turn it off it said could find the file specified i was typing it correctly and it worked once

im going to memtest again my eventlog is full


and yesterday my pc didnt boot it stalled at graphics card and wouldnt post and it beeped 3 short beeps taking 2 ramsticks out fixed it

changed the motherboard for an asus m5a99xevo the problem still occurs

i will try again to do a trace

12.29 edit:-

performance analyzer noticed that 204 events and 0 buffers were lost in this trace
this is usually caused by insufficient disk bandwidth????
please increasde miminum and maximum buffers?

i made a text but nothing is in that txt

something weird happened i rebooted and when os came back it was everything i had opened when i turned it the machine off (this has happened before
hibernate is off

Edited by haterz111, 17 April 2013 - 06:10 AM.


#1188
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,128 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

Run this:

xperf -on latency -stackwalk profile -buffersize 1024

and increase the value for buffersize if you still get lost events/buffers.
Posted Image

#1189
haterz111

haterz111
  • Member
  • 6 posts
  • Joined 16-April 13
  • OS:Windows 7 x64
  • Country: Country Flag
today everytime i installed something i got massive spikes from either msahci or any amd driver i used also even in ide mode

sometime ago i beleive i tested with a mechanical disk as the boot drive
and figured because i was still getting latency that it cant be my ssd

but this is not true and today i doubted it
because a mechanical drive has its own latency problems

i did a checkdisk found no errors on my ssd
looked in diskinfo disk shows good 98%

used hdtune and i saw WARNING ultra dma errors 55
i already tried different ports and different cables

when inspecting my drive the controller was loose on the ssd
and with the added weight of being plugged in and being with 2 spinning disks was obviously disconnecting on and off

i have sent a rma and it will be replaced as i sent print screens to manufacturer

thankyou for your help magic

#1190
haterz111

haterz111
  • Member
  • 6 posts
  • Joined 16-April 13
  • OS:Windows 7 x64
  • Country: Country Flag
interrupt to process latency reflects the measured interval that a usermode process needed to respond to a hardware request from the moment the interrupt service routine started execution. This includes the scheduling and execution of a DPC routine, the signaling of an event and the waking up of a usermode thread from an idle wait state in response to that event.

Highest measured interrupt to process latency (µs): 25457.510603
Average measured interrupt to process latency (µs): 4.834922

Highest measured interrupt to DPC latency (µs): 446.488711
Average measured interrupt to DPC latency (µs): 1.754637


_________________________________________________________________________________________________________
MEASURED SMI, IPI AND CPU STALLS
_________________________________________________________________________________________________________
The SMI, IPI and CPU stalls value represents the highest measured interval that a CPU did not respond while having its maskable interrupts disabled.

Highest measured SMI or CPU stall (µs) 19.135230


_________________________________________________________________________________________________________
REPORTED ISRs
_________________________________________________________________________________________________________
Interrupt service routines are routines installed by the OS and device drivers that execute in response to a hardware interrupt signal.

Highest ISR routine execution time (µs): 170.976576
Driver with highest ISR routine execution time: dxgkrnl.sys - DirectX Graphics Kernel, Microsoft Corporation

Highest reported total ISR routine time (%): 0.043450
Driver with highest ISR total time: dxgkrnl.sys - DirectX Graphics Kernel, Microsoft Corporation

Total time spent in ISRs (%) 0.080301

ISR count (execution time <250 µs): 689014
ISR count (execution time 250-500 µs): 0
ISR count (execution time 500-999 µs): 0
ISR count (execution time 1000-1999 µs): 0
ISR count (execution time 2000-3999 µs): 0
ISR count (execution time >=4000 µs): 0


_________________________________________________________________________________________________________
REPORTED DPCs
_________________________________________________________________________________________________________
DPC routines are part of the interrupt servicing dispatch mechanism and disable the possibility for a process to utilize the CPU while it is interrupted until the DPC has finished execution.

Highest DPC routine execution time (µs): 440.431846
Driver with highest DPC routine execution time: nvlddmkm.sys - NVIDIA Windows Kernel Mode Driver, Version 314.22 , NVIDIA Corporation

Highest reported total DPC routine time (%): 0.063275
Driver with highest DPC total execution time: rspLLL64.sys - Resplendence Latency Monitoring and Auxiliary Kernel Library, Resplendence Software Projects Sp.

Total time spent in DPCs (%) 0.193364

DPC count (execution time <250 µs): 3568895
DPC count (execution time 250-500 µs): 0
DPC count (execution time 500-999 µs): 18
DPC count (execution time 1000-1999 µs): 0
DPC count (execution time 2000-3999 µs): 0
DPC count (execution time >=4000 µs): 0


this is while running a benchmark
when i received that latency i couldnt type in google chrome
im using a mechanical drive
at the time i was running a benchmark on my whole system 50% load
is this anything to worry about

#1191
jords16

jords16
  • Member
  • 9 posts
  • Joined 10-April 13
  • OS:Windows 7 x64
  • Country: Country Flag

why do you want to go back to XP? XP is dead. Do you still have issues after updating the nvidia driver or not?


i just updated my nvidia driver and still wont fix the issues

#1192
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,128 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

i just updated my nvidia driver and still wont fix the issues


provide a new xperf trace.
Posted Image

#1193
joaomolina

joaomolina
  • Member
  • 3 posts
  • Joined 23-April 13
  • OS:Windows 7 x64
  • Country: Country Flag
HP Support < Microsoft Support < other forums < anonymous group < GOD < MagicAndre...

You r absolutly the only guy i saw solving this problem in the right way. and note it exists since 2007 or smth. Do u mind if i start to post this link in other forums?? ther r ppl out there getting srsly mad with this s***

I am having this prob time to time. will post infos soon as i get it. thank you in advance

#1194
Malphas

Malphas
  • Member
  • 5 posts
  • Joined 23-April 13
  • OS:Windows 7 x64
  • Country: Country Flag
First I just want to thank you. I've read through this and several other threads you have going on this issue and have learned more in the last couple of days about my computer than the last few years.

I'm hoping you can fix my issue too. I have the same CPU spikes that many people here are getting. I reinstalled windows 7 and updated every possible driver via the manufacturer website rather than letting windows do it and still have the issue. I've turned on max performance on both my GPU and CPU.
Here are my logs:

http://www.mediafire...nkewx3sckksw4o7
http://www.mediafire...cuza6gkddmrxt0s

My specs (if you even need them)

Intel Core i5-3570
8.00 GB RAM
Windows 7 64-bit
EVGA 660ti 2GB SC
120GB ADATA SSD
2TB HDD

#1195
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,128 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

Do u mind if i start to post this link in other forums??


post the link where ever you want so that a lot of users can solve their issues.

First I just want to thank you. I've read through this and several other threads you have going on this issue and have learned more in the last couple of days about my computer than the last few years.

I'm hoping you can fix my issue too. I have the same CPU spikes that many people here are getting. I reinstalled windows 7 and updated every possible driver via the manufacturer website rather than letting windows do it and still have the issue. I've turned on max performance on both my GPU and CPU.


the files you posted are useless. You've used Latencymon the same time and so the file is damaged.
Posted Image

#1196
Malphas

Malphas
  • Member
  • 5 posts
  • Joined 23-April 13
  • OS:Windows 7 x64
  • Country: Country Flag


Do u mind if i start to post this link in other forums??


post the link where ever you want so that a lot of users can solve their issues.

First I just want to thank you. I've read through this and several other threads you have going on this issue and have learned more in the last couple of days about my computer than the last few years.

I'm hoping you can fix my issue too. I have the same CPU spikes that many people here are getting. I reinstalled windows 7 and updated every possible driver via the manufacturer website rather than letting windows do it and still have the issue. I've turned on max performance on both my GPU and CPU.


the files you posted are useless. You've used Latencymon the same time and so the file is damaged.


Sorry, I wasn't aware that latencymon would mess with the results. Do I just need to run xperf with just dpc latency checker or with nothing running at all?

#1197
joaomolina

joaomolina
  • Member
  • 3 posts
  • Joined 23-April 13
  • OS:Windows 7 x64
  • Country: Country Flag
here i am again with 1 core always beating the 100 % -> 50 % of CPU

HP dv6675ep
ntel® Core 2 Duo T7500 - 2, 20 GHz

System Bus
800 MHz
4096 MB (2 x 2048 MB)
Disco Rígido320 GB SATA Hard Disk Drive 5400 rpm

Wireless i802. 11a/b/g
Bluetooth®
Rede ethernet 10/100BT


NVIDIA® GeForce 8400M GS

My ETL

Posted Image

Posted Image

Did i post the necessary files? sorry but im a noob on this things.

Thanks in advance.

Edited by joaomolina, 24 April 2013 - 05:18 AM.


#1198
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,128 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

Do I just need to run xperf with just dpc latency checker or with nothing running at all?


run xperf without any other DPC tool.

Did i post the necessary files? sorry but im a noob on this things.


you've posted the kernel.etl. I need the DPC_interrupt.etl file which is stored in the folder where you run the commands.
Posted Image

#1199
joaomolina

joaomolina
  • Member
  • 3 posts
  • Joined 23-April 13
  • OS:Windows 7 x64
  • Country: Country Flag
lol sorry. that was the only ETL i found on the moment.

here you go! thanks

ETL

#1200
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,128 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

the high CPU usage comes from the function DefPortWriteAcpiRegister in ACPI.sys.

Because you use a laptop, run speedfan and look at your CPU temperature. Maybe the CPU does CPU throttling:

http://en.wikipedia..../CPU_throttling

Also update the BIOS from F.58 to F.5A and look if this improves it.
Posted Image




3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users