• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
MagicAndre1981

How to get the cause of high CPU usage caused by apps?

206 posts in this topic

looks like you have a PCIExpress issue. If you have different PCI-E16 slots plug the ATI Radeon HD 4300/4500 into the other slot. The diagnostic policy service detects this issues. Also look into the Even log for more details about the PCI-E hardware issue.

0

Share this post


Link to post
Share on other sites

Thnx for ur support i will try that out. But the event log has no entries under hardware issues. the problem started the from the time I installed windows 7, which is just a few days ago. I was using windows XP before that. And the graphics card has always been working fine in the same slot. Also the cpu usage was fine (~0 when idle) when i was using XP. Do you think this problem could be because of a driver conflict caused by the graphics card?? I have tried updating the drivers but there is no change, the cpu usage is almost constantly at 100%

0

Share this post


Link to post
Share on other sites

XP doesn't have such an service and can't detect such issues. The service causes the high CPU usage because it write the data to the eventlog. Which motherboard do you have?

0

Share this post


Link to post
Share on other sites

motherboard name- Biostar P4M900-M7 FE

bus type- intel AGTL

bus width- 64 bit

0

Share this post


Link to post
Share on other sites

I cant believe this!! i finally solved this... would you believe my problem was due to the power plan i was using. The power plan was set was on balanced, which is the recommended one. I changed it to high performance and voila the cpu usage drops back to ~0 when idle..

Thanks for your support

0

Share this post


Link to post
Share on other sites

the power options have an entry to control PCI-E power saving. Try to disable this for the balanced power plan.

0

Share this post


Link to post
Share on other sites

has this solved the issue, too? High performance is not recommend because all power saving options are disabled.

0

Share this post


Link to post
Share on other sites

yes it does... i did think it was not the 'right' solution if i had to change it from the recommended settings, but I just needed to change the PCI-E setting

Thanks again

0

Share this post


Link to post
Share on other sites

but I just needed to change the PCI-E setting

ok :)

Thanks again

You're welcome :)

0

Share this post


Link to post
Share on other sites

nvm, posted in wrong thread, should have been the interrupt one.

Edited by evilpedro
0

Share this post


Link to post
Share on other sites

hello, I'm trying to follow your tutorial but encountered a problem. After typing in "xperf -on latency -stalkwalk profile" into cmd, i get "xperf: error: xperf: argument -stalkwalk unexpected."

any help on solving this? i downloaded the Windows Performance Toolkit and the installed x64 file for Windows x64 systems.

0

Share this post


Link to post
Share on other sites

Hi,

you made a spelling mistake: "StaCkwalk, not StaLkwalk.

André

0

Share this post


Link to post
Share on other sites

Hi,

you made a spelling mistake: "StaCkwalk, not StaLkwalk.

André

... *facepalm* okay, i feel stupid now.

thanks.. not for the feeling stupid but for pointing it out! ahahahah haaaaaaah

0

Share this post


Link to post
Share on other sites

ok, if you need help, compress the trace and upload it (skydrive, dropbix, mediafire.com) and send me the link.

0

Share this post


Link to post
Share on other sites

MagicAndre -- I've been trying to follow your guides, but am lost. Something is causing pops, clicks, and dropouts in my audio, esp. at lower latency settings. Have periodic (15 second) CPU spikes, and somewhat high DPC/ISR involving WDF01000.sys (Kernel mode driver framework runtime), usbport.sys, hal.dll, and ataport.sys (in that order). Being system files, I assume there's no updates for any of these.

This is a new, dedicated i7 machine for audio work, with all unnecessary services disabled (I usually shut off networking), and all drivers updated. I'm stumped.

A zip of the trace file is at http://dougstunes.com/DPC-Interrupt.zip

TIA!

0

Share this post


Link to post
Share on other sites

You Have high DPC usage caused by USBport data transfer (rdwm1117.sys driver).

You've also have Driver Verifier enabled. Disable Driver verifier and test again. It should fix the issues because the deep validations no longer occur.

0

Share this post


Link to post
Share on other sites

You Have high DPC usage caused by USBport data transfer (rdwm1117.sys driver).

You've also have Driver Verifier enabled. Disable Driver verifier and test again. It should fix the issues because the deep validations no longer occur.

A thousand thanks, Andre! Disabling Driver Verifier did seem to help. In all the forums I've visited, I'd never heard about doing this (I need to spread the word). Is this Verifier enabled by default in Windows 7?

Unfortunately, I'm still seeing these large spikes every 15 seconds, and am still not getting the latency that others seem to be reporting using the same Roland hardware. The spikes do seem to be connected to this hardware (They go away if I unplug it, and rdwm1117.sys is the Roland driver), but I'm wondering if something in my system is interacting with the driver to cause these spikes, which consume 100% of one core, and 15-20% of total CPU .

I've uploaded another trace -- http://dougstunes.com/DPC-Interrupt.zip -- this time with network disabled, no driver verifier, and no antivirus, if you'd be willing to take another look. (I can't even see the spikes in the trace). Is there simply something wrong with the Roland driver?

Thanks again...

Edited by tuner
0

Share this post


Link to post
Share on other sites

A thousand thanks, Andre! Disabling Driver Verifier did seem to help. In all the forums I've visited, I'd never heard about doing this (I need to spread the word). Is this Verifier enabled by default in Windows 7?

No, by default it is not activated. Did you have a BSOD and activated it to get better dumps?

Unfortunately, I'm still seeing these large spikes every 15 seconds, and am still not getting the latency that others seem to be reporting using the same Roland hardware. The spikes do seem to be connected to this hardware (They go away if I unplug it, and rdwm1117.sys is the Roland driver), but I'm wondering if something in my system is interacting with the driver to cause these spikes, which consume 100% of one core, and 15-20% of total CPU .

still the same issue with the roland driver. The SAM.exe ("C:\Program Files (x86)\MAGIX\Samplitude_Pro_X_Download_Version\Sam.exe" ) sends some data to the USb device.

post-70718-0-57419200-1337085766_thumb.p

Try the 1.5 drivers

http://www.rolandcorp.com.au/products/productdetails.aspx?p=1166&c=72

You use the 1.0.0 drivers. Maybe this helps. Also try to connect the device to a different USB port which doesn't share IRQs with other devices.

Edited by MagicAndre1981
0

Share this post


Link to post
Share on other sites

No, by default it is not activated. Did you have a BSOD and activated it to get better dumps?

I ran some root kit scanners, because someone had said that root kits sometimes hook into ataport.sys, which seemed to be misbehaving. One of them must have switched it on.

Try the 1.5 drivers

http://www.rolandcorp.com.au/products/productdetails.aspx?p=1166&c=72

You use the 1.0.0 drivers. Maybe this helps. Also try to connect the device to a different USB port which doesn't share IRQs with other devices.

Apparently 1.0.0 is the newest version of rdwm1117.sys – 1.5 refers to an updated control panel only. And the Quadcapture USB port doesn't appear to be sharing an IRQ with anything. Durn.

Having run out of solutions, I'm going to try replacing the Quadcapture with a new unit. It will be very funny (after eight months of troubleshooting) if that turns out to be the problem... :whistle:

0

Share this post


Link to post
Share on other sites

ask the support, maybe they have an idea.

0

Share this post


Link to post
Share on other sites

ask the support, maybe they have an idea.

Hi Andre,

I'd boxed up the Roland interface, ready to send back for a replacement, and was using my Mackie FireWire in its place, when suddenly the sound got all glitchy again. Rebooted the machine, and audio still breaks up, even though it had worked fine all day. Looking at CPU usage in task manager, it appears that the Mackie Onyx is consuming the most (about 50% of one core), which disappears when I disconnect it.

Neither Latency Checker nor Latencymon are showing any problem at all as these errors are occurring. I've uploaded yet another etl file, if you're willing to take a look:

http://dougstunes.com/DPC-Interrupt.zip

A probably unrelated curiosity shown in Latencymon are what seem to be extremely high hard page fault resolution times – 23383 us up to 76868 (that's 76 ms, right?). But these aren't occurring during the glitches; in fact they're pretty infrequent, since most of my RAM is free.

So maybe I have two crummy audio interfaces? :blink:

Thanks again...

0

Share this post


Link to post
Share on other sites

and was using my Mackie FireWire in its place, when suddenly the sound got all glitchy again. Rebooted the machine, and audio still breaks up, even though it had worked fine all day. Looking at CPU usage in task manager, it appears that the Mackie Onyx is consuming the most (about 50% of one core), which disappears when I disconnect it.

this Mackie device is the cause:

post-70718-0-83154000-1338646510_thumb.p

post-70718-0-89060300-1338646517_thumb.p

It sens again data to the device and ths causes the high DPC/ISR CPU usage. Do you use the latest drivers? Also update the Texas Instruments 1394 OHCI Compliant Host Controller drivers.

0

Share this post


Link to post
Share on other sites

Hello, i installed wdm kit but the xperf command isnt working

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.