Mim0

The File-Checker (HFSLIPFC) for HFSLIP

1,617 posts in this topic

I found a few problems in the 2K version:

KB951748-v2 <- it's for both Professional & Server (it says "not for server" now)

IE_W2K_4.CAB, WAB.CAB <- the explanation that you should extract the two files from them to HF\EXPERT doesn't mean that these cabs are not needed!! Other IE/OE files are included in them too! You mustn't remove them if you slipstream IE6/OE6.

Edited by tomasz86
0

Share this post


Link to post
Share on other sites

KB951748-v2 <- it's for both Professional & Server (it says "not for server" now)

Fixed.

IE_W2K_4.CAB, WAB.CAB <- the explanation that you should extract the two files from them to HF\EXPERT doesn't mean that these cabs are not needed!! Other IE/OE files are included in them too! You mustn't remove them if you slipstream IE6/OE6.

Both cab files and extracted files are marked as obsoleted when of them is NOT present. I agree that it's not clarified enough, though. I changed hints for them to more appropriate.

0

Share this post


Link to post
Share on other sites

Both cab files and extracted files are marked as obsoleted when of them is NOT present. I agree that it's not clarified enough, though. I changed hints for them to more appropriate.

I see :)

I use REPLACE\i386 to replace these files instead of HFEXPERT so that's the reason I saw the message.

0

Share this post


Link to post
Share on other sites

Mim0 & Parseus,

Thank you for bringing the 2k File Checker back to life.

I am getting the following error when I first start. Is this a typo or it is by design?

I tried to find the problem but am probably not looking in the right place.

See screenshot below.

My2GirlsDad

0

Share this post


Link to post
Share on other sites

Thank you for bringing the 2k File Checker back to life. <BR itxtNodeId="915">

Yes, congratulations only to Parseus! :thumbup I'm just hosting it... :whistle:

I am getting the following error when I first start. Is this a typo or it is by design?

Do you mean the "kVersion" when using automatic-update? Thx for reporting this! Thats a problem in my upload-script. I will fix the script and upload again... Edited by Mim0
0

Share this post


Link to post
Share on other sites

Upload-script is fixed. The error was just the version-number of W2K which was wrong (when checking for a new extension-version).

new file-checker extension for XP (just for MU/WU - not very interesting I think :D ):

2011-12-07
- Changed: Updated the version of windows Update Agent from 7.4.7600.226 to 7.6.7600.243
(but the file-checker cannot check for the correct version)
- Fixed: moved KB905474 (WGA-N) from WU-section to WIN-section and changed it
from optional to high-priority
- Fixed: moved obsolete KB917275 from WU-section to WIN-section
- Fixed: KB898461 changed from optional to high-priority
- Fixed: windows Update Agent changed from optional to high-priority

HFSLIPFC v.2011/11/16 with WindowsXP-update-list v.2011/12/07

0

Share this post


Link to post
Share on other sites

@ Mim0

this update:

Microsoft European Union Expansion Font Update 1.2

would be excellent complement to your list

Oh... cool!

How do you use it with HFSLIP?

Mimo

PS:

Following versions are inside of XP/SP3 and this font-update:

Font.................Windows XP..................EUupdate.exe

Arial.................3.0...................................3.06

Times.............3.0...................................3.06

Trebuchet.......1.23................................5.00

Verdana..........2.43.................................5.01

0

Share this post


Link to post
Share on other sites

They should be slipstreamed like any other update from HF... but someone should check if they're not already included in MDGx's True Type Fonts (TTF) Pack (which is also slipstreamed from HF ;)).

0

Share this post


Link to post
Share on other sites

...... but someone should check if they're not already included in MDGx's True Type Fonts (TTF) Pack ....

Wow! what for a confusing website (at least for me):D

I checked that. MDG wrote, that in his Unofficial Windows 9x/NT4/2000/ME/XP/2003 127 True Type Fonts (TTF) Pack the mentioned fonts (Microsoft European Union Expansion Font Update 1.2) are included.

But in fact: it isn't!

If downloaded his Unofficial Windows 9x/NT4/2000/ME/XP/2003 127 True Type Fonts (TTF) Pack und e.g. Arial v3.00 was inside (and not v3.06)!

They should be slipstreamed like any other update from HF ... (which is also slipstreamed from HF ;)).

But Microsoft European Union Expansion Font Update 1.2 (EUupdate.EXE) has a complete other structure inside. Other than "normal" updates and also another like Unofficial Windows 9x/NT4/2000/ME/XP/2003 127 True Type Fonts (TTF) Pack (TTFPAK.EXE).
0

Share this post


Link to post
Share on other sites
But Microsoft European Union Expansion Font Update 1.2 (EUupdate.EXE) has a complete other structure inside. Other than "normal" updates and also another like Unofficial Windows 9x/NT4/2000/ME/XP/2003 127 True Type Fonts (TTF) Pack (TTFPAK.EXE).

So what? :P;)

It's is slipstreamed like any other update. To be sure I've just tested it to confirm my thoughts.

0

Share this post


Link to post
Share on other sites

To be sure I've just tested it to confirm my thoughts.

That was quite fast! :w00t: Thx for the info! :thumbup
0

Share this post


Link to post
Share on other sites

Well, I only tested the slipstreaming process to see whether the files are unpacked and replaced correctly, didn't actually try to install Windows. I use ramdisk for this so it doesn't take very long time.

0

Share this post


Link to post
Share on other sites

new file-checker extension for Windows XP:

2011-12-09
- Added: European Union Expansion Font Update 1.02

HFSLIPFC v.2011/11/16 with WindowsXP-update-list v.2011/12/09

new file-checker extension for Windows 2000 from Parseus:

2011-12-07
- added: unofficial KBz2288621 for Windows 2000, language detection for KB887606 from XP extension
- removed: usp10.dll from KBz2288621 for MS Office 2007 SP2 (replaced by unofficial KBz2288621 for Windows 2000)
- fixed obsoleting KB951748-v2 for Server editions (thanks tomasz86)
- fixed a typo in detection of KB896260 (thanks piotrhn)
- fixed detection of KB834158
- fixed: windows Update Agent changed from optional to high-priority
- fixed: KB842773 changed from optional to high-priority
- changed hints for extracted IE6 files to be more clarified (thanks tomasz86)
- changed: Updated the version of windows Update Agent from 7.4.7600.226 to 7.6.7600.243 (but the file-checker cannot check for the correct version)

HFSLIPFC v.2011/11/16 with Windows2000-update-list v.2011/12/07

Edited by Mim0
0

Share this post


Link to post
Share on other sites

Mimo, the link on your site points to the version from dec 7, not to the one from dec 9.

And so does the link on the post immediatelyt before this one.

(I'm talking about the winxp version)

bye!

PD: thx!

PD2: the link for the 2k version points to the version from dec 5, not from dec 7.

Edited by jvidal
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.