Sign in to follow this  
Followers 0
zoomzeth

RIS autoincrement number

1 post in this topic

Hi all,

I've recently installed a RIS on Windows 2003 Server Standard Edition.

The problem that I'm facing is that the RIS server doesn't increment my computer number. So every time I install a new pc, it has the same name as I configured it into Remote Installation Services Properties.

Is there a way that I can enter manually the computer number when RIS starts the installation?

My ristndrd.sif file looks like this:

[data]

floppyless = "1"

msdosinitiated = "1"

OriSrc = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"

OriTyp = "4"

LocalSourceOnCD = 1

[setupData]

OsLoadOptions = "/noguiboot /fastdetect"

SetupSourceDevice = "\Device\LanmanRedirector\%SERVERNAME%\RemInst\%INSTALLPATH%"

[unattended]

OemPreinstall = yes

DriverSigningPolicy = Ignore

OemPnpDriversPath = \Drivers\A01;\Drivers\C01;\Drivers\N01;\Drivers\V01

FileSystem = LeaveAlone

ExtendOEMPartition = 0

TargetPath = \WINDOWS

OemSkipEula = yes

InstallFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"

LegacyNIC = 1

UnattendMode = "ReadOnly"

OemSkipEula = yes

[userData]

FullName = "%USERFIRSTNAME% %USERLASTNAME%"

OrgName = "%ORGNAME%"

ComputerName = %MACHINENAME%

ProductID = "win-serial"

[GuiUnattended]

OemSkipWelcome = 1

OemSkipRegional = 1

TimeZone = %TIMEZONE%

AdminPassword = "password"

[TapiLocation]

CountryCode = 40

AreaCode = 268

[RegionalSettings]

InputLocale = 0409:00000409

SystemLocale = 0409

UserLocale = ”0409

[Display]

BitsPerPel = 16

XResolution = 800

YResolution = 600

VRefresh = 60

[Networking]

[NetServices]

MS_Server=params.MS_PSched

[identification]

JoinDomain = RO

MachineObjectOU = "%MACHINEOU%"

CreateComputerAccountInDomain = Yes

DoOldStyleDomainJoin = Yes

[RemoteInstall]

Repartition = Yes

UseWholeDisk = Yes

[OSChooser]

Description ="Microsoft Windows XP Professional SP2"

Help ="Automatically installs Microsoft Windows XP Professional without prompting the user for input."

LaunchFile = "%INSTALLPATH%\%MACHINETYPE%\templates\startrom.com"

ImageType =Flat

Version="5.1 (2600)"

I saw that in ?:\RemoteInstall\OSChooser\English is a file called custom.osc, but I don't know how to add this file into RIS setup process.

Did anybody encountered this issue?

Thanks in advance.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.