Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Snow Leopard - Slow Network Printing

- - - - -

  • Please log in to reply
6 replies to this topic

#1
Stoic Joker

Stoic Joker

    I Hate Titles

  • Member
  • PipPip
  • 279 posts
  • Joined 16-August 05
  • OS:Windows 7 x64
  • Country: Country Flag
Greetings
a customer bought a refurbished HP Color LaserJet 3800n from the company I work for. It has been throughly checked out & performs flawlessly on a Windows network... However. The customer has an Apple AirPort WiFi network with two OSX 10.6.2 (Snow Leopard) laptops. Being a "network" install, I got roped into doing the setup. Fortunately, I've been futzing with Linux quite a bit here lately so I wasn't completely lost on the install (I used the HP JetDirect/socket option, which both Apple & HP support pages state is the correct option).

The printer works, sending a Word document, in a reasonably normal period of time. But. Trying to send a picture (1.4MB .jpg) from Adobe PhotoShop (or the Mac picture viewer) takes roughly half an hour (this is not an exaggeration). My Win7 machine at the office will print the same image to the same printer in 15 seconds.

I'm guessing at this point this is an Apple issue - Googling brings up several (hundred) hits that also imply that this is the case. However there is absolutely no consensus on what the cause/solution might be. ...And I'm not real comfortable just having-a-go at the machine for fear of screwing it up.

So, does anyone have any (preferably first hand but I'll take what I can get...) insight into what may be going on? I'm reasonably sure that it is not a network performance issue, and (at this point) that the problem lies with the Mac. What I don't know is what (if anything) can be done about it.


Side Note: When the customer connected the printer to their Mac via USB it printed fine (which I'm guessing gets Adobe off the hook). It is only the network printing performance that is suffering (horribly...). However being that this is a laptop, a USB connection is not an acceptable permanent solution.


How to remove advertisement from MSFN

#2
gamehead200

gamehead200

    SEARCH!!! SEARCH!!!

  • Patrons
  • 6,870 posts
  • Joined 02-September 02
  • OS:Windows 7 x64
  • Country: Country Flag
Sweet, a Mac issue I can troubleshoot!

I haven't had any issues printing images of that size with my MacBook Pro (also with Snow Leopard) over my wired and wireless networks (both with Windows computers), so this kind of stumps me. My guess is that it's probably an issue with either CUPS or SAMBA on the Mac. I'm no expert with configuring CUPS manually (since everything's done for you through the Printer GUI in System Preferences), so let's try playing with SAMBA first.

Most of the printer problems I've had with Macs on Windows networks usually has to do with either the computer the printer is being shared through (though, this doesn't like it applies to you since it sounds like the printer is hardwired to the network - please correct me if I'm wrong) or the workgroup the Mac is on (in my experience, Macs have never played well with workgroups). In your customer's Mac's System Preferences, check out the Network prefs, select the network interface you want to print over, then hit Advanced. Select the WINS tab from the window and make sure the workgroup is set to a common name across all of the Windows computers (and the printer, if it has an option for it).

Give that a try and post back if there's no improvement.

Cheers,

#3
Stoic Joker

Stoic Joker

    I Hate Titles

  • Member
  • PipPip
  • 279 posts
  • Joined 16-August 05
  • OS:Windows 7 x64
  • Country: Country Flag
Greetings, and thanks for popping in.

Let me clarify a few things, the first being... there are no Windows machines on this network (That's why I'm lost :)).

User in question is a sixty-ish photographer/blogger/Apple zealot. So there are only the two Snow Leopard laptops an AipPort, and the printer (with Bonjour enabled/running) as contenders on the wire. He's also not prone to "tinker" with the machine so what ever the defaults are is a safe assumption.

Yes you are correct is assuming that this is a direct IP (e.g. not shared) configuration.

Both Laptops are OSX 10.6.2 (which both behave the same (badly)) ... So I got no shot at a tie breaker.

(Ah! Just remembered...)
Both machines were upgraded to SL shortly after it came out (guy likes to stay current)

both machines printed fine to an HP LaserJet 3000 before and after the upgrade

Now, I'm assuming the SL upgrade did not also update the preexisting printer driver, but the newly add printer (printers actually - this is the third one he's tried) getting the new driver are dieing (performance wise) as a result. (Mind you, I'm just trying to piece together what I've Googled to create a "picture" to work from here)

Edited by Stoic Joker, 20 January 2010 - 08:16 AM.


#4
gamehead200

gamehead200

    SEARCH!!! SEARCH!!!

  • Patrons
  • 6,870 posts
  • Joined 02-September 02
  • OS:Windows 7 x64
  • Country: Country Flag
OK, this sounds more like a driver issue than what I described above. When SL first came out, HP was pretty slow at releasing updated Mac drivers for its line of printers (I think it took about a month before they finally released a driver for my own HP printer - I could use it to scan documents, but couldn't print to it until they came out with the new drivers :P). Does your customer have any outstanding software updates to apply?

#5
Stoic Joker

Stoic Joker

    I Hate Titles

  • Member
  • PipPip
  • 279 posts
  • Joined 16-August 05
  • OS:Windows 7 x64
  • Country: Country Flag

OK, this sounds more like a driver issue than what I described above.

I tempted to lean that way also, but I still suspect a spooling issue based on how the data is being sent to the printer (burst pause burst pause (for half an hour))

When SL first came out, HP was pretty slow at releasing updated Mac drivers for its line of printers (I think it took about a month before they finally released a driver for my own HP printer - I could use it to scan documents, but couldn't print to it until they came out with the new drivers :P).

I work for an HP Authorized Service Provided - They're really just slow with releasing updates ;)
...But HP's site (still) says to use the driver included with SL (which we did).

Does your customer have any outstanding software updates to apply?

Not that I'm aware of. The thing I find most troubling in this regard is the existence of several post on the Apple's support form which reference both Snow Leopard & slow network printing with devices from a variety of different manufacturers. There are a few Poke-and-hope (try this) solutions, but... The only consensus that I've found resolution wise is that Apple is working on it.

If it was beating on the processor and not getting to the spooler I'd go for the driver explanation. But it hits the spooler (print queue) just fine, which kind of implies the driver (pagination) is done with it.

#6
gamehead200

gamehead200

    SEARCH!!! SEARCH!!!

  • Patrons
  • 6,870 posts
  • Joined 02-September 02
  • OS:Windows 7 x64
  • Country: Country Flag
I'm stumped again. Not quite sure what it could be. I'd say wait until HP releases an update and see if that helps, but it might not... :unsure:

#7
Stoic Joker

Stoic Joker

    I Hate Titles

  • Member
  • PipPip
  • 279 posts
  • Joined 16-August 05
  • OS:Windows 7 x64
  • Country: Country Flag

I'm stumped again. Not quite sure what it could be. I'd say wait until HP releases an update and see if that helps, but it might not... :unsure:

Well, if you like troubleshooting Mac stuff, and can't figure it out either ... at least I can feel better about having the issue unresolved. :)

Thanks




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users