• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
bensam56

RT Seven Lite - RC build 1.7.0 and Beta build 2.6.0

1,970 posts in this topic

So far so good, it opens. Will start a basic build and let it run on it's own for a few hours

Edited by MrJinje
0

Share this post


Link to post
Share on other sites

Download the new installer my friend....i uploaded a new package. Sorry for any inconvenience

New link is giving me this

404 - Component not found

You may not be able to visit this page because of:

1. an out-of-date bookmark/favourite

2. a search engine that has an out-of-date listing for this site

3. a mistyped address

4. you have no access to this page

5. The requested resource was not found.

6. An error has occurred while processing your request.

Please try one of the following pages:

* Home Page

If difficulties persist, please contact the System Administrator of this site.

Component not found

The link provided on the website is invalid and being correct.

The link i have posted here is working fine

0

Share this post


Link to post
Share on other sites

In new build 1.3.0.0 I cant see new optional theme, sidebar and new background when windows logon into first time, still default from microsoft. Thanks for this GreatMax tool. Viva from Indonesia. sorry with my English

0

Share this post


Link to post
Share on other sites

Two quick things I notice

1) Driver tab seems limited to a single driver at a time, cannot add a folder ?? or am I missing something.

a) Why is one of my drivers in a high-lighted with maroon color. Does that mean anything ?

2) Update tab cannot find my .CAB updates, the GUI is limiting the Choose File dialog to .MSU file type only. It should allow both .CAB + .MSU file types.

0

Share this post


Link to post
Share on other sites

Two quick things I notice

1) Driver tab seems limited to a single driver at a time, cannot add a folder ?? or am I missing something.

a) Why is one of my drivers in a high-lighted with maroon color. Does that mean anything ?

2) Update tab cannot find my .CAB updates, the GUI is limiting the Choose File dialog to .MSU file type only. It should allow both .CAB + .MSU file types.

driver may be for 32 and tried to add in 64 bit and vice-versa.

i will update .cab in next release my friend....

0

Share this post


Link to post
Share on other sites

After a few hours (97%) it crashed with this error.

************** Exception Text **************
System.IO.IOException: Access to the path 'C:\Users\MrJinje\AppData\Local\Temp\RT_Mount\ProgramData\Microsoft\Windows\Start Menu\Programs\Tablet PC' is denied.

at RTWin7Lite.RT7LiteHome.permanentlyRemove() in D:\project-II\New folder\Final_state\RTWin7Lite\RTWin7Lite\RT7LiteHome.vb:line 37401
at RTWin7Lite.RT7LiteHome.btn_log_Commit_Click(Object sender, EventArgs e) in D:\project-II\New folder\Final_state\RTWin7Lite\RTWin7Lite\RT7LiteHome.vb:line 2311

0

Share this post


Link to post
Share on other sites

Two quick things I notice

1) Driver tab seems limited to a single driver at a time, cannot add a folder ?? or am I missing something.

a) Why is one of my drivers in a high-lighted with maroon color. Does that mean anything ?

2) Update tab cannot find my .CAB updates, the GUI is limiting the Choose File dialog to .MSU file type only. It should allow both .CAB + .MSU file types.

#1 yes it should allow adding folders.Trust me its a pain in tha a** to manually add 87 different .inf files one-by-one

Still i am unable to even start this program.Simply crashes when started.Tried every single compability option but still same:

r7litesw.jpg

Windows 7 Ultimate N x64 +Fully updated

WAIK for Win7

Latest Adobe Flash

UAC Disabled

No Anti-Virus installed

Installed .NET:

nete.jpg

Error messages:

r7liteerror.jpg

And:

Log Name:      Application
Source: Windows Error Reporting
Date: 13.03.2010 12:22:33
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: Custom
Description:
Fault bucket 1035746046, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: rtwin7lite.exe
P2: 1.0.0.0
P3: 4b99e018
P4: RTWin7Lite
P5: 1.0.0.0
P6: 4b99e018
P7: 15
P8: e9
P9: System.InvalidOperationException
P10:

Attached files:
C:\Users\User\AppData\Local\Temp\WERA039.tmp.WERInternalMetadata.xml

These files may be available here:
C:\Users\User\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_rtwin7lite.exe_bed885b058e1b06c4f4e2458a1721cf673324271_05d2b547

Analysis symbol:
Rechecking for solution: 0
Report Id: 52adb5de-2e8a-11df-87a7-0015f2c80684
Report Status: 0
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Windows Error Reporting" />
<EventID Qualifiers="0">1001</EventID>
<Level>4</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2010-03-13T10:22:33.000000000Z" />
<EventRecordID>2035</EventRecordID>
<Channel>Application</Channel>
<Computer>Custom</Computer>
<Security />
</System>
<EventData>
<Data>1035746046</Data>
<Data>5</Data>
<Data>CLR20r3</Data>
<Data>Not available</Data>
<Data>0</Data>
<Data>rtwin7lite.exe</Data>
<Data>1.0.0.0</Data>
<Data>4b99e018</Data>
<Data>RTWin7Lite</Data>
<Data>1.0.0.0</Data>
<Data>4b99e018</Data>
<Data>15</Data>
<Data>e9</Data>
<Data>System.InvalidOperationException</Data>
<Data>
</Data>
<Data>
C:\Users\User\AppData\Local\Temp\WERA039.tmp.WERInternalMetadata.xml</Data>
<Data>C:\Users\User\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_rtwin7lite.exe_bed885b058e1b06c4f4e2458a1721cf673324271_05d2b547</Data>
<Data>
</Data>
<Data>0</Data>
<Data>52adb5de-2e8a-11df-87a7-0015f2c80684</Data>
<Data>0</Data>
</EventData>
</Event>

0

Share this post


Link to post
Share on other sites

Another idea I had was to integrate some of the known issues with package removal. With vLite/7, we have to mess around and maintain a keep list of certain DLL's or it will break. Would be nice if we could integrate that sort of logic into the app.

In this new version you can add files not to be deleted.

That's nice, but not what exactly what I was getting at, it would be simpler if 7lite could be programmed to know which important DLL's to keep, without requiring every user to be a brain scientist.

0

Share this post


Link to post
Share on other sites

Another idea I had was to integrate some of the known issues with package removal. With vLite/7, we have to mess around and maintain a keep list of certain DLL's or it will break. Would be nice if we could integrate that sort of logic into the app.

In this new version you can add files not to be deleted.

That's nice, but not what exactly what I was getting at, it would be simpler if 7lite could be programmed to know which important DLL's to keep, without requiring every user to be a brain scientist.

you are right....i will make a list and make it in a popup window

0

Share this post


Link to post
Share on other sites

How about a script that collects required WAIK files into the 7Lite folder. Just something so that each person can create their own "portable 7Lite" from their locally installed copy.

Maybe if we can get a successful method for that, each person will only need to install the WAIK once (and then uninstall it). I think that avoids any redistribution issues, and resolves the complaints about having to install WAIK over and over, what do you think.

0

Share this post


Link to post
Share on other sites

I was able to complete an .iso with the program, however, it seems that no matter what options or packages I choose for removal, no reduction takes place - the resulting .iso is more or less the same size as the default windows image.

Edited by Bilar Crais
0

Share this post


Link to post
Share on other sites

well i was able to install it but when i try to run it i get window saying it stopped working with this error -

Stopped working

Problem signature:

Problem Event Name: CLR20r3

Problem Signature 01: rtwin7lite.exe

Problem Signature 02: 1.0.0.0

Problem Signature 03: 4b99e018

Problem Signature 04: RTWin7Lite

Problem Signature 05: 1.0.0.0

Problem Signature 06: 4b99e018

Problem Signature 07: 15

Problem Signature 08: e9

Problem Signature 09: System.InvalidOperationException

OS Version: 6.1.7600.2.0.0.256.1

Locale ID: 1033

any idea what is wrong? running 7 ultimate X64

0

Share this post


Link to post
Share on other sites

well i was able to install it but when i try to run it i get window saying it stopped working with this error -

any idea what is wrong? running 7 ultimate X64

Install this - it is one of the prerequisites for the program. I was getting a similar, if not the same message, until I installed it.

http://fpdownload.macromedia.com/get/flashplayer/current/licensing/win/install_flash_player_10_active_x.exe

0

Share this post


Link to post
Share on other sites

well i was able to install it but when i try to run it i get window saying it stopped working with this error -

any idea what is wrong? running 7 ultimate X64

Install this - it is one of the prerequisites for the program. I was getting a similar, if not the same message, until I installed it.

http://fpdownload.macromedia.com/get/flashplayer/current/licensing/win/install_flash_player_10_active_x.exe

Thanks.I was also able to get it working.Odd thos that it requires the Flash_ActiveX where as i have installed Flash_General

Since i dont normally use anything that requires Flash ActiveX then i had no need for this package.

0

Share this post


Link to post
Share on other sites

I didn't see anything in the latest version that couldn't be converted to gif to remove the flash requirement. That is, unless he is using flash to install some kind of phone home tracking cookie (LSO).

Edited by MrJinje
0

Share this post


Link to post
Share on other sites

I didn't see anything in the latest version that couldn't be converted to gif to remove the flash requirement. That is, unless he is using flash to install some kind of phone home tracking cookie (LSO).

i tried to convert it to gif....but its getting much grains

0

Share this post


Link to post
Share on other sites

on average how long does it take to complete? i am running it right now and it has been 120 minutes and still at same spot. it integrated everything i selected but is stuck on removing components.

0

Share this post


Link to post
Share on other sites

I was able to complete an .iso with the program, however, it seems that no matter what options or packages I choose for removal, no reduction takes place - the resulting .iso is more or less the same size as the default windows image.

Same here.Nothing removed and Install.wim still at same size.

Other things that could be improved:

*Ability to check folders for driver integration.RT 7 Lite finds all nessesary .infi files from the folder and its subfolders.Also i hope it knows how to use /ForceUnsigned flag for non WHQL drivers?

*Ability to integrate not only .theme files but also .themepack files that contain all nessesary resources.

*Ability to cycle trough options with doubleclick, instead of selecting option from drop-down box.This can speed up option setting quite a bit.vLite does this for example.

*"Protect Feature" option.Like in vLite where you select features to keep and vLite warns if you try to remove components that would brake that feature.

*Tooltip about Red components and short comment what removing them could brake.

*Auto detect Silent Installers for program integration.Currently i havent got a clue how to check if program executable supports silent install or not?(short of testing each one one-by-one)

*Ability to load previous RT 7 Lite settings(not implemented completely yet?).

*Ability to change TEMP folder location from RT 7 Lite settings(like vLite does).

*Show current operation on bottom of "Log" window`s progress bar.For example: Integrating KB123456.msu ;Removing: Accessibility and so on.Like vLite does.Currently it only shows Preparing and such general messages.

*Future Win7 SP1 Beta/RTM integration support?

0

Share this post


Link to post
Share on other sites

hey

thx for this tool

but could u adopt the present system file as vlite

cos there lots of config :)

0

Share this post


Link to post
Share on other sites

I was able to complete an .iso with the program, however, it seems that no matter what options or packages I choose for removal, no reduction takes place - the resulting .iso is more or less the same size as the default windows image.

Same here as well. Because of this I didn't even bother to try installing it on my VM.

0

Share this post


Link to post
Share on other sites

i tried to convert it to gif....but its getting much grains

Nothing to worry about, having to install flash isn't the end of the world.

How about a script that collects required WAIK files into the 7Lite folder. Just something so that each person can create their own "portable 7Lite" from their locally installed copy.

No answer on this one ??

EDIT: On Windows 7 it is working just fine if you just copy the files inside the WAIK\Tools\x86 or amd64, and paste them directly into your RT7Lite folder. (then copy RT7Lite folder to another Windows 7 machine) As long as you have flash activex installed on every machine it seems to work fine as a portable app.

Someone else will have to test on Vista and other OS'es, I'm only testing on Windows 7.

Edited by MrJinje
0

Share this post


Link to post
Share on other sites

will someone who has been successful in creating an install.wim (while not actually reducing it's size). Please open said install.wim with 7z file manager and take a screen shot.

I am in particular interested to know if the install.wim contains a folder called "Files" and how large that folder has become after running 7Lite. If that "Files" folder is more then 1Gb then that would confirm to me that file-removal has occurred. (but image export has not occurred)

exportedwim.png

The "Files" folder inside of a wim contains any files deleted from the WIM during a DISM session, these are basically orphan files that belong in none of the images inside the wim. The only way to get rid of them is to export the image using imagex or gimagex, thus creating a new wim without the orphaned files (and reducing it's size). DISM cannot do this, only imagex.

Edited by MrJinje
0

Share this post


Link to post
Share on other sites

just went through a quick removal and it seems to be working properly (save for exporting to a new wim). Here is the proof, see how my "Files" folder grew by 50Mb, while my "1" image folder is reduced.

test2u.png

Ben, please add the option (or make it the default) to "Export" the wim into a new install.wim file as the very final task.

For anyone else, here is how you can reclaim the wasted WIM space. (using gimagex)

gimagex.png

Either way, if you created an ISO with 7Lite even though the wim file is still the same size, the install will not be.

Edited by MrJinje
0

Share this post


Link to post
Share on other sites

just went through a quick removal and it seems to be working properly (save for exporting to a new wim). Here is the proof, see how my "Files" folder grew by 50Mb, while my "1" image folder is reduced.

[img=http://img52.imageshack.us/img52/1540/test2u.png]

Ben, please add the option (or make it the default) to "Export" the wim into a new install.wim file as the very final task.

For anyone else, here is how you can reclaim the wasted WIM space. (using gimagex)

[img=http://img519.imageshack.us/img519/4636/gimagex.png]

Either way, if you created an ISO with 7Lite even though the wim file is still the same size, the install will not be.

Jinje, thanks for doing the leg work on that.

Like I said, I assumed it was a waste of effort simply because the iso sizes were always the same. Now I guess we just have to work on getting it to not look that way.

0

Share this post


Link to post
Share on other sites

Jinje, thanks for doing the leg work on that.

Like I said, I assumed it was a waste of effort simply because the iso sizes were always the same. Now I guess we just have to work on getting it to not look that way.

Considering it is a single line of code that needs to be added, I imagine the next release will fix the problem.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.