• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
bensam56

RT Seven Lite - RC build 1.7.0 and Beta build 2.6.0

1,970 posts in this topic

wimgapi can't able to mount the image. Did u used vlite or vista waik imagex after Win 7 waik installed?

Nope nothing. Installed win7 x64 from the ISO i mentioned into VirtualBox (maybe that could be a problem..?), installed your tool, started it and pointed it to the source on the ISO. After it is done copying it local i get that message.

Just tested another ISO (7600.16384.090710-1945_x64fre_client_en-us_Retail_Ultimate-GRMCULXFRER_EN_DVD.iso) same problem.

Manually mounting the install.wim using C:\Program Files\Windows AIK\Tools\amd64\imagex.exe works fine.

Don't test rt 7 lite in virtual...

Edited by bensam56
0

Share this post


Link to post
Share on other sites

What is the problem about running it in a virtual machine? It seems to work using Vmware.

Got an exception at the "remove components" stage:

System.InvalidCastException: Conversion from string "c:\users\user\appdata\local\te" to type 'Boolean' is not valid. ---> System.FormatException: Input string was not in a correct format.
at Microsoft.VisualBasic.CompilerServices.Conversions.ParseDouble(String Value, NumberFormatInfo NumberFormat)
at Microsoft.VisualBasic.CompilerServices.Conversions.ToBoolean(String Value)
--- End of inner exception stack trace ---
at Microsoft.VisualBasic.CompilerServices.Conversions.ToBoolean(String Value)
at RTWin7Lite.RT7LiteHome.permanentlyRemove() in D:\Ben\4-8-2010\Final_state\RTWin7Lite\RTWin7Lite\RT7LiteHome.vb:line 45335
at RTWin7Lite.RT7LiteHome.btn_log_Commit_Click(Object sender, EventArgs e) in D:\Ben\4-8-2010\Final_state\RTWin7Lite\RTWin7Lite\RT7LiteHome.vb:line 3237
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

0

Share this post


Link to post
Share on other sites

Hi ben

this is the problem

http://www.msfn.org/board/topic/142382-rt-seven-lite-beta-build-108/page__view__findpost__p__928491

Error in version 1.0.8

I have just once the new version 1.0.8 (32bit and 64bit tested).

Old version I have previously uninstalled.

It comes at me with Win 7 x86 as well as in Win x64 7 after mount the image the following error message:

post-245271-127697053504_thumb.jpg

someone has an idea why the errors come from?

beatmaster

Other people on Win-Lite.de have the same problem. But under a virtual machine this error not comes.

i don`t understand this error

beatmaster

0

Share this post


Link to post
Share on other sites

Test with a english version, then the error should not come... Im getting a new version from ben soon and ill test it to see if he has found the bug.

0

Share this post


Link to post
Share on other sites

What is the problem about running it in a virtual machine? It seems to work using Vmware.

Got an exception at the "remove components" stage:

System.InvalidCastException: Conversion from string "c:\users\user\appdata\local\te" to type 'Boolean' is not valid. ---> System.FormatException: Input string was not in a correct format.
at Microsoft.VisualBasic.CompilerServices.Conversions.ParseDouble(String Value, NumberFormatInfo NumberFormat)
at Microsoft.VisualBasic.CompilerServices.Conversions.ToBoolean(String Value)
--- End of inner exception stack trace ---
at Microsoft.VisualBasic.CompilerServices.Conversions.ToBoolean(String Value)
at RTWin7Lite.RT7LiteHome.permanentlyRemove() in D:\Ben\4-8-2010\Final_state\RTWin7Lite\RTWin7Lite\RT7LiteHome.vb:line 45335
at RTWin7Lite.RT7LiteHome.btn_log_Commit_Click(Object sender, EventArgs e) in D:\Ben\4-8-2010\Final_state\RTWin7Lite\RTWin7Lite\RT7LiteHome.vb:line 3237
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Just see about this exception in previous page. This is due to Tablet PC removal. Its a small mistake i made while saving the project. Actually i debugged it from previous build but during compilation its reverted.

0

Share this post


Link to post
Share on other sites

Working fine so far having TabletPC not removed.

One thing i couldn't figure out so far: What to do to enable themes?

Themes always show up but they are greyed out. Both the aero themes but also the "Windows 7 Basic" theme.

0

Share this post


Link to post
Share on other sites

Working fine so far having TabletPC not removed.

One thing i couldn't figure out so far: What to do to enable themes?

Themes always show up but they are greyed out. Both the aero themes but also the "Windows 7 Basic" theme.

Post your lastSession.ini

You'll find it in the root directory of the rt7 lite program folder. You can attach it to a post.

0

Share this post


Link to post
Share on other sites

Alright got the theme part figured out.

I've been starting from the advanced template and only enabled a few minor things, see Lastsession.inf.

ISO size: 1,72 GB (1.852.082.176 Bytes)

The installation consumes:

post-291600-12771430595_thumb.jpg

The only thing i integrated besides a couple windows updates are the All-In-One Runtimes (sereby.org)

Is it possible that the integrated updates causing both the installation and the ISO to take so much space?

0

Share this post


Link to post
Share on other sites

hey bensam56

could u make the saving of config file before the apply ? the changes ?

and not after

thx

0

Share this post


Link to post
Share on other sites

Alright got the theme part figured out.

I've been starting from the advanced template and only enabled a few minor things, see Lastsession.inf.

ISO size: 1,72 GB (1.852.082.176 Bytes)

Is it possible that the integrated updates causing both the installation and the ISO to take so much space?

Actually, a 1.72GB .iso is as small an x64 .iso as you are ever likely to get without some serious voodoo. The smallest W7 x64 .iso I was ever able to obtain with Vlite was around 2.1GB with integrated updates and drivers with DismTool before hand.

I managed to get a 1.65gb iso with RT7 lite, but the end result was not practical, as a good deal of my apps require 3.5 .NET. The advanced option is probably impractical for *most* users. Winsxs cache removal should probably be a hidden option, as per Vlite, as it's only going to mess with most users. But just my opinion.

Edited by Bilar Crais
0

Share this post


Link to post
Share on other sites

My x64 iso is 1,5Gb but is a home basic. For me the best to tweak andis a iso that i use now.

0

Share this post


Link to post
Share on other sites

Alright, thanks for the feedback. I hope that removing the TabletPC part will drop a few pounds once it is fixed. ;)

0

Share this post


Link to post
Share on other sites

Where's the Snipping Tool check box? I don't even see it on there any more? Keeping the Tablet PC didn't keep the Snipping Tool for me.

0

Share this post


Link to post
Share on other sites

Did a test today with ultimate 64 win7 got it to around 1.1gb. And all my stuff still works.

0

Share this post


Link to post
Share on other sites

Where's the Snipping Tool check box? I don't even see it on there any more? Keeping the Tablet PC didn't keep the Snipping Tool for me.

If you know what the name of the executable is, you should be able to "protect" it, provided it resides in system32 and all of it's dependents are still in there.

0

Share this post


Link to post
Share on other sites

Did a test today with ultimate 64 win7 got it to around 1.1gb. And all my stuff still works.

Now this is a lastsession.ini that I MUST see.

0

Share this post


Link to post
Share on other sites

Did a test today with ultimate 64 win7 got it to around 1.1gb. And all my stuff still works.

Now this is a lastsession.ini that I MUST see.

Indeed.

0

Share this post


Link to post
Share on other sites

Bilar Crais check ur inbox man...thank you

0

Share this post


Link to post
Share on other sites

Did a test today with ultimate 64 win7 got it to around 1.1gb. And all my stuff still works.

Would you please upload your lastsession.inf????????????? I am trying to trim my OS but but my aero theme is not working.

Bilar Crais check ur inbox man...thank you

Benjamin, please give me that inf.

Edited by nice_guy75
0

Share this post


Link to post
Share on other sites

Did a test today with ultimate 64 win7 got it to around 1.1gb. And all my stuff still works.

Would you please upload your lastsession.inf????????????? I am trying to trim my OS but but my aero theme is not working.

Bilar Crais check ur inbox man...thank you

Benjamin, please give me that inf.

That pertained to something else entirely, nice_guy75.

Edited by Bilar Crais
0

Share this post


Link to post
Share on other sites

That pertained to something else entirely, nice_guy75.

Oh, sorry for misunderstanding.

0

Share this post


Link to post
Share on other sites

That pertained to something else entirely, nice_guy75.

Oh, sorry for misunderstanding.

@nice_guy: Wait for new build and In new build just select Advanced option and uncheck Windows Aero Themes from Multimedia and Services. I tested it and I will send you the inf via PM....check the screenshots

s2f7eb.png

2j0eg5g.png

Edited by bensam56
0

Share this post


Link to post
Share on other sites

@nice_guy: Wait for new build and In new build just select Advanced option and uncheck Windows Aero Themes from Multimedia and Services. I tested it and I will send you the inf via PM....check the screenshots

2j0eg5g.png

Wow, just 668mb :thumbup:thumbup:thumbup:thumbup:thumbup

New Build??????????????? Are you talking about the version v1.0.8 or you are going to release another version after v1.0.8?????????

And are you sure aero theme is working fine in your OS as I feel if move your cursor to any of the opened window it will not show the preview of the window.

I hope I am wrong.

0

Share this post


Link to post
Share on other sites

@nice_guy: Wait for new build and In new build just select Advanced option and uncheck Windows Aero Themes from Multimedia and Services. I tested it and I will send you the inf via PM....check the screenshots

2j0eg5g.png

Wow, just 668mb :thumbup:thumbup:thumbup:thumbup:thumbup

New Build??????????????? Are you talking about the version v1.0.8 or you are going to release another version after v1.0.8?????????

And are you sure aero theme is working fine in your OS as I feel if move your cursor to any of the opened window it will not show the preview of the window.

I hope I am wrong.

Aero basic is working right...thats on VMware. Releasing 1.0.9 now...Only thing is after windows installation you have to enable glass transparency manually becoz of WINSAT removal. But if you keep WINSAT it will increase the ISO to 713MB....you can remove other components leaving WINSAT but I can't give guarantee for your selections...

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.