• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
bensam56

RT Seven Lite - RC build 1.7.0 and Beta build 2.6.0

1,970 posts in this topic

Just tried 1.0.9 on x64 Enterprise and everything that I had troubles with before is now working smoothly. However, I encountered another issue. After installation was complete I ran Windows Updates and all updates install except the .NET ones. I saw the post about the conflict between removing winsxs and .net but I did not check that for removal.

Attaching my lastsession.inf file for examination.

Lastsession.inf

Edited by Elmoonfire
0

Share this post


Link to post
Share on other sites

Would like to see the ability to do write an Unattended xml file without mounting the WIM file - this takes SOOO long. Any chance this could be modified so you can just select the version from a dropdown and publish the xml in a few seconds.

Other than that everything else is awesome - I tried with with several versions and the ISO build went smooth.

0

Share this post


Link to post
Share on other sites

Mark in red the Action Center in Accessories and add to its description that removing it breaks the System Performance (or whatever it is called in english version. The GUI WinSAT thing ;p) Gui under my computer properties (buttons there stop working and they look odd). Took me 2 days to figure this one out ;p

0

Share this post


Link to post
Share on other sites

On second thought, I think this very telling right here. By merely removing ONE service, you couldn't complete the install? From what I can see, you removed nothing from the system section. I'd be willing to bet it's because you're using it with French Windows 7. Also, are you beginning with a fresh, unmodified W7 disc; not already modified by vLite?

I'm using a clean untouched MSDN french iso of Windows 7 x64 (same problem in x86)

Maybe it's beacause of the french version ...

I have done some tests, i could delete succesfully homegroup services and the installation can complete.

But if i do only one tweak in services tab, it crash at "starting services" screen.

I had this problem since the earlier release of RT 7 Lite.

But if i delete some components WITHOUT touching anything about services, and if i tweak services with vLite, the installation run smoothly to the end without any problem.

This one doesn't work for me (bug at the 2nd stage of the installation)

Lastsession.inf

This one works great ...

7 LITE Valide 2010-06-26.inf

0

Share this post


Link to post
Share on other sites

hi, question on the "Application" tab, some applications require a reboot. if the application reboot will rt7 continue where it was left off? thx

0

Share this post


Link to post
Share on other sites

Is there a way to save settings so that your choices are saved between sessions? I've tried to save my settings in the Session Settings but no INF files ever get created.

0

Share this post


Link to post
Share on other sites

As are generated. Inf files with this program? . VLite is generated in the files of the session you made but it is not meeting

0

Share this post


Link to post
Share on other sites

hi, question on the "Application" tab, some applications require a reboot. if the application reboot will rt7 continue where it was left off? thx

no...

0

Share this post


Link to post
Share on other sites

Is there a way to save settings so that your choices are saved between sessions? I've tried to save my settings in the Session Settings but no INF files ever get created.

INF will be created only after completion of customization.

0

Share this post


Link to post
Share on other sites

Would like to see the ability to do write an Unattended xml file without mounting the WIM file - this takes SOOO long. Any chance this could be modified so you can just select the version from a dropdown and publish the xml in a few seconds.

Other than that everything else is awesome - I tried with with several versions and the ISO build went smooth.

I'm adding this feature in next build

0

Share this post


Link to post
Share on other sites

It would be better if it were created before. So if something goes wrong and RT7 closes prematurely, you still save your custom settings. Otherwise you have to repeat the task manually every time you try ... with the resulting splash of balls . :thumbup

0

Share this post


Link to post
Share on other sites

It would be better if it were created before. So if something goes wrong and RT7 closes prematurely, you still save your custom settings. Otherwise you have to repeat the task manually every time you try ... with the resulting splash of balls . :thumbup

I'm adding another option for this as "Save settings and export Unattended XML" - This will just export the XML.

P.S: In integration you can also give your own command line switch to install the app silently....and if you forgot to select ISO bootable it will automatically popup a window and asks you a confirmation whether you want to create a image or not?....

Server 2008 r2 customizer also ready....sending it for testing....

0

Share this post


Link to post
Share on other sites

Thanks for the reply and your hard work in creating rt7. I try the v1.0.9 but is there anyway it can integrate with DriverPacks(DP). DP is in .7z?

Edited by cat2115
0

Share this post


Link to post
Share on other sites

Thanks for the reply and your hard work in creating rt7. I try the v1.0.9 but is there anyway it can integrate with DriverPacks(DP). DP is in .7z?

You can..just extract the 7z file and locate the folder using rt 7 lite....

0

Share this post


Link to post
Share on other sites

It would be better if it were created before. So if something goes wrong and RT7 closes prematurely, you still save your custom settings. Otherwise you have to repeat the task manually every time you try ... with the resulting splash of balls . :thumbup

I'm adding another option for this as "Save settings and export Unattended XML" - This will just export the XML.

P.S: In integration you can also give your own command line switch to install the app silently....and if you forgot to select ISO bootable it will automatically popup a window and asks you a confirmation whether you want to create a image or not?....

Server 2008 r2 customizer also ready....sending it for testing....

I do not test the app integration feature but i thin'k that are but i think it would be useful to create a list of applications that can be integrated in the installation. A bit like with the Nlite addon or vLite. Well fot 2008R2. I think that is an interesting operating system to change.

0

Share this post


Link to post
Share on other sites

here is list that i have integrated and tested via virtual machine -

[Application]

idman519=D:\downloads\Internet_Download_Manager_5.19.3\Internet_Download_Manager_5.19.3\idman519.exe$idman519.exe$3.06 MB

uiso93pes=D:\downloads\UltraISO_Premium_Edition_9.3.6.2750_Retail\UltraISO Premium Edition 9.3.6.2750 Retail\uiso93pes.exe$uiso93pes.exe$3.56 MB

7z913-x64_silent=D:\downloads\7z913-x64_silent.exe$7z913-x64_silent.exe$1.32 MB

BattleshipSetup=D:\downloads\BattleshipSetup.exe$BattleshipSetup.exe$48.34 MB

eav_nt64_enu_silent=D:\downloads\eav_nt64_enu_silent.exe$eav_nt64_enu_silent.exe$40.37 MB THIS NOD32

directx_Jun2010_redist=D:\downloads\directx_Jun2010_redist.exe$directx_Jun2010_redist.exe$95.63 MB

Thunderbird Setup 3.0.5=D:\downloads\Thunderbird Setup 3.0.5.exe$Thunderbird Setup 3.0.5.exe$8.61 MB

vlc-1.1.0-win32=D:\downloads\vlc-1.1.0-win32.exe$vlc-1.1.0-win32.exe$18.59 MB

solsuite2008_v86_setup=D:\downloads\solsuite2008_v86_setup.exe$solsuite2008_v86_setup.exe$12.77 MB

SBXF_PCDRV_LB_2_18_0015=D:\downloads\SBXF_PCDRV_LB_2_18_0015.exe$SBXF_PCDRV_LB_2_18_0015.exe$46.74 MB

ITPx64_1033_7.10.344.0=D:\downloads\ITPx64_1033_7.10.344.0.exe$ITPx64_1033_7.10.344.0.exe$15.26 MB

IPx64_1033_7.10.344.0=D:\downloads\IPx64_1033_7.10.344.0.exe$IPx64_1033_7.10.344.0.exe$16.01 MB

Firefox Setup 3.6.4=D:\downloads\Firefox Setup 3.6.4.exe$Firefox Setup 3.6.4.exe$8.19 MB

everestultimate550=D:\downloads\everestultimate550.exe$everestultimate550.exe$9.78 MB

0

Share this post


Link to post
Share on other sites

here is list that i have integrated and tested via virtual machine -

Has anyone tried any of the windows update executables, such as the Malicious Software Removal Tool?

0

Share this post


Link to post
Share on other sites

hi, after downloading driverspack x64 and extract .7z, i run RT7Lite 1.0.9 to integrate driver and selecting all drivers. i got this error. please see screenshot. also below is a full details.

See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.IndexOutOfRangeException: Index was outside the bounds of the array.

at RTWin7Lite.RT7LiteHome.getDriverInfo(String filename) in D:\Ben\4-8-2010\Final_state\RTWin7Lite\RTWin7Lite\RT7LiteHome.vb:line 2599

at RTWin7Lite.RT7LiteHome.setDriverDetails(String[] NIF_Files) in D:\Ben\4-8-2010\Final_state\RTWin7Lite\RTWin7Lite\RT7LiteHome.vb:line 2547

at RTWin7Lite.RT7LiteHome.btn_drivers_folder_Click(Object sender, EventArgs e) in D:\Ben\4-8-2010\Final_state\RTWin7Lite\RTWin7Lite\RT7LiteHome.vb:line 2629

at System.Windows.Forms.Control.OnClick(EventArgs e)

at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)

at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.ButtonBase.WndProc(Message& m)

at System.Windows.Forms.Button.WndProc(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************

mscorlib

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll

----------------------------------------

RTWin7Lite

Assembly Version: 1.0.9.0

Win32 Version: 1.0.9.0

CodeBase: file:///C:/Program%20Files/RT%207%20Lite/RTWin7Lite.exe

----------------------------------------

Microsoft.VisualBasic

Assembly Version: 8.0.0.0

Win32 Version: 8.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll

----------------------------------------

System

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Windows.Forms

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System.Drawing

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System.Runtime.Remoting

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll

----------------------------------------

RTWin7Lite.resources

Assembly Version: 1.0.9.0

Win32 Version: 1.0.9.0

CodeBase: file:///C:/Program%20Files/RT%207%20Lite/en-US/RTWin7Lite.resources.DLL

----------------------------------------

System.Configuration

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

Accessibility

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

post-285905-127795485037_thumb.jpg

Edited by cat2115
0

Share this post


Link to post
Share on other sites

Tell me which driver pack you downloaded and how you selected the folder as....I asked this same question to another user but I not yet received the answer. Till then I cannot solve this. The thing is required info is missing in some driver INF files. Thats y its happening.

0

Share this post


Link to post
Share on other sites

Tell me which driver pack you downloaded and how you selected the folder as....I asked this same question to another user but I not yet received the answer. Till then I cannot solve this. The thing is required info is missing in some driver INF files. Thats y its happening.

Thanks for the reply. I finally figure it out. What happen was i select all drivers in the folder that contain sound, graphic, lan, wlan, etc and i guess RT7Lite can only handle certain amount of selection. so to resolve, i select one at time. example, i select sound folder add it then go on to the next folder, etc

0

Share this post


Link to post
Share on other sites

Tell me which driver pack you downloaded and how you selected the folder as....I asked this same question to another user but I not yet received the answer. Till then I cannot solve this. The thing is required info is missing in some driver INF files. Thats y its happening.

Thanks for the reply. I finally figure it out. What happen was i select all drivers in the folder that contain sound, graphic, lan, wlan, etc and i guess RT7Lite can only handle certain amount of selection. so to resolve, i select one at time. example, i select sound folder add it then go on to the next folder, etc

not like that friend...app can handle any amount of drivers but the thing is if any required info is missing in any INF then that error will happen. Anyhow I sorted out that problem and fixed it.

0

Share this post


Link to post
Share on other sites

so if i were to redo it and select all driver in the folder it should work??? this is what i did:

i create a folder on the desktop called "driver" then i extract DP.7z into that folder.

Driver\sound\all subfolder and files from extraction

Driver\graphic\all subfolder and files from extraction

etc...

I right click on RT7Lite and run as Admin, browser to iso and select win7 version. then rt7lite did it things.

now i check on integration. i click on "driver" tab. then i click on i think it call "multi" file. i 4got what it called. from there i select the folder called "Driver" on my desktop and i highlight all drivers. it should work with no error as my previous post?

do i need to redownload rt7lite 1.0.9 again?

thx

Edited by cat2115
0

Share this post


Link to post
Share on other sites

Will there be any plans to integrate SP1 upon release?

0

Share this post


Link to post
Share on other sites

so if i were to redo it and select all driver in the folder it should work??? this is what i did:

i create a folder on the desktop called "driver" then i extract DP.7z into that folder.

Driver\sound\all subfolder and files from extraction

Driver\graphic\all subfolder and files from extraction

etc...

I right click on RT7Lite and run as Admin, browser to iso and select win7 version. then rt7lite did it things.

now i check on integration. i click on "driver" tab. then i click on i think it call "multi" file. i 4got what it called. from there i select the folder called "Driver" on my desktop and i highlight all drivers. it should work with no error as my previous post?

do i need to redownload rt7lite 1.0.9 again?

thx

one of the INF in that driver pack has no version information after the release date. Thats y that error is coming. Wait for next build. I got the same error while some info was missed in INF. I fixed that so wait for the next build friend....

@clavicle: It will be available once after the public Beta release of SP1

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.