krelian

Unusual memory issue - SOLVED -

28 posts in this topic

Hi everybody My build is made of a ICH7-P31 mobo and 2GB ram installed. However when I first installed Win98SE (using most of the switches foud here My link)I only used a single 512MB module just to make things easier. After that I installed SP2.1, placed the 2x1GB modules and everything was working just great, not a problem. Since I started installing softwares (mostly cd burning stuff and Ofiice XP+SP3) I noticed the system became unstable, i experienced many freezes and more importantly I'm unable to boot into safe mode. If I hit F8 abd select "Safe mode" I get this message:

Insufficient memory to initialize Windows. Quit one or more memory-resident programs or remove unnecessary utilities from your CONFIG.SYS and AUTOEXEC.BAT files, and restart your computer.
I made a bit of research obviously. I played around with settings I found in this threads: One Two Three Four but nothing fixed it I can start Windows normally no prob, but I guess the fact I can't get into safe mode isn't exactly a good sign? any help appreciated :hello: Edited by krelian
0

Share this post


Link to post
Share on other sites

My own personal experience with more than 512MB of RAM has led me to believe there is only one "good" solution - buy rloew's RAM patch. Before doing so I tried some of the other methods described in those threads you referenced, including the Unofficial Service Pack, and my system either would not boot with more than 512MB of RAM, or was unstable.

Maybe some of the other members can help you if you wish to experiment further with the free methods. You should post exactly which methods you have tried, and what the results of each experiment were so they will know how to advise you. :)

0

Share this post


Link to post
Share on other sites

You're far from having an "unusual" memory issue... And to access Safe Mode, some tweaks are needed.

I never said that running 9x/ME with > 1 GiB RAM for free is a walk in the park!

But I cannot help you on the meagre info you provided.

Post a machine configuration like those you can see in post #2 of the > 1 GiB RAM thread.

And attach, don't post, a zip file containing your AUTOEXEC.BAT, CONFIG.SYS, MSDOS.SYS, WIN.INI and SYSTEM.INI.

Then we can try to help you do it.

0

Share this post


Link to post
Share on other sites

Hi

well for starters I installed xeno86's Vcache fix, then followed dencorso's step-by-step guide to remove ACPI

Then I literally spent A MONTH playing in the system.ini and trying any possible combination gathered from the many threads I have read on the subject.....still nothing

The weird ting I could actually boot into safe mode when first installed, I must have installed something that messed things up

I didn't know about that RAM patch. I'm really tempted to purchase it

thanks a lot for your time :hello:

0

Share this post


Link to post
Share on other sites
You're far from having an "unusual" memory issue... And to access Safe Mode, some tweaks are needed.

I never said that running 9x/ME with > 1 GiB RAM for free is a walk in the park!

But I cannot help you on the meagre info you provided.

Post a machine configuration like those you can see in post #2 of the > 1 GiB RAM thread.

And attach, don't post, a zip file containing your AUTOEXEC.BAT, CONFIG.SYS, MSDOS.SYS, WIN.INI and SYSTEM.INI.

Then we can try to help you do it.

here we go

autoexec.bat is empty though, this I really don't undestand

take your time anyway

Euro zone here and I'm just leaving for work.....

I really appreciate it, thank you very much

edit:

it seems I'm unable to upload files, I'll sort it out later

sorry for the confusion

Edited by krelian
0

Share this post


Link to post
Share on other sites

Maybe the attachment system is disabled on this forum. It's happened before.

Can any of you all confirm it? If that's the case I'll see to it that it gets reenabled.

Please chime in.

@krelian: instead of attaching uploade the zip to rapidshare or uploaded.to and post the link here.

Don't forget to provide the machine's hardware info. When I have that, after musing over it some,

I'll suggest you something. Meanwhile, do create a bootable CD or floppy with memtest86+ and run it

continuously for at least 12h, to see whether your machine's RAM is OK.

0

Share this post


Link to post
Share on other sites

Maybe the attachment system is disabled on this forum. It's happened before.

Can any of you all confirm it? If that's the case I'll see to it that it gets reenabled.

Please chime in.

@krelian: instead of attaching uploade the zip to rapidshare or uploaded.to and post the link here.

Don't forget to provide the machine's hardware info. When I have that, after musing over it some,

I'll suggest you something. Meanwhile, do create a bootable CD or floppy with memtest86+ and run it

continuously for at least 12h, to see whether your machine's RAM is OK.

heh

I guess the problem was with Win98 itself. I'm now on my WinXP partition and could upload the file no problem.

I will run memtest meanwhile

OS: Windows 98SE

Memory: 2 GiB RAM (DDRII-800 - 2x 2 GiB Corsair XMS2)

Motherboard: Gigabyte GA-P31-ES3G

CPU: Pentium Dual E6500

Video card: Ati Radeon X550 (256 MB; PCIe)

thanks again

krelian.zip

autoexec.txt

Edited by krelian
0

Share this post


Link to post
Share on other sites

Let's start by doing some changes to your config.sys, and observing what happens:

1)Since you don't use EMM386.EXE (neither do I), there can be no UMBs nor EMS. So substitute:

"dos=high,umb" by "dos=high" and "devicehigh=ramdrive.sys /E 2048" by "device=ramdrive.sys /E 2048"

2)However, ramdrive.sys is a very limited ramdrive, so let's use XMSDSK. So substitute:

"device=ramdrive.sys /E 2048" by "INSTALL=XMSDSK.EXE 2048 /C1 /T /Y"

You'll need to have XMSDSK.EXE at the root directory of the boot disk or if you prefer to have it elsewhere:

"INSTALL=<path>\XMSDSK.EXE 2048 /C1 /T /Y", where <path> must be substituted be the actual path to XMSDSK

and

3)Let's use HIMEMX.EXE, instead of himem.sys. So substitute:

"device=himem.sys /testmem:off" by "device=himemx.exe /testmem:off"

You'll need to have himemx.exe at the root directory of the boot disk or if you prefer to have it elsewhere:

"device=<path>\himemx.exe /testmem:off", where <path> must be substituted be the actual path to himemex

Here's a good reference for MS-DOS 7 Commands, in case you ever need one and links to get HIMEMX and XMSDSK are findable in the 1st post of the > 1 GiB RAM thread.

Do all three changes at the same time, test how your system behaves and let me know.

Our next move will be to solve the "Safe Mode" issue, but first we should establish that the modifications I just suggested either make your system more generally stable or, at least, do not render it less stable.

Good luck!

0

Share this post


Link to post
Share on other sites

right, sorry for late, I have been w/out internet connection for a few days.

I did test both modules for 12hrs. No errors

Since I tested a module per time in slot 0, I tried to boot WIn98 with a single memory module, before even touching the config.sys and ta-da....I could boot into safe mode no problem.

When both modules were placed I got again that "Insufficient memory" error.

I made all the changes in config.sys but nothing changed IF both memory modules are inserted

couple of things (probably obvious):

1)Config.sys and autoexec.bat options are empty in the msconfig utility and at root.

Those that I put in the zip file are located in C:\WINDOWS\COMMAND\EBD

2) XMSDSK.EXE only works if I reboot in real DOS mode. If I try to access it via command line I get this message:

"XMSDSK.EXE driver not loaded. Can't load it: running under Windows. "

3) device=himemx.sys /testmem:off

is present 2 times in config.sys under both [NOCD] and [HELP]

I substituted both by himex.exe

4) if I access himem.sys (notepad) i can see this error:

"ERROR: HIMEM.SYS has detected unreliable XMS memory at address $5To continue starting your computer, press ENTER."

muito, muito obrigado

0

Share this post


Link to post
Share on other sites

1) you need to have a non-empty config.sys to be able to work with minimal reliability with > 1 GiB RAM

2) the config.sys must be in the root directory of the boot partition.

3) it has to have a line for HIMEMX.EXE (*NOT HIMEMX.SYS) or it'll use HIMEM.SYS by default.

4) HIMEMX.EXE and XMSDISK.EXE should be loaded from config.sys, not from the command line

5) to access "Safe Mode" with > 1 GiB RAM you'll need both the VCache.VxD modded by Xeno86 and xRayeR's patch to IO.SYS.

6) I'm trying to help you, but if you omit information (like the fact you were offering us the configuration files from C:\WINDOWS\COMMAND\EBD, which are irrelevant here, instead of making it clear you had no config.sys on the root directory or that it was an empty file), then what is already not very easy becomes impossible to do.

0

Share this post


Link to post
Share on other sites

5) to access "Safe Mode" with > 1 GiB RAM you'll need both the VCache.VxD modded by Xeno86 and xRayeR's patch to IO.SYS.

Are you sure? Did you read my posts about system.cb in safe mode? They are here: http://www.msfn.org/board/more-than-win9x-safe-mode-t142953.html

If my solution works for safe mode, it can be more useful than binary patches.

@Usher: I've read it, rest assured. Your solution may well work. I have not tested it, nor can do it easily, because nowadays I use the RAM Limitation Patch, which I deem the best solution. It gives the system much more stability than any of the free solutions and access to all the RAM. Since I've got no experience with your method, I cannot recommend it, although this does not mean I'm implying it doesn't work. I simply never tried it, and, as far as I know, nobody else did, since you posted it. But I'm willing to add your thread and your machine to the > 1 GiB list, provided you PM me the description of your system, in the lines of the descriptions of the machines already listed there.

But using xRayeR's patch is very reliable, and has been thoroughly tested by many users.

Xeno86's modded VCache.VxD and xRayeR's modded IO.SYS are perfectly safe, there's no need to be paranoid about them, and they obviate a lot of work.

I recommend doing the following (read this as a Mini How-To), which works for both Normal and Safe Modes:

1) Adding a "MaxPhysPage=48000", without the inverted commas to the [386Enh] section of C:\WINDOWS\SYSTEM.INI

2) Installing Xeno86's modded VCache.VxD (after this, usually, no MaxFileCache line is needed in SYSTEM.INI)

3) Adding HIMEMX.EXE to C:\WINDOWS, and then renaming it to HIMEM.EXE

4) Applying MS KB311561, then rebooting.

5) Running xRayeR's w98iopat.exe, in True DOS, from C:\

6) Creating a CONFIG.SYS in C:\, containing the single line "DEVICE=C:\WINDOWS\HIMEM.EXE /NUMHANDLES=64", without the inverted commas.

For even better results, one should instead use RLoew's RAM Limitation Patch, of course, but that's not for free, and the above procedure is the most reliable way to do it completely for free, in my experience.

0

Share this post


Link to post
Share on other sites

I'm trying to help you, but if you omit information (like the fact you were offering us the configuration files from C:\WINDOWS\COMMAND\EBD, which are irrelevant here, instead of making it clear you had no config.sys on the root directory or that it was an empty file), then what is already not very easy becomes impossible to do.

point taken

please dont think that I was being careless or something, it's just is something totally new to me. I genuinely thought to look at the correct config.sys until I've read your reply.

meanwhile, I copied the content of config.sys (EBD folder) into the config.sys in C:/.

also when I run xRayeR's ios.sys I ignored those the instructions given on screen.

Now it can't even boot normally. I got a black screen and a series of error messages.

I cant even boot a command prompt. I guess I screwed it up.

Probably better re-install it?

Edited by krelian
0

Share this post


Link to post
Share on other sites

There is no need to reinstall.

Copying the config.sys from ebd to c:\ will not work...

Supposing you did follow these instructions to the letter (now, did you?):

1) Add a "MaxPhysPage=48000", without the inverted commas to the [386Enh] section of C:\WINDOWS\SYSTEM.INI

2) Install Xeno86's modded VCache.VxD (after this, usually, no MaxFileCache line is needed in SYSTEM.INI)

3) Add HIMEMX.EXE to C:\WINDOWS, and then rename it to HIMEM.EXE

4) Apply MS KB311561, then reboot.

5) Run xRayeR's w98iopat.exe, in True DOS, from C:\

The this is how to fix the blotched step (6):

Boot to DOS from a floppy disk or a cd or a pendrive

Change partition Windows boots from (let's say it's C:\)

Delete config.sys.

Then, at the prompt type:

Copy con config.sys <Enter>

DEVICE=C:\WINDOWS\HIMEM.EXE /NUMHANDLES=64 <Ctrl>Z <Enter>

A new config.sys, containing just the correct line will be created.

Observe that to type <Ctrl>Z you should press and hold the <Ctrl> key and then press Z, and then release both keys.

After this, remove the floppy and reboot.

Tell me what happens.

BTW, do you speak Portuguese?

0

Share this post


Link to post
Share on other sites

There is no need to reinstall.

Copying the config.sys from ebd to c:\ will not work...

Supposing you did follow these instructions to the letter (now, did you?):

did everything ecept installing the KB311561 hotfix (it can't be executed under DOS, btw)

when I reboot it states there's an error in line 1 of config.sys

and that himem.exe and himem.sys are missing, which is strange because I can see them in the direcory.

I used to speak Portuguese as I lived in Portugal (and Brazil too) for some time, however I can hardly speak it anymore:(

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.