Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Kullenen_Ask

Portable Windows 7 build from Winpe 3.0

Recommended Posts

Mount wim to a folder read and write. Use this hive loader to mount software or system hive to your current registry. loadhive.exe If you loaded SYSTEM hive. import SYSTEM_00 reg file if not load SOFTWARE one. I suppose that you know the basic knowledge of mount a hive and import a reg key into it. If not this topic is not for to teach it to you.

Share this post


Link to post
Share on other sites
shivan    0

Nevermind i just figured it out, thanks, the correct files are in place, the keys are in the registry, still .msi extencions are not registered by default(fixed by a simple regsvr32 msi.dll"), i also tryie doind msiexec /regserver, still no luck, i cant start the msi service...

BTW, you know if there is any way to install VB2008 / 2005 redistributable once .msi installer is working? none of those .cab packages in Windows 7 Compact incluides it or something??? i have some programs that they "cant start becuase of a side-by-side configuration error".

Edited by shivan

Share this post


Link to post
Share on other sites
wimb    3

Make_PE3 will make 7PE with built-in msi support.

You will find in Make_PE3\MULTI\SxS_Fix_Win7PE folder info and file SxS_7PE_SFX.exe to fix the side by side errors.

Share this post


Link to post
Share on other sites
shivan    0

Make_PE3 will make 7PE with built-in msi support.

You will find in Make_PE3\MULTI\SxS_Fix_Win7PE folder info and file SxS_7PE_SFX.exe to fix the side by side errors.

Yeah! thanks that fixed all side by side errors! thanks.

about .msi installer

I cant use your tool for this, i need to be able to do the .wim file myselft, im very very close to finish this, i just need to be able to install OpenCL, (uses an msi installer), in a .wim image made by your tool it installed fine, i need to do the same. How you managed to make que windows installer to work?

i just need this to finish it. the msiexec seem to be registered, its the service who is not running.

BTW, i have to do something after loading a video driver? because the driver seems to be installing using drvload, but not init (no change in resolution).

Edited by shivan

Share this post


Link to post
Share on other sites
killerb255    0

Make_PE3 will make 7PE with built-in msi support.

You will find in Make_PE3\MULTI\SxS_Fix_Win7PE folder info and file SxS_7PE_SFX.exe to fix the side by side errors.

Yes, but Make_PE3 doesn't support SP1 or IE9...

Share this post


Link to post
Share on other sites

probably never support. it is just wimb advertisement. no need for sp1. my aim never be all people use my software or be famous. if i were want that it could be. all stuff started because of i do not want to use what someone wants me to use his software and i started to make my own and after hard works and interest i saw that it is not difficult to do because i am not an expert. because pre built coded builders will never be perfect as users wants it to be. just think of microsoft. they never compile a software what users want, they only build what they want and sell.

He can integrate everything without ask "why? what JFX or other users want to add (i know such experinced members very good and they do perfect work but) you (normal users) will not have anthing to complain about his GREAT WORK {i say it honestly, yiğidi öldür hakkını yeme (Turkish)}. If you want to complain, do by your own BETTER (also i say for my works). I always try to help user problems but they should be enough technical and the user should have basic knowledge for editing wim and registry.

With the genious of JFX findings and his explanations makes vss issue one step away. I have not need to use vss yet.

http://forum.sanbarrow.com/viewtopic.php?f=85&t=49

Some needed stuff by me. SP0 only

vss

vss mirror

th_vss.jpg

Edited by Kullenen_Ask

Share this post


Link to post
Share on other sites
ChrisB    0

kullenen_ask and wimb

Guys i have been trying to add a custom clid.reg created using kullenen_ask method in post 71 i think it was. After i import the reg and boot the sistem i receive a bsod with stop error: c000021a

okay now without adding the reg and changing winpeshl.ini to start wpeinit.exe winpe boots up CMD runs then the system reboots.

Any idea on the blue screen

i am using dart as the base boot.wim

i understand that the clid.reg is needed for explorer.exe to work as windows shell

This is how i created the clid

replaced all d:\ (hex entries as well) with x:\ and removed runas=interactive user

What is used to launch the explorer

Share this post


Link to post
Share on other sites

*Take your working untouched winpe.

*Do not touch your winpeshl.ini any (this is important in your case).

*Do d: -> x: conversions and copy that classes, explorer registry braches into your winpe. and make

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"Shell"="explorer.exe

change.

*Add the metioned files with muis to corresponding folders. (There should need more files at least they can show taskbar.)

*Boot your winpe. Now it should open with command prompt. If you write explorer.exe in command prompt shell should open. It looks like a winpeshl.ini mistake. Classes and Explorer registry branch change never gived blue screen in any experiment for me. They are safe for blue screen.

Edited by Kullenen_Ask

Share this post


Link to post
Share on other sites
ChrisB    0

Thanks for the information

Successfully booted Winpe with Explorer.exe (GUI support)

Thanks for your help Kellenen_Ask - Very much appreciated

Currently working on services and theme support

Logging in as Administrator

i read ur posts but i have not seen any information on logging in as different users

can this be set in the registry

Share this post


Link to post
Share on other sites

I do not know exact registry keys. It happens by itself. All i know it needs netprofm and for fast switching taskscheduler service.

Enable shutdown/reboot button on x64 winpe by JFX

source: enable shutdown buttons on 64Bit Win7PE


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoClose"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
"AppInit_DLLs"="ReBoot.dll"
"LoadAppInit_DLLs"=dword:00000001
"RequireSignedAppInit_DLLs"=dword:00000000

Put reboot.dll inside system32 folder

Reboot.dll

Reboot.dll mirror

Edited by Kullenen_Ask

Share this post


Link to post
Share on other sites
ChrisB    0

Personalization

When i use right click menu and go to personalize

This page is not available in this edition of windows

i have all files needed from Win 7 Pro

Netsvcs > themes

LocalSystemNetworkRestricted > UxSms

Services are started in PE... loaded from virtual box

Themes are started but then stop after desktop update then i have a black wallpaper

logging in as system

Winpeshl.ini

ux.exe

explorer.exe

Share this post


Link to post
Share on other sites
ChrisB    0

Thanks Kullenen_Ask :thumbup

Worked as you suggested

Exported system\controlsetXXX\control\productoptions key

Applied the reg key to custom system hive

booted WinPE and themes worked

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×