Kullenen_Ask

Portable Windows 7 build from Winpe 3.0

226 posts in this topic

Looks interesting, but was a little bit hard to understand everything. I assume you've merged stuff from newest Windows 7 Embedded (2011)..?

I had the dotnet framework working on RC1, but something changed in rtm, and it broke. Do you have dotnet working 100%? How about vss?

Would be nice to see some batches and registry files when you re finished with your project.

Btw, what language is your win?

Joakim

0

Share this post


Link to post
Share on other sites

Looks interesting, but was a little bit hard to understand everything. I assume you've merged stuff from newest Windows 7 Embedded (2011)..?

I had the dotnet framework working on RC1, but something changed in rtm, and it broke. Do you have dotnet working 100%? How about vss?

Would be nice to see some batches and registry files when you re finished with your project.

Btw, what language is your win?

Joakim

no. it was from windows 7 dvd. i dont added .net but .net framework dependent services works. vss works too. it is turkish language. i don't know why everybody wants .net framework. why it is for? i don't install it if i don't have to or a soft doesn't install without it. It will take lots of space inside wim and image will not be optimized for quick boot. What software you want to use inside it .net dependent. Can you give name? want to learn.

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

Thanks a lot the continuation of sharing your findings on internet Kullenen_Ask :thumbup

0

Share this post


Link to post
Share on other sites

Thanks a lot the continuation of sharing your findings on internet Kullenen_Ask :thumbup

i wish here to be more freedom. also if we can find a good coder we can automize some settings i think. there is only 2 hives and a couple of files. it shouldnt be difficult to make a soft. i can customize hives to languages and share to developers. it can be done a base winpe and some options to select functions that will copy needed files for that functions only. hives doesnt need to be changed. wbiosvc,multimedia service,stickynot coming soon. also will try to get windows updates functional too.

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

You got me a litle curious about the vss bit, as I only ever managed to get that service running correctly on a 2003 based PE. Can you verify the output of "vssadmin list writers" from within PE?

Keep up good work..

Joakim

0

Share this post


Link to post
Share on other sites

You got me a litle curious about the vss bit, as I only ever managed to get that service running correctly on a 2003 based PE. Can you verify the output of "vssadmin list writers" from within PE?

Keep up good work..

Joakim

i said that because vss service works. here is screenshot. your command gives inner error. other one says no objects. i didnt focus about everything yet. can focus later. functions for general users more important now.

th_veayc4.png

i try to get windows update work. my update log like this. anybody has idea to solve?


2010-04-11 23:32:26:375 860 7cc Misc =========== Logging initialized (build: 7.3.7600.16385, tz: +0200) ===========
2010-04-11 23:32:26:375 860 7cc Misc = Process: X:\windows\system32\svchost.exe
2010-04-11 23:32:26:375 860 7cc Misc = Module: x:\windows\system32\wuaueng.dll
2010-04-11 23:32:26:265 860 7cc Service *************
2010-04-11 23:32:26:375 860 7cc Service ** START ** Service: Service startup
2010-04-11 23:32:26:375 860 7cc Service *********
2010-04-11 23:32:26:843 860 7cc Agent * WU client version 7.3.7600.16385
2010-04-11 23:32:26:843 860 7cc Agent * Base directory: X:\windows\SoftwareDistribution
2010-04-11 23:32:26:984 860 7cc Agent * Access type: No proxy
2010-04-11 23:32:27:125 860 7cc Agent * Network state: Disconnected
2010-04-11 23:32:30:359 860 7cc DtaStor Default service for AU is {00000000-0000-0000-0000-000000000000}
2010-04-11 23:32:30:359 860 7cc DtaStor Default service for AU is {9482F4B4-E343-43B6-B170-9A65BC822C77}
2010-04-11 23:32:30:453 860 7cc Agent WARNING: Failed to read the service id for re-registration 0x80070002
2010-04-11 23:32:30:453 860 7cc Agent WARNING: Missing service entry in the backup data store; cleaning up
2010-04-11 23:32:31:796 860 7a0 Report CWERReporter::Init succeeded
2010-04-11 23:32:31:796 860 7a0 Agent *********** Agent: Initializing Windows Update Agent ***********
2010-04-11 23:32:31:796 860 7cc Agent Created new random SusClientId d787a859-302b-41e2-9b5b-a6d9cc5eb935. Old Id: none.
2010-04-11 23:32:31:796 860 7cc Report *********** Report: Initializing static reporting data ***********
2010-04-11 23:32:31:796 860 7cc Report * OS Version = 6.1.7600.0.0.65792
2010-04-11 23:32:31:796 860 7cc Report * OS Product Type = 0x00000004
2010-04-11 23:32:31:828 860 7a0 Agent *********** Agent: Initializing global settings cache ***********
2010-04-11 23:32:31:828 860 7a0 Agent * WSUS server: <NULL>
2010-04-11 23:32:31:828 860 7a0 Agent * WSUS status server: <NULL>
2010-04-11 23:32:31:828 860 7a0 Agent * Target group: (Unassigned Computers)
2010-04-11 23:32:31:828 860 7a0 Agent * Windows Update access disabled: No
2010-04-11 23:32:31:828 860 7a0 DnldMgr Download manager restoring 0 downloads
2010-04-11 23:32:31:843 860 7a0 AU ########### AU: Initializing Automatic Updates ###########
2010-04-11 23:32:31:843 860 7a0 AU AU setting next sqm report timeout to 2010-04-11 21:32:31
2010-04-11 23:32:31:843 860 7a0 AU AU setting next featured software notification timeout to 2010-04-11 21:32:31
2010-04-11 23:32:31:843 860 7a0 AU AU featured software notification sequence number is 4582, Generation Time:2010-04-11 21:32:31
2010-04-11 23:32:31:843 860 7a0 AU # AU disabled through Policy
2010-04-11 23:32:31:843 860 7a0 AU # Will interact with non-admins (Non-admins are elevated (User preference))
2010-04-11 23:32:31:859 860 7a0 Agent Switching to hardware-verified ClientId.
2010-04-11 23:32:31:859 860 7a0 AU Initializing featured updates
2010-04-11 23:32:31:859 860 7a0 AU Found 0 cached featured updates
2010-04-11 23:32:35:593 860 7cc Report * Computer Brand = VMware, Inc.
2010-04-11 23:32:35:593 860 7cc Report * Computer Model = VMware Virtual Platform
2010-04-11 23:32:35:687 860 7cc Report * Bios Revision = 6.00
2010-04-11 23:32:35:687 860 7cc Report * Bios Name = PhoenixBIOS 4.0 Release 6.0
2010-04-11 23:32:35:687 860 7cc Report * Bios Release Date = 2008-08-15T00:00:00
2010-04-11 23:32:35:687 860 7cc Report * Locale ID = 1055
2010-04-11 23:32:35:718 860 7a0 AU Successfully wrote event for AU health state:0
2010-04-11 23:32:35:718 860 7a0 AU Successfully wrote event for AU health state:0
2010-04-11 23:32:35:734 860 7a0 AU AU finished delayed initialization
2010-04-11 23:32:35:828 860 7cc AU AU setting next sqm report timeout to 2010-04-12 21:32:35
2010-04-11 23:32:40:890 860 10c Misc WARNING: Assert config failed, error = 80070002
2010-04-11 23:32:40:890 860 10c Report WARNING: Unable to assert evt log config: 0x80070002
2010-04-11 23:32:40:890 860 10c Report CWERReporter finishing event handling. (00000000)
2010-04-11 23:32:46:156 860 7d8 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:32:46:171 1036 7bc Misc =========== Logging initialized (build: 7.3.7600.16385, tz: +0200) ===========
2010-04-11 23:32:46:171 1036 7bc Misc = Process: X:\Windows\explorer.exe
2010-04-11 23:32:46:171 1036 7bc Misc = Module: X:\windows\system32\wucltux.dll
2010-04-11 23:32:46:156 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:32:50:015 860 7a0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:32:50:015 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:32:51:343 860 7d8 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:32:51:343 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:34:01:046 860 36c Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:34:01:046 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:34:02:421 860 36c Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:34:02:421 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:34:02:421 860 36c Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:34:02:437 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:34:02:796 860 36c Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:34:02:796 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:36:52:812 860 10c Report CWERReporter finishing event handling. (00000000)
2010-04-11 23:42:43:562 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:42:43:578 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:42:45:765 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:42:45:781 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:42:45:968 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:42:45:968 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:42:46:171 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:42:46:171 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:42:46:359 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:42:46:359 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:42:46:546 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:42:46:562 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:42:54:343 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:42:54:343 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:42:56:140 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:42:56:156 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:42:56:812 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:42:56:828 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:43:10:968 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:43:10:968 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:43:12:109 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:43:12:109 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:43:30:968 1036 7bc Misc Changed wuauserv to auto-start
2010-04-11 23:43:30:984 860 7ec AU ########### AU: Setting new AU options ###########
2010-04-11 23:43:30:984 860 7ec AU Successfully wrote event for AU health state:0
2010-04-11 23:43:30:984 860 7ec AU # Policy changed, AU refresh required = No
2010-04-11 23:43:30:984 860 7ec AU # AU disabled through Policy
2010-04-11 23:43:30:984 860 7ec AU # Will interact with non-admins (Non-admins are elevated (User preference))
2010-04-11 23:43:30:984 860 7ec AU AU settings changed through User Preference.
2010-04-11 23:43:33:109 860 7ec Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:43:33:109 1036 7bc WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:43:35:984 860 10c Report CWERReporter finishing event handling. (00000000)
2010-04-11 23:44:18:343 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:44:18:343 1036 52c Misc =========== Logging initialized (build: 7.3.7600.16385, tz: +0200) ===========
2010-04-11 23:44:18:343 1036 52c Misc = Process: X:\Windows\explorer.exe
2010-04-11 23:44:18:343 1036 52c Misc = Module: X:\windows\system32\wucltux.dll
2010-04-11 23:44:18:343 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:44:45:437 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:44:45:437 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:44:47:328 860 534 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:44:47:328 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:46:54:109 860 5d0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:46:54:109 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:46:54:796 860 5d0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:46:54:796 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:46:55:000 860 5d0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:46:55:000 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:46:55:187 860 5d0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:46:55:187 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:46:55:375 860 5d0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:46:55:375 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:46:55:578 860 5d0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:46:55:578 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:46:55:781 860 5d0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:46:55:781 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:46:57:625 1036 52c WUApp WARNING: User clicked "Get help" for error code 800703F0. Opening help failed with result 80080005.
2010-04-11 23:47:44:921 860 7cc AU ########### AU: Uninitializing Automatic Updates ###########
2010-04-11 23:47:44:921 860 7cc Report CWERReporter finishing event handling. (00000000)
2010-04-11 23:47:45:046 860 7cc Service *********
2010-04-11 23:47:45:046 860 7cc Service ** END ** Service: Service exit [Exit code = 0x240001]
2010-04-11 23:47:45:046 860 7cc Service *************
2010-04-11 23:47:47:718 860 64c Misc =========== Logging initialized (build: 7.3.7600.16385, tz: +0200) ===========
2010-04-11 23:47:47:718 860 64c Misc = Process: X:\windows\system32\svchost.exe
2010-04-11 23:47:47:750 860 64c Misc = Module: x:\windows\system32\wuaueng.dll
2010-04-11 23:47:47:718 860 64c Service *************
2010-04-11 23:47:47:750 860 64c Service ** START ** Service: Service startup
2010-04-11 23:47:47:765 860 64c Service *********
2010-04-11 23:47:47:781 860 64c Agent * WU client version 7.3.7600.16385
2010-04-11 23:47:47:781 860 64c Agent * Base directory: X:\windows\SoftwareDistribution
2010-04-11 23:47:47:781 860 64c Agent * Access type: No proxy
2010-04-11 23:47:47:796 860 64c Agent * Network state: Connected
2010-04-11 23:47:54:500 860 6a4 Report CWERReporter::Init succeeded
2010-04-11 23:47:54:500 860 6a4 Agent *********** Agent: Initializing Windows Update Agent ***********
2010-04-11 23:47:54:500 860 64c Report *********** Report: Initializing static reporting data ***********
2010-04-11 23:47:54:500 860 64c Report * OS Version = 6.1.7600.0.0.65792
2010-04-11 23:47:54:500 860 64c Report * OS Product Type = 0x00000004
2010-04-11 23:47:54:515 860 6a4 Agent *********** Agent: Initializing global settings cache ***********
2010-04-11 23:47:54:515 860 6a4 Agent * WSUS server: <NULL>
2010-04-11 23:47:54:531 860 6a4 Agent * WSUS status server: <NULL>
2010-04-11 23:47:54:531 860 6a4 Agent * Target group: (Unassigned Computers)
2010-04-11 23:47:54:531 860 6a4 Agent * Windows Update access disabled: No
2010-04-11 23:47:54:531 860 6a4 DnldMgr Download manager restoring 0 downloads
2010-04-11 23:47:54:531 860 6a4 AU ########### AU: Initializing Automatic Updates ###########
2010-04-11 23:47:54:531 860 6a4 AU # AU disabled through Policy
2010-04-11 23:47:54:546 860 6a4 AU # Will interact with non-admins (Non-admins are elevated (User preference))
2010-04-11 23:47:54:546 860 6a4 Agent Switching to hardware-verified ClientId.
2010-04-11 23:47:54:546 860 6a4 AU Initializing featured updates
2010-04-11 23:47:54:546 860 6a4 AU Found 0 cached featured updates
2010-04-11 23:47:55:515 860 64c Report * Computer Brand = VMware, Inc.
2010-04-11 23:47:55:515 860 64c Report * Computer Model = VMware Virtual Platform
2010-04-11 23:47:55:546 860 64c Report * Bios Revision = 6.00
2010-04-11 23:47:55:546 860 64c Report * Bios Name = PhoenixBIOS 4.0 Release 6.0
2010-04-11 23:47:55:546 860 64c Report * Bios Release Date = 2008-08-15T00:00:00
2010-04-11 23:47:55:546 860 64c Report * Locale ID = 1055
2010-04-11 23:47:55:828 860 6a4 AU Successfully wrote event for AU health state:0
2010-04-11 23:47:55:843 860 6a4 AU Successfully wrote event for AU health state:0
2010-04-11 23:47:55:843 860 6a4 AU AU finished delayed initialization
2010-04-11 23:47:55:843 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:47:55:859 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:00:640 860 5d4 Misc WARNING: Assert config failed, error = 80070002
2010-04-11 23:48:00:656 860 5d4 Report WARNING: Unable to assert evt log config: 0x80070002
2010-04-11 23:48:00:656 860 5d4 Report CWERReporter finishing event handling. (00000000)
2010-04-11 23:48:11:078 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:11:078 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:12:812 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:12:812 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:13:421 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:13:421 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:13:640 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:13:640 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:13:828 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:13:828 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:14:046 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:14:046 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:14:250 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:14:250 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:14:421 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:14:437 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:14:625 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:14:625 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:28:015 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:28:031 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0
2010-04-11 23:48:30:250 860 5b0 Service WARNING: GetUserTokenFromSessionId failed with error 800703f0 for session 1
2010-04-11 23:48:30:250 1036 52c WUApp WARNING: Failed to initiate detection, hr=800703F0

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

This looks like a good project, just one request, your images are very large. Change your images to use thumbnail links.

0

Share this post


Link to post
Share on other sites

my minimal winpe

th_WindowsVista-2010-04-13-01-54-18.png

need list:

1-)should make shutdown button work. (I don't think because of registry. I got it work before but unfortunately deleted the wim file and cant get it work now. At that time i remember only added some files. Maybe can be and adm group policy file or something else.)

2-)Get updates work. (error log at the previous post.)

3-)A few mmc snapins left.(TPM,Firewall,Nap client,Eventviewer) to get them work if i can. Services works.

4-)To get powercpl work. (Can be a connection with shutdown. maybe classes registry entries?)

5-)Change background wallpaper. (In themes i edited. registry added all i think. Can not see set as wallpaper option in photoviewer, it works)

Any helps i will be glad.

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites
1-)should make shutdown button work.....I got it work before
This will be very first I know when you manage. B)
5-)Change background wallpaper.
JFX manage that with wallpaper.script. Just check the .reg file inside that script + lines with reg_add,

ps: you can use paraglider's WBZipMgr to extract files.

Since I am not a pe3 fan but only a guy who reads the news, I can only wish my best luck. :thumbup

0

Share this post


Link to post
Share on other sites
1-)should make shutdown button work.....I got it work before
This will be very first I know when you manage. B)
5-)Change background wallpaper.
JFX manage that with wallpaper.script. Just check the .reg file inside that script + lines with reg_add,

ps: you can use paraglider's WBZipMgr to extract files.

Since I am not a pe3 fan but only a guy who reads the news, I can only wish my best luck. :thumbup

1-)I saw with my eyes and now it makes me more depressed can not do again :( (shutdown) Maybe i can spend my more time i cant find more stuff to work on. Now there is everything i want in it and this means i will have more time to spend shutdown dont want else more. But if i find i wont tell to anybody better someone else find it :) (sometimes needs secrets.)

2-)Wallpaper can be seen until wpeutil (winpe) but after that it enters user environment (windows shell). It looks like the the most easy part and the only thing i hope to find a short answer here.

3-)Thanks for the link. I could never get succesful to encode winbuilder secrets until you post here. (without build, also it deletes them after build too, need grap from temp folder) I don't understand why they should be encoded yet.

4-)Do you think an iso build by winpebuilder and a winpe different things? they are exactly same thing.

5-)I don't care who reads. I want answers.

6-)At least they grabed some usefull stuff from my words. Wish it can change the way of build a little and result more usefull stuff. Good improvement

- replaced clid.reg with complete classes subkey of full OS

- replaced win7peldr with peshell

- removed shell selection from Main Configuration, all needed settings in Shell section

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

Won't WPEUTIL SHUTDOWN command work for you? Just sent to ComSpec to that command and it will shutdown. I use it in my scripts, that and WPEUTIL REBOOT if needed.

0

Share this post


Link to post
Share on other sites

Won't WPEUTIL SHUTDOWN command work for you? Just sent to ComSpec to that command and it will shutdown. I use it in my scripts, that and WPEUTIL REBOOT if needed.

i want to use explorer shutdown button. at the time of writing this i managed to work powercpl by running "powercfg.cpl,1" command from command prompt, maybe getting closer. will be more easy to investigate with procmon whats going on. :) WBZipMgr doesn't works on xp :(

I succeed to boot to all windows 7 (tiny7) with all files and winsxs folder. Drive mount can work without any mounter. most of the other features looks remains like my other builds (if they doesnt work doesnt work too) it means i need more registry adds problem not from files. .net gives sidebyside errors. there is only 2 options to get it work.

1-) add sidebyside registry hives off full windows.

2-) use the previous trick i gave to all .net versions. Need vc90 in framework 3 folder.(post number 10)

I need to mix winpe sam and security hives with windows 7 ones. In winpe they are empty but in windows setup they have values. They have only hex values and user ids in it and i have no idea. My build sometimes complains about security identifiers can not found. If i add them unchanged it freeze at boot. Win 7 setup hive contents here.

Maybe can be easy because i need to delete only :) until it boots. i don't know what to delete, will see.

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

Also if you can add photoviewer directory and spool\drivers\color directory like internet explorer into custom folders. photoviewer will work too.

I tried PhotoViewer as proposed but it did not work for me.

Additionally adding \Windows\System32\d3d8thk.dll helps to let PhotoViewer Window Open,

but the picture will not load .....

Do you have a solution ?

If doesnt load it needs directx dlls, sti inf and drivers i think. it will get your wim bigger. directx dlls will need at least 10mb. i see you add only a few services. better like this, doesnt eat lots off memory and works fast. I can look with procmon about what it needs else file later. If we can get it work with less files. ok. if photoviewer opens it means very close to work. mine was like that before opens but doesnt show and it showed after color directory.if you add irfanview as extra program you will not need to delete its registry entries. i can return turkish words to english again. it will be more easy if you tell something about how make_pe3 works,process files and registry hives. and about the boot process of the iso created with makepe3

Edit: Needz for Photoviewer. My clid.reg, Program Files\Photoviewer directory, System32\spool\drivers\color directory,

d3d8thk.dll

d3d9.dll

icm32.dll

mspaint.exe

stobject.dll

Of course with mui files if they have. I tested. Tell if not works.

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

you are wellcome. i have one more request if you do that too i will be glad. it is very important for me. there should be a delete_files.txt like add_file.txt. i want to remove some files before unmount and commit the wim file. Forexample want to remove all other language folder and mui files before your soft commit wim.

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

Hello Kullenen_Ask ;)

Can i create a Winbuilder project with your settings (Directory, files list and registry setting) ?

Thank for your work :w00t:

It's very good work :yes:

P.S : If you want, i have Windows Player 12, Sidebar and Windows Photo viewer, DotNet 2.0, IE8 winbuilder script... for you. :thumbup

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.