Parseus

HFSLIPFC-2K

95 posts in this topic

HFSLIPFC-2K (HFSLIP File Checker 2K) is an extension for Windows 2000 users for HFSLIP File Checker. It's based on list maintained now by bristols.

HFSLIPFC-2K

Changelog:

--------------------------------------------------------------------

Changelog for HFSLIP File Checker extension for Windows 2000

When you see "- removed KB..." the KB is not really removed from

the file-checker. In this case the KB is marked as obsolete ®

which means it's removed from the currently active updates.

--------------------------------------------------------------------

2012-02-19

- added:

* KB832414

* KB888609

* KB890830-v4.5

* KB914783-943729

* KB935839-v5b

* KB936357

* KB950982-960071-961451

* KB953024-970063

* KB959334

* KB971913

* KB973904-v3

* KBz2575928

* KBz2584146

* KBz2584577

* KBz2585542-v2

* KBz2598479

* KBz2603381

* KBz2618451

* KBz2631813

* Windows Script 5.8-v2

- added obsoleted:

* KB890830-v4.4 (replaced by KB890830-v4.5)

* KB921606 (replaced by KB973904-v3)

* KBz2585542 (replaced by KBz2585542-v2)

- removed:

* KB890830-v4.3 (replaced by KB890830-v4.5)

* KB960071 (replaced by KB950982-960071-961451)

* KB961451 (replaced by KB950982-960071-961451)

* KB968006 (replaced by KB971913)

* KBz2506212 (replaced by KBz2584577)

* KBz2562937 (replaced by KBz2618451)

* Windows Script 5.8-v1 (replaced by WScript 5.8-v2)

- changed folder for KB952069

2011-12-21

- added: KB890830-v4.3, KBz2476490, KBz2508429-v6

- added obsoleted: KB817446, KB829395, KB833154, KBz2360131

- removed: KB890830-v4.2, KBz2508429-v5

- fixed non-showing obsoletion hints for IE6 cabs

- fixed RDP 5.2 installer not obsoleting KB958470 (thanks My2GirlsDad)

- fixed non-detected files from REPLACE\I386 (thanks My2GirlsDad)

2011-12-05

- added: KBz2393802-v8, KBz2508429-v5, Roots Certificates Update November 2011 (32.0.2195.0), usp10.dll from KBz2288621 for MS Office 2007 SP2, KBz2633952

- added hint for KB884272 hotfix and unofficial KB978706-v2/v3

- removed: hint for KB885258, KBz2485376 (was already obsoleted by KBz2507618), KB935839-v5a (replaced by KBz2393802-v8), RDP 7.0 (doesn't work), Roots Certificates Update October 2011 (31.0.2195.0), KBz2570791 (replaced by KBz2633952)

- fixed a typo in detection of msvbvm60.dl_ (thanks piotrhn)

- fixed a typo in detection of additional files from IE6 cabs (thanks piotrhn)

- fixed detection of language for unofficial updates

- fixed situation when all WMP9 updates were marked as wrong (thanks Mim0)

- fixed wrong version of KB896290 (it should be KB896290-v2) (thanks piotrhn)

- changed version for MRT (4.2.5503.0 -> 4.2.5600.0) (thanks piotrhn)

- changed name of KBz2423089

- KB885258 is now optional instead of HBR

2011-11-14

Many changes after a long break ;)

2011-04-08

So many changes :) By AKuHAK

2010-06-09

- added URL for auto-update

- added: KB890830-v3.8, KB979559, KB975562, KB978695, KB979332, KB979482, KB980195, KB982381

- removed: KB890830-v3.7 (replaced byKB890830-v3.8), KB969947 (replaced by KB979559), KB978262 (replaced by KB980195), KB980182 (replaced by KB982381)

2010-05-21

- fixed showing that DX9 was not extracted (in HFCABS) even when it was extracted

2010-05-20

- DX9 detection is finally working correctly (thanks Mim0)

2010-05-17

- better SP detection

- corrected VBScript update detection

- changed folder for KB977816 (from HF to HFSVCPACK_SW1)

- KB926121 is now only for Server editions

- KB973037 is now not only for Server editions

- added WMP6 updates for WMP9 (WMP6 is not replaced by WMP9), KB955759 and KB975542

- some changes for DX9 detection

- corrected a few typos

2010-05-14

- fixed showing KB981349 as obsolete

- added info about type of extracted DirectX 9.0c

- added detecting of extracted DirectX 9.0c (standard)

2010-05-12

- fixed situation when script showed all updates as wrong or unknown (thanks tommyp)

- fixed situation when Server updates were listed as wrong (thanks Mim0)

- corrected languages for KB917275, MSXML4 and MSXML6

- corrected Swedish language for Service Pack 4

- added outdated: KB935843, KB960715, KB822831, IE updates

- added: KB839228, KB899591, KB975254, KB978542, Windows Messenger 5.1 and Windows Script 5.7 installer

- KB887606 is now optional

- removed KB973354 (replaced by KB978542), KB890830-v.3.6 (replaced by KB890830-v.3.7)

2010-04-28

- fixed code responsible for DirectX 9.0c (gaming) (thanks Mim0)

- removed KB980858 (replaced by KB980858-v2)

- moved MSXML2 to Windows updates

2010-04-26 (thanks My2GirlsDad)

- corrected size of Root Certificates Update

- fixed situation of VBScript update (it was not working correctly)

- added remains from IE6 slipstreaming in HFSLIP to ignore

2010-04-19 (thanks again, stephan_bauer)

- finally fixed naming of Windows Rights Management Services

- corrected KB977816 name

- added KB890830-v3.6

- removed KB890830-v3.5 (replaced by KB890830-v.3.6)

- added KB924667

2010-04-18 (thanks for all stephan_bauer)

- fixed German naming of Windows Rights Management Services and IE install files

- included old KB890830 and Outlook Express versions

- corrected version of KB975025, KB911280 and KB961371

- fixed KB891122 language

- added KB973354 for OE 6.0 SP1 (supersedes KB951066)

- removed KB951066 for OE 6.0 SP1

- fixed wrong number of KB hotfix replacing KB941644 and KB945553 (it should be KB951748, not KB953230)

2010-04-17

- initial release

Edited by Parseus
0

Share this post


Link to post
Share on other sites

Hello Parseus,

thank you for the script.

This is what I found:

- There is a version 2 of KB975002: Windows2000-WindowsMedia-KB975025-v2-x86-DEU.exe

- WindowsRightsManagementServices has a strange language naming. For German:WindowsRightsManagementServicesSP2-KB917275-Client-GER-x86.exe

This is already solved in the original hfslipfc.cmd

- Old versions of kb890830 are not included. Found in hfslipfc.cmd

R|HF\windows-kb890830-v3.0.exe|Malicious Software Removal Tool v3.0, replaced by v3.1

R|HF\windows-kb890830-v3.1.exe|Malicious Software Removal Tool v3.1, replaced by v3.2

R|HF\windows-kb890830-v3.2.exe|Malicious Software Removal Tool v3.2, replaced bei v3.3

R|HF\windows-kb890830-v3.3.exe|Malicious Software Removal Tool v3.3, replaced bei v3.4

R|HF\windows-kb890830-v3.4.exe|Malicious Software Removal Tool v3.4, replaced bei v3.5

- IE install file HFCABS\SCRIPTGER.CAB is called SCRIPTDE.CAB in German

Regards

Stephan

Edited by stephan_bauer
0

Share this post


Link to post
Share on other sites

There are no language versions of WindowsMedia9-KB891122-x86-Global-ENU.exe

windows-kb890830-v3.6.exe missing

0

Share this post


Link to post
Share on other sites

There is a version 2 of KB911280: Windows2000-KB911280-v2-x86-DEU.EXE

There is a version 2 of KB961371: Windows2000-KB961371-V2-x86-DEU.EXE

OE6.0sp1-KB973354-Windows2000-x86-ENU.exe missing

repaces OE6.0sp1-KB951066-Windows2000-x86-ENU.exe

There are these two entries:

R|HF\Windows2000-KB941644-x86-!lang!.EXE|MS08-001: TCP/IP, replaced by KB953230

R|HF\Windows2000-KB945553-x86-!lang!.EXE|MS08-020: DNS Client, replaced by KB953230

but no KB953230

0

Share this post


Link to post
Share on other sites

Thanks for all, stephan_bauer. I updated the first post and a link to HFSLIPFC 2K.

0

Share this post


Link to post
Share on other sites

Windows2000-KB977816-x86-DEU.EXE is called Windows2000-WindowsMedia-KB977816-x86-DEU.exe

windows-kb890830-v3.6.exe still missing

windows-kb890830-v3.5.exe obsolete

WindowsRightsManagementServices not fixed you need the code from hfslipfc.cmd "Getting lang2 and ln979099 from lang"

To my knowlegde this rootupd.exe is the lastest working with w2k:

http://www.download.windowsupdate.com/msdownload/update/v3-19990518/cabpool/rootsupd_fe44934fd80dd11fec2f0f9b24431658a4f6d589.exe

found at http://users.telenet.be/tc76/winup/_win2k.html

This update is also at the list of http://www.vorck.com/windows/hotfixes_2000.html

Windows2000-KB924667-x86-ENU.EXE

0

Share this post


Link to post
Share on other sites

Thanks again :-) First post updated.

0

Share this post


Link to post
Share on other sites

anyone willing to make a version suitable for 2k3 and another for XP x64???

it would be greatly appreciated!

bye!

0

Share this post


Link to post
Share on other sites

anyone willing to make a version suitable for 2k3 and another for XP x64???

it would be greatly appreciated!

bye!

I'm not making a promise, but I'll think about that ;)

0

Share this post


Link to post
Share on other sites

If we end up having one for XP, 2K, 2K3, and XP64 - not knowing anything at all about the inner workings, but does it make any sense at all to combine them in some way? It just seems to me that by having one program to update rather than multiple versions there would be less to update, easier to keep in sync, less likely an error would creep into one version and not another, etc, etc. And of course my argument would then be to include it as a part of HFSLIP itself. But that's just my two cents. I've always thought that functions so closely related should be combined, but I know others think it's better to keep each function separate. Different programming styles I guess.

Cheers and Regards

0

Share this post


Link to post
Share on other sites

Firstly, thank you for creating this program for Win2k. I've been using Mimo's XP Checker since it inception and both of these programs help greatly to keep track of our update lists.

I would like to point out a couple of problems I have found.

unknown: HF\Windows2000-KB981349-x86-ENU.EXE

missing (S): HF\Windows2000-KB981350-x86-ENU.EXE (MS10-022: VBScript (update from 5.1 to 5.6 version))

KB981349 updates VBSCRIPT from version 5.1 to 5.7. On these updates it would be either but not both. Maybe you need an entry in the INI file whether user wants version 5.6 or version 5.7. Something to think about.

missing (S): HF\Windows2000-KB917537-x86-ENU.EXE (MS06-034: Internet Information Services (IIS))

missing (S): HF\Windows2000-KB926121-x86-ENU.EXE (MS06-077: Remote Installation Services)

missing (S): HF\Windows2000-KB926247-x86-ENU.EXE (MS06-074: SNMP)

missing (S): HF\Windows2000-KB942831-x86-ENU.EXE (MS08-005: Internet Information Services (IIS))

missing (S): HF\Windows2000-KB953155-x86-ENU.EXE (MS08-062: Internet Printing Service)

missing (S): HF\Windows2000-KB957097-x86-ENU.EXE (MS08-068: SMB)

missing (S): HF\Windows2000-KB976323-x86-ENU.EXE (MS10-024: SMTP Service

missing (S): HF\Windows2000-KB977290-x86-ENU.EXE (MS10-014: Kerberos)

missing (S): HF\Windows2000-WindowsMedia-KB975025-v2-x86-ENU.exe (MS09-051: Audio Compression Manager)

missing (S): HF\WindowsMedia9-KB969878-x86-ENU.exe (MS09-051: WMA Voice Codec)

You have all the updates tagged as High-Priority, but I believe they should be marked as Optional as Windows/Microsoft Updates does not ask for any of them. Am I correct?

unknown: HFCABS\_IE6_HFSLIP.CAB

unknown: HFCABS\_IE6b_HFSLIP.CAB

unknown: HFCABS\_OE6_HFSLIP.CAB

These files are created the first time you run HFSLIP. Should they be included in your list?

Found unexpected version of Roots Certificates (HF\rootsupd.exe)

While you have the version correct, 22.0.2195.0 SEP 2009, the size you have is incorrect. The size should be 239000.

Thank again for all your efforts

M2GD

Edited by My2GirlsDad
0

Share this post


Link to post
Share on other sites

If we end up having one for XP, 2K, 2K3, and XP64 - not knowing anything at all about the inner workings, but does it make any sense at all to combine them in some way? It just seems to me that by having one program to update rather than multiple versions there would be less to update, easier to keep in sync, less likely an error would creep into one version and not another, etc, etc. And of course my argument would then be to include it as a part of HFSLIP itself. But that's just my two cents. I've always thought that functions so closely related should be combined, but I know others think it's better to keep each function separate. Different programming styles I guess.

Cheers and Regards

That's possible. The FC can use any update-list, not just the internal which is for XPSP3. Currently it can be configured in the INI - no automatism.

I've compared Parseus changes and there is a little bit to do because W2K has a few other sections than XP. But the changes are minimal.

Just an idea for a first step:

- I include Parseus changes, Parseus offers a current update-list for W2K.

- I make an OS-detection of the SOURCE-folder to take the correct update-list automatically.

Second step:

- I extend the automatic update to download not just the current version of the FC, but also the update-list(s)

Third step:

- Support other OSs

If Parseus like to to that... ;)

Edited by Mim0
0

Share this post


Link to post
Share on other sites

MG2D - If your winnt.sif file has IIS or whatever optional stuff installed, then WU will prompt for an update. If it's not installed, then WU won't ask for it. However, if the iso is all up to snuff and you installed some other optional windows component later on, the latest binary will be ready to go.

0

Share this post


Link to post
Share on other sites

unknown: HF\Windows2000-KB981349-x86-ENU.EXE

missing (S): HF\Windows2000-KB981350-x86-ENU.EXE (MS10-022: VBScript (update from 5.1 to 5.6 version))

KB981349 updates VBSCRIPT from version 5.1 to 5.7. On these updates it would be either but not both. Maybe you need an entry in the INI file whether user wants version 5.6 or version 5.7. Something to think about.

INI-entry is not necessary. Security-Updates (MS...) are mandatory. But Parseus can define a dependency-check in the update-tables in that way that KB981350 will not shown as missing when KB981349 is existing. And even more: KB981350 will be shown as obsolete if KB981349 was found. :)

...

You have all the updates tagged as High-Priority, but I believe they should be marked as Optional as Windows/Microsoft Updates does not ask for any of them. Am I correct?

MS... are always mandatory. As tommy already said, it's good to have the latest binaries on your cd even if you don't install them.

...

These files are created the first time you run HFSLIP. Should they be included in your list?

I thought that hfslip always deletes files which are created by hfslip (regarding the folders HF, CABS, ...). For that, Parseus has to define an IGNORE-section containing these files. :)

CU...

Edited by Mim0
0

Share this post


Link to post
Share on other sites

New version released.

That's possible. The FC can use any update-list, not just the internal which is for XPSP3. Currently it can be configured in the INI - no automatism.

I've compared Parseus changes and there is a little bit to do because W2K has a few other sections than XP. But the changes are minimal.

Just an idea for a first step:

- I include Parseus changes, Parseus offers a current update-list for W2K.

- I make an OS-detection of the SOURCE-folder to take the correct update-list automatically.

Second step:

- I extend the automatic update to download not just the current version of the FC, but also the update-list(s)

Third step:

- Support other OSs

If Parseus like to to that... ;)

Sure, no problem ;) HFSLIPFC 2K has been already prepared for automatic update BTW. I think both HFSLIP FC's could be released as one f.e. after the May updates, but I also think it couldn't be any problem for releasing it earlier :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.