Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Make_PE3 Program to Create Portable Windows 7 PE

- - - - -

  • Please log in to reply
379 replies to this topic

#351
click-click

click-click

    Member

  • Member
  • PipPip
  • 107 posts
Hi JFX,

Glad to see you here. Yes there was a uim_x86 .exe too besides the inf and sys files, but that did not end up in the Driverstore. It's still in the UIM directory of the Application though. Do I just run that after Win7PE is booted?


How to remove advertisement from MSFN

#352
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 458 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Do I just run that after Win7PE is booted?

As far as i remember yes, just run it after boot. It's a silent installer and should create a log file next to it.
But I have not used it for a long time cause it makes trouble with the shadowprotect driver I use.

Posted Image

#353
click-click

click-click

    Member

  • Member
  • PipPip
  • 107 posts
Well, that looks like the solution to install the drivers, but I can't get the Archiive Tab to appear in the Paragon SW. This is where a mount/unmount can be selected for a given backup. I thought this condition was because the drivers were not being installed, but I guess I'm still missing something. I have not gotten anyone to confirm if they have this working in a Win7PE.

Edited by click-click, 21 July 2012 - 02:22 PM.


#354
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 458 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Try to delete the HKLM\SYSTEM\CurrentControlSet\Control\MiniNT registry key before starting Paragon software.

Maybe they disabled some features in WinPE mode. But don't forget to create the MiniNT key after running paragon as it's required for shutdown/restart.

Posted Image

#355
click-click

click-click

    Member

  • Member
  • PipPip
  • 107 posts
That key does not exist in my Win7Pe. I thought that only applied to XP PE. Maybe I need to
include VSS. I saw your post here, but I did not see how to patch the three files you mentioned there.

Edited by click-click, 23 July 2012 - 04:01 AM.


#356
click-click

click-click

    Member

  • Member
  • PipPip
  • 107 posts
I made a mistake about the presence of the MiniNT key . It does exist on my system. I will try this and see what happens.

Edited by click-click, 23 July 2012 - 04:48 PM.


#357
click-click

click-click

    Member

  • Member
  • PipPip
  • 107 posts
Removing MiniNT unlocks the archive tab for the Paragon Backup/Recovery SW that I have tested, but mounting does not work for the 2012 versions. I can mount with HDM10, but when I try to unmount the drive, I get an error. There is no Force Unmount check-box in HDM10 Suite like in HDM12 Pro.

Edited by click-click, 29 July 2012 - 02:44 AM.


#358
click-click

click-click

    Member

  • Member
  • PipPip
  • 107 posts

driver_fix.cmd is essential and preferred in all cases :)
driver_fix.cmd loads many drivers and start a lot of services where PENetwork is only limited to Network.


Anyone know why netvwifibus.inf shows an error (0xe0000102) in a Make_PE3 build when drv_fix.cmd loads the various infs? This is the only inf that it complains about with the laptop I'm using.

Edited by click-click, 29 July 2012 - 04:24 AM.


#359
Tduy

Tduy
  • Member
  • 4 posts
  • OS:none specified
  • Country: Country Flag
How Added Japanese, Korean and Chinese Support to Make_Pe (read file name and page Web)
Thank All ! :D

#360
BigDawgFelton

BigDawgFelton

    Newbie

  • Member
  • 11 posts
  • OS:Windows 7 x86
  • Country: Country Flag
Has anyone seen any issue in prior builds where having USB devices such as mouse/keyboard plugged into certain ports causing issues with programs or other devices installed?

Basically what I have done is taken the win7pe build and customized the image for diagnostics of some specific PCs. All drivers, and programs have been installed. I have added touchscreen support and everything was working well with our original unit. A similar unit is now being built except with a different style touchscreen. All OS images are the same for this machine so I assume no drivers have changed for this.

We use a program that is built to read motherboard information such as serial number and other information. When I have USB and mouse plugged in on certain ports during startup this program fails to function. Does anyone have any ideas? Driver issues? Device mapping problem? I am lost at this point.

If I leave these devices unplugged from the certain USB ports on bootup the program functions properly. I can plug in the devices to the problematic ports after bootup with no issues.

#361
Tamimctg

Tamimctg

    Tech____AnALyZer

  • Member
  • 29 posts
  • OS:Windows 7 x86
  • Country: Country Flag
Can not install Sound & Vga Driver in Multimedia Version of make pe3..pls solve.

#362
wimb

wimb

    Senior Member

  • Developer
  • 679 posts
-
*** Update Make_PE3_44 package ***
  • Added - Adobe Flash Version 11 Plugin for Make_PE3 - file Make_PE3_Flash_V11.exe
  • Changed - Program Version - latest version is 4.4
Download - Make_PE3_44

It is required to extract Make_PE3_44.exe to the root of your drive.
Make_PE3_44.exe does not contain Adobe Flash - You need to make use of the NEW plugin.
The plugin has the same folder structure as Make_PE3 and to insert the plugin you can
Extract Make_PE3_Flash_V11.exe to the same drive as where Make_PE3 folder is located.

Make_PE3 can be used in Windows 8/7/XP Multi-Boot environment
Source can be fresh installed Win7 SP0 without Updates or Win7 DVD SP0 or SP1 - x86 or x64 versions
Adobe Flash V 11 plugin supports x86 and x64 version of 7 PE - Browsers IE8 Or Portable Firefox Opera or QtWeb

More Info - http://www.911cd.net...showtopic=23931

:)

Edited by wimb, 28 March 2013 - 09:22 AM.


#363
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 458 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Hi wimb,

there is a small problem with SidebySide components on x64 SP1 sources.
The reg file PE3-SOFTWARE_SxS.reg is only compatible with SP0 sources.

The SP1 version will not be compatible with SP0 again, so MakePE3 would need to make a check for service pack and apply the right one.

Attached Files


Edited by JFX, 30 March 2013 - 05:40 AM.


#364
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,378 posts
  • OS:none specified
  • Country: Country Flag

Hi wimb,

there is a small problem with SidebySide components on x64 SP1 sources.
The reg file PE3-SOFTWARE_SxS.reg is only compatible with SP0 sources.

The SP1 version will not be compatible with SP0 again, so MakePE3 would need to make a check for service pack and apply the right one.

Just to keep you informed, you have at least one satisfied user of the new set :thumbup :
http://reboot.pro/to...-7-pe/?p=170386

jaclaz

#365
wimb

wimb

    Senior Member

  • Developer
  • 679 posts

there is a small problem with SidebySide components on x64 SP1 sources.
The reg file PE3-SOFTWARE_SxS.reg is only compatible with SP0 sources.

The SP1 version will not be compatible with SP0 again, so MakePE3 would need to make a check for service pack and apply the right one.

Thanks JFX :thumbup for your solution for winsxs problems when using x64 Win7 SP1 as Source.

Thanks also to jaclaz for communicating this solution to other users :thumbup

Next version of Make_PE3 will certainly have this fix integrated ....

:)

#366
wimb

wimb

    Senior Member

  • Developer
  • 679 posts

-
*** Update Make_PE3_45 package ***
 


Download - Make_PE3_45

It is required to extract Make_PE3_45.exe to the root of your drive.
Make_PE3_45.exe does not contain Adobe Flash - You need to make use of the NEW plugin.
The plugin has the same folder structure as Make_PE3 and to insert the plugin you can
Extract Make_PE3_Flash_V11.exe to the same drive as where Make_PE3 folder is located.

Make_PE3 can be used in Windows 8/7/XP Multi-Boot environment
Source can be fresh installed Win7 SP0 without Updates or Win7 DVD SP0 or SP1 - x86 or x64 versions
Adobe Flash V 11 plugin supports x86 and x64 version of 7 PE

smile.gif


Edited by wimb, 27 November 2013 - 01:53 PM.


#367
arvindmsfnforums

arvindmsfnforums
  • Member
  • 1 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Hi

I mounted the .wim file. loaded the registry hive from mount\windows\system32\config\SOFTWARE hive to hklm\SOFTWARE_FROM_PE.

But I am unable to change
1 classes to classes.old
2 microsoft\internet explorer to internetexplorer.old
3 microsfot\windows\cv\explorer to explorer.old

using regedit. it says unable to rename.

How do I make changes? Is there any problem?

Thanks in advance.

#368
click-click

click-click

    Member

  • Member
  • PipPip
  • 107 posts

I see there's a v4.7 of Make_PE3. Are there any notable changes since your last 4.5 announcement?



#369
wimb

wimb

    Senior Member

  • Developer
  • 679 posts

I see there's a v4.7 of Make_PE3. Are there any notable changes since your last 4.5 announcement?

 

BOOT_IMG.exe is updated according to UEFI_MULTI project to make Multi-Boot USB-Drives

http://www.911cd.net...showtopic=25269

 

Make_PE3 was updated to Increase Language winsxs Array Size probably only needed for some rare cases ....

http://www.911cd.net...ndpost&p=173679

 

:)



#370
wimb

wimb

    Senior Member

  • Developer
  • 679 posts
-
*** Update Make_PE3_48 package ***
 
  • Update  - 7z files in makebt replaced by version 4.65 for better compatibility
  • Update  - files logoncli.dll and wtsapi32.dll are added to SysWow64 folder in case of amd64 version
  • extra files required for support of ListUsbDrives.exe and CCleaner.exe
  • Update  - Grub4dos version grub4dos-0.4.5c-2013-03-03.7z
  • Update  - ImDisk file imdiskinst.exe version 1.7.6
  • Update  - portable app ImgBurn version 2.5.8.0
  • Update  - portable app WinContig version 1.1.5
  • Update  - BOOT_IMG.exe version 8.0 - to make Grub4dos boot menu for VHD IMG ISO or WIM
  • Changed - Program Version - latest version is 4.8
  •  
    Download  - Make_PE3_48 - mirror
     
    It is required to extract Make_PE3_48.exe to the root of your drive.
    Make_PE3_48.exe does not contain Adobe Flash - You need to make use of the NEW plugin.
    The plugin has the same folder structure as Make_PE3 and to insert the plugin you can
    Extract Make_PE3_Flash_V11.exe to the same drive as where Make_PE3 folder is located.
     
    Make_PE3 can be used in Windows 8/7/XP Multi-Boot environment
    Source can be fresh installed Win7 SP0 without Updates or Win7 DVD SP0 or SP1 - x86 or x64 versions
    Adobe Flash V 11 plugin supports x86 and x64 version of 7 PE
     
     
    :)

    Edited by wimb, 27 November 2013 - 03:32 AM.


    #371
    sittingduck

    sittingduck

      Newbie

    • Member
    • 16 posts
    Does Make_pe3 support using WAIK 3.1?
    Also, what's the difference between using the exe and the batch file?
    Thanks.

    #372
    wimb

    wimb

      Senior Member

    • Developer
    • 679 posts

    The exe and the batch file have the same functionality and make the same 7pe

     

    I suppose that WAIK 3.1 is supported, but personally I have not used WAIK 3.1 yet .....

     

    :)


    Edited by wimb, 01 December 2013 - 12:42 AM.


    #373
    wimb

    wimb

      Senior Member

    • Developer
    • 679 posts

    Make_PE3 - Portable Windows 7 PE



    Support topic - http://www.911cd.net...showtopic=23931
    More Info - http://reboot.pro/to...e-windows-7-pe/

    Download - http://www.mediafire.../?fi81wqcdmzdv5

     

    :)



    #374
    click-click

    click-click

      Member

    • Member
    • PipPip
    • 107 posts

    When booting my 7pe, I use a different background image, but before it displays, I briefly see a different background and I haven't been able to find where this resource is located so I can change it to match my background. The image I am seeing is below. On a normal Win7 system it is located in oobe as background.bmp, but in the Make_PE3 image, this dir is not present. Anyone know how this can be changed?

    Attached Files

    • Attached File  bg.jpg   36.85KB   0 downloads


    #375
    wimb

    wimb

      Senior Member

    • Developer
    • 679 posts

    Probably the image is related to setup.bmp found in X:\Windows\system32

     

    Try to modify by adding your setup.bmp to folder PE3_mod\PE3_add\x86\Windows\System32


    Edited by wimb, 30 May 2014 - 12:53 AM.





    4 user(s) are reading this topic

    0 members, 3 guests, 0 anonymous users


      Baidu (1)


    How to remove advertisement from MSFN