wimb

Make_PE3 Program to Create Portable Windows 7 PE

398 posts in this topic

You can try to Update 7-zip to latest version 7z920-x64.msi

http://www.7-zip.org/download.html

Thanks for the advice, but that didn't work. I already had that version installed, so I tried uninstalling and re-installing 7-zip, but got the same result when extracting.

I did try something as an alternative. I wanted to see if it was a 64-bit issue or not. I have Windows XP Mode installed, so I tried extracting while in the Windows XP Mode. As a result, it extracted perfectly. Maybe things don't extract right on a 64-bit version of Windows 7?

0

Share this post


Link to post
Share on other sites

[ Maybe things don't extract right on a 64-bit version of Windows 7?

No problem here with 64-bits Windows 7 OS

Anyway it is SFX selfextractor, so there should not be any problem.

Just doubleclick on Make_PE3.exe should work.

I don't know what is causing your problem .....

Edited by wimb
0

Share this post


Link to post
Share on other sites

[ Maybe things don't extract right on a 64-bit version of Windows 7?

No problem here with 64-bits Windows 7 OS

Anyway it is SFX selfextractor, so there should not be any problem.

Just doubleclick on Make_PE3.exe should work.

I don't know what is causing your problem .....

Hmmmm....I'm not sure what would be causing that either. I'll have to try it out on another system that has a 64-bit version of Windows 7. If that doesn't work for me, I'll just extract it in Windows XP Mode and copy the files over.

Thanks for all of your help.

0

Share this post


Link to post
Share on other sites

=

*** Update of Make_PE3 package to Create Portable Windows 7 PE ***

  • Added - Extra letter (X B E or M) in 7 PE ISO filename to distinguish different versions (MIN BS EXP and Media)
  • Added - Added Windows 7 PE Size and Version Info in entry of grub4dos menu.lst
  • Added - Q-Dir Filemanager
  • Update - 7-Zip version 9.20 and Ghost - Thanks to ericgl
  • Changed - folder SxS_Fix_Win7PE moved to folder MULTI - manually run SxS_7PE_SFX.exe from here to fix Side by Side Errors
  • Added - Autorun of SxS_7PE_SFX.exe by driver_fix.cmd when copied to folder PE3_mod\PE3_add\x86\Windows\System32
  • Changed - Program Version - latest version is now 4.0

After Driver Fix and Start of Services by driver_fix.cmd

then one can fast install any missing driver in two ways using Desktop Icon and Hardware Menu:

- Drivers from Win7 Host DS - is autosearch for Windows 7 DriverStore and let pecmd.exe Install the drivers

- DriverPacks from Folder - user can select DriverPacks folder and drivers are installed by dpinst.exe

Download - Make-PE3

It is required to extract Make_PE3.exe to the root of your drive

More Info - See post #1

cheers.gif

0

Share this post


Link to post
Share on other sites

Hello to everybody in this forum,

I'm new here (registered 5min ago), but I follow your work since W7RC was released.

First I will thank you for the inspiration, improvements, advantages making winpe better.

Compared with you guys (developpers, administrators), I'm a newbie/greenhorn.

I cant programm, assamble, compile, develop things - so I do not understand every

thread in this forum.

Most of you, I think, trace a winemb-feature-package integration into a winemb install.wim

and applies the traced information (files/reg-keys) over a Win7 setup install.wim to finally

copy it to the winpe.wim. This is effective but time expensive and difficult.

Because of my "enduser"-knowledge, I would microsoft tools do the job for me and would

share me success with you. I decided to try the reverse way ...

1.) I mouted winpe.wim (round 8000files / 774MB) and install.wim (round 48000files / 4.3GB).

2.) I copied everything to a temp-working directory (except sxs, framework, driverstore) = 1.15GB.

3.) I deleted some things, winpe does'nt need (SAT, MIGWIZ, SPP, WUA, SLIC, NLS...) = 550MB

4.) The remaining files compared with the files from winpe.wim (525 duplicates -100MB) =450MB

5.) I copied all the files into winpe.wim and applied as much regkeys as I found

6.) the final winpe.wim growed from 112MB to 329MB

A.) The booted winpe.wim consists of explorer-shell, IE8, controlpanel, mediaplayer, mmc,

networkcenter, fax/scan, vss, printer, remotedesktop, directx, ......ect.....ect.

B.) Now I mounted winpe.wim again integrated WMI-package, and enabled Service-Profiling

C.) After unmounting I booted once again and executed every bat, com, exe, vbs, msc, services ....etc.

D.) Now I used wpeutil to save the profile

E.) I mounted winpe.wim a third time and applied the traced profile, which removed additional 100MB

(big disadvantage - the winpe.wi is'nt serviceable anymore from this point)

Finally I ended up with a 270MB winpe.wim including 80% of the original W7 in about 3hrs.

Last but no least I would thank you guys again for the great work. Hope to see you in W8 :-))

Bye

tom

0

Share this post


Link to post
Share on other sites

ha, that should work too. interesting approach. ill mess with it later.

oh, and if it boots, i can service it. (see one of my above posts with attachments)

service pack 1 is out. winpe 3.0 is now 3.1 (most relevant thing is hdd drivers 512b/4k access)

waik sp1 update

0

Share this post


Link to post
Share on other sites

Hi,wimb,thank you for your powerful tools to build win7pe!

When I use the tools "make_pe3" a win7pe,and I start the win7pe from my computer,I found a problem:when press the combine key "ctrl +alt+del" ,the win7pe will run the program "peshell.exe",but in windows 7 ,it should run the program "taskmgr.exe"!

How can I modify this to run "taskmgr.exe"?

Thank you !

0

Share this post


Link to post
Share on other sites

[ Maybe things don't extract right on a 64-bit version of Windows 7?

No problem here with 64-bits Windows 7 OS

Anyway it is SFX selfextractor, so there should not be any problem.

Just doubleclick on Make_PE3.exe should work.

I don't know what is causing your problem .....

Hmmmm....I'm not sure what would be causing that either. I'll have to try it out on another system that has a 64-bit version of Windows 7. If that doesn't work for me, I'll just extract it in Windows XP Mode and copy the files over.

Thanks for all of your help.

I figured out what was happening on the computer I was trying to extract on. McAfee VirusScan was stopping it. After I disabled the McAfee services, I was able to extract successfully.

On a different note, I might be able to contribute a little. I figured out how to start PE Network Manager and close it when done. I used an AutoIt script to accomplish this. Below is the code that I used.

;Disable AutoIt System Tray Icon
TraySetState(2)

;Disable keyboard and mouse while PE Network Manager is running to prevent user clicking off of main window
BlockInput(1)

;Start PE Network Manager
Run(@ProgramFilesDir & '\PENetwork\PENetwork.exe')

;Wait for the main PE Network Manager window to be active
WinWaitActive('PE Network Manager 0.56', 'Network Drives')

;Close the main PE Network Manager window
WinClose('PE Network Manager 0.56', 'Network Drives')

;Re-enable keyboard and mouse
BlockInput(0)

I then named and compiled it as NetStartAndClose. After that, I copied NetStartAndClose.exe to the PE Network Manager program files directory and added the lines in the code box below to startnet.cmd after the following line: :: start "Audio Fix PE3 - Wait ...." /wait "%SystemRoot%\System32\audio_fix.cmd"

:: start "PE Network Manager" and close when done
"%programfiles%\PENetwork\NetStartAndClose.exe"

Hopefully, this helps some people out.

Edited by Echo_Platoon
0

Share this post


Link to post
Share on other sites

Wimb:

Will Make_PE3 be updated to be compatible with a Windows 7 SP1 source and Internet Explorer 9? Using Windows 7 SP1/IE9 results in an RTM Make_PE3 build and a broken Internet Explorer (the icons look as if IE9 ported over, but opening up IE9 results in the browser opening and closing after about 1/2 second...)

0

Share this post


Link to post
Share on other sites

Will Make_PE3 be updated to be compatible with a Windows 7 SP1 source and Internet Explorer 9?

I don't have 7 SP1 to do experiments and besides I don't have enough time ....

But if someone else gives solution, then of course I will add it to the package ....

Another approach would be to try VHD_W7_Compact.exe for SP1 Win 7 Source.

Personally I think this is far better than 7 PE

http://www.911cd.net/forums//index.php?showtopic=23553&view=findpost&p=167661

Edited by wimb
0

Share this post


Link to post
Share on other sites

Will Make_PE3 be updated to be compatible with a Windows 7 SP1 source and Internet Explorer 9?

I don't have 7 SP1 to do experiments and besides I don't have enough time ....

But if someone else gives solution, then of course I will add it to the package ....

Another approach would be to try VHD_W7_Compact.exe for SP1 Win 7 Source.

Personally I think this is far better than 7 PE

http://www.911cd.net/forums//index.php?showtopic=23553&view=findpost&p=167661

Hi master,

can you give me tips to activate the print spooler service

I don't know how to do

0

Share this post


Link to post
Share on other sites

can you give me tips to activate the print spooler service

The Mini 7 version of 650 MB has Printer Support and is probably the best and the easiest solution.

http://www.911cd.net/forums//index.php?showtopic=23553&view=findpost&p=167661

You can compare filelist of mini_7vhd.txt with 7PE.

At least you need to add to 7PE folder


\Windows\System32\spool\*.*

and these files and their corresponding mui files.

\Windows\System32\compstui.dll
\Windows\System32\DeviceCenter.dll
\Windows\System32\DeviceDisplayObjectProvider.exe
\Windows\System32\DeviceDisplayStatusManager.dll
\Windows\System32\DeviceEject.exe
\Windows\System32\DeviceMetadataParsers.dll
\Windows\System32\DevicePairing.dll
\Windows\System32\DevicePairingFolder.dll
\Windows\System32\DevicePairingHandler.dll
\Windows\System32\DevicePairingProxy.dll
\Windows\System32\DevicePairingWizard.exe
\Windows\System32\DeviceProperties.exe
\Windows\System32\DeviceUxRes.dll
\Windows\System32\localspl.dll
\Windows\System32\localui.dll
\Windows\System32\ntprint.dll
\Windows\System32\ntprint.exe
\Windows\System32\print.exe
\Windows\System32\PrintBrmUi.exe
\Windows\System32\printfilterpipelineprxy.dll
\Windows\System32\printfilterpipelinesvc.exe
\Windows\System32\PrintIsolationHost.exe
\Windows\System32\PrintIsolationProxy.dll
\Windows\System32\printmanagement.msc
\Windows\System32\printui.dll
\Windows\System32\printui.exe
\Windows\System32\spoolss.dll
\Windows\System32\spoolsv.exe
\Windows\System32\tcpmon.dll
\Windows\System32\tcpmon.ini
\Windows\System32\tcpmonui.dll
\Windows\System32\upnpcont.exe
\Windows\System32\winspool.drv
\Windows\System32\WINSPOOL.EXE

Then you need extra registry keys for 7 PE derived from working mini 7


[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\Control\Print]

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\Enum\Root\LEGACY_HTTP]

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\services\HTTP]

[HKEY_LOCAL_MACHINE\PE3-SOFTWARE\Microsoft\Print]

[HKEY_LOCAL_MACHINE\PE3-SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print]

Edited by wimb
0

Share this post


Link to post
Share on other sites

can you give me tips to activate the print spooler service

The Mini 7 version of 650 MB has Printer Support and is probably the best and the easiest solution.

http://www.911cd.net/forums//index.php?showtopic=23553&view=findpost&p=167661

You can compare filelist of mini_7vhd.txt with 7PE.

At least you need to add to 7PE folder


\Windows\System32\spool\*.*

and these files and their corresponding mui files.

\Windows\System32\compstui.dll
\Windows\System32\DeviceCenter.dll
\Windows\System32\DeviceDisplayObjectProvider.exe
\Windows\System32\DeviceDisplayStatusManager.dll
\Windows\System32\DeviceEject.exe
\Windows\System32\DeviceMetadataParsers.dll
\Windows\System32\DevicePairing.dll
\Windows\System32\DevicePairingFolder.dll
\Windows\System32\DevicePairingHandler.dll
\Windows\System32\DevicePairingProxy.dll
\Windows\System32\DevicePairingWizard.exe
\Windows\System32\DeviceProperties.exe
\Windows\System32\DeviceUxRes.dll
\Windows\System32\localspl.dll
\Windows\System32\localui.dll
\Windows\System32\ntprint.dll
\Windows\System32\ntprint.exe
\Windows\System32\print.exe
\Windows\System32\PrintBrmUi.exe
\Windows\System32\printfilterpipelineprxy.dll
\Windows\System32\printfilterpipelinesvc.exe
\Windows\System32\PrintIsolationHost.exe
\Windows\System32\PrintIsolationProxy.dll
\Windows\System32\printmanagement.msc
\Windows\System32\printui.dll
\Windows\System32\printui.exe
\Windows\System32\spoolss.dll
\Windows\System32\spoolsv.exe
\Windows\System32\tcpmon.dll
\Windows\System32\tcpmon.ini
\Windows\System32\tcpmonui.dll
\Windows\System32\upnpcont.exe
\Windows\System32\winspool.drv
\Windows\System32\WINSPOOL.EXE

Then you need extra registry keys for 7 PE derived from working mini 7


[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\Control\Print]

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\Enum\Root\LEGACY_HTTP]

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\services\HTTP]

[HKEY_LOCAL_MACHINE\PE3-SOFTWARE\Microsoft\Print]

[HKEY_LOCAL_MACHINE\PE3-SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print]

Thank you very much Master

I will try my best to understand

this code

0

Share this post


Link to post
Share on other sites

Thank you very much master

It works! The http.sys driver started successfully.

The print spooler service activate successfully.

Now I post files for sharing

\Windows\System32\spool\*.* derived from windows 7 x86 without installing any printer driver

and these files and their corresponding mui files.

\Windows\System32\compstui.dll

\Windows\System32\DeviceCenter.dll

\Windows\System32\DeviceDisplayObjectProvider.exe

\Windows\System32\DeviceDisplayStatusManager.dll

\Windows\System32\DeviceEject.exe

\Windows\System32\DeviceMetadataParsers.dll

\Windows\System32\DevicePairing.dll

\Windows\System32\DevicePairingFolder.dll

\Windows\System32\DevicePairingHandler.dll

\Windows\System32\DevicePairingProxy.dll

\Windows\System32\DevicePairingWizard.exe

\Windows\System32\DeviceProperties.exe

\Windows\System32\DeviceUxRes.dll

\Windows\System32\localspl.dll

\Windows\System32\localui.dll

\Windows\System32\ntprint.dll

\Windows\System32\ntprint.exe

\Windows\System32\print.exe

\Windows\System32\PrintBrmUi.exe

\Windows\System32\printfilterpipelineprxy.dll

\Windows\System32\printfilterpipelinesvc.exe

\Windows\System32\PrintIsolationHost.exe

\Windows\System32\PrintIsolationProxy.dll

\Windows\System32\printmanagement.msc

\Windows\System32\printui.dll

\Windows\System32\printui.exe

\Windows\System32\spoolss.dll

\Windows\System32\spoolsv.exe

\Windows\System32\tcpmon.dll

\Windows\System32\tcpmon.ini

\Windows\System32\tcpmonui.dll

\Windows\System32\upnpcont.exe

\Windows\System32\winspool.drv

\Windows\System32\WINSPOOL.EXE

search the windows 7 x86 windows\system32 for the *.mui

registry keys derived from windows 7 x86 without installing any printer driver

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\\Control\Print]

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\Enum\Root\LEGACY_HTTP]

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\services\HTTP]

[HKEY_LOCAL_MACHINE\PE3-SOFTWARE\Microsoft\Print]

[HKEY_LOCAL_MACHINE\PE3-SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print]

I am not sure activate print spooler servie can install printer driver

Now, I want to activate the usbscan.sys driver and sti service

Can you give me some tips

Thank you very much master!

0

Share this post


Link to post
Share on other sites

It works! The http.sys driver started successfully.

The print spooler service activate successfully.

....

Now, I want to activate the usbscan.sys driver and sti service

That is good news. :thumbup:thumbup

I found the filelist when reducing to mini 7 while trying to keep Printer working.

Also in mini 7 the sti service is working.I think files extra for Paint were needed:


\Windows\System32\stclient.dll
\Windows\System32\sti.dll
\Windows\System32\storage.dll
\Windows\System32\wiaservc.dll

GOOD LUCK

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.