wimb

Make_PE3 Program to Create Portable Windows 7 PE

398 posts in this topic

It works! The http.sys driver started successfully.

The print spooler service activate successfully.

....

Now, I want to activate the usbscan.sys driver and sti service

That is good news. :thumbup:thumbup

I found the filelist when reducing to mini 7 while trying to keep Printer working.

Also in mini 7 the sti service is working.I think files extra for Paint were needed:


\Windows\System32\stclient.dll
\Windows\System32\sti.dll
\Windows\System32\storage.dll
\Windows\System32\wiaservc.dll

GOOD LUCK

Hi, master

\Windows\System32\stclient.dll

\Windows\System32\sti.dll

\Windows\System32\ sti.dll.mui

\Windows\System32\storage.dll

\Windows\System32\wiaservc.dll

\Windows\System32\wiaservc.dll.mui

I also add these files

I don't know these files are necessary or not

sti_ci.dll.mui

sti_ci.dll

wiaacmgr.exe

wiaacmgr.exe.mui

stisvc services start successfully

;======================StiSVC Service================================

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\services\StiSvc]

"Start"=dword:00000003

"DisplayName"="@%SystemRoot%\\system32\\wiaservc.dll,-9"

"ErrorControl"=dword:00000001

"ImagePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\

74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\

00,76,00,63,00,68,00,6f,00,73,00,74,00,2e,00,65,00,78,00,65,00,20,00,2d,00,\

6b,00,20,00,69,00,6d,00,67,00,73,00,76,00,63,00,00,00

"Type"=dword:00000010

"Description"="@%SystemRoot%\\system32\\wiaservc.dll,-10"

"DependOnService"=hex(7):52,00,70,00,63,00,53,00,73,00,00,00,53,00,68,00,65,00,\

6c,00,6c,00,48,00,57,00,44,00,65,00,74,00,65,00,63,00,74,00,69,00,6f,00,6e,\

00,00,00,00,00

"ObjectName"="NT Authority\\LocalService"

"ServiceSidType"=dword:00000001

"RequiredPrivileges"=hex(7):53,00,65,00,43,00,68,00,61,00,6e,00,67,00,65,00,4e,\

00,6f,00,74,00,69,00,66,00,79,00,50,00,72,00,69,00,76,00,69,00,6c,00,65,00,\

67,00,65,00,00,00,53,00,65,00,43,00,72,00,65,00,61,00,74,00,65,00,47,00,6c,\

00,6f,00,62,00,61,00,6c,00,50,00,72,00,69,00,76,00,69,00,6c,00,65,00,67,00,\

65,00,00,00,53,00,65,00,49,00,6d,00,70,00,65,00,72,00,73,00,6f,00,6e,00,61,\

00,74,00,65,00,50,00,72,00,69,00,76,00,69,00,6c,00,65,00,67,00,65,00,00,00,\

00,00

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\services\StiSvc\Parameters]

"ServiceDll"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,\

00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,\

77,00,69,00,61,00,73,00,65,00,72,00,76,00,63,00,2e,00,64,00,6c,00,6c,00,00,\

00

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\services\StiSvc\Security]

"Security"=hex:01,00,14,80,a0,00,00,00,ac,00,00,00,14,00,00,00,30,00,00,00,02,\

00,1c,00,01,00,00,00,02,80,14,00,ff,01,0f,00,01,01,00,00,00,00,00,01,00,00,\

00,00,02,00,70,00,05,00,00,00,00,00,14,00,fd,01,02,00,01,01,00,00,00,00,00,\

05,12,00,00,00,00,00,18,00,ff,01,0f,00,01,02,00,00,00,00,00,05,20,00,00,00,\

20,02,00,00,00,00,14,00,8d,01,02,00,01,01,00,00,00,00,00,05,04,00,00,00,00,\

00,14,00,8d,01,02,00,01,01,00,00,00,00,00,05,06,00,00,00,00,00,14,00,00,01,\

00,00,01,01,00,00,00,00,00,05,0b,00,00,00,01,01,00,00,00,00,00,05,12,00,00,\

00,01,01,00,00,00,00,00,05,12,00,00,00

; USB Section

[HKEY_LOCAL_MACHINE\PE3-SYSTEM\ControlSet001\services\usbscan]

"Type"=dword:00000001

"Start"=dword:00000003

"ErrorControl"=dword:00000001

"Tag"=dword:00000017

"ImagePath"=hex(2):73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,44,00,\

52,00,49,00,56,00,45,00,52,00,53,00,5c,00,75,00,73,00,62,00,73,00,63,00,61,\

00,6e,00,2e,00,73,00,79,00,73,00,00,00

"DisplayName"="USB "

"Group"="Base"

But usbscan.sys can be load into the pe

But it cannot start successfully

Master, what dll files I am missing or what's wrong

Can you give me tips

Thanks

Edited by PE3MakerNewbie
0

Share this post


Link to post
Share on other sites

But usbscan.sys can be load into the pe

But it cannot start successfully

Test if usbscan is working in mini 7 or in Portable 7 made with VHD_W7_Compact.exe

If it works in one of these versions, you can make filelist comparison and add extra files

and take working registry entries for usbscan.

Also you can watch with ProcMon what files are being used and add these.

Otherwise no more info availble for now .....

0

Share this post


Link to post
Share on other sites

But usbscan.sys can be load into the pe

But it cannot start successfully

Test if usbscan is working in mini 7 or in Portable 7 made with VHD_W7_Compact.exe

If it works in one of these versions, you can make filelist comparison and add extra files

and take working registry entries for usbscan.

Also you can watch with ProcMon what files are being used and add these.

Otherwise no more info availble for now .....

Hi, Master

When I install the canon printer driver

I can't find the usb port

What's wrong. Can you give me some ideas

snap3y.png

0

Share this post


Link to post
Share on other sites

Hi, master wimb

I have tried to install my canon mp496 printer for a few days

Until now i can only install the canon mp490 scanner

when i try to install the MP490P3.inf

it said the can't find the path

when i use the add new printer to install the mp490

it said the printer driver was not installed

i have tried many ways to solve

but i still don;t know why

I hope you can give me tips

here's my registry file (install toharddisk and change to x:)

Code was too large, was crashing browsers

http://pastehtml.com/view/bmq0s5dre.txt

if i use this registry

the printer appear normally in printer device centre window

But when i try to print a test page

it said the print iis full

Edited by Tripredacus
uploaded reg code to pastehtml
0

Share this post


Link to post
Share on other sites

Hello

Respect for the great knowledge about the construction of the system ...

Maybe someone will tell what exactly I have to add that "diskmgmt.msc" works on winpe3.1 ?

I use *.cmd batch to navigate in PE

BR

-->

...already found

sorry was looking carelessly :/

Edited by Pajqk
0

Share this post


Link to post
Share on other sites

Towards the end of my attempt at making a Make_PE3 USB key I get the following GRUB errors.

b19f76.png

3b9a38.png

Is this expected or should the final boot configuration be automated? The key I am using boots fine with BartPE and WinPE 3.

0

Share this post


Link to post
Share on other sites

These are NOT Errors but WARNINGS.

It has to do with the way you have made your USB-stick bootable.

May be just everything is OK e.g. if your stick has Grub4dos MBR bootcode

Anyway, the program only warned you that Windows MBR bootcode was not found.

Did you try to boot from USB with your 7pe_x86_M.iso ?

0

Share this post


Link to post
Share on other sites

=

*** Update of Make_PE3 package to Create Portable Windows 7 PE ***

  • Update - Grub4dos is now version grub4dos-0.4.5c-2012-01-17
    Thanks to chenall - http://code.google.com/p/grub4dos-chenall/downloads/list
  • Update - BOOT_IMG.exe - avoid unnecessary WARNINGS
  • Changed - Make_PE3.exe - ppAppsGenPE.exe for making Portable Apps Desktop Icons is Not running Auto anymore
    to prevent empty cardreader alert in case of Samsung S2 portable USB harddisk.
    Instead launch ppAppsGenPE.exe now on demand with Desktop Icon.
  • Changed - Program Version - latest version is now 4.2

Download - Make-PE3

It is required to extract Make_PE3.exe to the root of your drive

More Info - See post #1

0

Share this post


Link to post
Share on other sites

@wimb

Hi, I'm new to MAKE_PE3 and so far this seems to be the best solution for me to create a decent Win7 recovery iso.

I noticed that the Make_PE3.exe GUI has a small DPI issue if you do not use Windows standard 96DPI (I use 120DPI).

There is some text truncation. If you are coding this with Autoit, this might be of interest to you:

fontgui-resizing

or this in general:

DPIAware

Since I am just starting to use this tool, I have not found all the key areas that can be customized or how to do it.

My first test was just to build the iso without WAIK which was fine except that I have a German Keyboard and the

windows cmd prompt uses the U.S. keyboard layout. This would be one thing I would like to change, but not sure how.

Is there a way to change the keyboard layout to German?

0

Share this post


Link to post
Share on other sites

I noticed that the Make_PE3.exe GUI has a small DPI issue if you do not use Windows standard 96DPI (I use 120DPI).

There is some text truncation. If you are coding this with Autoit, this might be of interest to you:

fontgui-resizing

or this in general:

DPIAware

Thanks for this Info on how to take DPI setting into account.

I am using indeed AutoIt3 and will try to add such function to the program.

German keyboard can be selected with Administrative Tools > System > Keyboard

KeyboardLayoutChanger will allow to set keyboard.

:cheers:

0

Share this post


Link to post
Share on other sites

Yes, when I boot the iso, I can change it. What I meant was to already have this as a default in the iso. Basically, I would like to make an iso with a few customized settings etc. that would end up being the default. I need to investigate the docs and all the subdirs under \MAKE_PE3. I would assume the keyboard can be set with a reg file somewhere.

BTW, can make_pe_42.exe be extracted to a root drive that does not have a system installed on it and why do you specify that it needs to be on the root?

Thanks for your help .....

Edited by click-click
0

Share this post


Link to post
Share on other sites

I understand that 7pe_x86.iso (without WAIK) and pe3_x86.iso (with WAIK) are made from different .wim files, but does anyone know what advantage one iso has over the other?

0

Share this post


Link to post
Share on other sites

I understand that 7pe_x86.iso (without WAIK) and pe3_x86.iso (with WAIK) are made from different .wim files, but does anyone know what advantage one iso has over the other?

http://www.911cd.net/forums//index.php?showtopic=23931

- 7pe contains Recovery software in folder sources which is missing in pe3

- pe3 option NO Reduce of size has /Enable-profiling which allows to make Optimization profile (see WinPE.chm help in WAIK)

Using WAIK has advantage that oscdimg.exe can be used instead of mkisofs.exe

oscdimg.exe makes smaller and unfragmented ISO

Edited by wimb
0

Share this post


Link to post
Share on other sites

I would assume the keyboard can be set with a reg file somewhere.

BTW, can make_pe_42.exe be extracted to a root drive that does not have a system installed on it and why do you specify that it needs to be on the root?

In Make_PE3\PE3_mod\PE3_reg\x86 you find file PE3-USER.reg and folder plugins

In plugins you see examples of Russian and Chinese keyboard Settings

Make_PE3_42.exe can be extracted to any local drive, but root is necessary because of extreme path length in .NET support

:)

Edited by wimb
0

Share this post


Link to post
Share on other sites

I'm still having some problems with my ISO. I did not see any sample keyboard layouts except for the one to

toggle between EN and RU. I added the following .reg, but when I look at change keyboard in Region and Language,

Keyboard US is there instead of Keyboard German and cmd prompt is still mapped to the en layout.


Windows Registry Editor Version 5.00

; Keyboard Layout Default German

[HKEY_LOCAL_MACHINE\PE3-USER\Keyboard Layout]
@=hex(0):
[HKEY_LOCAL_MACHINE\PE3-USER\Keyboard Layout\Preload]
"1"="00000407"

I got my WLAN to work, but the implementation of IE8 seems to be broken for me. When I launch IE8, I get a message

saying "a problem displaying google.com caused IE to refresh the webpage using compatibility view", but nothing

is displayed. If I use portablefirefox, I can view web pages without problems.

When I try to use an Ethernet Connection, there's no connection and the icon shows Failed Authentication. The driver

seems to be installed correctly and this usually works without problems on other boot cds that I have tried.

Thanks for any pointers. Also, if there is a better place to post my questions, please let me know.

Edited by click-click
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.