wimb

Make_PE3 Program to Create Portable Windows 7 PE

398 posts in this topic

Doesn't it works? it works in mine. check uxtheme.dll,mfc42u.dll,odbcint.dll,odbc32.dll,sfc.dll,sfc_os.dll all exist. Ofcourse mui

Procmon.exe http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

Thanks for the link to Procmon.exe

I did use Dependency Walker, but will try to use Procmon

I checked and the required files exist, but MS Paint does not work yet for me ...

Need more study.

Edited by wimb
0

Share this post


Link to post
Share on other sites

Doesn't it works? it works in mine. check uxtheme.dll,mfc42u.dll,odbcint.dll,odbc32.dll,sfc.dll,sfc_os.dll all exist. Ofcourse mui

Procmon.exe http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

Thanks for the link to Procmon.exe

I did use Dependency Walker, but will try to use Procmon

I checked and the required files exist, but MS Paint does not work yet for me ...

Need more study.

used your makepe_3 and add internet explorer and photoviewer. didnt do something else it works. add some more files but i don't think they have any connection with it.

dui70.dll,duser.dll,dwm.exe,dwmcore.dll,dwmredir.dll,dxgi.dll,sti.dll,sti_ci.dll

0

Share this post


Link to post
Share on other sites

used your makepe_3 and add internet explorer and photoviewer. didnt do something else it works. add some more files but i don't think they have any connection with it.

dui70.dll,duser.dll,dwm.exe,dwmcore.dll,dwmredir.dll,dxgi.dll,sti.dll,sti_ci.dll

Added these files but MS Paint is not working yet :(

Procmon shows that all necessary files are loaded.

I assume there is something with the registry.

May be yours is working because of other language settings ....

0

Share this post


Link to post
Share on other sites

i didnt add anything to registry. i don't have any idea. as i said that files shouldnt have connection. maybe shouldn't need to change hex values in classes.reg. i don't know. there is an option in procmon to save log file. if you can send your log file i can try to help. As Logfile.PML file. try to keep it short. run procmon and as soon as mspaint and stop when it gives error or it will not load

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

*** Update of Make_PE3 package to Create Portable Windows 7 PE ***

Required AIK for Windows 7 - KB3AIK_EN.iso - Microsoft - Windows PE 3.0

http://www.microsoft.com/downloads/details.aspx?familyid=696DD665-9F76-4177-A811-39C26D3B3B34&displaylang=en

Dism.exe of AIK must be version 6.1.7600.16385 (earlier version 7000 gives Errors)

Guide with More Info:

http://www.911cd.net/forums//index.php?showtopic=21883&st=35

http://www.msfn.org/board/make-program-create-portable-windows-t143529.html

=

Windows PE 3.0 with Internet Explorer and Photo Viewer and PStart Menu for Portable Programs

=

PE3_IE8.png

=

Edited by wimb
0

Share this post


Link to post
Share on other sites

thx for the update. if you want more i can help if i can

0

Share this post


Link to post
Share on other sites

thx for the update. if you want more i can help if i can

Is everything working OK for you ?

No problems with Source Language anymore ?

Is MS Paint working (for me not) ?

0

Share this post


Link to post
Share on other sites

thx for the update. if you want more i can help if i can

Is everything working OK for you ?

No problems with Source Language anymore ?

Is MS Paint working (for me not) ?

I build 2 isos with turkish source and turkish opk.. First nothing changed turkish selected. Other with en-US values changed with tr-TR values in WIN7_Files.txt,WIN7_add_explor.txt,WIN7_add_files.txt. first one didn't boot any :( peshellwrapper comes. second one works with mmc and photoviewer but ie8 not works. ie8 works after registering ieproxy.dll. I think you removed my clid.reg. i can succesfully installed my ethernet card from device manager. Manage at right click at my computer not works. It can be solved with from classes registry. will check mspaint

*What EXCL and INCL means at "Reduce Size of PE3.iso"? I selected no

*It couldn't find my wireless hotfix that i put near other packages. How can it find other packages in my OPK WinPE_FPs folder and it wants wireless package to be in WinPE_OCs folder?

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

ie8 works after registering ieproxy.dll. I think you removed my clid.reg. i can succesfully installed my ethernet card from device manager. Manage at right click at my computer not works. It can be solved with from classes registry. will check mspaint

IE8 is working for me.

What are exactly the required registry changes that make IE8 work for you

and the command that you used is may be

regsvr32 "X:\Program Files\Internet Explorer\ieproxy.dll"

Can you also give the registry tweak to get Manage at right click at my computer working.

Your clid.reg contains too many Turkish names in the context menu.

Edited by wimb
0

Share this post


Link to post
Share on other sites

i watched with procmon and regsrv32 ieproxy.dll changes too many keys in classes registry so i cant give a certain reg file i wish i can give. /s is only for make it silent not important. i explained in my topics how i did if you don't want to use because of turkish names you can do like that. feel need to explain again. make a boot iso. boot it in a virtual environment. register "regsrv32 ieproxy.dll". take a backup of software\classes reg. use it as clid.reg. you can do it for anything that needs a registered dll file (i think so). there are too many guides about right click registry tweaks in internet. can be this key "[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command]" you can google it and can put anything to right click of my computer. probably paint doesnt work because of clid.reg too.

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

one is enough for me if it not works but it works without register anything now, why need it. i want to register all dll files in wim and take backup of the classes key. we can not know if there is not registered dll exist in wim. if there is such tool for to register everything will be much better. i will use the soft you advise in this situation thx. there are ie8 related dll files in system32 folder. are they really need? in my builds it can work without them

Edited by Kullenen_Ask
0

Share this post


Link to post
Share on other sites

Please, add Spanish support (basically add this lines to "Make_PE3.cmd" ;) ):

IF "!_ok!"=="s" SET Lang=es-ES
IF "!_ok!"=="S" SET Lang=es-ES

With this, it works great with Spanish Windows 7 Ultimate x86! :lol:

post-290036-127229800135_thumb.png

Thanks!

PD: Sorry for my bad English...

Edited by aaaaalex1994
0

Share this post


Link to post
Share on other sites

*** Update of Make_PE3 package to Create Portable Windows 7 PE ***

  • IE8 ieproxy.dll is registered at startup with startnet.cmd
    Thanks to ChinaDragon and Kullenen_Ask for help with IE8
  • Improvements in making Workfolder winpe3_x86

Required AIK for Windows 7 - KB3AIK_EN.iso - Microsoft - Windows PE 3.0

http://www.microsoft.com/downloads/details.aspx?familyid=696DD665-9F76-4177-A811-39C26D3B3B34&displaylang=en

Dism.exe of AIK must be version 6.1.7600.16385 (earlier version 7000 gives Errors)

Download - Make-PE3 - mirror

Guide with More Info:

http://www.911cd.net/forums//index.php?showtopic=21883&st=35

http://www.msfn.org/board/make-program-create-portable-windows-t143529.html

@aaaaalex1994

Thanks for reply and feedback.

In next version I will add Spanish as Option.

0

Share this post


Link to post
Share on other sites

Preview: Make_PE3 - Wireless Internet IE8 + Audio working OK for Realtek Soundcard

AudioActivatorPE.exe is not compatible with my Realtek Soundcard.

Solution:

  • In PE3 Install all drivers by running PnPutil - X:\WINDOWS\system32\PnPutil.exe -i -a X:\Windows\inf\*.inf
  • Remove from registry the SPDIF related entry in key
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render
    so that Speakers are becoming Default for Audio playback and SPDIF icon is removed from Sound playback selector
  • In Speakers Properties entry add the three extra (missing) lines from Windows 7 registry using PE3 GUID as installed by PnPutil
  • Run audio.bat to Activate (red cross in sound icon disappears)

Win PE3 Speakers Properties - Registry tweak for Realtek HD Audio

- use your GUID instead of {1f14c1c7-586f-4fd0-9e83-978f051577b1}

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render\{1f14c1c7-586f-4fd0-9e83-978f051577b1}\Properties]
"{f19f064d-082c-4e27-bc73-6882a1bb8e4c},0"=hex:41,00,20,74,01,00,00,00,fe,ff,\
02,00,44,ac,00,00,10,b1,02,00,04,00,10,00,16,00,10,00,03,00,00,00,01,00,00,\
00,00,00,10,00,80,00,00,aa,00,38,9b,71
"{e4870e26-3cc5-4cd2-ba46-ca0a9a70ed04},0"=hex:41,00,20,74,01,00,00,00,fe,ff,\
02,00,44,ac,00,00,20,62,05,00,08,00,20,00,16,00,20,00,03,00,00,00,03,00,00,\
00,00,00,10,00,80,00,00,aa,00,38,9b,71
"{e4870e26-3cc5-4cd2-ba46-ca0a9a70ed04},1"=hex:41,00,00,00,01,00,00,00,d3,8c,\
01,00,00,00,00,00

audio.bat

NET STOP Audiosrv
NET START Audiosrv

In fact it is the procedure as described by NewBSOD but carried out manually instead of using AudioActivatorPE.exe

http://www.boot-land.net/forums/index.php?showtopic=6688&st=130&p=64383entry64383

Next version of Make_PE3 will have automated Audio support ..... - Size of ISO Boot Image = 240 MB

Edited by wimb
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.