• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
santac

I cannot get my autounattended file working!

17 posts in this topic

ok, i have spent 10 hours on this, but my windows 7 64 bit installation is still not automatic!

I run windows 2008 server R2 with deployment role, and i deploy windows 7 with PXE and VM ware. I created an autoattended.xml file, but nothing happens, it just installs as normal, you have to click, please help

2r7atu8.jpg

<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="specialize">

<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<Identification>

<Credentials>

<Domain>larsdc1</Domain>

<Password>**********Password>

<Username>administrator</Username>

</Credentials>

<JoinDomain>larsdc1.local</JoinDomain>

</Identification>

</component>

</settings>

<settings pass="oobeSystem">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<OOBE>

<HideEULAPage>true</HideEULAPage>

<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>

<NetworkLocation>Home</NetworkLocation>

<ProtectYourPC>1</ProtectYourPC>

</OOBE>

<UserAccounts>

<AdministratorPassword>

<Value>bQBhAGcAbgB1AHMAcwBvAG4AMgAhAEEAZABtAGkAbgBpAHMAdAByAGEAdABvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value>

<PlainText>false</PlainText>

</AdministratorPassword>

<DomainAccounts>

<DomainAccountList wcm:action="add">

<Domain>larsdc1.local</Domain>

</DomainAccountList>

</DomainAccounts>

</UserAccounts>

<TimeZone>FLE Standard Time</TimeZone>

<RegisteredOwner>user org</RegisteredOwner>

<RegisteredOrganization>client org</RegisteredOrganization>

<ShowWindowsLive>false</ShowWindowsLive>

</component>

<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<InputLocale>en-US</InputLocale>

<SystemLocale>en-US</SystemLocale>

<UILanguage>en-US</UILanguage>

<UserLocale>en-US</UserLocale>

<UILanguageFallback></UILanguageFallback>

</component>

</settings>

<settings pass="auditSystem">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<UserAccounts>

<AdministratorPassword>

<Value>bQBhAGcAbgB1AHMAcwBvAG4AMgAhAEEAZABtAGkAbgBpAHMAdAByAGEAdABvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value>

<PlainText>false</PlainText>

</AdministratorPassword>

</UserAccounts>

</component>

</settings>

<cpi:offlineImage cpi:source="wim:c:/sources/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

</unattend>

0

Share this post


Link to post
Share on other sites

Open WDS, right click on your Server Properties. Did you specify that XML for your architecture ?

dd637990.20c9bbb7-2ead-4ad3-9246-2c81c6fbc6a7%28en-us,WS.10%29.gif

0

Share this post


Link to post
Share on other sites

Open WDS, right click on your Server Properties. Did you specify that XML for your architecture ?

dd637990.20c9bbb7-2ead-4ad3-9246-2c81c6fbc6a7%28en-us,WS.10%29.gif

no but you dont need to do that since you can right click install image and select unattended from there right?

beahxe.jpg

Edited by santac
0

Share this post


Link to post
Share on other sites

I tried it, still didnt work...

can VM ware do this?

at this point i am going crazy

Edited by santac
0

Share this post


Link to post
Share on other sites

Is the problem the security prompt in your first screenshot? If so, there's nothing you can do about that one. You say it's a regular install (which would mean the original screenshot wasn't related to this at all), hence the confusion.

0

Share this post


Link to post
Share on other sites

Is the problem the security prompt in your first screenshot? If so, there's nothing you can do about that one. You say it's a regular install (which would mean the original screenshot wasn't related to this at all), hence the confusion.

no the language screen comes up, and i have to click "next" (which should be automated right?) and I have to fill credentials for the client to automatically join my domain.

0

Share this post


Link to post
Share on other sites
and I have to fill credentials for the client to automatically join my domain.

You probably aren't specifying your domain creds in your WDSClient.xml. Assuming you already read Cluberti's link, you should be using two separate XML files. Please paste ATTACH your WDSClient.xml.

If you are still only using the one XML, that is the first thing we need to fix. Follow this link and download the samples here. (courtesy of arwidmark)

Those particular domain creds go in your "WDSClient.XML" and they are done slightly differently than for the image specific XML. See how they wrap their Domain creds inside the "WindowsDeploymentServices" block. That is likely the cause of your issue. You probably still need your other domain creds (in your ImageSpecific.xml) so don't go deleting them.

       <WindowsDeploymentServices>
<Login>
<Credentials>
<Domain>TSLAB</Domain>
<Password>P@ssw0rd</Password>
<Username>BuildAccount</Username>
</Credentials>
</Login>
</WindowsDeploymentServices>

From what I gather, WDSClient.xml is the WDS equivalent to the windowsPE portion of a DVD based installation. Basically it controls the PXE session and automates partitioning, imaging, everything up until the first reboot. Anything else would go in the OS or ImageSpecific.xml file.

Edited by MrJinje
0

Share this post


Link to post
Share on other sites
and I have to fill credentials for the client to automatically join my domain.

You probably aren't specifying your domain creds in your WDSClient.xml. Assuming you already read Cluberti's link, you should be using two separate XML files. Please paste ATTACH your WDSClient.xml.

If you are still only using the one XML, that is the first thing we need to fix. Follow this link and download the samples here. (courtesy of arwidmark)

Those particular domain creds go in your "WDSClient.XML" and they are done slightly differently than for the image specific XML. See how they wrap their Domain creds inside the "WindowsDeploymentServices" block. That is likely the cause of your issue. You probably still need your other domain creds (in your ImageSpecific.xml) so don't go deleting them.

       <WindowsDeploymentServices>
<Login>
<Credentials>
<Domain>TSLAB</Domain>
<Password>P@ssw0rd</Password>
<Username>BuildAccount</Username>
</Credentials>
</Login>
</WindowsDeploymentServices>

From what I gather, WDSClient.xml is the WDS equivalent to the windowsPE portion of a DVD based installation. Basically it controls the PXE session and automates partitioning, imaging, everything up until the first reboot. Anything else would go in the OS or ImageSpecific.xml file.

waithow many XML files do you need in order to get it automated? I thought i only needed autounattend and now i need two more?

0

Share this post


Link to post
Share on other sites

waithow many XML files do you need in order to get it automated? I thought i only needed autounattend and now i need two more?

Already been answered, please read a little closer.

WDS unattended installs (truly unattended) require two unattended xml files.

In short, you only need 2 XML files, the one you already have (which is your OS/Image specific XML), and the WDSClient.xml sample file I mentioned.

Follow this link and download the samples here. (courtesy of arwidmark)

Report back after you have tested the sample WDSClient.xml, and have followed the procedure as outlined in Cluberti's link. Here are the steps in case you are unable (or unwilling) to follow Cluberti's link.

This is a quick guide and samples files for a fully unattended setup of Vista W7 using WDS.

Download sample unattend.xml files from the Vista repository

http://www.deployvista.com/Repository/WindowsVista/tabid/72/Default.aspx

Step-by-step guide...

To add The Windows Deployment Services client unattend.xml

1. Copy the Sample WDSClientUnattend.xml to \RemoteInstall\WDSClientUnattend

2. In the Windows Deployment Services Console, expand Servers, right-click the server and select properties

3. In the Client tab, select the "Enable unattended installation" checkbox, browse to \RemoteInstall\WDSClientUnattend\WDSClientUnattend.xml and click OK

Edited by MrJinje
0

Share this post


Link to post
Share on other sites

Okay before I start, does it matter that the files are made for vista and not windows7, is there anything i need to edit?

0

Share this post


Link to post
Share on other sites

I tell you what, send a PM to arwidmark (the author of this book), he is a member here. If anyone knows off the top of their head, he will.

Otherwise, you should just try running it and report back any errors and we will help on a case-by-case basis. For all we know, we don't need to change anything.

0

Share this post


Link to post
Share on other sites

Okey I got everything to work, but there is only one step that is not automated and it is the step where you select the OS to install. Does anyone know the XML setting for that? Thanks.

Step2.jpg

Edited by santac
0

Share this post


Link to post
Share on other sites

Good catch, based on the sample I think we change this line in your WDSClient.xml

<ImageName>Windows Vista Enterprise</ImageName>

to

<ImageName>Windows 7 Enterprise</ImageName>

0

Share this post


Link to post
Share on other sites

Good catch, based on the sample I think we change this line in your WDSClient.xml

<ImageName>Windows Vista Enterprise</ImageName>

to

<ImageName>Windows 7 Enterprise</ImageName>

nope I already did that. It didn't work.

0

Share this post


Link to post
Share on other sites

You might need to edit your "ImageGroup" setting.

Search Unattend.chm (from WAIK) for greater details. I assume it has to match what you used when you created your images in WDS.

      <InstallImage>
<ImageGroup>My IMAGE GROUP</ImageGroup>
</InstallImage>

Edited by MrJinje
0

Share this post


Link to post
Share on other sites

You might need to edit your "ImageGroup" setting.

Search Unattend.chm (from WAIK) for greater details. I assume it has to match what you used when you created your images in WDS.

      <InstallImage>
<ImageGroup>My IMAGE GROUP</ImageGroup>
</InstallImage>

I got it to work, thank you

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.