cloferba

how to hide "select network location" window?

14 posts in this topic

hello!

its any way to hide this assistant after install my unattended W7?

windows-7-ubicacion-red.jpg

0

Share this post


Link to post
Share on other sites

Easiest way is to specify a network location in your XML.

<OOBE>

<NetworkLocation>Home</NetworkLocation>

</OOBE>

But in case you prefer not to, there is another method. Try running this VBScript from oobeSystem > RunAsynchronous to kill it.

Set WshShell = Wscript.CreateObject("WScript.Shell")
Do While Not Wshshell.AppActivate ("Establecer ubicacion de Red")
Wscript.sleep 1000
Loop
Wshshell.AppActivate "Establecer ubicacion de Red"
Wshshell.SendKeys "%{F4}"

Original source

0

Share this post


Link to post
Share on other sites

This was discussed previously here, and a solution (well, workaround) was found:

0

Share this post


Link to post
Share on other sites

easiest way is to set a GPO to:

Computer Configuration\Windows Settings\Security Settings\Network List Manager Policies\All Networks. Change Network Location to "User cannot change location"

0

Share this post


Link to post
Share on other sites

But in case you prefer not to, there is another method. Try running this VBScript from oobeSystem > RunAsynchronous to kill it.

Set WshShell = Wscript.CreateObject("WScript.Shell")
Do While Not Wshshell.AppActivate ("Establecer ubicacion de Red")
Wscript.sleep 1000
Loop
Wshshell.AppActivate "Establecer ubicacion de Red"
Wshshell.SendKeys "%{F4}"

Original source

Having read the blog posting, I still don't know how to import the <RunAsynchronous> section with the WSIM: Microsoft's tool only suggests it for windowsPE, but not under oobeSystem. Any ideas or expertise on how to do this?

And what about the <Path> attribute, i.e. where to put this vbs script within the installation directory structure?

Thanks in advance,

Mikka

Edit:

Instead of oobeSystem it seems specialize will do. But same problem here: How to refer back to the file?

Edited by Mikka
0

Share this post


Link to post
Share on other sites

Easiest way is to specify a network location in your XML.

<OOBE>

<NetworkLocation>Home</NetworkLocation>

</OOBE>

Original source

but some reason even put <NetworkLocation>Home</NetworkLocation> windows launch the select network pop up but if you put

<NetworkLocation>Other</NetworkLocation> windows dont launch the select network well this work for me if you have a home network or work you can adjust settings in control panel after first logon.

0

Share this post


Link to post
Share on other sites
but some reason even put <NetworkLocation>Home</NetworkLocation> windows launch the select network pop up but if you put <NetworkLocation>Other</NetworkLocation> windows dont launch the select network well this work for me if you have a home network or work you can adjust settings in control panel after first logon.

I tried it with every option, the windows shows up anytime.

0

Share this post


Link to post
Share on other sites
but some reason even put <NetworkLocation>Home</NetworkLocation> windows launch the select network pop up but if you put <NetworkLocation>Other</NetworkLocation> windows dont launch the select network well this work for me if you have a home network or work you can adjust settings in control panel after first logon.

I tried it with every option, the windows shows up anytime.

this is my code in OOBE.


<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Other</NetworkLocation>
<ProtectYourPC>3</ProtectYourPC>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
</OOBE>

and the select pop up never showed.

if it doesnt work should be something wrong in unattend.xml <NetworkLocation>Other</NetworkLocation> skip the network selection for sure.

0

Share this post


Link to post
Share on other sites

this is my code in OOBE.


<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Other</NetworkLocation>
<ProtectYourPC>3</ProtectYourPC>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
</OOBE>

and the select pop up never showed.

if it doesnt work should be something wrong in unattend.xml <NetworkLocation>Other</NetworkLocation> skip the network selection for sure.

I was made aware of this misconception and tried it explicitely with both <NetworkLocation>Other</NetworkLocation> and <ProtectYourPC>3</ProtectYourPC>. I had the friggin window showing up again, no difference to Work/2, Home/1.

(If I omit the attribute <SkipMachineOOBE>, the "select network location" window won't appear, instead I'm nagged for entering data for a new user account which I don't want either as it breaks my unattended installation.)

Edit: Attached latest Autounattend.xml

Autounattend.xml

Edited by Mikka
0

Share this post


Link to post
Share on other sites

this is my code in OOBE.


<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Other</NetworkLocation>
<ProtectYourPC>3</ProtectYourPC>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
</OOBE>

and the select pop up never showed.

if it doesnt work should be something wrong in unattend.xml <NetworkLocation>Other</NetworkLocation> skip the network selection for sure.

I was made aware of this misconception and tried it explicitely with both <NetworkLocation>Other</NetworkLocation> and <ProtectYourPC>3</ProtectYourPC>. I had the friggin window showing up again, no difference to Work/2, Home/1.

(If I omit the attribute <SkipMachineOOBE>, the "select network location" window won't appear, instead I'm nagged for entering data for a new user account which I don't want either as it breaks my unattended installation.)

Edit: Attached latest Autounattend.xml

<SkipUserOOBE> and <SkipMachineOOBE> are deprecated by microsoft so there is no need to use them still works but you can use others methods to avoid user creation like in localccounts create a new user:


<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Other</NetworkLocation>
<ProtectYourPC>3</ProtectYourPC>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
</OOBE>

and this in useraccounts:



<UserAccounts>
<AdministratorPassword>
<Value>password-value</Value>
</AdministratorPassword>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Password>
<Value>password-value</Value>
</Password>
<Description>testing</Description>
<DisplayName>test-user</DisplayName>
<Group>Administrators</Group>
<Name>test-user</Name>
</LocalAccount>
</LocalAccounts>
</UserAccounts>

try this.

you can create a script to delete or disable any user you create in localaccounts after install windows if you dont want any other accounts.

0

Share this post


Link to post
Share on other sites

If you install this on Virtual machine it will show that window anyhow. I have also tried making unattended.xml with rt7lite, but when you will install it on actual machine it will not pop-up.

I have observed it personally.

0

Share this post


Link to post
Share on other sites

No kidding? Microsoft established this splendid behaviour specially for VM users? What a bunch of morons ...

What a disgrace!

0

Share this post


Link to post
Share on other sites

Hello!

I haven't this problem with Sun VirtualBox!

Regards

0

Share this post


Link to post
Share on other sites

Hello!

I haven't this problem with Sun VirtualBox!

Regards

yeah virtual box is better but it doesn't support aero effect.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.