Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sp0iLedBrAt

[SOLVED] KB982168 install fails

Recommended Posts

Sp0iLedBrAt    0

I just tried to install NDP30SP2-KB982168-x86.exe and I got this error

Action complete. Log File: C:\DOCUME~1\USER~1\LOCALS~1\Temp\Microsoft .NET Framework 3.0-KB982168_20100611_223117875-Msi1.txt
[6/11/2010, 22:35:51] (HotIron::MspInstallerT<class HotIron::ApplicablePatchPackages>::PerformMsiOperation) exiting function/method
[6/11/2010, 22:35:51] (HotIron::MspInstallerT<class HotIron::ApplicablePatchPackages>::PerformMsiOperation) failed and rolled back
[6/11/2010, 22:35:51] (HotIron::CBaseMspInstaller::Install) PerformMsiOperation returned 0x2
[6/11/2010, 22:35:51] (HotIron::CBaseMspInstaller::Install) exiting function/method
[6/11/2010, 22:35:51] (HotIron::CBaseMspInstaller::Install) PerformMsiOperation returned 0x2
[6/11/2010, 22:35:51] (HotIron::CompositeInstaller::Install) Composite Installer is reporting 0x80070002 - The system cannot find the file specified.
[6/11/2010, 22:35:51] (HotIron::CompositeInstaller::Install) exiting function/method
[6/11/2010, 22:35:51] (HotIron::CompositeInstaller::Install) The system cannot find the file specified.

I also expanded the log file to verbose, but there is no extra information. I recently installed .NET 3.5SP1 full package. Any ideas?

Thanks in advance

Edit: I tried to incorporate it into the Silent .NET Maker and got this error:

post-236786-127629690419_thumb.jpg

I am using XP Pro x86 SP3 and .NET 3.5 SP1; the download is from here http://www.microsoft...&displaylang=en ; I got the x86 version.

Edited by Sp0iLedBrAt

Share this post


Link to post
Share on other sites
Sp0iLedBrAt    0

To expand on it, it appears that the package has three .msp files: NDP20SP2-KB976765.msp, NDP20SP2-KB980773.msp and NDP30SP2-KB976769.msp . The first two install just fine when extracted and run individually; the third, however, asks for the source netfx30a_x86.msi, which I don't have, as .NET 3.0 SP2 was installed as part of the full .NET 3.5 SP1 package. I can confirm all versions (including updates) show in Add/Remove Programs.

Share this post


Link to post
Share on other sites
cluberti    5

Is it specifically looking for that file during the install? Seems very odd that it would require the original installer for an MSP - does a procmon give any clues as to why it wants that specific file?

Share this post


Link to post
Share on other sites
Sp0iLedBrAt    0

Well, I did what it wanted me to do: I extracted the netfx30a_x86.msi from the .NET 3.5 SP1 package, pointed to it at the cue and the installation of NDP30SP2-KB976769.msp worked. May I just add that I also tried with a modified netfx30a_x86.msi from an AIO installer (Silent .NET Maker) and it didn't work.

So, I'm renaming this to "SOLVED".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×