MrBiggz

Question about .NET framework

8 posts in this topic

hi!

I have an addon that installs but when I try to run it, it tells me that I need .NET v2.0 framework installed. Now this is where I think i got myself into trouble. Does .NET3 supersede .NET2 and .NET1? Or do you have to have 1 installed then 2 then 3?

Thanks for any input!

0

Share this post


Link to post
Share on other sites

1.1 then 3.5 (which includes 2 & 3) then 4.0 will cover all the bases for any .NET based application you might run into.

0

Share this post


Link to post
Share on other sites

Gracias sir! I was sort of on the right path!

0

Share this post


Link to post
Share on other sites

1.1 then 3.5 (which includes 2 & 3) then 4.0 will cover all the bases for any .NET based application you might run into.

I have Windows 7 home premium 32-bit, & I need to install the .net frameworks that the above quote mentions. My system used to have them, but a trojan corrupted them. Don't worry, I made sure to remove what was left of them as preparation for re-installing them. My question is this. There are 2 versions of 4.0, so which one should I install? Also, when there is a choice, do you recommend a Standalone Installer version or a Web Installer version?

.NET Framework 4 Full

.NET Framework 4 Client Profile

Edited by natsumerio
0

Share this post


Link to post
Share on other sites
The .NET Framework 4 Client Profile is a subset of the .NET Framework 4 that is optimized for client applications. It provides functionality for most client applications, including Windows Presentation Foundation (WPF), Windows Forms, Windows Communication Foundation (WCF), and ClickOnce features. This enables faster deployment and a smaller install package for applications that target the .NET Framework 4 Client Profile.
source here http://msdn.microsoft.com/en-us/library/cc656912.aspx

So, if you only want to run .NET 4.0 applications, the Client Profile is more than enough.

Cheers

0

Share this post


Link to post
Share on other sites

some people say that 1.1 and 4 are enough since supposedly 4 covers CLR2

this true or all 1,2,3,4 are a must ?

0

Share this post


Link to post
Share on other sites
The .NET Framework 4 is highly compatible with applications that are built with earlier .NET Framework versions, except for some changes that were made to improve security, standards compliance, correctness, reliability, and performance.The .NET Framework 4 does not automatically use its version of the common language runtime to run applications that are built with earlier versions of the .NET Framework. To run older applications with .NET Framework 4, you must compile your application with the target .NET Framework version specified in the properties for your project in Visual Studio, or you can specify the supported runtime with the <supportedRuntime> Element in an application configuration file.

Source: http://msdn.microsoft.com/en-us/library/ms171868%28v=VS.100%29.aspx

Hope that helps

0

Share this post


Link to post
Share on other sites
The .NET Framework 4 does not automatically use its version of the common language runtime to run applications that are built with earlier versions of the .NET Framework

so this means that user actualy needs full bloat of 2, 3, 3.5 and 4 afterall ?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.