Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


RYU81

I can't change my homepage in IE8

14 posts in this topic

You've got your main start and default pages in your profile's registry (HKCU) and the local machine registry (HKLM). IE8 is going to read both, so I'm going to suggest looking at deleting the values at least in HKLM for default search, default page, and start page, and see if that helps.

0

Share this post


Link to post
Share on other sites

You've got your main start and default pages in your profile's registry (HKCU) and the local machine registry (HKLM). IE8 is going to read both, so I'm going to suggest looking at deleting the values at least in HKLM for default search, default page, and start page, and see if that helps.

I try that before show me error when edit or delete.

0

Share this post


Link to post
Share on other sites

You need to make sure, when you run regedit, that you run it as administrator. Hopefully you will be able to remove these that way.

0

Share this post


Link to post
Share on other sites

You need to make sure, when you run regedit, that you run it as administrator. Hopefully you will be able to remove these that way.

I'm sure run it as administrator.

0

Share this post


Link to post
Share on other sites

what virus/malware products do you have installed? Many can protect the home page on your browsers.

0

Share this post


Link to post
Share on other sites

what virus/malware products do you have installed? Many can protect the home page on your browsers.

I use Norton 2010,I try to uninstall it after that I try to change my homepage and still I can't.

0

Share this post


Link to post
Share on other sites

You might see if this works.......

Log on with an administrator account not guest or limited

Create the following registry file

====================================================================================

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]

"Homepage"=dword:00000000

====================================================================================

Note the blank line after "Windows Registry Editor Version 5.00

There must also be a blank line after the "Homepage" line

Do NOT include the ================ lines.

Save the file as a .REG file

Right click on the file and select "Open With" and then select "Registry Editor"

Answer the questions and that should do it.

If you want to reverse this and re-LOCK the homepage, change the dword's last 0 to a 1

Edited by Blekthor
0

Share this post


Link to post
Share on other sites

You might see if this works.......

Log on with an administrator account not guest or limited

Create the following registry file

====================================================================================

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]

"Homepage"=dword:00000000

====================================================================================

Note the blank line after "Windows Registry Editor Version 5.00

There must also be a blank line after the "Homepage" line

Do NOT include the ================ lines.

Save the file as a .REG file

Right click on the file and select "Open With" and then select "Registry Editor"

Answer the questions and that should do it.

If you want to reverse this and re-LOCK the homepage, change the dword's last 0 to a 1

not working :}

0

Share this post


Link to post
Share on other sites

At this point, Ryu, can you run process monitor while trying to delete those values, and then save out the .PML file? We need to see why you're unable to delete these (as long as these entries exist in policies, you will not be able to override them).

0

Share this post


Link to post
Share on other sites

Hi,Navigate to the Web site you'd like to use for your homepage. Then, click the down arrow next to the Home icon on the Internet Explorer 8 toolbar and select Add or Change Home Page. Now you can select whether you want to Use this webpage as your only home page, or Add this webpage to your homepage tabs. Click Yes to save your changes.

0

Share this post


Link to post
Share on other sites

Here is the solution of your problem by changing the registry but Modification in the registry is very harmful and if you are not able to do correctly you might have to reinstall o.s so do at your own risk......

To change the registry, follow these steps:

1. Click StartCollapse this imageExpand this im, in the Start Search box, type regedit.

2. In the Programs list, click Regedit.exe.

· If you are prompted for an administrator password or confirmation, type the password or click Continue.

3. Find and then click the following registry subkey:

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main

4. In the details pane, click New, and then click DwordValue.

5. Set RunOnceComplete to 1.

6. In the details pane, click New, and then click DwordValue.

7. Set RunOnceHasShown to 1.

8. Close Registry Editor.

9. Restart Internet Explorer.

0

Share this post


Link to post
Share on other sites

Pankaj, if there is a homepage set in policy, it won't matter what you set as the homepage or as the firstrun under HKCU - it will *not* read them, and this is expected behavior. Your posts will not help.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.