TmEE

Problems with sharing files between XP and 98

15 posts in this topic

So, I have XP and 98SE machine, in same workgroup, files shared out, and I cannot access XP files from 98 site. I am greeted with a password prompt...

I did not have any problems with that on my old but now dead 98SE setup, I could access files without problems...

I don't really know what is different this time, and the steps I've done that I got from google have not worked...

EDIT: password is asked when I want to access the XP PC, I don't see the files etc.

Edited by TmEE
0

Share this post


Link to post
Share on other sites

I did not have any problems with that on my old but now dead 98SE setup, I could access files without problems...

because 98 doesn't use NT security. Can you not just use the XP login name and (no)password if that is what you have to log on your XP system ?

Or check how the files are shared on the XP machine (any restrictions?)

0

Share this post


Link to post
Share on other sites

So, I have XP and 98SE machine, in same workgroup, files shared out, and I cannot access XP files from 98 site. I am greeted with a password prompt...

I did not have any problems with that on my old but now dead 98SE setup, I could access files without problems...

I don't really know what is different this time, and the steps I've done that I got from google have not worked...

EDIT: password is asked when I want to access the XP PC, I don't see the files etc.

You should run the network setup wizard on your XP computer (Open "Control Panel", then "Network and Internet Connections", then "Set up or change your home or small office network"). Depending on your configuration, you also may have to create a floppy disk, in Windows XP, from which floppy disk you can run the network setup wizard on your Windows 98SE computer.

You may also have to adjust your firewall settings in XP and/or 98SE.

0

Share this post


Link to post
Share on other sites

Thats faulty of XP' Local Security Settings.

Control Panel -> Administrative Tools -> Local Security Policy -> Local Policies -> Security Options

Look something like "Network access: " that has disable/enable settings

fiddling with them could resolve it.

(Usualy this:

Network access: Do not allow annoymous enumeration of SAM accounts and shares.

in my settings i change it to: Disabled,

counter intuitive with double negative.)

However, i also recomend to DISABLE "Remote Registry", in Control Panel -> Administrative Tools -> Services

Before i disable that services, i've discover that other connected XP machine interfering with registry that revert my custom XP local security setings to their unconfortable 'default' settings.

Some malicious malware also exploit that services too.

Remote Registy .., i glad win9x doesn't have this stupidity.

0

Share this post


Link to post
Share on other sites
Remote Registy .., i glad win9x doesn't have this stupidity.

Ah but you can actually install it off of the CD if you want to not that its a good idea, remote registry is something I always disable.

0

Share this post


Link to post
Share on other sites

I have ran the network wizard, I have disabled the policy stuff, I have even messed with registry... fun thing was that I had none of this happen with my old 98 install, which should not have been any different from current one on the network part... XP does not log in with a password either, so I have no idea what password do I have to enter, since I have not specified any passwords anywhere...

I'm beginning to feel I got to uninstall all network stuff and start over...

EDIT: my old 98 setup had no trouble accessing files in a completely different network either...

So I guess there are changes needed on the 98 side. I have tried adding different protocols and tried different login methods.

I'm using "..." too much :P

Edited by TmEE
0

Share this post


Link to post
Share on other sites

If XP does not login with a password then it probably doesn't have one.

You should only need the TCP/IP protocol unless you need IPX/SPX for older games that use it.

Usually you should have the Client for Microsoft Networks as the Primary Network Logon.

At the Network logon screen where it asks you to enter your network password you should have the same username as you have on XP/

If your not sure what it is look it up in the Control Panel -> User Accounts, you can also check if you have a password or not.

As long as both computers have the same Username and Password they should be able to share files easily.

EDIT: is this password prompt you speak of where it asks for an IPC$ password?

Edited by awergh
0

Share this post


Link to post
Share on other sites

IIRR, XP will refuse a remote logon to an account with blank password, no matter what.

0

Share this post


Link to post
Share on other sites

Yea, it asks for IPC$ password.

I did a workaround, which was creating a user account on XP machine with my 98 account name.

It is only a workaround, because if I took that setup to work, it would not be able to do anything regarding network. My old setup did, and I had no passwords etc. either.

0

Share this post


Link to post
Share on other sites

It can be done, but I recommend either using the 98 machine as the "server" or setting up an FTP and using FileZilla if you want to go the other way. It's quicker and easier to do.

0

Share this post


Link to post
Share on other sites

Ironically, Win98 is actually a better fileserver than XP or Win2K; They both have limits on the number of open network files (Something stupid like 5 IIRC) whereas Win98 doesn't.

Also, Win98 uses Share level security and not User level security, which is less secure but much easier to access for random machines.

User level security REQUIRES a user account to access.

I think WinXP has a kludge called guest-mode share to let anonymous machines access shares without 'proper' authentication, but it is very hit and miss. Simple filesharing has to be used to make it work.

0

Share this post


Link to post
Share on other sites

So, I have XP and 98SE machine, in same workgroup, files shared out, and I cannot access XP files from 98 site. I am greeted with a password prompt...

I did not have any problems with that on my old but now dead 98SE setup, I could access files without problems...

I don't really know what is different this time, and the steps I've done that I got from google have not worked...

EDIT: password is asked when I want to access the XP PC, I don't see the files etc.

I running the XP And Win98 Networks

Go to the Folder of your Sharing on Xp

Right Click the Folder

Click on Properties

Check Share this folder on the network

Check Allow Network user to change my files

If you did all of this

then go to My Computer

Right Click

Click on Properties

Click on the tab Remote

UnClick

Allow Remote

Allow Users

For i had to turn them off on my XP

or if do not like that, Click Select Remote User

and it will tell how to go on from here

Edited by hottext
0

Share this post


Link to post
Share on other sites

Just a possibility - try adding Windows Family Login [edit: Microsoft Family Logon] as a Client in your W98 PC's Network Properties.

Joe.

Edited by jds
0

Share this post


Link to post
Share on other sites

When file-sharing has not yet been enabled on the WinXP computer you get this message on the Win98 computer: "Enter Network Password. You must supply a password to make this connection. Resource: \\xxxxxx\IPC$. Password:".

To enable file-sharing on the WinXP computer:

- Right-click on a partition in My Computer -> Sharing and Security -> click on the text "I understand that"

- in the next window in section "network sharing and security": -> click again on the text "I understand that..."

- in window "Enable File Sharing": -> select "Just enable filesharing" -> Ok

After file-sharing is enabled on the WinXP computer, there is no more "Enter Network Password.... IPC$".

But I don't know how to turn off file-sharing under WinXP.

On my Win98/XP network I have the Win98 computers set in Control Panel -> Network to "Windows Logon", to get rid of the annoying "Enter Network Password. Enter your network password for Microsoft Networking" message when Win98 starts up.

Edited by Multibooter
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.