Sp0iLedBrAt

My Computer and Show Desktop lost icons

29 posts in this topic

I recently (have no idea how) lost the icons for My Computer and Show Desktop. I don't mean they are not there, I mean they've lost the appearance.

My Computer

post-236786-055192800 1285238913_thumb.j

Show Desktop

post-236786-088474100 1285238919_thumb.j

Now, when the window opens for me to save something, I can't see My Computer, but I can see Show Desktop :blink:

post-236786-027522600 1285238925_thumb.j

Any ideas?

Cheers

0

Share this post


Link to post
Share on other sites

Hello!

Maybe you can try this reg file:


Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}]
@="My Computer"
"InfoTip"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,\
6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,\
00,53,00,48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,\
2d,00,32,00,32,00,39,00,31,00,33,00,00,00
"IntroText"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,\
6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,\
00,53,00,48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,\
2d,00,33,00,31,00,37,00,35,00,31,00,00,00
"LocalizedString"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,\
6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,\
00,5c,00,53,00,48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,\
2c,00,2d,00,39,00,32,00,31,00,36,00,00,00

[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
65,00,2c,00,30,00,00,00

[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\InProcServer32]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,00,48,00,\
45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,00,00
"ThreadingModel"="Apartment"


[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"Start_ShowMyComputer"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
"DesktopProcess"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
;My Computer
"{20D04FE0-3AEA-1069-A2D8-08002B30309D}"=dword:00000000

But it's inside my French localised Windows version!!

Cheers

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

I also forgot to point out that the My Computer icon is not visible in the Start menu.

post-236786-016677100 1285242894_thumb.j

@myselfidem

Unfortunately, it doesn't work, but I think it could be because lines are wrongly separated by the forum display. Could you attach the original .reg file as you created it?

Thank you

0

Share this post


Link to post
Share on other sites

Hello Sp0LedBrAt !

I give you here as attachment! But maybe the reason is that it's an reg file for my localised Windows French version?

Cheers

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

I don't think so. As far as I know, My Computer, My Documents etc. have the same class IDs on any XP. I have applied the .reg file, but will report after I restart.

Cheers

0

Share this post


Link to post
Share on other sites

OK!

If it's needed, I give you another reg file with HKLM reg for MY_Computer inside!

Cheers

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

I'm afraid both attempts were a failure. Any other ideas?

Thank you

0

Share this post


Link to post
Share on other sites

Hello!

Maybe you can try: Right-click on the Desktop; select: Properties; Desktop: Customize Desktop and select: My Computer; validate:OK.

I give you new reg file!

I hope that will help you!

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

I did my Google search before I posted ;) That's why I said

I don't mean they are not there, I mean they've lost the appearance

Anyway, the appearance of My Computer is the same there and in every other place.

Thanks

0

Share this post


Link to post
Share on other sites

This is the master icon:

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon]
@=hex(2):25,53,79,73,74,65,6d,52,6f,6f,74,25,5c,45,78,70,6c,6f,72,65,72,2e,65,\
78,65,2c,30,00

(It says @=%systemroot%\Explorer.exe,0)

Check if there's something in [HKEY_CURRENT_USER...]{the rest is the same as above}. It shouldn't be, unless you've customized desktop icons and/or used some theme

Check both [HKLM/HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\ShellIconOverlayIdentifiers] - if there is anything and post it here.

Check both [HKLM/HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons]/{20D04FE0-3AEA-1069-A2D8-08002B30309D}=0

Check whether

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer]
"Max Cached Icons"="4096"

is big enough, I'd say at least "512".

Delete %systemdrive%\Documents and Settings\Sp0iLedBrAt\Local Settings\Application Data\IconCache.db :)

REBOOT IMMEDIATELY

GL

*Edit: One more place: %systemdrive%\Documents and Settings\Sp0iLedBrAt\Application Data\Microsoft\Windows\Themes\Custom.theme < edit with Notepad if necessary, but customizing desktop should be enough.

Edited by GrofLuigi
0

Share this post


Link to post
Share on other sites

@GrofLuigi:

I did all the steps you recommended; the first one did not have a hex value

hex(2):25,53,79,73,74,65,6d,52,6f,6f,74,25,5c,45,78,70,6c,6f,72,65,72,2e,65,\

78,65,2c,30,00

, but it did have
%systemroot%\Explorer.exe,0
. Everything else was OK (even the custom theme), except for
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer]

"Max Cached Icons"="4096"

. This didn't exist, so I created it as a DWORD value with a decimal of 4096. I also deleted IconCache.db, which I was thinking of rebuilding with TweakUI.exe. After the restart, however, it's still the same.

Fala sepak :rolleyes:

Thanks

0

Share this post


Link to post
Share on other sites

It's string. And they say there's another step, change display color depth. :unsure:

If I had this problem, I'd try with Process Monitor...

GL

0

Share this post


Link to post
Share on other sites

@GrofLuigi

This link you attached made me think; I didn't (and I still don't) think it's important, but a part of my notebook screen broke and I got an old CRT screen and hooked it up as secondary display (Intel Dual Display Clone mode). Do you think this may have anything to do with it?

BTW, the change of color depth didn't work.

Cheers

0

Share this post


Link to post
Share on other sites

Sorry if this was step 1, I just didnt see it tried in the thread.

right click on any shortcut and go to properties

hit change icon

browse C:\WINDOWS\Explorer.exe for icons

are the little computer and desktop icons there, and if so can you apply them to other shortcuts?

Edited by iamtheky
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.