Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Kazung-Q

Office 2010 Proofing ToolKit Silent Installation

15 posts in this topic

Hi,

I'm trying to make a silent installation for the Office 2010 Proofing Tools. I've updated the ProofKit.WW\config.xml file with all settings but I can't figure out how to get setup.exe to actually use the config.xml file.

setup.exe /config config.xml or setup.exe /config c:\path\to\config.xml don't do much

any help is hugely appreciated.

Walter

0

Share this post


Link to post
Share on other sites

Post your config.xml (minus serial) lets see what it looks like

Edited by ricktendo64
0

Share this post


Link to post
Share on other sites

here goes. But I doubt it has anything to do with the config-file. I'm also posting the logfile it generates. It throws an error on my locale setting. Both my Windows and Office installation are in English. My regional settings are set to Dutch Belgium (locale ID 2067). Knowing the error is step 1. I'm a bit clueless about how to resolve this.


<Configuration Product="Proofkit">
<Display Level="basic" CompletionNotice="yes" SuppressModal="no" AcceptEula="yes" />
<Logging Type="standard" Path="c:\altiris\installlog" Template="Microsoft Office Proofkit Setup(*).txt" />
<OptionState Id="ProofingTools_1043" State="local" Children="force" />
<Setting Id="SETUP_REBOOT" Value="Never" />
</Configuration>


PERF: TickCount=255337569 Name=OBootStrapper::Run Description=Begin function
Operating System version: 6.1.7600 . Platform ID: 2
Running 32-bit setup on a 32-bit operating system.
Command line: setup.exe /config c:\temp\pt\proofkit.ww\config.xml
Parsing command line.
Config XML file specified: c:\temp\pt\proofkit.ww\config.xml
Parsing config.xml at: c:\temp\pt\proofkit.ww\config.xml
Preferred product specified in config.xml to be: PROOFKIT
Parsed setting: SETUP_REBOOT with value: Never in config.xml.
Logging type standard specified in config.xml.
Log directory: c:\altiris\installlog specified in config.xml
Log file template: Microsoft Office Proofkit Setup(*).txt specified in config.xml
Display level basic specified in config.xml.
Suppression of modal dialogs specified in config.xml.
Show completion notice specified in config.xml.
Auto accept license specified in config.xml.
Verify file signature in "C:\temp\PT\setup.exe"
C:\temp\PT\setup.exe is trusted.
Verify file signature in "C:\temp\PT\ProofKit.WW\PSETUP.DLL"
C:\temp\PT\ProofKit.WW\PSETUP.DLL is trusted.
Using setup controller dll at [C:\temp\PT\ProofKit.WW\PSETUP.DLL].
PERF: TickCount=255338177 Name=OBootStrapper::Run Description=Calling RunSetup

PERF: TickCount=255338177 Name=RunSetup Description=Begin function
Catalyst execution began: 01/06/2011 14:37:23.
Parsing config.xml at: c:\temp\pt\proofkit.ww\config.xml
Preferred product specified in config.xml to be: PROOFKIT
Parsed setting: SETUP_REBOOT with value: Never in config.xml.
Logging type standard specified in config.xml.
Log directory: c:\altiris\installlog specified in config.xml
Log file template: Microsoft Office Proofkit Setup(*).txt specified in config.xml
Display level basic specified in config.xml.
Suppression of modal dialogs specified in config.xml.
Show completion notice specified in config.xml.
Auto accept license specified in config.xml.
Setupexe Resiliency Mode is set to [PerformIfApplicable]; thus Resiliency is [disabled] for the [InstallExecutionMode]
Searching for updated versions of resource files under the 'updates' folder [C:\temp\PT\updates].
Found [0] resource files under the update folder.
Searching for default versions of resource files under the folder [C:\temp\PT].
Resource File Manager : Found (CultureTag=en-US) resource file at [C:\temp\PT\ProofMUI.en-us\PSETUPUI.DLL].
Resource File Manager : Found (CultureTag=fr-FR) resource file at [C:\temp\PT\ProofMUI.fr-fr\PSETUPUI.DLL].
Found [2] resource files under the default folder.
Resource File Manager : Current user's LCID is [2067].
Resource File Manager : Failed to find a suitable FallBackCulture (from [nl-BE] to the list of of specified CultureTags).
Unable to locate a suitable resource file which contains resources that match the current user's Locale [2067].
Checking the value of 'Software\Microsoft\Office\14.0\Common\LanguageResources[PreferredSetupLanguage]'
Unable to select the language in which to run setup because no resource file matches contains resources that match the current user's locale. User's Locale=[2067]; Available Resources=[en-US,fr-FR]
Not prompting user to select the language in which to run setup.exe because UILevel==None.
Error: Installation of this product requires operating system supplemental language support. ErrorCode: 0(0x0). Failed final attempt to load a setupexe resource file.
Error: Installation of this product requires operating system supplemental language support. Type: 54::NoSupportedCulture.

Not showing message because suppress modal has been set. Title: 'Setup Error', Message: 'The language of this installation package is not supported by your system.
'
Message returned: 1
Catalyst execution finished: 01/06/2011 14:37:23. Return code: 30054. Exception caught: NoSupportedCulture.
PERF: TickCount=255338255 Name=RunSetup Description=End function

0

Share this post


Link to post
Share on other sites

I know these pages by heard by now :rolleyes:

I found the problem. But it was not in my config.xml file.

When I start the setup manually I'm presented a language selection dialog first (with only English and French as options) before the actual setup dialog is presented.

In the root folder there are also 2 folders ProofMUI.en-us and ProofMUI.fr-fr. There isn't an option to set the setup-dialog-language in the config.xml file, but when I remove the fr-fr-folder....setup will continue and start the installation (many thanks to MS for NOT documenting the use of those MUI folders. *sigh*)

But now up to the next undocumented problem: the installation starts and when the progress bar is at about 10 or 15% it presents the following error:

"setup cannot find proofkit.ww\proof.ar\proof.cab", with an "file open" dialog. If I point the installer to the ...\proof.ar\proof.cab file it gives me the error "This folder can't be used". Nice :angry: Also If I point it to a copy (!) of the installation files on a different location it gives the exact same error. See attached screenshots

Any help on this is greatly appreciated.

post-32658-0-35861500-1295277194_thumb.p post-32658-0-47883000-1295277062_thumb.p)

post-32658-0-19496100-1295277193_thumb.p

0

Share this post


Link to post
Share on other sites

It seems that the temp path isn't correct!

Could you please attach your config.xml?

0

Share this post


Link to post
Share on other sites

the file is the same as I've posted above. I've also tried including ALL languages, but that gives the exact same error.

0

Share this post


Link to post
Share on other sites

Your file config.xml you give above isn't complete!!

0

Share this post


Link to post
Share on other sites

What's missing? These are all parameters I've configured. The others are commented out. As for the option state: this was my test (add 1 proofing language). But I've also tried with all possible languages (including arabian).

in the install log I find these lines on the error:

LIS: wait for package "{90140000-004B-0000-0000-0000000FF1CE}" to complete caching
LIS failed to cache download "{90140000-004B-0000-0000-0000000FF1CE}-C" resource "Proof.ar|Proof.cab". Cache Error 0x80070017
Source Resolution succeeded
LIS: start caching file "Proof.ar|Proof.cab"
LIS failed to cache download "{90140000-004B-0000-0000-0000000FF1CE}-C" resource "Proof.ar|Proof.cab". Cache Error 0x80070017
Source Resolution cancelled
Error: User had cancelled setup Type: 90::UserCancel.

The first line is the caching of the proof.ar file (although in my config file it's set as ABSENT)

the error isn't even known by Google

"Source Resolution succeed" is when I browse for the correct file

after which the same error is returned

The cancelled line is because I cancelled the setup after which a rollback happens.

Edited by Kazung-Q
0

Share this post


Link to post
Share on other sites

I don't have the CD with Proofing tools!

But I think that the config.xml must writed like this for an unattended installation:

config.xml

<Configuration Product="ProofKit">

<Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" />

<Logging Type="standard" Path="%temp%" Template="Microsoft Office Proofing Tools Kit Setup(*).txt" />

<USERNAME Value="Customer" />

<COMPANYNAME Value="MyCompany" />

<INSTALLLOCATION Value="%programfiles%\Microsoft Office" />

<!-- <LIS CACHEACTION="CacheOnly" /> -->

<!-- <LIS SOURCELIST ="\\server1\share\Office;\\server2\share\Office" /> -->

<DistributionPoint Location="%sytemdrive%\Office14" />

<!-- <OptionState Id="OptionID" State="Local" Children="force" /> -->

<OptionState Id="IMEMain_1028" State="Absent" Children="force"/>

<OptionState Id="IMEMain_1041" State="Absent" Children="force"/>

<OptionState Id="IMEMain_1042" State="Absent" Children="force"/>

<OptionState Id="IMEMain_2052" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1025" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1026" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1027" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1028" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1029" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1030" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1031" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1032" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1033" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1035" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1036" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1037" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1038" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1040" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1041" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1042" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1043" State="Local" Children="force"/>

<OptionState Id="ProofingTools_1044" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1045" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1046" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1048" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1049" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1050" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1051" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1053" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1054" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1055" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1056" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1058" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1060" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1061" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1062" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1063" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1069" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1081" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1087" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1094" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1095" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1097" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1099" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1102" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_1110" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_2052" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_2068" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_2070" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_2074" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_3076" State="Absent" Children="force"/>

<OptionState Id="ProofingTools_3082" State="Absent" Children="force"/>

<Setting Id="Setup_Reboot" Value="Never" />

<Command Path="%windir%\system32\msiexec.exe" Args="/i %systemdrive%\Office14\ProofKit.WW\ProofKitWW.msi" QuietArg="/qn" ChainPosition="after" Execute="install" />

</Configuration>

And the command to launch is like this:

setup.exe /config %systemdrive%\Office14\\ProofKit.WW\config.xml

Check if the file ProofKitWW.msi is correct because I don't have this program!

I hope that can help you!

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

@myselfidem: nope my Config file is correct. Every option has a default. in your config file you only have to set the "non-default" values

I found it by the way. The proof.ar\proof.cab file turned out to be corrupt. I donwloaded the iso file again from the MS site and it works flawlessy with my config file and after deleting the ProofMUI.fr-fr folder. (you'd really think that was a documented feature)

Thanks for all your support! :hello:

0

Share this post


Link to post
Share on other sites

Thanks for your sharing! :rolleyes:

Btw, do you use the full CD profing tools (with all the files) for your silent installation?

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.