blackwingcat

KernelEx for Win2000

890 posts in this topic

Wow :thumbup

Thank you very much for adding the compatiblity with WB's path to your shell32.dll.

As for the psapi.dll, isn't it possible to use the XP file as it is?

0

Share this post


Link to post
Share on other sites

Wow :thumbup

Thank you very much for adding the compatiblity with WB's path to your shell32.dll.

As for the psapi.dll, isn't it possible to use the XP file as it is?

Where do you download wildbill's latest? I'm going hold off for blackwingcat's v16 for the Thunderbird compatibility but I would like to see what he's got.

0

Share this post


Link to post
Share on other sites
Where do you download wildbill's latest? I'm going hold off for blackwingcat's v16 for the Thunderbird compatibility but I would like to see what he's got.

There are actually three files:

2479628-v9a

2393802-v8

2508429-v6

You must install them in this order, and of course you should uninstall the BWC Kernel v15 before doing it. Alternatively you can install my UURollup (ENU) where all of them are included together with a few other files from BlackWingCat's kernel.

Edited by tomasz86
0

Share this post


Link to post
Share on other sites

Thanks I'll go through it tomorrow or sometime this week and let you know how it goes.

You've got a lot of good info on your site, the latest UURollup says it requires Update Rollup 1 to be present in the system so I looked and that appears to be this update from page 2 of the thread: Windows2000-UU-KB914783-KB974266-x86-ENU.exe (replaces KB914783-KB943729) posted on Feb 21st so if I go with yours I want to make sure it's right.

0

Share this post


Link to post
Share on other sites

Before I had compatibility problem.

So I made patch from Windows 2000 binary.

Wow :thumbup

Thank you very much for adding the compatiblity with WB's path to your shell32.dll.

As for the psapi.dll, isn't it possible to use the XP file as it is?

0

Share this post


Link to post
Share on other sites

When I installed the new kernel package v15m, it seems that Safari no longer connects to the internet. My internet connection itself works fine but Safari always comes up with a cannot find server error. It has always worked for me in the past but it will not now. I'm suspecting iphlpapi.dll is the problem but I don't know for sure. I've tested both version 3.2.3 (prefered) and the new version 5 something and neither work. Any ideas?

0

Share this post


Link to post
Share on other sites

I released v15p English / Traditional Chinese /Japanese Version.

I checked Saferi 3.2.3. and It seems to work :)

FlashPlayer 11.2 and EarlyBird 13a2 work on this kernel.

When I installed the new kernel package v15m, it seems that Safari no longer connects to the internet. My internet connection itself works fine but Safari always comes up with a cannot find server error. It has always worked for me in the past but it will not now. I'm suspecting iphlpapi.dll is the problem but I don't know for sure. I've tested both version 3.2.3 (prefered) and the new version 5 something and neither work. Any ideas?

0

Share this post


Link to post
Share on other sites

BlackWingCat,

would it be very difficult to add GetLayeredWindowAttributes to your user32.dll? It's the only API that your user32.dll is lacking compared to the one from WildBill.

0

Share this post


Link to post
Share on other sites

Installed latest v15p but ran into several problems. First was the icons seemed to lack much color when selected, almost as if the display settings were on 256 colors. These are the custom ATI 9.0 drivers so I thought maybe a newer version might fix that but unfortunately the Device Manager would not initialize or open and it was impossible to update any drivers. After uninstalling v15p everything's back to normal. Will probably return to v15j for now, won't have Thunderbird but everything else seems to be fine.

0

Share this post


Link to post
Share on other sites

Thx to report.

I use custom ATI 11.7 dirver but Japanese version has no problem and I can't check it.

But I found English and Taiwan Version advpi32.dll has problem. and fixed on v15p2.

I think that you can open device manager. :)

Installed latest v15p but ran into several problems. First was the icons seemed to lack much color when selected, almost as if the display settings were on 256 colors. These are the custom ATI 9.0 drivers so I thought maybe a newer version might fix that but unfortunately the Device Manager would not initialize or open and it was impossible to update any drivers. After uninstalling v15p everything's back to normal. Will probably return to v15j for now, won't have Thunderbird but everything else seems to be fine.

GetLayeredWindowAttributes requires to expand win32k.sys .

I have heard WilldBill's fix has problem on PAE mode.

If it fix , I'll joint WildBill's kernel library. :)

would it be very difficult to add GetLayeredWindowAttributes to your user32.dll? It's the only API that your user32.dll is lacking compared to the one from WildBill.

0

Share this post


Link to post
Share on other sites

I still can't get Safari to work anymore, but that's okay. I found Google Chrome works perfectly with this new kernel update and had almost no problems installing it. So now I'm using it instead of Safari and it seems a lot more stable anyway. However, I want to give a big shout out to blackwingcat. You're simply amazing. You're keeping my favorite OS patched and making it compatible with almost everything new that is released. I have just recently succeeded installing Office 2007 with the new kernel and it works flawlessly. Thank you so much for the time and effort you put into this kernel extension, us Windows 2000 fans truly appreciate your hard work! :D I'm hoping I can get Windows Media Player 11 working well as I love the library layout much more than WMP10. I'm sure I can get it functional. Also, is there a way to get the sidebar from Windows 7 working? I've copied all the files from it and have it stored on my external hard drive. It seems it needs advapi32.dll to have EventUnregister, is there way to add that in?

Edited by SearanoX
0

Share this post


Link to post
Share on other sites

WMP11 works on extended kernel with a little changing.

But its network component requires HTTPFilter Service.

Windows 2000 doesn't have it.

So WMP11 can't access any network music contents. :wacko:

I'm hoping I can get Windows Media Player 11 working well as I love the library layout much more than WMP10. I'm sure I can get it functional.

Edited by blackwingcat
0

Share this post


Link to post
Share on other sites

That's strange, but it makes sense. I did get it installed and it runs, but the library is a bit messed up. It's not the end of the world now though. What are your future plans for the Kernel project?

0

Share this post


Link to post
Share on other sites

Current Future Plans.

* Resolving "The system administrator has set policies to prevent this installation" (advapi32 fix)

* Improvement More compatibility with WildBill Kernel (user32 fix)

* Equip function ShellItrems (shell32 fix)

* Add GetLogicalProcessorInformation (kernel32 fix)

What are your future plans for the Kernel project?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.