Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

KernelEx for Win2000

- - - - -

  • Please log in to reply
610 replies to this topic

#601
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 829 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag

Does anyone have Windows2000-KB905198-x86-ENU ?
It is "Windows 2000 Service Pack 4 COM + 1.0 Rollup Package 38".

Inner version is 2000.2.3542.0


Edited by blackwingcat, 20 April 2015 - 07:01 PM.

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+


How to remove advertisement from MSFN

#602
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 829 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag

Is there any permision problem ? (for example registry)

On my extended kernel environment

http://t.co/VpNSOufCRd

 

@Blackwingcat

Is it possible that kernel 2.4f breaks windows update? First everything seemed to work fine (last post), but now I have problems with windows update. Executing wupdmgr.exe should start IE with windows update, but now nothing happens without showing any error. When I start windows update within ie6, it works, let me choose express or custom, but then hangs on scanning the devices, also without error. In windows update log, no error, it finds 4 updates. IE itself seems to be OK. Any ideas?

Edit: it seems to be a problem with the permissions, because now - not only wupmgr shows no reaction, also when I want to send / receive emails with Outlook 2003, I get message that I donĀ“t have permission to do this (I have administrator privileges on that system). So something I must have missed when copying exkernel xp files on my system. Perhaps some new policies must be applied?

Greetings Joe


+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#603
LoneCrusader

LoneCrusader

    Resistere pro causa resistentiam.

  • MSFN Sponsor
  • 846 posts
  • Joined 11-May 09
  • OS:98SE
  • Country: Country Flag

Donator

Does anyone have Windows2000-KB905198-x86-ENU ?
It is "Windows 2000 Service Pack 4 COM + 1.0 Rollup Package 38".

Inner version is 2000.2.3542.0

 

Is this what you need?



#604
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 829 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag

 

Does anyone have Windows2000-KB905198-x86-ENU ?
It is "Windows 2000 Service Pack 4 COM + 1.0 Rollup Package 38".

Inner version is 2000.2.3542.0

 

Is this what you need?

 

Thx. When I try to open same page yesterday, It showed there is no support file....

It's very strange. :P


+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#605
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 829 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag

Windows 2000 Extended Kernel English version 2.5b / 2.5bG are available.

PHP 5.6 becomes to work on Windows 2000 Extended Kernel. :)
 


+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#606
LoneCrusader

LoneCrusader

    Resistere pro causa resistentiam.

  • MSFN Sponsor
  • 846 posts
  • Joined 11-May 09
  • OS:98SE
  • Country: Country Flag

Donator

Thx. When I try to open same page yesterday, It showed there is no support file....
It's very strange. :P

Hmm... Microsoft at work I suppose, lol. Anyway you're welcome. :thumbup

#607
JosefReisinger

JosefReisinger

    Newbie

  • Member
  • 42 posts
  • Joined 25-June 14
  • OS:Windows 2000 Professional
  • Country: Country Flag

@blackwingcat:

I could not overcome my policy problems, so I slipstreamed extended kernel v24fG localized DEU and did a clean install. Now I am happy, everything is perfect. Windows Update working, all programs OK. Only warning is Office2003 MOF can not be loaded, but outlook works.

Do you know the file which ressources are responsible for showing "files and folders" in explorer where you can choose to "display files and folders in different colours" or to "show hidden files or folders" ? There I have english / german mismatch. I must have slipstreamed an english update, but I cannot find out which file, because all updates are named "DEU". Also, "administrative tools" are not DEU in control panel.

My second question: I want to localize exkernel 2.5 now, which files are different to 2.4?

Greetings, Joe


Edited by JosefReisinger, 23 April 2015 - 04:33 PM.


#608
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 829 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag

First question.

How about effection does  MOF error ocuur on Office 2003 ? 

And I will research it soon about Admin Tools.

 

Second Question.

You can know from my blog English article.

Do you check my blog?

http://blog.livedoor...es/1899749.html

 

@blackwingcat:

I could not overcome my policy problems, so I slipstreamed extended kernel v24fG localized DEU and did a clean install. Now I am happy, everything is perfect. Windows Update working, all programs OK. Only warning is Office2003 MOF can not be loaded, but outlook works.

Do you know the file which ressources are responsible for showing "files and folders" in explorer where you can choose to "display files and folders in different colours" or to "show hidden files or folders" ? There I have english / german mismatch. I must have slipstreamed an english update, but I cannot find out which file, because all updates are named "DEU". Also, "administrative tools" are not DEU in control panel.

My second question: I want to localize exkernel 2.5 now, which files are different to 2.4?

Greetings, Joe


Edited by blackwingcat, 25 April 2015 - 03:39 AM.

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#609
JosefReisinger

JosefReisinger

    Newbie

  • Member
  • 42 posts
  • Joined 25-June 14
  • OS:Windows 2000 Professional
  • Country: Country Flag

I cannot replicate MOF error on Office 2003, it is gone after applying Office hotfixes, I do not know which one did the trick.

I could overcome ressource problem german - english mismatch in explorer "folder options". These ressources are located in shell32.dll. When I localized exkernel, I only changed string table, but I did not change REGINST ressource (it is in english and normally does not need not be changed, but there are DESC descriptors for registry, which should be changed). After changing these now I had to apply to registry, too; Now everything is german, no mismatch any more.

Exkernel is very stable on my system. I want to test DEU version a little longer, then I will put it on google drive, so everybody can get it, who wants to have DEU version of exkernel.

*I could install java 7 update 79 on exkernel. It seems to work when opening programs which depend on java. In event viewer, I get message "Service Control Manager", ID 7031 "service "Java quick starter" was shut down unexpected, this happened 1 time....."

Can this be ignored?

I tried to install windows defender. I could not find a suitable download with microsoft, so I downloaded cnet. I could bypass "Need XP SP2", then GDI+ Message popped up. I have gdiplus.dll in system32, since I have exkernel, and some older gdiplus files in office and works. But it seems the installer (defender version  1.1.1593.0) is not satisfied with this (perhaps wants to see in wsxs in folder with some nice "x86_Microsoft.Windows.Gdiplus_6595b64144blablabla-x-ww-blabla"). I tried to regsvr32 gdiplus.dll, but it tells me DllRegisterEntryPoint was not found. Perhaps the right base of gdiplus_vista_dll has to be found out in DEU environement.

I could get another defender version 1.1.1593.0 german, but this will install only with w2k and then not work (but not show gdi message), in xp it will not install and message "policy problem". So I did a repair of this version on w2k with the one from cnet, and now I have  everything installed, but message "error on initiating 0x80010534, service was stopped because of problem". When I look into services, Windows defender is set automatic and seems to work, but when I stop the service, message Service control manager ID 7031 "service was stopped unexpected".

Perhaps my windows defender version is not the right one? Where can I download a reliable version for w2k exkernel?

Perhaps it would be easier to get MSE to work on exkernel? On installation it crashes with "epplauncher caused problems and need to be closed".

Greetings Joe


Edited by JosefReisinger, 26 April 2015 - 03:47 PM.


#610
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 829 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hi.

 

I can not know resource how the problem is. can you tell its detail ?

Java Quick Starter is even poison, it should be disabled.

Before I was asked about Windows Defender  Deutsch version problem, but I could not resolve it....  Sorry.

If you want to make  force them to read from system32, you can register well known dlls registry them.

 

 

I cannot replicate MOF error on Office 2003, it is gone after applying Office hotfixes, I do not know which one did the trick.

I could overcome ressource problem german - english mismatch in explorer "folder options". These ressources are located in shell32.dll. When I localized exkernel, I only changed string table, but I did not change REGINST ressource (it is in english and normally does not need not be changed, but there are DESC descriptors for registry, which should be changed). After changing these now I had to apply to registry, too; Now everything is german, no mismatch any more.

Exkernel is very stable on my system. I want to test DEU version a little longer, then I will put it on google drive, so everybody can get it, who wants to have DEU version of exkernel.

*I could install java 7 update 79 on exkernel. It seems to work when opening programs which depend on java. In event viewer, I get message "Service Control Manager", ID 7031 "service "Java quick starter" was shut down unexpected, this happened 1 time....."

Can this be ignored?

I tried to install windows defender. I could not find a suitable download with microsoft, so I downloaded cnet. I could bypass "Need XP SP2", then GDI+ Message popped up. I have gdiplus.dll in system32, since I have exkernel, and some older gdiplus files in office and works. But it seems the installer (defender version  1.1.1593.0) is not satisfied with this (perhaps wants to see in wsxs in folder with some nice "x86_Microsoft.Windows.Gdiplus_6595b64144blablabla-x-ww-blabla"). I tried to regsvr32 gdiplus.dll, but it tells me DllRegisterEntryPoint was not found. Perhaps the right base of gdiplus_vista_dll has to be found out in DEU environement.

I could get another defender version 1.1.1593.0 german, but this will install only with w2k and then not work (but not show gdi message), in xp it will not install and message "policy problem". So I did a repair of this version on w2k with the one from cnet, and now I have  everything installed, but message "error on initiating 0x80010534, service was stopped because of problem". When I look into services, Windows defender is set automatic and seems to work, but when I stop the service, message Service control manager ID 7031 "service was stopped unexpected".

Perhaps my windows defender version is not the right one? Where can I download a reliable version for w2k exkernel?

Perhaps it would be easier to get MSE to work on exkernel? On installation it crashes with "epplauncher caused problems and need to be closed".

Greetings Joe


+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#611
JosefReisinger

JosefReisinger

    Newbie

  • Member
  • 42 posts
  • Joined 25-June 14
  • OS:Windows 2000 Professional
  • Country: Country Flag

I disabled java quick starter and deactivated the service.

Resource: Perhaps you could add to the instruction for localize exkernel:

SHELL32 requires more steps:

Not only stringtable, menu and dialogs, also REGINST resource must be changed, according to local version of original shell32.

 

If I do regsvr32 gdiplus.dll, Message text is: "gdiplus was loaded, but the DllRegisterServer entry point was not found. DllRegisterServer may not be exported, or a corrupt version of gdiplus may be in memory. Consider using PView to detect and remove it". What does this mean?

 

I found out, that windows defender which I could install with the "repair trick will not ask GDI+" has lecacy driver windefend, but also creates a second legacy driver, which is named different in each session, e.g. MpKsl0b6f594b, the correspondig sys file show up in Allusers Directory definitions update [2f87e732-7173-4B5F-8F2C-6735557F0D5D] and is also named different in each session. If this sysfile is not present, driver cannot load and defender service will not work. Problem is that on windows 2000 DEU, windows defender will not create this sysfile. I did not find out, which process is responsible for creating the sysfile. In XP registry, I found more than 70 entries for windows defender, so it seems to be difficult. I tried to manually install the driver with registry, but then it breaks PAE and BSOD "inaccesible boot device". So I will give up. Perhaps I use clamav until I have a better idea.

 

In the next days, I will localize exkernel 2.5 and do further testing with exkernel.

 

Greetings, Joe


Edited by JosefReisinger, Yesterday, 02:56 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users