Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Accessing a Windows 98 network drive from Linux

- - - - -

  • Please log in to reply
12 replies to this topic

#1
Sfor

Sfor

    Senior Member

  • Member
  • PipPipPipPip
  • 582 posts
  • Joined 01-July 07
  • OS:Windows 2000 Professional
  • Country: Country Flag
I've been playing around with a few Linux distributions. Most of them have problems with Polish national characters on Windows 98 network shares. I do not mean mounting network drives here. All I did was exploring the Windows SMB network from the file managers.

I've tested a Slax, Debian and EasyPeasy. The last one is based on the Ubuntu, and the one I made most intensive testings on. To put things short: Polish national characters are recognized fine when accessing a Windows 2000 share. On the other hand Windows 98 shares are treated without proper Polish characters support.

On the other end of this stick is Xandros I got with my Asus EeePC. There were no problems with Polish national characters while accessing any Windows version network share.

So, what is the cause, Linux seems to treat differently Windows 2000 and Windows 98 network drives, when it comes to the national characters support? How to force Ubuntu or EasyPeasy to do the same the Xandros does?

A note: I'm not particulary skilled with Linux ways.

Edited by Sfor, 30 January 2011 - 06:53 AM.



How to remove advertisement from MSFN

#2
Mijzelf

Mijzelf

    Advanced Member

  • Member
  • PipPipPip
  • 462 posts
  • Joined 11-April 07
I think you'll have to study the differences in /etc/samba/smb.conf on the different Linux distros, and then especially 'dos charset' and 'unix charset' settings.

#3
Sfor

Sfor

    Senior Member

  • Member
  • PipPipPipPip
  • 582 posts
  • Joined 01-July 07
  • OS:Windows 2000 Professional
  • Country: Country Flag
I do know the smb.conf is responsible for the Samba and sharing resources. But, in this particular case the problem lies in accessing SMB resources from Linux. Is the Samba and smb.conf responsible for both server and client related network tasks?

Edited by Sfor, 31 January 2011 - 01:51 AM.


#4
Mijzelf

Mijzelf

    Advanced Member

  • Member
  • PipPipPip
  • 462 posts
  • Joined 11-April 07

I do know the smb.conf is responsible for the Samba and sharing resources. But, in this particular case the problem lies in accessing SMB resources from Linux. Is the Samba and smb.conf responsible for both server and client related network tasks?

Sorry, I don' t know. When you mount a samba share, all these settings can be added to the mount command. But I suppose you are browsing the network using Nautilus or something like that, which means that there is no *real* mount. You see a smb:// url in the address bar. I *think* it's a wrapper around smbclient, but I don' t know if there are settings, and where they could be. It could be a global setting of smbclient (which *could* be smb.conf), or a setting of Nautilus.

#5
Sfor

Sfor

    Senior Member

  • Member
  • PipPipPipPip
  • 582 posts
  • Joined 01-July 07
  • OS:Windows 2000 Professional
  • Country: Country Flag
Yes, its the Nautilus, indeed. The Xandros has a different file manager, as far as I remember. I can not check it, since I've replaced Xandros with EasyPeasy.

And yes, I'm accessing the network shares trough the smb:// url.

#6
Sfor

Sfor

    Senior Member

  • Member
  • PipPipPipPip
  • 582 posts
  • Joined 01-July 07
  • OS:Windows 2000 Professional
  • Country: Country Flag
Anyways, I've decided to test the Samba server functions.

I used the Nautilus to add a share. It told me it has to install two packets to make file sharing work. Then two Samba related packets were downloaded, and after a reboot I was able to add a folder share.

This is the part when the first problems came out:

1) When trying to access a newly created share from a Windows computer I had to use IP address. The NetBios names were not available. A patch to smb.conf solved the issue.
[global]
netbios name = xxxxxxx
2) The Windows XP was able to access the share without any problem or password, but Windows 98 kept asking for a password before being able to display server shares. What's more important no password were accepted. It was not possible to get through the password dialog. Fortunately there is a solution available. I had to make a change in the smb.conf, again.

####### Authentication #######
security = share

After that, Windows 98 was able to access the network share without any problems. I sent a few files with the Polish national character in their names and everything worked correctly.

So, the conclusion is Nautilus uses some different settings. Samba network shares do not have any problems with national character, while the Nautilus can not read them correctly through smb://.

--------------------------------------------------

I did some research. Nautilus is using libgnomevfs2-extra to work with many different virtual file systems. The next software layer i libsmbclient (a part of Samba suite).

Edited by Sfor, 02 February 2011 - 06:15 AM.


#7
Mijzelf

Mijzelf

    Advanced Member

  • Member
  • PipPipPip
  • 462 posts
  • Joined 11-April 07
I suppose you saw this in the manpages:

When libsmbclient is invoked by an application it searches for a directory called .smb in the $HOME directory that is specified in the users shell environment. It then searches for a file called smb.conf which, if present, will fully over-ride the system /etc/samba/smb.conf file. If instead libsmbclient finds a file called ~/.smb/smb.conf.append, it will read the system /etc/samba/smb.conf and then append the contents of the ~/.smb/smb.conf.append to it.



#8
Sfor

Sfor

    Senior Member

  • Member
  • PipPipPipPip
  • 582 posts
  • Joined 01-July 07
  • OS:Windows 2000 Professional
  • Country: Country Flag
I tried to access the SMB:// from Firefox, with the same effect. So, the conclusion is, the problem is related to libsmbclient, somehow.

- I found no .smb folder on the HDD.
- There are three smb.conf files
1) /etc/samba/
2) /usr/share/samba/
3) in some documentation and example related folder
- I replaced the two significant smb.conf files with the one from Xandros with no apparent effect.

I'm out of ideas. Perhaps the libsmbclient have a bug of some sort.

#9
Sfor

Sfor

    Senior Member

  • Member
  • PipPipPipPip
  • 582 posts
  • Joined 01-July 07
  • OS:Windows 2000 Professional
  • Country: Country Flag

dos charset = 852
display charset = UTF8
unix charset = UTF8


These three lines in smb.conf solved problem.

#10
Sfor

Sfor

    Senior Member

  • Member
  • PipPipPipPip
  • 582 posts
  • Joined 01-July 07
  • OS:Windows 2000 Professional
  • Country: Country Flag
I have yet another problem with accessing files from Linux. This time I can not get the polish national characters in file names working correctly in Backup PC. This software uses smbclient, as far as I know. I have little experience with this scripting tool, I'm afraid. Anyways, the SMB access from Nautilus works perfectly. The only problem is Backup PC.

I was able to get the national characters working correctly in the administative pannel in Backup PC by upgrading Ubuntu to 11.04. I was able to install a newer version of Backup PC, because of that. Older versions had a problem with processing national characters. Still I do not know, if the current problem is related to the Backup PC processing, or the SmbClient parameters, or something else.

#11
Sfor

Sfor

    Senior Member

  • Member
  • PipPipPipPip
  • 582 posts
  • Joined 01-July 07
  • OS:Windows 2000 Professional
  • Country: Country Flag
Well, the BackupPC does use the Samba settings, while working with SMB shares. So, BackupPC national character settings are ignored, in such a case. All I had to do was to set a correct national character translation in the samba.conf. The BackupPC expects Samba to convert national characters to UTF8.

But, I've encountered yet another problem. Apparently, I can not access password protected Windows 98 network shares with Samba. Everything works fine, if no password is necesary.

#12
Mijzelf

Mijzelf

    Advanced Member

  • Member
  • PipPipPip
  • 462 posts
  • Joined 11-April 07
Still using a wrapper around smbclient I suppose? Have you tried the bare smbclient?
smbclient //server/share password
should work in this case. As far as I know a different authentication will be used when using
smbclient //server/share -U username%password
and I wouldn't be surprised if tha latter is the default of the wrapper. (Shares with only a password are rare these days.)

#13
Sfor

Sfor

    Senior Member

  • Member
  • PipPipPipPip
  • 582 posts
  • Joined 01-July 07
  • OS:Windows 2000 Professional
  • Country: Country Flag
The smbclient does not work, as well. But, it provides some information about source of the problem. Here is the message:

Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled.


------------------------------------------------
Addition of a following line to smb.conf solved the problem:
client lanman auth = yes

Edited by Sfor, 13 July 2011 - 05:29 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users