Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

WinNTSetup v3.6.1


  • Please log in to reply
960 replies to this topic

#576
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

ask a question: which tools to use to unpack or repack WinNTSetup2

 

7zip is the easiest solution. In the misc folder of my Skydrive there is an repack example using 7zr.exe




How to remove advertisement from MSFN

#577
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

First Work In Process version of WinNTSetup3 is now available!

 

It was not tested on so many sources as v2, but should work good enough.

Please report any Bugs you find.

 

http://sdrv.ms/13YWwCY



#578
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 184 posts
  • OS:none specified
  • Country: Country Flag

Thanks JFX, I was already looking forward to this one... It surprised me somewhat that the program looks the same as the 2.x branch, but hey, if it ain't broke...

I'm looking forward to testing it next weekend! So this one's programmed in a different language? Are there any other new things in the new version?

Thanks!!

EDIT: Found your announcement from march 30:

  

Following improvements are planned.

- command line will be more logical
- better language file support
- VHDX support is still missing

I might also include some tools, I use in very often in WinPE

- offline product key finder
- offline admin password reset
- gui wrapper for BCDEdit 


Edited by Atari800XL, 29 August 2013 - 01:56 PM.


#579
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Hi Atari800XL, yes this one is complete rewritten in a different language.

 

So far not to much changes since v2.

 

- VHDX is fully supported (but no instant creation of fixed ones, yet)

- language file is now a resource dll with much better loading speed as a simple text file.

- command line now have options and switches, well not much changed but more parameters are planed

 

- Windows Product key finder and password reset are integrated



#580
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 184 posts
  • OS:none specified
  • Country: Country Flag

Thanks, I will test the new version with XP, W7, W8. Nice to see the commandline is still supported and, in fact, enhanced. As there is no new howto's as far as I can see, I assume the commandline in the testversion is the same as the last version in the 2.x branch.

[Sorry, didn't see/read the helpfile, didn't think it was available yet, as pressing F1 didn't bring it up. Turns out it *is* available from the sysmenu]

EDIT1: First quick test: Boot Win8PESE, tccle prompt:

WinNTSetup_x86.exe nt6 -source:y:\OS\w7.wim (OK, source detected)

WinNTSetup_x86.exe nt5 -source:d: (Source not detected). When I select drive D: in the gui, everything's fine. Also tested with -source:d:\ -source:"d:" (d: is a mounted xp iso).


Edited by Atari800XL, 30 August 2013 - 06:30 AM.


#581
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Seems I forgot F1 hot key for the Help page.

Your command line example actually works, it just forgets to update the description label.



#582
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 184 posts
  • OS:none specified
  • Country: Country Flag

OK, so both points were valid? Thanks, I will test further...

 

EDIT1: Did a successful test with the new V3WIP version to install a W8 version that has been around as long as V3WIP. Works fine!

EDIT2: Could it be that the commandline option "-reboot" doesn't "take" in the gui? (ie: the option is not ticked).


Edited by Atari800XL, 30 August 2013 - 12:00 PM.


#583
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Yes, your right some command line options are not take in the check boxes and therefor maybe don't work.

 

Your the number one bug hunter again  :thumbup



#584
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 184 posts
  • OS:none specified
  • Country: Country Flag

Well JFX, sometimes I can't believe that not "everybody" uses WinNTSetup...

These are just things I run into when using your fine tool...

More hunting:

(1) My unattended file is not (fully?) used, even though it's specified in the commandline (and also ticked and selected in the GUI). I'm sure you're aware of this? If not, let me know, I'll give more details (tested: The new W8WIP version, first with new WinNTSetup 3, then with old WinNTSetup 2.6.x. First setup was not unattended, second *was*).

(2) BootToDesktop was not executed for W8WIP. Same story: 2.6.x: OK 3WIP: Not OK.

...although I must add that W8WIP setup using 2.6.x version stalled right at the end of setup [needed an extra reboot]. Not sure exactly what's going on there, but this might not be WinNTSetup-related. Needs even more testing (has the unattend.xml syntax changed? etc).

 

Still, (1) and (2) above do seem to differ between 2.6 and 3. I'll await your response, we'll see after that.

Please let me know when/ if a new WIP version becomes available!

And thanks again for your programs!


Edited by Atari800XL, 30 August 2013 - 01:02 PM.


#585
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Ok next version is ready.

 

WIP 08/31/2013

 

- change winhttp linking to dynamic
- removed winmm.dll dependency
- fixed F1 and Escape hotkey not working
- fixed cmdline source not updating description text
- fixed cmdline reboot, addotheros, nobootsect doesn't click respected checkbox
- fixed unattend file not copy if \Windows\Panther folder is missing
- fixed BootToDesktop was not integrated

 

http://sdrv.ms/13YWwCY


Edited by JFX, 31 August 2013 - 01:47 AM.


#586
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 184 posts
  • OS:none specified
  • Country: Country Flag

Nice!

- You say "BootToDesktop" was not integrated, but I believe that one *did* work. Not important, now it works with double power.

 

(1) Can you please make the "setup" button the default button again like in the 2.x version? This way, when I start with commandline options (and nothing has to be changed) I only need to hit "Enter" (VERY convenient! eg. when run from a hotkey). On the other hand, if I want to do some minor adjustments (say, a different wim, or a different unattend file for audit mode, etc), I only need to change a few thing here and there. This is what's so great about WinNTSetup!!

 

(2) In the latest version, in the last screen (just before apply), the bootsector dropdown now defaults to "Do not update the bootcode". Is this by design? I would like it to default to one of the other options (not sure which was default before, bootsect.exe or bootice). I believe this changed in this latest version.

 

Hope you don't mind the continuous testing, it's just a very nice task for my spare nc6320 sitting quietly in the corner...



#587
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

BootToDesktop might have been set somewhere else but not by WinNTSetup.

 

1) added the return hotkey for setup button

2) yes new bug and fixed again

 

 

WIP 08/31/2013 Rev 1 uploaded!



#588
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 184 posts
  • OS:none specified
  • Country: Country Flag

Thanks JFX, looks like W8/W8.1Preview/W8.1WIP is sorted now, at least as far as I can see. Congratulations! I think the bits are now pretty much "burnt-in" to the partition (you know, like an old CRT) after a bunch of test-setups.

 

So that's partition 2 covered. Leaves p1 for Windows 7 and p3 for XP. I'm testing XP first. Uh-oh, doesn't work. After the first reboot I get "not enough memory for iastor.sys". So I'm on to figuring out what's going on there. I rebooted in Win8PESE and copied all files from C: to a folder on another drive in a folder called "new" (for comparison). Then I formatted C: and started the *old* WinNTSetup with the same source. Right before reboot I copied everything to another drive in a folder called "old". Those two folders look quite different! I'll let you know the details later, but right now XP is installing with the "old" files on C:, just to make sure it installs OK! (which it does...)

 

I'm not trying to take up all your time, just telling you how my test is going. Please take your time! If you already have an idea about what's going on, I'd love to hear it, otherwise I'll come back here later and pass along some more details about the differences in dir structures between "old" and "new". Seems like one has the driverfiles extracted while the other has them compressed. This might have something to do with it, but first I'll await the successful "old" XP install (to rule out errors in my XP source).

 

EDIT1: OK, old setup went OK (as expected). Now back to new WinNTSetup again.

Some details:

(1)I launch it with commandline options, had to change

-drivers:"L:" back to

-drivers:L:

(this was discussed before in this thread)

(2) I see a yellow exclamation mark on "NTLDR PBR" which I never saw before. Not sure what that's about (never have trouble with booting, I use Grub4Dos after OS install, so I can boot from 3 primary partitions).

OK, that's it for now, on to more checking and testing...


Edited by Atari800XL, 31 August 2013 - 09:36 AM.


#589
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

I changed the driver integration and bootfolder stuff a bit and it worked with my notebook.
I'll change it back to the old version.

 

(1) -drivers:"L:" and -drivers:L: are the same, the quotes get's stripped in the very beginnig.

The problem I remember was L:\ is a valid windows path, but dism wants L: (which is actully wrong)

 

(2) yellow exclamation replaces the red cross for MBR and PBR now.

 

like a traffic light:

- green means drive
- yellow is just a warning but means drive
- red means stop



#590
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 184 posts
  • OS:none specified
  • Country: Country Flag

Thanks. The quotes did cause some problem somewhere, but that's not important. Thanks for the explanation, I will use L: from now on without the quotes.

Please take your time for the next update, enjoy your weekend. (For me it's actually kind of fun to "play around" with this!).

I will take this time to test W7, I don't expect any problems there.

One question that was still on my mind:

For W7/W8 I use -runafter:CopySetupScripts.exe (which is a silent WinRAR SFX) which I find very convenient (easy to maintain etc). I notice that "runafter" is launched from a cmd prompt (is that correct?) so a console window is briefly visible. Is it possible you could make some kind of "RunAfter" that doesn't show a window? No hurry, and also not superimportant, I was just wondering!

Thanks!



#591
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Don't worry I enjoy my weekend. Next version will have to wait a few days.

For RunAfter I'm wonder too, should have been hidden (maybe forgot it while debugging).



#592
amitri

amitri

    Junior

  • Member
  • Pip
  • 57 posts

Hi JFX

 

just tried latest v3 rev1 with latest leaked 8.1 RTM iso and gives me "BFSVC error: 0X1F" in GUI at Updating boot code (Failed to create Bootfiles).

v2 works OK with the same configuration.

 

Thanks in advance

 



#593
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Hi amitri,

 

don't tell me you still use WinXP!?

 

XP support will be re-added, but you should upgrade to Windows 7, if you want full functionality.



#594
click-click

click-click

    Member

  • Member
  • PipPip
  • 104 posts

Please keep XP in there - at least until it goes out of support in April. I still use WinNTSetup  to build a new XP every patch-tuesday. For those of us that have multi-boot systems, it would be nice if the XP code were left in there.

 

On another note, I recently did a new Win8 install and thought I would try the Boot to Desktop Option. I was a bit disappointed because after booting, the desktop only showed up briefly before the metro start screen took over again. Is there any way to make it stay with the desktop?


Edited by click-click, 01 September 2013 - 05:53 AM.


#595
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 184 posts
  • OS:none specified
  • Country: Country Flag

- click-click, you're aware that BootToDesktop is for Windows 8.1 only, right?

- I agree with you on XP, please keep it around. I need it on several PC's that control weighing systems, etc. My tiny usb stick with Win8PESE, several OS install iso's and WinNTSetup are perfect for installing any OS anywhere/ anytime. XP will live on for years and years on similar systems, never mind the support. People seem to forget that some of these systems are offline, so even on XPSP3 without any further updates, they run perfectly fine. But of course, reinstalls always will occur due to hardware/ user failure, etc.


Edited by Atari800XL, 01 September 2013 - 06:32 AM.


#596
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

I didn't mean support for installing WinXP.

 

The problem is running (winnt)setup from inside XP to install latest windows version.
I can fix the BCDBoot.exe incompatibility like I did in v2.

 

However driver integration is another story.
You can't integrate driver to Win 8.1, if you run from Vista or earlier.



#597
amitri

amitri

    Junior

  • Member
  • Pip
  • 57 posts

Hi amitri,

don't tell me you still use WinXP!?

XP support will be re-added, but you should upgrade to Windows 7, if you want full functionality.

True, I was using some unofficial tiny "Mini XP" just to boot and run WiNTsetup - faster than any of my WinPE versions and good for older PCs.



#598
click-click

click-click

    Member

  • Member
  • PipPip
  • 104 posts

- click-click, you're aware that BootToDesktop is for Windows 8.1 only, right?

Now that you mention it, yes 8.1 lets you do this via settings. I assumed this was a reg tweak that applied to 8 also.



#599
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 184 posts
  • OS:none specified
  • Country: Country Flag

 

- click-click, you're aware that BootToDesktop is for Windows 8.1 only, right?

Now that you mention it, yes 8.1 lets you do this via settings. I assumed this was a reg tweak that applied to 8 also.

 

If it was in 8.0 already, there would have been no reason to release 8.1 :}



#600
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 446 posts
  • OS:Windows 7 x64
  • Country: Country Flag

WinNTSetup v3 (WIP 03/09/2013)

 

- changed XP boot folder creation back to v2 version
- fixed BCDBoot XP compatibility
- fixed buffer overflow in Product key decoding

 

http://sdrv.ms/13YWwCY






2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users



How to remove advertisement from MSFN