Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

WinNTSetup v3.7.2 / 3.7.5 Beta 1


  • Please log in to reply
1045 replies to this topic

#276
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag
hmm, there should be success or failed message for every *.inf file found in L:\ and it's subfolders.

like this:

Integrate Drivers using DISM from: L:\drv_test

1.inf: The driver package was successfully installed.
2.inf: Error - An error occurred. The driver package could not be installed.



EDIT: Okay there is a bug, the trailing \ cause the trouble

Edited by JFX, 23 September 2012 - 02:22 PM.



How to remove advertisement from MSFN

#277
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 201 posts
  • Joined 10-March 12
  • OS:none specified
  • Country: Country Flag
Part of the log (note the *two* empty lines)

Start applying WIM
	Applying WIM finished successfully
	Applying took: 03:43

Integrate Drivers using DISM from: L:\


using user defined unattend.xml: q:\winntsetup\autounattend_w8.xml

loading offline registry: C:\Windows\System32\config
It's a Windows 7 driver, don't know if that's of any influence. But as I said, it works perfectly as a "manual" install.

Weird...?

[EDIT: Okay, I read *your* edit about the trailing backslash]

Edited by Atari800XL, 23 September 2012 - 02:32 PM.


#278
Scampy82

Scampy82

    Newbie

  • Member
  • 19 posts
  • Joined 16-August 12
  • OS:Windows 7 x64
  • Country: Country Flag
*From translator*
How cancel installation process? For example I chose not that edition Win7... If that is impossible, it is possible to add the button "Cancel"

#279
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag
Hi Scampy82,

currently it's not possible, but I add a Cancel Button in the next version.

Posted Image

Edited by JFX, 09 March 2013 - 10:20 AM.


#280
adef

adef
  • Member
  • 3 posts
  • Joined 26-September 12
  • OS:none specified
  • Country: Country Flag
error occurs when creat VHD,win8 enterprise x64.

#281
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag

error occurs when creat VHD,win8 enterprise x64.

That's too much informations. ;)

The VHD creation is just a wrapper for windows' diskpart.exe.
Anyway there should be some error printed in the black window.
Also WinNTSetup should give back the error code and it's description.

#282
adef

adef
  • Member
  • 3 posts
  • Joined 26-September 12
  • OS:none specified
  • Country: Country Flag


error occurs when creat VHD,win8 enterprise x64.

That's too much informations. ;)

The VHD creation is just a wrapper for windows' diskpart.exe.
Anyway there should be some error printed in the black window.
Also WinNTSetup should give back the error code and it's description.

Sorry,my OS is win8 enterprise x64 Chinese (Simplified).
when creat VHD ,this error pop-up.
Attached File  2.png   18.43KB   20 downloads
If I switch display language to english(I install english language pack just now for creating a bug report in english :D ), But creat VHD ok,no error. :o
so,the bug report is still in chinese. :wub:

Edited by adef, 26 September 2012 - 07:40 AM.


#283
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag
Thanks,

it seem this only occurs with some unicode languages. It's properly a bug in the text formating.

I'll download the 90 days win8 ZH-CN trail version and take a look at it.

Posted Image

Edited by JFX, 09 March 2013 - 10:20 AM.


#284
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag
hmm, strange either Chinese ANSI and OEM codepage can have different amount of characters or Stringlen() eats some :blink:

Please try v 2.3.0.2

Posted Image

Edited by JFX, 09 March 2013 - 10:20 AM.


#285
adef

adef
  • Member
  • 3 posts
  • Joined 26-September 12
  • OS:none specified
  • Country: Country Flag

hmm, strange either Chinese ANSI and OEM codepage can have different amount of characters or Stringlen() eats some :blink:

Please try v 2.3.0.2

Posted Image

2.3.0.2 works ok,thank you man :thumbup

#286
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 201 posts
  • Joined 10-March 12
  • OS:none specified
  • Country: Country Flag
Was the "driver-trailing-backslash" also fixed in 2.3.0.2? (No hurry.....)

#287
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag

Was the "driver-trailing-backslash" also fixed in 2.3.0.2? (No hurry.....)

Yes, forgot to mention that :)

#288
Scampy82

Scampy82

    Newbie

  • Member
  • 19 posts
  • Joined 16-August 12
  • OS:Windows 7 x64
  • Country: Country Flag
Hi, JFX!
Whether the program correctly works in WinPE? If yes that why isn't created the file bootmgr? I can incorrectly that that I do? :blink:
Thanks

#289
Smokie BlahBlah

Smokie BlahBlah
  • Member
  • 2 posts
  • Joined 07-February 10
When installed SATA disk with active partition (first boot priority in bios) & ide disk with active partition WinNTSetup defaultly detects IDE active partition as a boot drive. Not issue, but it will be ideally if it detect boot drive right

sorry, i'm russian

Edited by Smokie BlahBlah, 02 October 2012 - 01:55 AM.


#290
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag

Whether the program correctly works in WinPE?

Yes, it is designed to work under WinPE.

If yes that why isn't created the file bootmgr?

No idea yet, at least an error message should be displayed, if there is any problem with bootmgr or Boot\*.* files creation.

I can incorrectly that that I do? :blink:

actually not, bootmgr should be created on the partition you selected.




When installed SATA disk with active partition (first boot priority in bios) & ide disk with active partition WinNTSetup defaultly detects IDE active partition as a boot drive. Not issue, but it will be ideally if it detect boot drive right

It's difficult to say, which disk is the "wanted" boot disk as the program is mostly use from WinPE or Portable Windows.
Also as you noticed Windows detects different between IDE, SATA, USB, ...

I'll try to improve it.

Posted Image

Edited by JFX, 09 March 2013 - 10:21 AM.


#291
Scampy82

Scampy82

    Newbie

  • Member
  • 19 posts
  • Joined 16-August 12
  • OS:Windows 7 x64
  • Country: Country Flag
Hi JFX!
I don't have a mistake that bootmgr and Boot\*.* aren't created, and from all the same isn't present. May be you to try to make of my assembly of WinPE? *.wim image = 30Mb
Thanks

#292
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag

May be you to try to make of my assembly of WinPE? *.wim image = 30Mb

Yes, that could help. Please sent me details via PM.

#293
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag
Hi Scampy82,

I found it! Your WinPE is missing ntmarta.dll in \Windows\system32 folder

Also your WinPE don't show hidden and supper hidden files.

Posted Image

Edited by JFX, 09 March 2013 - 10:21 AM.


#294
Scampy82

Scampy82

    Newbie

  • Member
  • 19 posts
  • Joined 16-August 12
  • OS:Windows 7 x64
  • Country: Country Flag
Hi, JFX!
:w00t: :w00t: :w00t: very big thanks for you!!! Everything works! The reason means was in only missing ntmarta.dll???
And for what there are so much folders (cs-CZ, da-DK........) in \Boot\
I think that it is connected with languages but I do not understand for what them so much if Windows7 Russian or English or any other.

#295
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag

The reason means was in only missing ntmarta.dll???

Yes only this missing file was cause all trouble :)

And for what there are so much folders (cs-CZ, da-DK........) in \Boot\
I think that it is connected with languages but I do not understand for what them so much if Windows7 Russian or English or any other.

I wonder about that, too.
Well, only Microsoft knows the reason

Posted Image

Edited by JFX, 09 March 2013 - 10:21 AM.


#296
Scampy82

Scampy82

    Newbie

  • Member
  • 19 posts
  • Joined 16-August 12
  • OS:Windows 7 x64
  • Country: Country Flag
Once again thanks for the help :thumbup

#297
Scampy82

Scampy82

    Newbie

  • Member
  • 19 posts
  • Joined 16-August 12
  • OS:Windows 7 x64
  • Country: Country Flag
Hi JFX!
When there is a new version with the button "Cancel"? :rolleyes:

#298
JFX

JFX

    Advanced Member

  • Member
  • PipPipPip
  • 480 posts
  • Joined 17-January 11
  • OS:Windows 7 x64
  • Country: Country Flag
Update: Version 2.3.1.0

- added "Cancel Button" :rolleyes:
- XP Setup now faster, due to new file copy engine
- added tweak to avoid silly Windows 8 first logon animation
- fixed vhd creation (crash on Chinese Windows 8)
- fixed driver integration with trailing back slash
- slightly adjusted active primary detecting

Posted Image

Edited by JFX, 09 March 2013 - 10:21 AM.


#299
Scampy82

Scampy82

    Newbie

  • Member
  • 19 posts
  • Joined 16-August 12
  • OS:Windows 7 x64
  • Country: Country Flag
:thumbup :w00t:

#300
Atari800XL

Atari800XL

    Member

  • Member
  • PipPip
  • 201 posts
  • Joined 10-March 12
  • OS:none specified
  • Country: Country Flag
Thanks JFX!!! Nice going on the Windows 8 animation tweak :sneaky:

Could you please elaborate a little on the new XP file copy engine? Is it really much faster? I'm already looking forward to more testing!! :yes:




5 user(s) are reading this topic

1 members, 4 guests, 0 anonymous users


    josywong