• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
JFX

WinNTSetup v3.8.6 / 3.8.7 Beta 3

1,519 posts in this topic

Well, there is -DisableSystemRestore but as already told we can't have cmdline options for everything so get familiar with the ini file ;)

You are right :yes: it is time to transfer on ini files :rolleyes:

0

Share this post


Link to post
Share on other sites

JFX

Could you please make available for me the v2.3.4.0 language.ini in order to update Spanish translation.

Thanks in advance

0

Share this post


Link to post
Share on other sites

Oh, I forgot to update it. Here is the latest language.zip

I put that link to 1 page, but so far I don't expect any language changes for version 2.x anymore.

0

Share this post


Link to post
Share on other sites

Thanks JFX! WinNTSetup drivers zip archives can process and integrate or just the drivers are unpacked, the *. Inf files???

Edited by xcv150
0

Share this post


Link to post
Share on other sites

Thanks JFX! WinNTSetup drivers zip archives can process and integrate or just the drivers are unpacked, the *. Inf files???

No Zip file!

Only unpacked folder than contains the *inf files.

0

Share this post


Link to post
Share on other sites

JFX

Thanks for the language.ini, the updated Spanish translation is at:

My link

Best regards

Edited by alacran
0

Share this post


Link to post
Share on other sites

Thanks alacran

Spanish translation added to first topic :)

0

Share this post


Link to post
Share on other sites

Seems WinNTSetup got very popular and my dropbox sharing is now gone.

Have added SD mirror, hope this works for everyone.

Also we now have Chinese translation by cy06 :thumbup

0

Share this post


Link to post
Share on other sites

Hi JFX, thanks your great job

there is question as follow:

After installing WIN7 by WinNTSetup2.3.4(choose the default parameters when installing), why the signal of system drive is D acquiescently but not C?

I have to choose the option parameters of "Mount Installation drive" as C when installing WIN7, the drive C signifies exactly right.

I wish that drive C is still C if I choose the default parameters when installing !

0

Share this post


Link to post
Share on other sites

Hi martin,

many people wonder about that, but it's correct behavior of WinNTSetup.

Microsoft has create Vista and Windows 7 images with default system letter D:.

WinNTSetup is not only used as a setup tool, but also as an generic WIM Image applier.

Therefor it's not always wanted to change the letter.

0

Share this post


Link to post
Share on other sites

Thanks for 4Li, we now have Korean translation :thumbup

0

Share this post


Link to post
Share on other sites

Seems I won't get enought time to finished version 3 in a foreseeable time, so here comes a new minor update:

Version 2.3.5.0

- small fixed and code improvments

- ADK files are now required

WinNTSetup will of course help you downloading these files automaticly.

With latest ADK files it should be possible to support legacy system like Windows XP for a longer time.

cheers.gif

0

Share this post


Link to post
Share on other sites

Thanks for the new version. I still use WinNTSetup almost every day.

As an example: Today somebody gave me an Acer TravelMate 4150 (from 2004-2005) with a busted DVDRW. "I guess it's a total write-off, right?" he told me . I booted from USB (Win8PESE) (he never saw OS setup from USB before...), installed XP, W7 and W8 (all updated versions, from same USB), after two hours he had XP (which he needs for his scanner), W7 (for daily use with Office 2010), and W8 (for testing) all on 1 PC. Never saw a bigger smile!!! ("Hey, this one now boots quicker than my 2009 desktop PC!)

I'd like to pass that smile on to you, JFX!!!!!

:thumbup

(What are you planning for version 3? Could it really get better still?)

Edited by Atari800XL
0

Share this post


Link to post
Share on other sites

Hmm, not so sure about new features, Version 3 will be a complete rewrite in a more suited language.

Following improvements are planned.

- command line will be more logical

- better language file support

- VHDX support is still missing

I might also include some tools, I use in very often in WinPE

- offline product key finder

- offline admin password reset

- gui wrapper for BCDEdit

maybe an offline regedit could be added to.

0

Share this post


Link to post
Share on other sites

When you say Offline regedit do you mean being able to add/modify reg entries from an offline wim? That would be nice.

0

Share this post


Link to post
Share on other sites

When you say Offline regedit do you mean being able to add/modify reg entries from an offline wim? That would be nice.

No, only from an already applied wim file or other offline windows.

0

Share this post


Link to post
Share on other sites

I just ran the latest WinNTSetup from XP for a Win7 system build and the system to start the install on will not boot. I used 'use bootsect.exe to update the boot code' with no other boxes checked on that menu. It looks like the win7 boot files were not copied to that partition. How can I fix this?

Edited by click-click
0

Share this post


Link to post
Share on other sites

I managed to fix this from XP by running bcdboot w:\windows /s w: which copied the required W7 files. Isn't WnNTSetup supposed to do this for me?

I noticed with the new WinNTSetup, you included a Tools directory. Could it be that WinNTSetup is not finding the tools?

Edited by click-click
0

Share this post


Link to post
Share on other sites

I noticed with the new WinNTSetup, you included a Tools directory. Could it be that WinNTSetup is not finding the tools?

That, properly the problem.

I used all paths for tools folder correct, but for forgot the the bcdboot patcher search in all places expect the tools folder :ph34r:

Update v.2.3.5.1 is online

0

Share this post


Link to post
Share on other sites

Fyi ... the tools directory included with the new 2.3.5.1 is empty. :huh:

Nevermind, I forgot that the files get downloaded when you run the exe the first time. Sorry for

the false alarm.

Edited by click-click
0

Share this post


Link to post
Share on other sites

/configfile will only accept a full path and will not look in the current directory is that correct?

I tried C:\Toolbx\WinNTSetup\WinNTSetup2_x86.exe /configfile:W8_WinNTSetup.ini which is in the same dir as the exe and this does not work.

Edited by click-click
0

Share this post


Link to post
Share on other sites

Should be fixed now ;)

0

Share this post


Link to post
Share on other sites

JFX, I was trying out the new 2.3.5 version, and noticed the strange message box right before "Integrating drivers". I then tried 2.3.5.1, no change.

Any ideas what this could be? If I click OK, everything proceeds normally, and the setup seems to be OK. I used a new .wim file, but don't think that's it. Still, I will do more testing, first with an older .wim file, then with an older WinNTSetup version. But if you have any ideas in the meantime, please share...

[EDIT: Attachment removed, not needed anymore, it was just an empty dialog box]

Edited by Atari800XL
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.