JFX

WinNTSetup v3.8.6 / 3.8.7 Beta 4

1,540 posts in this topic

Could you please elaborate a little on the new XP file copy engine? Is it really much faster? I'm already looking forward to more testing!! :yes:

Well, the old copy used SHFileOperation, practically windows default for every file copy.

Somehow it's kinda slow, especially for copying many files.

Also it did not give me any infos for the progress bar, therefor unnecessary disk access was needed.

So i had to write my own tool, that just populate a LinkedList with all files/folders and than starts coping.

With fully cached files the copying is twice as fast for many files and in default (uncached) case it still should be noticeable faster.

@cy06

You'r welcome :)

cheers.gif

Edited by JFX
0

Share this post


Link to post
Share on other sites

I tested the new XP "file copy engine" on my old HP nc6320 (5400rpm HD, so extra speed is welcomed!):

"Old version": File copy takes 108s (16s for driver copy etc), so XP source file copy: 92s

New version: XP source file copy: 63s!!

That's a 29 second improvement, or 30+ % !!!!!

Very nice, never expected that you could squeeze a little more performance out of it. Great that you don't forget about XP just yet!

:thumbup

0

Share this post


Link to post
Share on other sites

JFX

Great Tool, it works flawlessly installing Windows 7 or 8 to HDD, after trying that, I went to tray install 8 Pro to VHD, during creation of VHD, I renamed the default Windows7.vhd to Win8.vhd, after creation, just curious went to verify in disk management the mounted Z, it's tag was Win7 VHD (Z:), then I decided to stop the procedure and report it to you, when unmounting the VHD it said in the little box "C:\Win8.vhd", any way I unmount it.

P.D. Thinking a bit more about this, It seams to me "Win7 VHD" is partition tag and then no matter, maybe if you use only "Win VHD" for tag then you cover any version.

Windows 8 Pro installed without any trouble to VHD, just chaged partition tag to Win 8 VHD, It runs just like in HDD.

Thanks for this great tool.

Edited by alacran
0

Share this post


Link to post
Share on other sites

Hi alacran,

Win7 VHD is just the drive label and can be changed without problem whenever the VHD is mounted.

But your right is a bit confusing now with Windows 8.

Guess the best is if I change the label to the user selected filename

cheers.gif

Edited by JFX
0

Share this post


Link to post
Share on other sites

Hi JFX

Is there a way to translate your great tool to other languages? in order to make it available to other people that don't speak English, If you are agree I can translate it to Spanish (my mother tongue), I have done it before with other free tools.

Once again thanks for your great tool, now make it accessible to the entire world.

Best regards

0

Share this post


Link to post
Share on other sites

Hi alacran,

just change this language.ini as you like and put in the same folder.

2.3.1.1 is now available with better VHD label

cheers.gif

Edited by JFX
0

Share this post


Link to post
Share on other sites

JFX

Spanish translation finished, thanks again.


http://www.mediafire.com/?mzmyeekynvbw8n8

P.D. During VHD creation every thing is in English, for some reason translation doesn’t change the original

That's from dialog 3000 to 3048, Tested with v2.3.1 and v2.3.1.1

Best regards

Edited by alacran
0

Share this post


Link to post
Share on other sites

JFX, thanks for the language.ini, this just shows once more how professional your program is [the fact that we can easily translate it, I mean]!

I found a few spelling errors in the file, is it OK if I post them here?

004 contain -> contains, 007 contain -> contains, 007 inculde -> include 104 installationsdrive -> installationdrive 169 Dou -> do 217 unsinged -> unsigned 1021 an first -> at first, deaktivated -> deactivated 1028 BallonTips -> Balloontips 2031 completly -> completely 3030 avalibe -> available 3035 Finshed -> Finished 3040 occured -> occurred 3045 Faild -> Failed

Maybe you can change them in the original files? Please don't think that this is criticism, hey, I'm not a native English speaker myself, but I'm sure you're too busy yourself to take notice of these little "slips of the pen".

Edited by Atari800XL
0

Share this post


Link to post
Share on other sites

@alacran

thanks for translation :thumbup

I've found the problem with VHD creation strings, should be fixed in 2.3.1.2.

@Atari800XL

absolutely no problem, have found quite some more with Word 2007 blush.gif

new language.ini is in previous link and built in 2.3.1.2

cheers.gif

Edited by JFX
0

Share this post


Link to post
Share on other sites

Hi JFX

It's my pleasure to tell you the translation is working very well with last version (2.3.1.2), I had to modify minor details once it was possible to see translated strings during VHD creation, some of them were not seen well, all of them are okay now, only two more comments at String 014= I added Windows 8 Pro and Enterprise, as they also can be installed to VHD, maybe you forgot to update this line, string 166 it said Windows 7 now it says Windows 7 or 8

Assuming all changes you did were only Orthographical, I didn’t check farther.

Last version of Spanish translation:


http://www.mediafire.com/?ibucaxulzz43izm

Once again thanks, I love this little program, I am glad now it's going to be usefull for more people.

Best Regards

0

Share this post


Link to post
Share on other sites

@JFX

Chinese translation finished, thanks again.

0

Share this post


Link to post
Share on other sites

Ok, been trying to read all the pages and I must be missing something. Tried this newest tool for the first time today and XP txt setup portion went well and then BSOD (the x000000000007) so not sure if I did the drivers right. Should the source I am using already have Driver Packs slipstream to or should I leave driver packs out and just point to my mass storage drive folder to be copied to c when all the files are being copied with the add driver tab? I also tried Win 7 and everything worked well, just having issues (driver issues) with XP. The only mod to my XP source is the Driver Pack Stuff.

Thanks for your work.

Edited by laddanator
0

Share this post


Link to post
Share on other sites

@alacran

Thanks, I'll fix string 014 in next version. 166 is only thought for win7, the usbboot checkbox has no effect on win8 installs.

@cy06

Great, thanks for translating :thumbup

@laddanator

At what state of setup does the BSoD occurs (TXTMODE or GUIMODE) ?

Does it work if you boot it from CD/DVD?

Actually there should be no problem with already slipstreamed Driver Packs,

but there could be a version conflict with a newer or older driver.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.