JFX

WinNTSetup v3.8.6 / 3.8.7 Beta 4

1,535 posts in this topic

Hello,

I am new to all this, but I am hoping you can help me. I am trying to install Windows 7 onto a laptop. I am using SOME WAREZ boot CD (which i put on USB) and trying to use the WinNTSetup v2.3.1 which is on it. I am using the program, and pointing it to another USB which contains the Windows 7 installation files. My problem is that i have one 'Red X' left: 'BOOTMGR PBR'. Any ideas how to get that one green, so it will boot when its all done?

Edited by jaclaz
Removed name of warez
0

Share this post


Link to post
Share on other sites

@judoman09

Just install it, the MBR and PBR icons are not so important.

MBR and PBR will be updated later.

Some people with multi boot environments doesn't wanted the automatic updated of the boot records.

So it's now optional (default) and the icons are only there as warning.

0

Share this post


Link to post
Share on other sites

judoman,

check VERY attentively, the Rules of this Board:

http://www.msfn.org/board/index.php?app=forums&module=extras&section=boardrules

Paricularly Rule #1.a:

» No Illegal/Copyrighted Software Discussion

1.a This is not a warez site! Links/Requests to warez and/or illegal material (e.g., cracks, serials, etc.) will not be tolerated. Discussion of circumventing WGA/activation/timebombs/license restrictions, use of keygens, or any other illegal activity, including, but not limited to, requests for help where pirated software is being used or being discussed, will also not be tolerated. Offenders may be banned on first violation.

jaclaz

0

Share this post


Link to post
Share on other sites

ask a question: which tools to use to unpack or repack WinNTSetup2

thank you

0

Share this post


Link to post
Share on other sites

ask a question: which tools to use to unpack or repack WinNTSetup2

7zip is the easiest solution. In the misc folder of my Skydrive there is an repack example using 7zr.exe

0

Share this post


Link to post
Share on other sites

First Work In Process version of WinNTSetup3 is now available!

It was not tested on so many sources as v2, but should work good enough.

Please report any Bugs you find.

http://sdrv.ms/13YWwCY

0

Share this post


Link to post
Share on other sites

Thanks JFX, I was already looking forward to this one... It surprised me somewhat that the program looks the same as the 2.x branch, but hey, if it ain't broke...

I'm looking forward to testing it next weekend! So this one's programmed in a different language? Are there any other new things in the new version?

Thanks!!

EDIT: Found your announcement from march 30:

Following improvements are planned.

- command line will be more logical
- better language file support
- VHDX support is still missing

I might also include some tools, I use in very often in WinPE

- offline product key finder
- offline admin password reset
- gui wrapper for BCDEdit

Edited by Atari800XL
0

Share this post


Link to post
Share on other sites

Hi Atari800XL, yes this one is complete rewritten in a different language.

So far not to much changes since v2.

- VHDX is fully supported (but no instant creation of fixed ones, yet)

- language file is now a resource dll with much better loading speed as a simple text file.

- command line now have options and switches, well not much changed but more parameters are planed

- Windows Product key finder and password reset are integrated

0

Share this post


Link to post
Share on other sites

Thanks, I will test the new version with XP, W7, W8. Nice to see the commandline is still supported and, in fact, enhanced. As there is no new howto's as far as I can see, I assume the commandline in the testversion is the same as the last version in the 2.x branch.

[sorry, didn't see/read the helpfile, didn't think it was available yet, as pressing F1 didn't bring it up. Turns out it *is* available from the sysmenu]

EDIT1: First quick test: Boot Win8PESE, tccle prompt:

WinNTSetup_x86.exe nt6 -source:y:\OS\w7.wim (OK, source detected)

WinNTSetup_x86.exe nt5 -source:d: (Source not detected). When I select drive D: in the gui, everything's fine. Also tested with -source:d:\ -source:"d:" (d: is a mounted xp iso).

Edited by Atari800XL
0

Share this post


Link to post
Share on other sites

Seems I forgot F1 hot key for the Help page.

Your command line example actually works, it just forgets to update the description label.

0

Share this post


Link to post
Share on other sites

OK, so both points were valid? Thanks, I will test further...

EDIT1: Did a successful test with the new V3WIP version to install a W8 version that has been around as long as V3WIP. Works fine!

EDIT2: Could it be that the commandline option "-reboot" doesn't "take" in the gui? (ie: the option is not ticked).

Edited by Atari800XL
0

Share this post


Link to post
Share on other sites

Yes, your right some command line options are not take in the check boxes and therefor maybe don't work.

Your the number one bug hunter again :thumbup

0

Share this post


Link to post
Share on other sites

Well JFX, sometimes I can't believe that not "everybody" uses WinNTSetup...

These are just things I run into when using your fine tool...

More hunting:

(1) My unattended file is not (fully?) used, even though it's specified in the commandline (and also ticked and selected in the GUI). I'm sure you're aware of this? If not, let me know, I'll give more details (tested: The new W8WIP version, first with new WinNTSetup 3, then with old WinNTSetup 2.6.x. First setup was not unattended, second *was*).

(2) BootToDesktop was not executed for W8WIP. Same story: 2.6.x: OK 3WIP: Not OK.

...although I must add that W8WIP setup using 2.6.x version stalled right at the end of setup [needed an extra reboot]. Not sure exactly what's going on there, but this might not be WinNTSetup-related. Needs even more testing (has the unattend.xml syntax changed? etc).

Still, (1) and (2) above do seem to differ between 2.6 and 3. I'll await your response, we'll see after that.

Please let me know when/ if a new WIP version becomes available!

And thanks again for your programs!

Edited by Atari800XL
0

Share this post


Link to post
Share on other sites

Ok next version is ready.

WIP 08/31/2013

- change winhttp linking to dynamic
- removed winmm.dll dependency
- fixed F1 and Escape hotkey not working
- fixed cmdline source not updating description text
- fixed cmdline reboot, addotheros, nobootsect doesn't click respected checkbox
- fixed unattend file not copy if \Windows\Panther folder is missing
- fixed BootToDesktop was not integrated

http://sdrv.ms/13YWwCY

Edited by JFX
0

Share this post


Link to post
Share on other sites

Nice!

- You say "BootToDesktop" was not integrated, but I believe that one *did* work. Not important, now it works with double power.

(1) Can you please make the "setup" button the default button again like in the 2.x version? This way, when I start with commandline options (and nothing has to be changed) I only need to hit "Enter" (VERY convenient! eg. when run from a hotkey). On the other hand, if I want to do some minor adjustments (say, a different wim, or a different unattend file for audit mode, etc), I only need to change a few thing here and there. This is what's so great about WinNTSetup!!

(2) In the latest version, in the last screen (just before apply), the bootsector dropdown now defaults to "Do not update the bootcode". Is this by design? I would like it to default to one of the other options (not sure which was default before, bootsect.exe or bootice). I believe this changed in this latest version.

Hope you don't mind the continuous testing, it's just a very nice task for my spare nc6320 sitting quietly in the corner...

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.