JFX

WinNTSetup v3.8.7

1,543 posts in this topic

BTW, can you host your file on another site? Mediafire is blocked in my country. I think Data File Host is a great alternative. :rolleyes:

Sure have added Data File Host Mirror to first page :)

You rocks man! :lol:

0

Share this post


Link to post
Share on other sites

Thanks JFX for your replies and new version.

Another question for you (and others):

I can't get the "-drivers" commandline swith to "take"... When I type this:

(K:=Mounted XP Iso, Y:=USB)

WinNTSetup2_x86.exe -nt5 -source:k: -syspart:c: -unattend:"winnt.sif" -savedriveletters -drivers:"Y:\Drivers" -sysletter:c

... all the options are successfully set (and visible) in the program, except for the Drivers folder. When I manually select the folder in the GUI, it displays the exact same folder ("Y:\Drivers"). Now it's probably my own stupidity (again...) but I don't understand what I'm doing wrong (I studied your example in post #1, as far as I can see you use the same syntax: " -drivers:...")

0

Share this post


Link to post
Share on other sites

Update: Version 2.2.0.1

- fixed file copy errors for some nlite update packs

Funny you should mention this...

My XP setup (nlited with IE8, SATA, etc) is giving errors on the following files:

l3codec.xax, oleacc.dll, oleaccrc.dll

These file copy errors don't occur on a "normal" setup with this ISO on CD or USB.

Does this have anything to do with the file copy errors you were talking about?

I just tested it with version 2.2.0.1, but the errors on these 3 files still occur.

... but other that these issues, I think WinNTSetup2 is great!!!!!! So far I tested with XP, W7 and W8! All versions unattended.

0

Share this post


Link to post
Share on other sites

Atari800XL,

Please download again, I used wrong return code in one function that must cause failure of the "-drivers:" parameter.

For nlite packs, I only fixed some that were reported multiple times. Fixing the root of this nlite problem would be way to much work.

Thanks for reporting these bugs :thumbup

cheers.gif

Edited by JFX
0

Share this post


Link to post
Share on other sites
Please download again, I used wrong return code in one function that must cause failure of the "-drivers:" parameter.
Thanks!!!! Working now!
For nlite packs, I only fixed some that were reported multiple times. Fixing the root of this nlite problem would be way to much work.
Is there another solution for this? Skipping the files/ Adding them somewhere manually/ Removing them from some "files_to_be_copied" list? Anything to prevent the filecopy to halt three times....

JFX, I'm amazed by the support you provide for your program, please feel free to tell me to shut up any time :lol:

... just kidding, thanks a lot for the support!

Edited by Atari800XL
0

Share this post


Link to post
Share on other sites

somewhere manually/ Removing them from some "files_to_be_copied" list? Anything to prevent the filecopy to halt three times....

I think The reason of these errors is that setup somehow request these files in both states, compress (oleacc.dl_) and uncompressed (oleacc.dll)

If you only have oleacc.dl_ than try add expanded version to the same location. (with expand.exe or 7Zip)

if you only have oleacc.dll than just make a copy and rename it to oleacc.dl_ (does not need to be compressed API accept it both ways, just the extension matters )

JFX, I'm amazed by the support you provide for your program, please feel free to tell me to shut up any time :lol:

Thanks!

Actually I highly appreciate feedback! Supporting all these windows version is very time consuming. Knowing problems helps a lot. :)

cheers.gif

Edited by JFX
0

Share this post


Link to post
Share on other sites

JFX Hello !!!

First of all Thank you very Much for WinNTSetup v2.2 !!!

Noticed the presence of language.ini - which is amenable to the Russification"well, and so the very WinNTSetup too.

The question arose, and can not be used WinNTSetup with Russified language.ini (unpacked),

no problems, etc. This information would be very interesting ! :rolleyes:

Russian original text!

JFX Здравствуйте !!!

Во первых Большое Спасибо за WinNTSetup v2.2 !!!

Заметил наличие language.ini - который поддаётся русификации - ну и соответственно сама WinNTSetup тоже.

Возник вопрос, а можно ли будет использовать WinNTSetup с русифицированным language.ini (в распакованном виде),

не возникнет проблем и т.д. Эта информация была бы очень интересна !

Картинка пробной русификации

6b40b174ee4e0511565e64e020441bf3.jpeg

0

Share this post


Link to post
Share on other sites
I think The reason of these errors is that setup somehow request these files in both states, compress (oleacc.dl_) and uncompressed (oleacc.dll)

If you only have oleacc.dl_ than try add expanded version to the same location. (with expand.exe or 7Zip)

if you only have oleacc.dll than just make a copy and rename it to oleacc.dl_ (does not need to be compressed API accept it both ways, just the extension matters )

In the ISO, in \i386, I have:

l3codecx.ax_

oleacc.dl_

oleaccrd.dl_

So I should expand them to:

l3codecx.ax (that's the correct extension I believe, just the 2 letters "ax")

oleacc.dll

oleaccrd.dll

But where should I put them? Putting them inside the ISO proably has no effect? Because then I have to change the list of files to be copied? (Sorry, don't have the correct procedure in my head right now).

Or should I manually put them on the Harddisk, after WinNTSetup2 has run (just before the reboot)?

EDIT: Hold on, I took a look at TXTSETUP.SIF, and saw that there are *two* occurences of de the three files mentioned above:

l3codecx.ax = 1,,,,,,,2,0,0

l3codecx.ax = 100,,,,,,,2,0,0

oleacc.dll = 1,,,,,,,2,0,0,,1,2

oleacc.dll = 100,,,,,,,2,0,0

oleaccrc.dll = 1,,,,,,,2,0,0

oleaccrc.dll = 100,,,,,,,2,0,0

And the [sourceDisksNames.x86] section has this:

1 = %cdname%,%cdtagfilei%,,\i386

100 = %spcdname%,%spcdtagfilei%,,\i386,1

So the file must be missing in one of those places. Now I must admit that some of this is going over my head, but I *will* do some testing tonight, to see if I can safely delete one of those double entries, to prevent the "file not found" error.

Any help is appreciated, though...

[EDIT 2:]

This might have less and less to do with specific WinNTSetup things, but I *do* wonder why I don't have these "file not found" errors in a "normal" XP setup from CD or USB, using the same ISO (incl. same WINNT.SIF, etc)

Edited by Atari800XL
0

Share this post


Link to post
Share on other sites

Not sure if its working as intended but only giving the nt5/nt6 parameter in the command line does not work, it always runs the Windows7 setup screen, if I add the source parameter as well, it works and goes to the proper install screen

0

Share this post


Link to post
Share on other sites

Hi LeoZhu,

You very quick finding the language.ini. This "feature" is not ready yet and will change in subsequent version.

Well it's up to you, I've uploaded version 2.2.0.3 that will accept the file in "unpacked" form.

@Atari800XL,

You would need the rebuild the ISO with these files added to \I386 folder.

Carefully deleteing the lines in txtsetup.sif may help, have not tryed this. Maybe the same goes for dosnet.inf also.

But you could also copy these files after WinNtSetup has run. Place them inside \$WIN_NT$.~LS\i386\ folder.

The nomral Windows setup parses the txtsetup.sif and dosnet.inf to build up the $WIN_NT$.~LS folder.

WinNTSetup just copies the complete i386 folder.

@IceBlackIce

Thanks, fixed in version 2.2.0.3

cheers.gif

Edited by JFX
0

Share this post


Link to post
Share on other sites
You would need the rebuild the ISO with these files added to \I386 folder.

OK, I added the expanded files and finally had time to test it. I've been thinking about possible solutions at work all day (hence all the edits in the above message). Of course, I should've just taken your first advice...

The nomral Windows setup parses the txtsetup.sif and dosnet.inf to build up the $WIN_NT$.~LS folder.

WinNTSetup just copies the complete i386 folder.

OK, very informative!

So, with those last annoyances out of the way (the missing files), it looks like my perfect USB drive is a reality:

- Boot with Win PE SE

- Silently setup XPSP3 (updated edition w/ IE8-SATA etc) (a nice tribute to "good old XP", to have it installed from USB)

- Same for Windows 7, Windows 8

- Automatic postinstall with all my apps, settings, etc. etc.

- Personal data backups in TrueCrypt containers (faster for USB and safe).

THANK YOU!!!!!

:thumbup:w00t::thumbup

Edited by Atari800XL
0

Share this post


Link to post
Share on other sites

JFX Thank You!!! All works, it will be more comfortable now !!!

:thumbup:)

0

Share this post


Link to post
Share on other sites

@JFX

Could you please explain what is done in the "Integrate drivers" part? Do all files get copied to some folder?

0

Share this post


Link to post
Share on other sites

Could you please explain what is done in the "Integrate drivers" part? Do all files get copied to some folder?

For Windows Vista and 7 the offline servicing tools pkgmgr and dism are use directly on the selected folder.

XP and 2003 Install are a bit different:

- drivers are copied in "Drv" folder in the root of the installation drive

- all sub folder from this will be listed in "OemPnPDriversPath" of the unattended file "winnt.sif"

- MSSTMake is used on this folder to extract mass storage drivers and required information to load them in TXTMode of setup

- MSSTMake results are merge in txtsetup.sif and setupreg.hiv,

found driver files are copied to $WIN_NT$.~BT folder in the root of the selected boot drive

Edited by JFX
0

Share this post


Link to post
Share on other sites

Thank you for the explanation..

I'll take a look on some of that info to integrate on my deployment tools.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.