Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Can't Image due to different hdd controller driver

- - - - -

  • Please log in to reply
3 replies to this topic

#1
drive55

drive55

    Newbie

  • Member
  • 37 posts
  • Joined 16-April 07
Well, I've learned alot & been able to solve alot of challenges from studying this Drivers section
of the forum, but I've got a situation I can't figure out :

We want to commission (another) older laptop into service in our business,
and I'd like to image it with the same image we used previously, & successfully, for the other laptops.

From a fully configured volume licensed machine, I've prepared several "Generic" images to accomodate different hardwares :

First, under Device Manager > Computer, I set up a different image each for :

** ACPI Multiprocessor
** ACPI Uniprocessor
** Advanced Configuration and Power Interface (ACPI) PC
** Standard PC

Next, under Device Manager > IDE ATA/ATAPI controllers, I changed to:

** Standard Dual Channel PCI IDE Controller for each of the 4 scenarios above.

These combinations have successfully installed on a variety of different machines with their different hardwares -
I install the image, then install the specific drivers on each target,
then make a new image of the target that is now fully configed w/ apps + drivers, and then we're all set.

But none of these have worked on a Gateway 7405gx with a Mobile AMD Athlon 64 3200+ cpu,
and more importantly - a VIA K8T800 (VT8383) chipset -

the problem lies in the storage controller for the hard drive - it's listed as a VIA 0571 device ID, and that leads to a VIA_HyperionPro_V509A driver download.

After imaging the Gateway target, the machine begins to boot, but then goes into a perpetual loop -
I believe because there is no recognition of the hard drive from the "Standard Dual Channel PCI IDE Controller" ,
since it's very specific that it needs the VIA drivers for the VIA chipset.

My problem, I think, is that I can't load the VIA driver in the source machine to prepare an image,
since the source doesn't have that chipset and so it won't load the driver.

How can I make these 2 things work together? -

a fully prepped image from my source machine so I don't have to spend the time configing the target,
and a hard drive controller that will allow the target to boot?

or, will this just plain not work, & I have to bite the bullet and spend that time configing?

Thanks for any guidance !


How to remove advertisement from MSFN

#2
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,572 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

Thanks for any guidance !

You may want to review Offline Sysprep.
Are we talking of XP, right?

Here:
http://www.911cd.net...hp?showforum=43

jaclaz

#3
drive55

drive55

    Newbie

  • Member
  • 37 posts
  • Joined 16-April 07

You may want to review Offline Sysprep.
Are we talking of XP, right?

Here:
http://www.911cd.net...hp?showforum=43

jaclaz


XP Pro sp3, yes.

I've only read about Sysprep, never implemented it - seemed just a bit beyond my mental reach,
tried to work around it with careful nLite-ing & multiple imaging as described above, so here we go to yet learn that tool :D

"that which we resist persists until we desist;
joyously embracing all, even the densest barricades fall" :yes:

tho' before I go thrashing off into the weeds - would you kindly clarify the relationship/need of "Offline Sysprep" to regular Sysprep?
as, why is it necessary? - I really appreciate a global view before burrowing into the details.

..... and Thanks again to <j> who has assisted me many times under other names in other places ~

*** edit *** ok, I have been studying Sysprep @ Vernalex's site, and it occurs to me that the reason I need "Offline Sysprep"
is exactly because I want to "slipstream" some drivers that an "online" running system will not accept - eh?

& I'll need to apply my image to its own partition as a "workshop" or working space -
I typically use an empty external laptop hard drive just for this purpose,
partitioning it to the desired size & format with gParted, setting flag=boot, etc.

.... am I starting to get the big picture?
.... for better or worse, it seems that my brain needs to understand overall relationships of the process
before it agrees to comprehend the details :unsure: ... :D

Edited by drive55, 31 January 2011 - 07:24 PM.


#4
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,572 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag
Well, it's not that difficult (the base concept I mean). :unsure:

You are whining :ph34r: about not being able to image because you have an image (actually a set of images) that is/are hardware dependent..

Offline Sysprep promises:
http://www.911cd.net...showtopic=22064

Use:

· For SysPrepping a Windows XP or 2003 32-bit partition that is hardware independent (yes, hardware independent!) while offline (yes, a non-booted Windows partition!)

· For SysPrepping a Windows XP or 2003 32-bit partition that is hardware independent while booted in Windows but with a partition/drive to sysprep attached and assigned a drive letter (ie a non-booted WinXP/2003 partition).

· You can use an unattended solution by locating sysprep.inf in the \userfiles\ directory of the OfflineSysPrep plugin or in the \userfiles\ folder of the Windows version.


Doesn't it look a lot like a solution to the problem?

jaclaz




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users