Sign in to follow this  
Followers 0

Safely Disable Stservice.exe Process In Windows 7

1 post in this topic

Although I've been a member for some time, this is my first post, so please, don't be too harsh!

The procedure detailed below may assist others who have issues with the Dell DataSafe software that comes pre-installed on their machines.

The Dell DataSafe backup/recovery software is known to cause numerous issues, including jerky media playback, and irregular service crashes. This is caused by the Dell DataSafe Scheduler, which sets the Stservice.exe process running at startup.

Most users do not require this software, as they use alternative means of backup. There is an update patch available from Dell which supposedly stops the jerky media issue, but the service crashes still seem to be an issue; they certainly were on my PC.

Regular uninstalling appears to be problematic, and can leave your PC in a worse state than before.

There have been several posts on the internet on how to effectively remove this software, some of which need registry hacks, others booting in safe mode, etc. etc.

I needed a way to just disable the scheduler so that the Stservice.exe process was never run, and I would still have the recovery options available in future if I needed them.

There is a SoftThinks Agent Service process visible in services.msc, but disabling this (which also removes it from msconfig.exe) does not successfully stop the process from running again at startup.

The following procedure worked for me on a Dell 1545 Laptop running Windows 7 64 bit, and does not require any registry hacks/boots into safe-mode/software installs/uninstalls etc.

Step 1: Use Task Manager to end the STservice.exe (*32) process

Step 2: Run services.msc from START, scroll to SoftThinks Agent Service, right-click on this and select properties, then Startup type to Manual, and stop the service if still running running.

Step 3: Using Explorer, navigate to C:\Program files (x86)\DelDataSafe Local Backup

Step 4: Rename Scheduler folder to xscheduler (need to be logged on as administrator)

Re-boot, and Stservice.exe will no longer be running.

Hope this is useful.

Regards, Harry


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.