bapt

[SOLVED] problem with Vlite 1.2 and Win7 SP1 (MSDN)

189 posts in this topic

the "take ownership " does not work with me, I right click on winsxs but nothing happens (the window "cmd"opens and closes, immediately)

Why?

and I can not use the "Change_Folder_Date_Time" (see above)

thanks ;)

Edited by bapt
0

Share this post


Link to post
Share on other sites

Strange : any of the images in kit which i mount with gimagex works fine with take ownership, but try the long way : Folder Properties Security Advanced Owner Edit and select your user from list , confirm the message, etc.

0

Share this post


Link to post
Share on other sites

Strange : any of the images in kit which i mount with gimagex works fine with take ownership, but try the long way : Folder Properties Security Advanced Owner Edit and select your user from list , confirm the message, etc.

for winsxs, I can do it, but I receive an error message for all files/folder located in winsxs (it's good and not?)

and "Change_Folder_Date_Time" how to do, then?

I can not change the date?

thanks ;)

Edited by bapt
0

Share this post


Link to post
Share on other sites

Than you can change the date of winsxs folder, no ? I hope for you, my brain is on fire and I decide to watch some movies just to forget about painfull SP1 (I have the impression that Microsoft plans to release his own Lite Edition and vlite performances looks like an unwanted competition).

0

Share this post


Link to post
Share on other sites

Sorry its being a pain for you bapt, not sure what else it could be on the take ownership.

ahh possible that your Administartor account is not Administrators and is actually Administrator

if so then take ownership may fail

or better yet here is the reg file with just administrator

try this to see if it werks..


Windows Registry Editor Version 5.00

;Add "Take Ownership" to context menu ( This one will do many folders deep unlike the other one )
[HKEY_CLASSES_ROOT\*\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrator:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrator:F"

[HKEY_CLASSES_ROOT\exefile\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\exefile\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrator:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrator:F"

[HKEY_CLASSES_ROOT\dllfile\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\dllfile\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrator:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrator:F"

[HKEY_CLASSES_ROOT\Directory\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrator:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrator:F /t"

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrator:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrator:F /t"

I tested 2 versions in x86 so far by doing this and it does werk on it also as both Starter and Home Basic now are able to be modded in Vlite and no corruption on install.

I am sure there is a easier way to get around this, but until its all werkd out and a simpler guide is created I'll keep at it until someone can say it workd for them.

And Yes ONLY the winsxs folder needs take ownership ran on it , the Windows folder you can change date time right after mounting the .wim file

Only Windows and winsxs folder needs attention, no other folders from my results.

EDIT: ok for the x86 do the system32 folder too then see if that does the trick, imma getting ready to do the x86 Home Premium so I'll post what I do for it to werk in a few ( hour or so )

Edited by monkie53
0

Share this post


Link to post
Share on other sites

I tested other software to change the date and time

I set 13/07/2009 and 20h20mn00s for winsxs and all contents of winsxs

Some folders in winsxs are to 14/07/2009 (I know not why)

save the change, and unmount install.wim

reboot and mount install.wim with gimagex and the .dll, .exe files are still corrupted ...

I'm testing on a x64...

after, why changing the date of winsxs, Vlite that will be compatible?

I tested with Windows 7 and sp1 integrated, "date modified, etc...." are not changed and it works very well

and the "creation date" is the same (creation date: 14/07/2009) for 7 sp1 MSDN and 7 sp0 and sp1 integrated

thank you to explain ;)

EDIT: after I tested on a install.wim where I customize some dll (imageres, etc. ...)

but no problem with windows 7 and sp1 integrated

Edited by bapt
0

Share this post


Link to post
Share on other sites

I tested other software to change the date and time

I set 13/07/2009 and 20h20mn00s for winsxs and all contents of winsxs

Some folders in winsxs are to 14/07/2009 (I know not why)

save the change, and unmount install.wim

reboot and mount install.wim with gimagex and the .dll, .exe files are still corrupted ...

I'm testing on a x64...

after, why changing the date of winsxs, Vlite that will be compatible?

I tested with Windows 7 and sp1 integrated, "date modified, etc...." are not changed and it works very well

and the "creation date" is the same (creation date: 14/07/2009) for 7 sp1 MSDN and 7 sp0 and sp1 integrated

thank you to explain ;)

EDIT: after I tested on a install.wim where I customize some dll (imageres, etc. ...)

but no problem with windows 7 and sp1 integrated

did you get to run the takeown successfully on the winsxs folder?? this maybe the issue if not even with a program changing the folder date ( just guessing here )

0

Share this post


Link to post
Share on other sites

did you get to run the takeown successfully on the winsxs folder?? this maybe the issue if not even with a program changing the folder date ( just guessing here )

I removed the protection on any files contained in winsxs (and also winsxs) with software to modify the attribute, and I changed the date of winsxs and all content

I used vLite, reboot and mounted install.wim with gimagex

winsxs is the date of 13/07/2009 (the 3 dates) and all content winsxs also and I always corrupt files

0

Share this post


Link to post
Share on other sites

Monkie53, I used an imagex batch (attached) which includes the ownership part for mounting install.wim, then I used a third party program to modify date. I verified in every moment files attributes just to be shure that the date is 07/13/2009 (all 3 dates). Even in final vlited ISO. I applied date modifications to ENTIRE Windows folder including subfolders (and , of course, including winsxs folder). But winload error is still there. I will try your application and i will modify dates in windows (without subfolders) and winsxs only (like you sayed). And I will use gimagex too ...

This will not work as Install Wim Tweak is for taking ownership of the reg hives in the install.wim so you can Remove Packages and such, it will work for that and that only.

This has to be done by a take ownership as I did, no application is going to work, this is a winsxs folder MS has locked all these files down hard, so applications to do it in just a few seconds will not work here, nor will using the windows Security - Permissions setting native buildt into windows as I tried that last night also, even though I can do it and use the Change Folder Date Time.exe it still corrupts the files so even MS's own Permission tools sux here.

Its all about getting that take own to work, thats all that has worked for me so far out of all the things posted here.

I have a feeling its a Language barrier with the reg tweak I posted and the Change Folder Date Timexe.exe, I dont know how to work with these issues to get a working solution if this is the case.

after appling the reg tweak I posted does the language change to Your native language or how does these things work in say French windows environment?? I am clueless here..

Is there any native English users here that can try this and say if it works for them or not?? that would be a help, dont know how but I think if someone else can get it to work that would be a good thing.

I'll check back later today, as today is a busy one for me.

0

Share this post


Link to post
Share on other sites

I tried this on x64 Ultimate and it didn't work either. I get the errors after install.

0

Share this post


Link to post
Share on other sites

I've tested with a "take ownership" that works, Monkie53'software (to change the date) does not work for me (error message)

I used another software, changed the 3 dates "winsxs" folder (and contents) on 13/07/2009 and that's OK with vLite, no problem :thumbup

I also change the date of the "windows" folder (not contents) on 14/07/2009

is what to do or not?

0

Share this post


Link to post
Share on other sites

i think i may have found a workaround. i successfully installed msdn sp1 x86 after vlite removal. will post details after some more testing and a nice hot bath :P

Edited by dead0
0

Share this post


Link to post
Share on other sites

i think i may have found a workaround. i successfully installed msdn sp1 x86 after vlite removal. will post details aftesome more testing and a nice hot bath :P

ok thank you for your feedback ;)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.