Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

[SOLVED] problem with Vlite 1.2 and Win7 SP1 (MSDN)

- - - - -

  • Please log in to reply
188 replies to this topic

#26
romantiq

romantiq

    Newbie

  • Member
  • 27 posts
  • Joined 17-June 07
named "07/13/2009 kit", the one that have SP1 slipstreamed. Vlite works perfect with that image.


How to remove advertisement from MSFN

#27
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag
Indeed, if I integrate SP1 to Windows 7 ISO, Vlite works fine
if I use Windows 7 SP1, there are problems with Vlite

what is the difference between a Windows 7 SP1 and Windows 7 with sp1 integrated

just the SP1 Update in Windows 7 sp1?

and I still do not understand the history to change the date and time ^ ^

named "07/13/2009 kit", the one that have SP1 slipstreamed. Vlite works perfect with that image.


what do I have to rename in 07/13/2009 Kit (with windows 7 sp1 MSDN?)

I watched with a Windows 7 and sp1 integrated
date of install.wim (example) is the January 17, 2011 and no problems with Vlite

I do not know what to Modify

thanks ;)

EDIT:

for the windows folder

creation date: 13 July 2009
modifiaction date: February 23, 2011

same for the winsxs folder

Edited by bapt, 24 February 2011 - 08:35 AM.

sorry for my english :)

#28
romantiq

romantiq

    Newbie

  • Member
  • 27 posts
  • Joined 17-June 07
Dates of install.wim or boot wim are not relevant, is the date of release creation (depends of the creator) , but the rest of files date is 11/20/2010 when SP1 MSDN was released. Setup files, bootmgr and many other files are different (not just by date) between images and I think that vlite have problems with newest SP1 files.

#29
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag

Dates of install.wim or boot wim are not relevant, is the date of release creation (depends of the creator) , but the rest of files date is 11/20/2010 when SP1 MSDN was released. Setup files, bootmgr and many other files are different (not just by date) between images and I think that vlite have problems with newest SP1 files.


and what needs to be changed then?
for Windows sp1 MSDN works with Vlite

that's what I do not understand :unsure:

thank you very much ;)
sorry for my english :)

#30
romantiq

romantiq

    Newbie

  • Member
  • 27 posts
  • Joined 17-June 07
Sorry for my english too :) (I am romanian) ... My work with Windows 7 is a little bit complex, because I use "7elite32" method for size reduction (vlite + some batches, another topic in this forum). This metod worked fine with original W7 kit, but in W7SP1 case my problem is the poor size reduction applied to original W7 kit+SP1. So I have tried MSDN SP1 kit and - surprize - vlited image don't work ! Windows cannot start after the first reboot :(. Too shame because the image and installation size both are very small, much smaller than image obtained with W7 original+SP1. I am sure that vlite must be "adapted" to the MSDN kit and therefore I believe that replacing wimfltr and wimgapi is seemed a good ideea.

#31
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag
ok, so Vlite works great with Windows 7 and sp1 integrated but not with windows 7 sp1 MDSN

with the method of monkie53 (replaced wimfltr and wimgapi) the problem is that Vlite closes itself after the removal of components (we just unmount the image with dism but some "adjustments"are not applied)

for example, I disable UAC, but the padlocks are still some folder
and I delete "file and printer sharing (Server) but I still have these options in Windows 7 after installation

how to have Vlite compatible with Windows 7 sp1 MSDN without it closes by itself?

EDIT: I noticed that when it removes components with Vlite it closes by itself, if you add drivers, we made adjustments, there'll have no problems ...

Edited by bapt, 24 February 2011 - 12:50 PM.

sorry for my english :)

#32
romantiq

romantiq

    Newbie

  • Member
  • 27 posts
  • Joined 17-June 07
The question is : removing WHAT component(s) generates Vlite crash ? Some components of SP1 have something particular : another architecture, different dependencies ? But why in MSDN kit only? Questions ... :)

#33
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag
The question is : removing WHAT component(s) generates Vlite crash ?

just remove "file and printer sharing (server)" generates Vlite crash...
sorry for my english :)

#34
romantiq

romantiq

    Newbie

  • Member
  • 27 posts
  • Joined 17-June 07
Ok, seems like Vlite causes erros in installation process by modifying files "digital signature" , so windows don't recognize files version. I think I will compare files in vlited wims from both versions of W7 SP1 (MSDN and slipstreamed). Sounds like is a crazy move, but what els can I do? :no:

Edited by romantiq, 24 February 2011 - 02:35 PM.


#35
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag
I can already make a list of some .dll and files corrupt and modified ;)

I think Vlite removes components correctly but when cleaning (just after the removal of components) that vLite crash...
sorry for my english :)

#36
Schemek

Schemek
  • Member
  • 3 posts
  • Joined 10-January 10
  • OS:Windows 7 x64
  • Country: Country Flag
Hi I have been playing for quite a while now with dism scripts, vLite, RT7Lite, 7Customizer and other tools. I think that development of RT7Lite is going in the wrong direction. vLite is like a Porsche here:) I just hope it will be better in the future. Anyway good to hear that, it's not only me having problems with corrupted files during installation:) I thought it was my fault, because of deep cleaning of install.wim. Here is the list of corrupted files spotted so far:

system32

pdhui.dll polstore.dll PortableDeviceApi.dll PortableDeviceClassExtension.dll PortableDeviceConnectApi.dll PortableDeviceStatus.dll PortableDeviceSyncProvider.dllPortableDeviceTypes.dll PortableDeviceWiaCompat.dll PortableDeviceWMDRM.dll puiapi.dll rasapi32.dll rascfg.dll rasdiag.dll rasmxs.dll rasser.dll resutils.dll samlib.dll sbeio.dll sdshext.dll srclient.dll wercplsupport.dll wfapigp.dll wmi.dll wscisvif.dll wscproxystub.dll wscsvc.dll WSManMigrationPlugin.dll WsmAuto.dll wsmplpxy.dll WsmRes.dll plasrv.exe printui.exe resmon.exe ROUTE.EXE rrinstaller.exe SearchFilterHost.exe wsmprovhost.exe

wbem

NCProv.dll wbemprox.dll wbemsvc.dll WinMgmtR.dll WmiApRes.dll WMICOOKR.dll WMIsvc.dll

oobe

WinLGDep.dll winsetup.dll wdsutil.dll

setup

cmmigr.dll

shared/res

padrs404.dll padrs411.dll

Might be useful for someone. :sneaky:

#37
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag
thank you for this list ;)

I will add
spwizimg.dll in SysWOW64
WinMgmt.exe in System32

Will someone an idea to make it compatible Vlite with 7 sp1 MSDN?

Edited by bapt, 25 February 2011 - 05:14 AM.

sorry for my english :)

#38
alvinkhorfire

alvinkhorfire

    Member

  • Member
  • PipPip
  • 104 posts
  • Joined 11-May 08
Guys, how do you know which files are corrupted?

#39
monkie53

monkie53

    Newbie

  • Member
  • 10 posts
  • Joined 10-July 09

I wish I tell that your - everyone - solution solved my problem, but my "lite" installation of W7 SP1 vlited fails - after first restart of installation - with a blank screen, with white text, telling me that : "Windows fails to start" with error code 0xc0000428, "Windows cannot verify digital signature of file : C:\Windows\System32\winload.exe",


Yes I tested the x86 version and yes issues with the winload.exe is corrupted when using Vlite and x86 MSDN SP1 , do the same thing to the x86 as I stated above in changing date/time for all
( Date Created, Date Modified, and Date Accessed ) will fix the issues, it did for me.

I have fixed my ISO files, they now werk fine with Vlite and are the same files except the date changes were changed to July 13 2009.

Mounting the install.wim is easy with GimageX, take ownership of the winsxs folder is really a hard issue if you do not know how the "easy" way..

here is a simple ( source code found in google ) change folder date time I used

source code included - .exe in main folder to use ( needs Visual Basic 6 application to use the source code, for those that needs to know this :) )
Attached File  Change_Folder_Date_Time_Code.7z   9.25KB   120 downloads

here is my right click take own reg tweak I have been using for over a yr now..

NOTE: You have to take ownership of the winsxs folder before you can change the date on this folder as You do not have *access rights to modify it*

NOTE 2: running take ownership of the winsxs folder when mounted will take some time ( 10 ~15 minutes or more *depends on Your PC speed* ) so be patient with this step
Windows Registry Editor Version 5.00

;Add "Take Ownership" to context menu ( This one will do many folders deep unlike the other one )
[HKEY_CLASSES_ROOT\*\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"

[HKEY_CLASSES_ROOT\exefile\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\exefile\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"

[HKEY_CLASSES_ROOT\dllfile\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\dllfile\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"

[HKEY_CLASSES_ROOT\Directory\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"


Edited by monkie53, 25 February 2011 - 06:43 AM.


#40
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag

Yes I tested the x86 version and yes issues with the winload.exe is corrupted when using Vlite and x86 MSDN SP1 , do the same thing to the x86 as I stated above in changing date/time for all
( Date Created, Date Modified, and Date Accessed ) will fix the issues, it did for me.

I have fixed my ISO files, they now werk fine with Vlite and are the same files except the date changes were changed to July 13 2009.

Mounting the install.wim is easy with GimageX, take ownership of the winsxs folder is really a hard issue if you do not know how the "easy" way..

here is a simple ( source code found in google ) change folder date time I used

source code included - .exe in main folder to use ( needs Visual Basic 6 application to use the source code, for those that needs to know this :) )
Attached File  Change_Folder_Date_Time_Code.7z   9.25KB   120 downloads

here is my right click take own reg tweak I have been using for over a yr now..

NOTE: You have to take ownership of the winsxs folder before you can change the date on this folder as You do not have *access rights to modify it*

NOTE 2: running take ownership of the winsxs folder when mounted will take some time ( 10 ~15 minutes or more *depends on Your PC speed* ) so be patient with this step

Windows Registry Editor Version 5.00

;Add "Take Ownership" to context menu ( This one will do many folders deep unlike the other one )
[HKEY_CLASSES_ROOT\*\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"

[HKEY_CLASSES_ROOT\exefile\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\exefile\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"

[HKEY_CLASSES_ROOT\dllfile\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\dllfile\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"

[HKEY_CLASSES_ROOT\Directory\shell\takeownership]
@="Take Ownership"
"HasLUAShield"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\takeownership\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"


hello monkie53

thank you for your great work :thumbup

if I understand it, take possession on the "windows" and "winsxs" folder (when mounted install.wim with Gimagex example), and apply your patch, right?

thank you very much ;)
sorry for my english :)

#41
romantiq

romantiq

    Newbie

  • Member
  • 27 posts
  • Joined 17-June 07
Monkie53, I used an imagex batch (attached) which includes the ownership part for mounting install.wim, then I used a third party program to modify date. I verified in every moment files attributes just to be shure that the date is 07/13/2009 (all 3 dates). Even in final vlited ISO. I applied date modifications to ENTIRE Windows folder including subfolders (and , of course, including winsxs folder). But winload error is still there. I will try your application and i will modify dates in windows (without subfolders) and winsxs only (like you sayed). And I will use gimagex too ...

Attached Files


Edited by romantiq, 25 February 2011 - 08:00 AM.


#42
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag
I can not change the date and time ....

I mounted install.wim, use the "Take Ownership" in the winsxs folder (I did not even have time to see the Windows command prompt :blink: ) and it not work, the file is still locked (delete and rename)

but I can not change the date with "Change_Folder_Date_Time"

Posted Image

what do I forget?

thanks ;)
sorry for my english :)

#43
romantiq

romantiq

    Newbie

  • Member
  • 27 posts
  • Joined 17-June 07
Do you have cheched Read and Write in mounting step ?

#44
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag

Do you have cheched Read and Write in mounting step ?


yes ;)
sorry for my english :)

#45
romantiq

romantiq

    Newbie

  • Member
  • 27 posts
  • Joined 17-June 07
I mounted image no 3 (Home Premium) in gimagex , Take Ownership runs in CMD window for long time to be observed (10-15 min). Change Date prog worked and nou I see that only the 2 folders had to be modifyied, not all files in the 2 folders (monkey 53, sorry for missunderstanding)

Edited by romantiq, 25 February 2011 - 09:21 AM.


#46
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag
the "take ownership " does not work with me, I right click on winsxs but nothing happens (the window "cmd"opens and closes, immediately)

Why?

and I can not use the "Change_Folder_Date_Time" (see above)

thanks ;)

Edited by bapt, 25 February 2011 - 10:54 AM.

sorry for my english :)

#47
romantiq

romantiq

    Newbie

  • Member
  • 27 posts
  • Joined 17-June 07
Maybe is a stupid question : your user is administrator ?

#48
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag
yes ;)
sorry for my english :)

#49
romantiq

romantiq

    Newbie

  • Member
  • 27 posts
  • Joined 17-June 07
Strange : any of the images in kit which i mount with gimagex works fine with take ownership, but try the long way : Folder Properties Security Advanced Owner Edit and select your user from list , confirm the message, etc.

#50
bapt

bapt

    Member

  • Member
  • PipPip
  • 143 posts
  • Joined 09-August 07
  • OS:Windows 7 x64
  • Country: Country Flag

Strange : any of the images in kit which i mount with gimagex works fine with take ownership, but try the long way : Folder Properties Security Advanced Owner Edit and select your user from list , confirm the message, etc.


for winsxs, I can do it, but I receive an error message for all files/folder located in winsxs (it's good and not?)

and "Change_Folder_Date_Time" how to do, then?

I can not change the date?


thanks ;)

Edited by bapt, 25 February 2011 - 01:20 PM.

sorry for my english :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users