monroe

[Solved] Win 98/98SE System Restore

43 posts in this topic

OK ... dencorso rocks ! .... thanks

Oh wow you took my rock away! just kidding you can actually test your system restore now.

Create a restore point, install a program then restore it back. It worked for me. Glad you got it working.

0

Share this post


Link to post
Share on other sites

Maybe change title to "Solved - Windows 98/98SE System Restore" + "How To From Windows ME CD"?

Would make it "glare out" at "surfers"...

0

Share this post


Link to post
Share on other sites

Well, on my 2nd computer, the SR install was a failure. I have no restore points showing, it will do a restore point but when I go to see what restore points are available it tells me that no restore points have been made since after Saturday December 30, 1899 .... yes, 1899. I put my Ghost backup on and did the SR a second time on a clean machine and everything is still the same, no restore points have been made since Saturday December 30, 1899. I have two more computers that I will work with this weekend, I'll see how SR will install on them. The first computer, an old Toshiba that I use for testing software, is OK ... everything installed perfect and I see the restore point that was created on it's own dated today Feb 25, 2011, not 1899. Oh well, win some, lose some. If anyone else sees 1899 on their computer in the SR program, I'd be interested in hearing about it.

... Yes, I guess we can mark the SR problem solved ... I don't know what the problem is with the one computer.

Edited by duffy98
0

Share this post


Link to post
Share on other sites

Well, on my 2nd computer, the SR install was a failure. I have no restore points showing, it will do a restore point but when I go to see what restore points are available it tells me that no restore points have been made since after Saturday December 30, 1899 .... yes, 1899. I put my Ghost backup on and did the SR a second time on a clean machine and everything is still the same, no restore points have been made since Saturday December 30, 1899. I have two more computers that I will work with this weekend, I'll see how SR will install on them. The first computer, an old Toshiba that I use for testing software, is OK ... everything installed perfect and I see the restore point that was created on it's own dated today Feb 25, 2011, not 1899. Oh well, win some, lose some. If anyone else sees 1899 on their computer in the SR program, I'd be interested in hearing about it.

... Yes, I guess we can mark the SR problem solved ... I don't know what the problem is with the one computer.

you have to change the system date and time to the right time and reinstall SR all over again.

0

Share this post


Link to post
Share on other sites

Well I installed SR on my third computer today and it was also a failure ... getting that Dec 30, 1899 date again. I'm not sure if I understand what you are saying about changing the date ... my date and time are correct, that's the first thing I checked in the lower right hand corner. I was hoping that would be the solution, somehow the date was out of sync but the date was just fine and when I do a restore point it will tell me the correct date and time when SR has completed doing the restore point ... that is all just fine but when I ask to see earlier restore points, it tells me there are no restore points available and there are none after Saturday, December 30, 1899. This was a Dell notebook and the other was an IBM Thinkpad that have the crazy 1899 date ... The Toshiba SR setup is just fine ... all computers are set up the same, the company drivers being different I guess ... but I have pretty much the same programs installed on each computer.

Edited by duffy98
0

Share this post


Link to post
Share on other sites

Well I installed SR on my third computer today and it was also a failure ... getting that Dec 30, 1899 date again. I'm not sure if I understand what you are saying about changing the date ... my date and time are correct, that's the first thing I checked in the lower right hand corner. I was hoping that would be the solution, somehow the date was out of sync but the date was just fine and when I do a restore point it will tell me the correct date and time when SR has completed doing the restore point ... that is all just fine but when I ask to see earlier restore points, it tells me there are no restore points available and there are none after Saturday, December 30, 1899. This was a Dell notebook and the other was an IBM Thinkpad that have the crazy 1899 date ... The Toshiba SR setup is just fine ... all computers are set up the same, the company drivers being different I guess ... but I have pretty much the same programs installed on each computer.

Try this link

http://support.microsoft.com/kb/275646

Edited by PROBLEMCHYLD
0

Share this post


Link to post
Share on other sites

You rock PROBLEMCHYLD ! ... there, gave it back to you ... that could be the solution, especially since it matches the exact 1899 date problem on my computer. I will try the registry fix out later today ... so there is still hope SR will work on those notebooks. I guess I should have thought to check that date thing out more on Google but I wanted to wait till I install SR on my NEC computer later today and see how that went. I just figured there must be a software conflict or something. Thanks again ... I will try it all out later today.

extra ... that registry fix also may solve another problem .... I didn't mention it earlier, went I went into the Help section to look for help on the date thing, the pages were blank and this information is added at the bottom of the link you provided:

The absent registry key may also cause blank pages to be displayed in Windows Me Help and Support. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

Q275651 Blank Pages in Windows Me Help and Support

Edited by dencorso
0

Share this post


Link to post
Share on other sites

If you decide to copy the text offered by MS and paste it to notepad, don't forget to add *two* blank lines at the end, before saving as a .reg and merging it to the registry.

It's a famous quirck of regedit.exe: the two blank lines at the end are a must... and people always forgets about them.

Adding more than two lines doesn't hurt any, too. It's two lines minimum. I've done it for you, this time, just as an example.

HTH. :)

1899.zip

0

Share this post


Link to post
Share on other sites

One blank line at the end of a registry file always has been enough here... :w00t:

I am on Windows ME though.

Btw, whenever I (extremely rarely) install Windows ME, the first thing I do is get rid of that PC Health and System Restore. :thumbup

0

Share this post


Link to post
Share on other sites

Hello again ... SUCCESS !!! ... the registry fix did work on the notebook and 1899 is now gone ... there is a Restore Point dated for today and the Help Files are no longer blank pages.

Registry Fix:

REGEDIT4

[HKEY_CLASSES_ROOT\.htc]

"Content Type"="text/x-component"

[HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/x-component]

"CLSID"="{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}"

"Extension"=".htc"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}]

@="Microsoft Html Component"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}\InProcServer32]

@="C:\WINDOWS\\SYSTEM\\MSHTML.DLL"

"ThreadingModel"="Apartment"

[HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\.htc]

"Content Type"="text/x-component"

-----------------------------------------------------------------------------------------------------------------------------------

Thanks dencorso for the advice on the blank lines ... I didn't see your post till after I ran the "fix" but luckly I had left two blank lines, I thought I had left only one, figured that was all that was needed. I did read to leave at least one blank line between REGEDIT4 and the registry fix.

Everybody Rocks !!!

loblo ... yes I know a lot of people seem to turn SR off or get rid of it, at least that's what I've read ... but this was a challenge and I wanted to see it through. I'll see if I get any benefits from using it and how it works.

Edited by duffy98
0

Share this post


Link to post
Share on other sites

One blank line at the end of a registry file always has been enough here... :w00t:

One is usually enough. Two is bullet-proof!

Btw, whenever I (extremely rarely) install Windows ME, the first thing I do is get rid of that PC Health and System Restore. :thumbup

I do, too! On Win ME (with OPPCOMME) and on Win XP (together with WFP and DEP). (And I'm trying to find out how to do it on 7... But that's way off-topic! :blushing:) I consider SR a nuisance to be avoided (I do create system and data images regularly, as back-ups, obsessively, though), but grant it may be useful to some. And, yes, I do appreciate it was a worthy challenge to port it to Win 98 FE/SE, of course!

Now, credit where credit's due: although I did patch that one VxD at his request (and never touched it afterwards), System Restore on Win 98 FE/SE always was ProblemChyld's project, and it was only due to his research, persistence and hard work that it came int being. So all kudos ought to go to him. And to duffy98 who first tested it on various other machines, proving it's mature. This thread is now listed in the Important / "Stickified" / Pinned Windows 95/98/98 SP1/98 SE/ME Topics list, as warranted. :yes:

But now that things are working and the main issues identifyed and solved, I'd like to ask duffy98 to write a wrap-up post, a one-post how-to, to help other users who may be willing to try it on their systems. I reckon there are many important details scattered throughout this thread (and maybe the previous one quoted on post #1), so a wrap-up would be most helpful.

Later edit: Thanks a lot, duffy98, for providing the one-post how-to! :thumbup

0

Share this post


Link to post
Share on other sites

Getting System Restore To Work On Windows 98 / 98SE

When Windows Me came along there was a new program called System Restore that Microsoft included with the OS. System Restore can provide a way to "go back" or repair damage that has occurred from a bad software install or if you installed a program to try out and then decided to remove it. However, System Restore is not a 100% guarantee that everything will be the way it was when going back to an earlier Restore Point. It can be a "hit and miss" thing ... but it may be of use to some 98 users.

Thanks to some smart and crafty MSFN Forum people ... System Restore can now work (run) on Windows 98FE / 98SE. You will need a Windows Me Installation CD, the patched version of the "vxdmon file" and the 290700usam.exe from Microsoft.

vxdmon file (patched)

290700usam.exe

If all goes well then that may be all you really need, in my case I also needed some other files and a registry fix to get System Restore up and running.

First ... extract or copy "PCHealth.inf" from your WinMe CD to C:\Windows\Inf

Then run this command:

C:\windows\rundll.exe setupx.dll,InstallHinfSection PCHealth.Install 132 C:\WINDOWS\INF\PCHealth.inf

This is where the missing files may start showing up and you will have to have the WinMe CD handy ... it will be asking for the Windows 98SE Installation Disk but you will be using the WinMe CD instead. I had trouble with these two missing files ... checksr.bat + ebdundo.exe ... so I extracted them and put them in a folder to have handy. All the other missing files should be automatically found on the WinMe CD.

After the above command has finished running, then go to Windows\System\Vmm32 and remove the "vxdmon file" and replace it with the patched "vxdmon file".

Then install "290700usam.exe" and you should be good to go. I will add here that "290700usam.exe" would not install for me until I used KernelEx Final to change the compatibility to Windows Millennium. It then installed with no problem.

The System Restore tab will be in the Start\Programs\Accessories\System Tools area.

Now there could be another problem which may or may not show up when you open System Restore. When you open the earlier Restore Points area you should be seeing a newly created Restore Point only a few minutes old ... since you just installed the System Restore program. However, you might see no Restore Points and the date Saturday December 30, 1899. Also, if you click on the "Help" tab in the upper right area, you may see only blank white pages. If you are seeing the 1899 date and blank pages then you will have to do a quick registry fix that should correct the problem.

Back up your registry first if you have COP or some other registry backup program ... just to be on the safe side and then add this fix: Just what is between the lines ... dencorso also made a small registry fix download ... either will work.

1899 Registry fix

--------------------------------------------------------------------------------

REGEDIT4

[HKEY_CLASSES_ROOT\.htc]

"Content Type"="text/x-component"

[HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/x-component]

"CLSID"="{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}"

"Extension"=".htc"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}]

@="Microsoft Html Component"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}\InProcServer32]

@="C:\WINDOWS\\SYSTEM\\MSHTML.DLL"

"ThreadingModel"="Apartment"

[HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\.htc]

"Content Type"="text/x-component"

--------------------------------------------------------------------------------

This procedure worked for me ... provided by PROBLEMCHYLD

PROBLEMCHYLD said this about dencorso: All credit goes to dencorso, without him patching the vxd file, we would not be running system restore on Win98SE.

Thanks dencorso.

... and dencorso said this about PROBLEMCHYLD: Now, credit where credit's due: although I did patch that one VxD at his request (and never touched it afterwards), System Restore on Win 98 FE/SE always was ProblemChyld's project, and it was only due to his research, persistence and hard work that it came into being. So all kudos ought to go to him.

So we can appreciate having the System Restore program for Windows 98FE / SE finally.

.... Some follow up information. I was wondering if after awhile the Restore Points would start to build up and a person might like to delete some of the older Restore Points eventually. Also can the disk space usage setting be adjusted from the MS default setting, if someone wanted to do this. I got this information from PROBLEMCHYLD:

In order to have the option (Disk Space Usage) in System Restore you will need 98SE2ME also in order to disable System Restore, which will then allow older points created to be deleted. You need 98SE2ME because it installs some system files. If you just want to create Restore Points + Restore them back, then 98SE2ME is not needed, but if you want those two options then 98SE2ME is needed.

Edited by duffy98
0

Share this post


Link to post
Share on other sites

Just FYI, these two are the same thing ...


[HKEY_CLASSES_ROOT\.htc]
"Content Type"="text/x-component"

[HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\.htc]
"Content Type"="text/x-component"

0

Share this post


Link to post
Share on other sites

Hi CharlotteTheHarlot ... I got that registry fix from the MS Support page .... so I just went with what they supplied ... if it can be altered or changed, I don't know. It's a bit over my head. They show a manual registry fix and then the REGEDIT4 fix, which I decided to use. There are two fixes in that REGEDIT4 ... the 1899 date fix and the blank Help pages fix, so that may have some bearing on why MS supplied that particular fix, I can't say for sure.

System Restore Shows Date of Saturday, December 30, 1899

http://support.microsoft.com/kb/275646

To merge all the information at one time, you can copy and paste the following text into Microsoft Notepad, and then save it as a .reg file:

REGEDIT4

[HKEY_CLASSES_ROOT\.htc]

"Content Type"="text/x-component"

[HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/x-component]

"CLSID"="{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}"

"Extension"=".htc"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}]

@="Microsoft Html Component"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}\InProcServer32]

@="C:\WINDOWS\\SYSTEM\\MSHTML.DLL"

"ThreadingModel"="Apartment"

[HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\.htc]

"Content Type"="text/x-component"

-------------------------------------------------------------------------------------------------------------------------------------

Edited by duffy98
0

Share this post


Link to post
Share on other sites

Hi CharlotteTheHarlot ... I got that registry fix from the MS Support page .... so I just went with what they supplied ... if it can be altered or changed, I don't know. It's a bit over my head. They show a manual registry fix and then the REGEDIT4 fix, which I decided to use. There are two fixes in that REGEDIT4 ... the 1899 date fix and the blank Help pages fix, so that may have some bearing on why MS supplied that particular fix, I can't say for sure.

Understood. There is nothing wrong with what they did, you can put the identical entry in over and over, don't matter a wit.

It's just interesting that the last key is using HKLM but all previous were HKCR. The last one seems to have been tacked on later for some reason even though it needn't be there.

Just a curiosity, nothing more. Anyone else reading this intending to use the script can ignore this!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.